23:00:15 <nickm> #startmeeting weekly network team meeting, 6 Nov
23:00:15 <MeetBot> Meeting started Tue Nov  6 23:00:15 2018 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:15 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
23:00:21 <nickm> Let's spell "Nov" right! :)
23:00:25 <dgoulet> evening!
23:00:27 <nickm> https://pad.riseup.net/p/tor-netteam-2018.1-keep is the meeting pad
23:00:29 <ahf> hej!
23:00:36 <nickm> whom do we have tonight?
23:00:37 <ahf> it's the 7th here :-P
23:00:39 * ahf giggles
23:01:18 <gaba> :)
23:01:33 <gaba> do we have teor in the room? :)
23:01:34 <mikeperry> I made it!
23:01:38 <gaba> yeah!
23:01:40 <nickm> I see dgoulet, ahf, gaba.  Do we have mikeperry, teor, catalyst, asn?
23:01:46 <nickm> hi mikeperry !
23:01:47 * teor is here
23:01:48 <catalyst> hi
23:01:52 <nickm> whoa
23:01:56 <ahf> very nice
23:01:58 <nickm> I am hoping that asn is asleep :)
23:02:01 <gaba> nice
23:02:07 <nickm> ahf: I am hoping that you are okay with being awake :)
23:02:23 <ahf> i'm perfectly ok with it
23:02:27 <ahf> i think it's great we are doing this
23:02:35 <nickm> me too
23:02:40 <nickm> it's good to have you here, teor!
23:03:11 <teor> I am glad to be here. It's been a few years since I've been at a weekly meeting
23:03:19 <dgoulet> \o/
23:04:13 <nickm> Before we start with the roadmap, we should remember our meta-priorities:
23:04:23 <nickm> because sponsor 8 ends at end-of-year, we really need to get it all done...
23:04:36 <nickm> ... and the most "not done" thing there right now is O2.5, improved bootstrap reporting
23:04:50 <nickm> so if at all possible, those are the top priorities, IIUC.
23:04:52 <gaba> do anybody doing the sponsor8 tickets need help with anything?
23:04:54 <nickm> Right, gaba?
23:04:55 <ahf> i hope to be able to jump in and help with some of that at latest next week
23:05:10 <gaba> yep
23:05:37 <nickm> ok
23:05:54 <nickm> so, looking at the roadmap, are we up to date? Are we all working on stuff that's on there?
23:05:58 <gaba> please please please reach out if any doubt/comment or help with planning it
23:06:20 <dgoulet> ahf: fyi, I'm waiting on you finalizing the mainloop patch before jumping on reporting PT msg to the control port that is #28180
23:06:29 <ahf> dgoulet: yep!
23:06:31 <nickm> teor, catalyst: we should divide up the stuff on catalyst's list of subtickets for #28018 ?
23:07:02 <nickm> teor, catalyst: or at least make sure we have them divided up enough to have a plan
23:07:06 <catalyst> nickm: we've been sending mail about it?
23:07:17 <nickm> yes, and I've been seeing it -- i don't know if it's finalized though
23:08:07 <catalyst> ok i think #11966 is reviewing the patch from isis and running CI on it. we can clean it up when we have the tracker abstractions built.
23:08:24 <catalyst> #27100 needs new code, but probably not a lot
23:09:07 <ahf> i can take #27100
23:09:16 <ahf> it is a bit related to what i have on the plate already
23:09:38 <catalyst> both of these will possibly need spec changes. or maybe not, because we say that controllers shouldn't depend on the details of bootstrap reporting
23:10:09 <nickm> teor, catalyst: are we on track to get all the stuff divided up and started?  I'm happy taking on whatever neither of you wants, and/or backend things.
23:10:44 <catalyst> i reclassified a few tickets as sponsor8-can. these are things that i think aren't essential for the sponsor8 deliverable, but nice to have.
23:10:53 <catalyst> if people disagree with that, let's talk
23:11:30 <ahf> catalyst: are they related to bootstrap?
23:11:44 <catalyst> yeah, children of #28018
23:12:01 <ahf> was it OK for me to take #27100? i can just reassign it to me
23:12:11 <teor> I did the same with some HSv3 tickets, because that's the only system that will depend on a live consensus after #23605 is done
23:12:19 <catalyst> ahf: feel free to take #27100
23:12:27 <teor> oops #24661
23:13:08 <catalyst> next biggest win for UX is probably #24661 and related tickets. those will potentially improve our wrong-time-zone behavior by a lot
23:13:11 <teor> I also want to do #28203 in s8, so we can actually see bootstrap in chutney
23:13:24 <nickm> that would be valuable
23:13:26 <teor> I am on #24661 and that rabbithole
23:13:43 <nickm> Is there anything important that I should bang out here?
23:13:44 <catalyst> is the rabbithole big enough we should split the work further?
23:14:11 <teor> So far it is #24661 and #28319
23:14:18 <teor> Which is easier to do at the same time
23:14:58 <teor> If we decide to fix HSv3 as part of s8, then that might be a job for asn or dgoulet
23:15:34 <catalyst> teor: so HSv3 is still broken with large clock skews if we fix those two?
23:15:48 <teor> yeah
23:15:57 <teor> I put all the related tickets under #23605
23:16:07 <catalyst> teor: cool, thanks!
23:17:15 <teor> I think we might want a chutney mode where we run the clients a few hours skewed using libfaketime. That might be easy, or it could be really hard now that tor uses a lot of different timing sources
23:17:50 <catalyst> teor: that would be cool too, but yeah possibly difficult
23:18:19 <teor> After I think I've fixed the bugs, I will try, but set a time limit on it
23:18:21 <nickm> It sounds like you don't need me here just now? :)
23:19:04 <catalyst> nickm: maybe take a look at the children of #28018 that are sponsor8-can and see if you agree if they're optional for the deliverable?
23:19:35 <nickm> #action nickm reviews "can" children for #28018 and makes sure they are optional
23:19:38 <nickm> okay
23:20:04 <dgoulet> teor, catalyst: can you expand on the large clock skew "hs v3 broken" here?
23:20:12 <dgoulet> (maybe after the meeting)
23:20:27 <catalyst> dgoulet: i think teor knows much more about it than i do
23:20:29 <dgoulet> not sure what "fixing hsv3" means also for s8 :S
23:21:33 <nickm> Is everybody else happy with the roadmap as it stands, and working on stuff fairly high on the list?
23:21:42 * ahf is
23:21:43 <nickm> mikeperry, gaba : I think we should get the packet whitepaper on the roadmap
23:21:58 <nickm> we should get it done at least a week before the mozilla allhands if we can
23:22:22 <mikeperry> nickm: ok
23:22:43 <nickm> gaba: is that okay with you?
23:22:45 <gaba> ok, i will check with mikeperry later on that
23:22:46 <gaba> yes
23:22:57 <mikeperry> nickm: I have been meaning to do it asap but keep getting distracted by getting wtf-pad stuff done timely for review, etc. but it's on my list for sure
23:23:10 <teor> dgoulet: #27299 and #23764: make HSv3 clients accept a reasonably live consensus
23:23:29 <dgoulet> teor: oh those, ok thanks
23:23:35 <nickm> gaba, catalyst, teor: here is a query that shows the children of #28018 along with their sponsor fields:
23:23:38 <nickm> https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&parent=~%2328018&col=id&col=summary&col=status&col=type&col=priority&col=milestone&col=component&col=sponsor&order=priority
23:23:49 <teor> nickm: I am not doing PrivCount, so I don't know how we feel about that
23:23:51 <nickm> mikeperry: no worries
23:24:00 <nickm> teor: you mean "not at all" or "not right now"?
23:24:14 <teor> not right now, not sure how long s8 will take
23:24:19 <nickm> Either way, S8 O2.5 needs to take precedence
23:24:28 <nickm> so it's the right call
23:24:30 * gaba step out for 5 sec
23:24:34 <teor> ok
23:24:52 <nickm> if you need to take a break for a day or so to clear your mind at some point, then like feel free to poke privcount... but it's less urgent
23:25:33 <nickm> I think we're ready to move past the roadmap
23:25:36 <teor> I will probably do the fallback directory mirrors in a break day
23:25:37 <nickm> next is reviewer assignments
23:26:14 <nickm> please take a look at the relevant spreadsheet page and see whether youcan do the stuff that you're listed for there
23:26:31 <nickm> I see that dgoulet and asn have not assigned my #28330 branch.
23:26:36 <nickm> IMO it's not _that_ big :)
23:27:07 <dgoulet> ain't that big indeed just fun + new :)
23:27:25 <dgoulet> so I wanted to leave it to anyone who wants it instead of force assigning
23:27:30 <nickm> ah
23:27:44 <nickm> okay, so the question becomes whether anybody likes reviewing that kind of thing :)
23:28:07 * dgoulet throws his name into consideration :P
23:29:16 <nickm> okay, if nobody else wants it, then dgoulet gets it.
23:29:19 <nickm> thanks, dgoulet!
23:29:31 <dgoulet> o/
23:29:44 <nickm> any other issues with the reviews?
23:29:56 <nickm> wrt leftover reviews from last week, is everything moving according to plan?
23:31:08 <teor> I don't know if we should merge #27490
23:31:38 <teor> It works as an experimental feature, but it might mess up pathbias
23:31:58 <nickm> hm.  mikeperry, you're the pathbias expert. do you have time to opine on that ticket?
23:32:23 <teor> Our options are "merge it as experimental" or "make it not mess up pathbias, then merge it"
23:32:31 * gaba needs to move next door and will be back very shortly. sorry. everything looks good so far
23:32:52 <nickm> teor: I'm fine with both of those options.  How hard is the second one?
23:32:53 <mikeperry> hrmm. I don't understand at a glance the path bias conflict
23:32:58 <mikeperry> but have not looked at the code
23:33:24 <teor> Tor clients on IPv4-only networks that set this option will fail half their connections to IPv6 relays
23:33:46 <mikeperry> oh, that might mess up the guard code more than path bias
23:33:49 <teor> Would that trigger pathbias?
23:33:58 <mikeperry> path bias only counts stuff as failures if your circuit makes it at least 2 hops first
23:34:04 <teor> oh right
23:34:33 <teor> Then I think we should merge it as experimental, and fix any guard bugs that happen
23:34:43 <nickm> ok
23:35:06 <mikeperry> the guard code has its own failure counters for deciding to switch to your filtered guard list, etc
23:35:14 <asn> o/
23:35:17 <mikeperry> separate from path bias
23:35:18 <nickm> whoa
23:35:27 <nickm> asn: hi!
23:35:31 <asn> hello :)
23:35:35 <asn> pretty late night but made it!
23:35:39 <asn> sorry for being late
23:35:44 * asn goes through backlog
23:35:45 <nickm> you know this is optional for europe, right?
23:36:01 <asn> its ok np
23:36:08 <teor> So if everything is working right, then most clients will fail most guards an average of once
23:36:20 <teor> hi asn :-)
23:36:49 <teor> Oh, in fact, it's better than that, because we only try to have one or two guards
23:36:50 <asn> (fwiw i really like the idea of having a weekly meeting with teor)
23:37:01 <nickm> next agenda thing is rotations: catalyst on triage and mikeperry on CI.  (This is after I re-rand the scripts yesterday. Please check the rotations carefully to make sure I didn't mess anything up)
23:37:51 <nickm> asn: If you and teor (and maybe ahf?) want to do that, I think it would be awesome, but you should schedule it together :)
23:38:02 <asn> no i meant this one
23:38:11 <nickm> asn: this one is monthly :)
23:38:28 <teor> Thursdays at 1100 UTC is our optional time
23:38:31 <ahf> we have the option to schedule meetings thursday too for europe + australia :-)
23:38:42 <ahf> (and everyone else who wants to join!)
23:38:43 <asn> yep sorry for failing to explain it, but i like the idea of having a monthly network team meeting with teor.
23:38:52 <ahf> +1
23:39:00 <nickm> cool
23:39:47 <nickm> If we're set on rotations, then let's move on to discussion?
23:40:19 <nickm> ahf: where are we with our intro-to-snowflake plans?
23:40:41 * gaba is back
23:41:11 <ahf> nickm: i've started looking at it, i haven't written much down yet since the documentation that was around it was pretty decent
23:41:21 <nickm> good
23:41:28 <ahf> so building it etc. is pretty easy
23:41:39 <nickm> ahf: were we going to schedule a "kickoff" / "intro to snowflake" meeting?
23:42:07 <ahf> we talked about it, but what should we do during it? would it be to start spreading out all the non-assigned s19 tasks?
23:42:40 <ahf> so, dgoulet and i talked with dcf on irc last week about s8 things, but he also mentioned some of the possibilities for a backup PT design
23:42:44 <ahf> which is also an s19 task
23:42:50 <ahf> one of them that was brought up is the HTTPS proxy
23:43:08 <ahf> https://github.com/sergeyfrolov/httpsproxy
23:43:10 <ahf> is the code
23:44:22 <nickm> gaba: any thoughts there?
23:44:28 <nickm> ahf: interesting
23:44:42 <nickm> I think it would be mainly "let's all learn and think and talk about snowflake for a bit"
23:45:03 <gaba> yes, I think it should be a start to look at what needs to be done
23:45:25 <gaba> and learn and think about snowflake for people to work on it
23:45:26 <ahf> maybe combine them? or maybe not? that would probably take over an hour
23:45:47 <gaba> a presentation on snowflake with dicussion would be good
23:45:58 <ahf> gaba and i talked about trying to encourage people to look at snowflake, so maybe we could try to coordinate *when* we do that and then maybe try to do it at the same time?
23:46:07 <ahf> i don't know if that would work
23:46:21 <ahf> i did it friday morning this week, which obviously wont work for everyone in here :-)
23:46:27 <ahf> err, last week
23:46:52 <gaba> yes, one morning a week for snowflake for people to get up to speed
23:47:04 <nickm> (morning in whose timezone?)
23:47:08 <gaba> hehe
23:47:11 <gaba> MY MORNING :)
23:47:12 <ahf> it could be a morning for US people, an afternoon/evening for me?
23:47:14 <teor> this time works for me
23:47:19 * catalyst looked at the client side of snowflake maybe a year ago
23:47:20 <gaba> yes
23:47:40 <ahf> how about friday at 15 UTC? :-P
23:47:46 * ahf totally dragged that number out of nowhere
23:47:54 <gaba> the issue about friday is that is teor's saturday
23:48:00 <ahf> ahhhh, right
23:48:20 <teor> We aren't going to be able to find a few hours that work for everyone
23:48:27 <ahf> nope :-/
23:48:44 <gaba> what about people looking at snowflake on their own and then at the end of the month do a specific meeting on snowflake
23:48:58 <ahf> gaba: i think that would be a good idea. at the end of november?
23:49:01 <gaba> it could be for the last tuesday
23:49:01 <ahf> possibly at this time again
23:49:04 <gaba> yes
23:49:09 <nickm> works for me
23:49:18 <teor> Sounds good
23:49:21 <gaba> ok
23:49:23 <nickm> ahf: could you send a reminder to the list?
23:49:23 <ahf> so *everyone* on the team begins to spend a bit of time each week looking at snowflake?
23:49:30 <gaba> +1
23:49:31 <nickm> yes, if possible
23:49:32 <teor> What are we looking for?
23:49:33 <ahf> nickm: yep, i assume the public list here?
23:49:38 <nickm> yeah
23:49:50 <ahf> teor: figuring out how it works, building it, getting it to run, see if it has problems, etc. is my understanding
23:50:05 <gaba> yes
23:50:35 <ahf> one part of this i'm unsure about with s19: is *eveyrone* on the network team going to be working on it?
23:50:44 <teor> Ok, is there a snowflake test framework
23:50:46 <ahf> i have no idea what our planned allocations is for that sponsor
23:51:03 <ahf> teor: that is above my current level of knowledge, sorry
23:51:08 <ahf> teor: but worth looking into!
23:51:19 <nickm> S19 is our main funding in the first half of next year IIUC
23:51:24 <ahf> for all of us?
23:51:30 <teor> If there isn't, then the best use of my time is probably writing a PT mode in chutney
23:51:31 <nickm> gaba: is that right?
23:51:39 <ahf> i just worry a bit if we waste some people time on this too
23:51:51 <ahf> asking everyone to spend some ... 1/14th of their workweek on this might not be ideal
23:52:07 <ahf> err, 1/10th
23:52:17 <teor> Well, not for me, because I'll be PrivCount? Or is there not much Sponsor V left?
23:52:26 <gaba> mm, right now we don't have anybody taht can work on it other than ahf and we need people for snowflake work
23:52:54 <gaba> yes teor
23:53:03 <ahf> maybe the right question is who's really excited about the upcoming snowflake work and wants to start looking into it?
23:53:11 <ahf> or maybe want to look into to figure out if they are really excited about it
23:54:17 <nickm> privcount can be a small part of s19 if we are out of v
23:54:19 <nickm> IMO
23:54:23 <gaba> yes
23:54:50 <ahf> i'm gonna send an email to our internal list and to tor-project that we are going to have this meeting on the last tuesday of this month at this time (23 utc)
23:54:51 <gaba> we need at least 3 people for snowflake so this will be work for the first couple of months in 2019
23:54:57 <gaba> yes, thanks
23:54:58 <ahf> and what we will go over things about snowflake
23:55:06 <ahf> and people should try to look a bit into it before joining :-)
23:55:07 <ahf> ideally
23:55:12 <gaba> yes, i think this is a good start
23:55:15 <ahf> great
23:56:48 <nickm> pfew! On to more discussion?
23:56:59 <dgoulet> quick one: 0.4.0!
23:57:07 <nickm> oh, yeah.
23:57:10 <dgoulet> no objection so far so I say we should bump it
23:57:23 <nickm> okay, I'm on it, unless somebody objects now
23:57:33 <ahf> very nice
23:57:41 <nickm> looks like teor has questions.
23:57:47 <nickm> wrt #28096, I'd be happy to help
23:58:05 <nickm> teor: is "some time this week " soon enough, or does it need to be sooner?
23:58:06 <teor> We currently run Appveyor on Windows Server 2012, but Windows Server 2016 also works. Should we add it? We get better coverage, but it doubles the build time. #28318
23:58:24 <teor> nickm: any time this week is fine, there's no hurry on that patch
23:58:29 <nickm> teor: ack, ty
23:59:04 <nickm> teor: I have no opinion -- appveyor is already slow enough that I don't wait around for it.  (Can we throw money at them? Does travis have a timeline for windows support?)
23:59:49 <teor> Re: #28096, wur Windows versions will continue to be a bit wrong on clients until we do #28097
23:59:57 <ahf> didn't travis just announce windows support?
00:00:11 <teor> yeah, but not the bits we need. No C compilers yet.
00:00:19 <teor> I guess we could install one.
00:00:20 <ahf> oh, early beta it seems
00:00:32 <ahf> https://docs.travis-ci.com/user/reference/windows/
00:02:49 <gaba> ok, anything else in the meeting today?
00:02:57 <nickm> wrt #27376, anybody willing to opine about build documents?  I'd suggest that we ask our application-team friends , since they're they ones who do cross-compilation
00:03:10 <nickm> *the ones
00:03:13 <teor> oops, not the right ticket
00:03:57 <teor> #26376
00:04:17 <nickm> okay, same question about that one
00:04:36 <nickm> what are the tradeoffs between them?  Should we just concatenate them and let somebody else edit them into shape? :)
00:05:15 <ahf> i still don't get #26376 much. i think the only one i can think of that uses that environment is hello71
00:05:19 <teor> I honestly think ahf's is much better
00:05:28 <ahf> i think everyone else is using the homebrewed versions of the dodgy makefile i wrote
00:05:49 <teor> But I also think we are confused about how we want to support Windows builds in general
00:05:57 <ahf> yes
00:06:01 <teor> Or at least, I am confused
00:06:17 <catalyst> did Hello71 end up deleting the MXE stuff?
00:06:23 <teor> Yes
00:08:27 <teor> How can we move forward? Decide which Windows build systems we want to support?
00:09:12 <catalyst> honestly my preference, if i had the time to do it, would be to just clean up or rewrite Hello71's doc to be what we want, instead of continuing to go back and forth
00:09:12 <teor> In practice, we support whatever we do in CI, and whatever Tor Browser does. Everything else is maintained.
00:09:27 <ahf> i think that we are less in need of deciding on this one because we are not the ones shipping binaries: the application team does
00:09:43 <ahf> so i think from my point of view the important angle is to get an environment where you can debug CI issues and normal issues
00:09:54 <ahf> on whatever we are using for our normal work environment
00:10:10 <catalyst> yeah, i think this doc is primarily useful to us when we need to work on debugging windows build stuff on our local machines
00:10:49 <ahf> yeah
00:11:14 <ahf> i wrote the makefile thing once because i was pretty impressed by nickm's fedora setup with building cross compiled binaries and running tests in wine
00:11:51 <teor> Ok, so in my case, my travel laptop does Windows, and I need a build that will run on Windows. But for most of us (including me), cross-compiling and Wine is the way to go.
00:12:24 <ahf> yeah, i have a windows machine now, but i use the makefile too via the windows linux support subsystem
00:12:27 <ahf> in a debian container
00:12:34 <teor> Except for fun tickets like #28096, where we needed to test on a real Windows client and server
00:12:37 <ahf> (so many levels of weird cross environments when doing that)
00:12:52 <teor> ahf: fun race conditions, too
00:13:43 <ahf> i need to checkout soon, i'm sitting and falling a bit asleep :-S
00:14:11 <nickm> should we call this meeting and continue the cross-compilation discussion on #tor-dev?
00:14:25 <gaba> yes :)
00:14:25 <teor> Sure
00:15:02 <nickm> okay.  Thanks everybody!  I'll see you all online!
00:15:04 <nickm> #endmeeting