#tor-meeting: prop#245 prop#282

Meeting started by isis at 23:11:08 UTC (full logs).

Meeting summary

    1. ACTION: update the target releases in prop#245 (teor4, 23:20:39)
    2. https://gitweb.torproject.org/torspec.git/tree/proposals/245-tap-out.txt (isis, 23:21:05)
    3. https://gitweb.torproject.org/torspec.git/tree/proposals/282-remove-named-from-consensus.txt (isis, 23:21:27)
    4. ACTION: revise prop#245 to make it clear that optional-tap is a good on its own, even if we don't do complete removal. (nickm, 23:22:13)
    5. ACTION: remove §4 (isis, 23:27:36)
    6. ACTION: revise step 1 to upgrade the parsing algorithm on clients as well (teor4, 23:31:04)
    7. ACTION: write a section about testing. (nickm, 23:31:20)
    8. ACTION: after changes to prop#245, make a "Ticket:" field and put it in "State: Accepted" with a note that we're doing step 1 in 0.3.4 (isis, 23:47:02)
    9. ACTION: write a proposal to declare our consensus method deprecation plan. (nickm, 23:49:47)
    10. ACTION: make a proposal for removing old consensus methods in general (nickm, 00:01:57)
    11. ACTION: make a ticket for removing methods up through 24ish (nickm, 00:02:25)
    12. ACTION: add the ticket to the "Ticket:" field! (this is now required :) (isis, 00:03:01)
    13. ACTION: put prop#282 in "Status: Accepted" and give it a "Ticket:" field (isis, 00:09:54)


Meeting ended at 00:11:01 UTC (full logs).

Action items

  1. update the target releases in prop#245
  2. revise prop#245 to make it clear that optional-tap is a good on its own, even if we don't do complete removal.
  3. remove §4
  4. revise step 1 to upgrade the parsing algorithm on clients as well
  5. write a section about testing.
  6. after changes to prop#245, make a "Ticket:" field and put it in "State: Accepted" with a note that we're doing step 1 in 0.3.4
  7. write a proposal to declare our consensus method deprecation plan.
  8. make a proposal for removing old consensus methods in general
  9. make a ticket for removing methods up through 24ish
  10. add the ticket to the "Ticket:" field! (this is now required :)
  11. put prop#282 in "Status: Accepted" and give it a "Ticket:" field


People present (lines said)

  1. nickm (85)
  2. isis (56)
  3. teor4 (52)
  4. MeetBot (2)


Generated by MeetBot 0.1.4.