#tor-meeting: prop#285 utf-8 in directory documents, 12 Feb 2018

Meeting started by teor at 21:04:51 UTC (full logs).

Meeting summary

    1. ACTION: use "Unicode Scalar" to describe the set of code points in section "Which UTF-8 exactly?" (teor, 21:17:54)
    2. ACTION: Since we exclude 0x00 (nul), note this difference from Rust (teor, 21:20:00)
    3. ACTION: Since we exclude byte order marks, note this difference from Rust (teor, 21:20:23)
    4. ACTION: Reference Rust definition of char at https://doc.rust-lang.org/1.0.0/unicode/char/ (teor, 21:20:58)
    5. https://en.wikipedia.org/wiki/UTF-8#Byte_order_mark (teor, 21:23:35)
    6. ACTION: reference RFC 3629 section 6 to forbid the BOM https://tools.ietf.org/html/rfc3629#section-6 (teor, 21:33:02)
    7. ACTION: update dir-spec.txt to define contact as excluding NUL and NL (teor, 21:38:57)
    8. ACTION: update dir-spec.txt to define platform as ASCII? (teor, 21:39:18)
    9. ACTION: require directory document keywords to be ASCII to avoid confusion attacks (teor, 21:49:13)
    10. ACTION: specify that unicode newlines are not valid dir-spec NLs (teor, 21:51:36)
    11. ACTION: email relay and bridge operators with non-UTF-8 in their contact info (teor, 21:56:38)


Meeting ended at 21:59:18 UTC (full logs).

Action items

  1. use "Unicode Scalar" to describe the set of code points in section "Which UTF-8 exactly?"
  2. Since we exclude 0x00 (nul), note this difference from Rust
  3. Since we exclude byte order marks, note this difference from Rust
  4. Reference Rust definition of char at https://doc.rust-lang.org/1.0.0/unicode/char/
  5. reference RFC 3629 section 6 to forbid the BOM https://tools.ietf.org/html/rfc3629#section-6
  6. update dir-spec.txt to define contact as excluding NUL and NL
  7. update dir-spec.txt to define platform as ASCII?
  8. require directory document keywords to be ASCII to avoid confusion attacks
  9. specify that unicode newlines are not valid dir-spec NLs
  10. email relay and bridge operators with non-UTF-8 in their contact info


People present (lines said)

  1. teor (64)
  2. nickm (54)
  3. isis (17)
  4. Samdney (3)
  5. MeetBot (2)


Generated by MeetBot 0.1.4.