17:00:05 <nickm> #startmeeting weekly network team meeting
17:00:05 <MeetBot> Meeting started Mon May  2 17:00:05 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:05 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:22 <isabela> !
17:00:26 <isabela> boom
17:00:29 <nickm> yeah
17:00:30 <mikeperry> hello all
17:00:36 <nickm> Yawning: dgoulet: athena: isabela: isis: mikeperry: asn:  special: karsten: Sebastian: armadev: ^
17:00:41 <nickm> hi hi
17:00:49 <asn> hello friends :)
17:00:55 <athena> hello meeting
17:01:20 <nickm> quick update: spent last week trying to get deliverables and bug reports done. distracted by EOM stuff and various drama. This week: more coding, more review, and trying to get as much as possible DONE.
17:01:37 <nickm> I've carried most of the remaining april tickets into May.
17:01:39 <isis> hey
17:01:52 <isabela> april is empty! (i just checked)
17:02:01 <nickm> I've also selected a few tickets that I was owner of for May. I hope I can get more things done than just those, but let's start small.
17:02:20 <nickm> #action everyone: If you haven't gotten a few tickets selected for may, please do so today.
17:02:35 <nickm> #action everybody: remember timesheets for April too, if you're supposed to be doing timesheets.
17:02:44 <isabela> aha
17:02:52 <nickm> #item we should be talking about 029-proposed items.
17:03:14 <nickm> recommendation: When you're picking stuff to do in may: look for:
17:03:27 <nickm> - tickets that are needs_review in the may keyword, but have no reviewer.
17:03:41 <nickm> - tickets that are in the 0.2.9 milestone, where sponsor != "".
17:04:27 <isabela> yes, my update is that i will do a review of april/may and also status report of 029 progress -- this is my work this week, last week i was more working on end of everything (month, quarter etc) reports and otf grant - which i will email core tor team about later today
17:04:28 <nickm> that's it for me for now. going to make more tea; back in 3 minutes
17:04:37 <athena> update: on code review patrol last week, but not very productively as distracted by a nasty cold for a couple days.  expect to be dong the same this week unless someone throws anything else at me.
17:05:10 <nickm> please put yourself as reviewer on the ones you'll be reviewing this week
17:05:19 <nickm> also please grab some tickets to work on in May as described above! :)
17:05:41 <asn> i can go next
17:06:03 <asn> Hello. During the past week, I did some prop224 spec work and triaged April
17:06:06 <asn> tickets and moved stuff to May. I also did a Tor talk in a FOSS conference over
17:06:07 <asn> here that went fine. I also finalized a months old sideproject of mine about
17:06:09 <asn> secure messaging: https://moderncrypto.org/mail-archive/messaging/2016/002181.html
17:06:12 <asn> Over the next week, I need to get up to date with the prop259 work that has
17:06:14 <asn> been done (the thoughtworks team is moving on with other projects, so they put
17:06:15 <asn> prop259 on lower priority and there is still lots of work to be done there). I
17:06:18 <asn> also need to prepare for the prop224 meeting in Montreal, so that it's as
17:06:20 <asn> productive as possible. I'm going to take a few May tickets for review after
17:06:21 <asn> this meeting.
17:06:24 <asn> boom
17:06:29 <isabela> !
17:07:11 <asn> next plz
17:07:51 <nickm> (Also folks! Please feel free to ask me if you can steal tickets that I was listed as owner on. I am listed as owner on too much.)
17:09:01 <mikeperry> Last week I reviewed #18362, #7378 and did a high-level review of #18365 with some comments. I then tasked switched to OTF and media stuff.
17:09:09 <mikeperry> I wrote a mock-up better patch for #18362, but it still needs a consensus method check and changes file. I think we're going to keep it testing-network only, still, but with a consensus method. Should I ask Rob to merge my mock-up with his previous patch explicitly?
17:09:18 <mikeperry> This week, I need to help finish the OTF proposal, do some research into Windows Sandboxing, and more media things. I hope to fit in a review of #7478 still.
17:10:10 <mikeperry> arg, #7378 should be #14881
17:10:19 <nickm> when you say mock-up-bettet patch for #18362, d9o you mean something different there?
17:10:50 <mikeperry> yeah, I meant #14881
17:10:56 <nickm> ok
17:12:02 <nickm> I think you and rob probably have a better command of how/whether to merge your patches together than the rest of us do
17:12:28 <nickm> I agree there should be a consensus method and appropriate backward compatibility if this is for merge with mainstream tor
17:12:42 <nickm> more? next update?
17:12:48 <mikeperry> that is it for me
17:14:11 <nickm> next person?
17:14:20 <nickm> I see an email to network-team@ from dgoulet saying he's offline atm
17:14:31 <nickm> (he includes an update in the email. nicely done.)
17:14:37 <nickm> I bet Yawning is asleep; he stayed up till dawn
17:14:40 <nickm> anybody else?
17:15:08 <isis> i can go next
17:15:20 <isis> reviewed #18240 #17158 #8185 (again) #18921 #18929
17:15:29 <isis> created #18933 and made a patch for it
17:15:38 <isis> rebased #7144 onto 0.2.9-root and started fixing a bunch of problems that arose
17:15:47 <isis> i'm a bit stuck on fixing up my #7144 patches, since the code seems to work fine if there's already a cached consensus
17:15:52 <nickm> SUCH PRODUCTIVE. VERY ISIS. WOW.
17:15:56 <isis> but something (possibly in the fallback directory code?) is making the first bootstrap not work for bridges with bridge guards
17:15:59 <isabela> hehe
17:16:01 <isis> nickm: :)
17:16:53 <isis> i also worked a little bit on my proposal for the new handshake
17:17:08 <isis> https://code.ciph.re/isis/torspec/src/propXXX-newhope/proposals/XXX-newhope-hybrid-handshake.txt
17:17:21 <isis> that's it for me, i think
17:17:42 <nickm> (are you in touch with yawning about that? both of you seem interested in it)
17:17:52 <isis> yes, we've been talking a bunch
17:17:55 <nickm> great
17:18:32 <isis> mikeperry also put both of us in contact with trevor perrin to discuss prosibly using his new "noise protocol" to describe our handshakes
17:18:32 <nickm> the #7144 debugging is probably going to involve digging into the code, adding logging statements, figuring out what's not working, etc etc etc
17:18:42 <isis> http://noiseprotocol.org/noise.html
17:19:15 <isis> nickm: yep… that's been my debugging process so far :/
17:19:50 <isis> it's kind of slow and frustrating but oh wel
17:20:05 <nickm> bugs gonna bug :(
17:20:21 <nickm> anybody else?
17:22:02 <nickm> okay.  Let's turn our eyes towards the 029-proposed tickets.
17:22:32 <nickm> doom-url: https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&keywords=~029-proposed&col=id&col=summary&col=status&col=type&col=priority&col=milestone&col=component&order=priority
17:22:44 <nickm> oh damn there are way too many of them.
17:23:10 <nickm> 23
17:23:36 <nickm> #action add our commonly-used queries to the wiki page
17:23:51 <nickm> anybody want to nominate some for NON-inclusion in 0.2.9?
17:24:14 <nickm> or for inclusion I guess.
17:24:21 <isabela> yeah
17:24:37 <nickm> #18934 and #18889 are trivial patches that I wrote code for. #18934 fixes a testing bug.
17:24:42 <nickm> I want to put them in.
17:24:49 <isabela> btw, like I said on my update i plan on send status report on 029 as i do a review of the month
17:24:52 <isis> nickm: i don't see a patch on #17150?
17:24:59 <isabela> so we know where we are at
17:25:25 <nickm> seeing no objections on the two I mentioned, planning to put them in.
17:25:46 <nickm> isis: damn, that's on the wrong ticket.
17:26:10 <nickm> wait now it isn't.
17:26:27 <nickm> yes it is.
17:27:10 <nickm> Moving that to 0.2.???.
17:29:03 * nickm tries to add points to these 029-proposed tickets.
17:29:39 <nickm> should we try to discuss these, or should I be dictatorial, or should I be dictatorial when I'm sure and we discuss the others?
17:29:45 <nickm> and are there other discussion topics for today?
17:30:05 <isabela> hmm
17:30:23 <isabela> i would say maybe email the list about this and give a chance till end of the day tomorrow for feedback?
17:30:38 <isabela> because dgoulet is not here and teor
17:30:39 <nickm> okay, good idea.
17:30:44 <nickm> will do
17:30:47 <isabela> cool
17:32:12 <isis> for the tickets regarding -ftrapv and integer overflows in the curve25519 code, could it be intentional that it's overflowing in order to e.g. save some mod operations?
17:32:27 <isis> #13538 #17983
17:32:45 <nickm> It could be, but I'm not really sure.
17:32:54 <isis> i suppose i could take a closer look
17:33:26 <nickm> #action nickm proposes include/no-include decisions for all/most 029-proposed tickets, and sends note to network team list.
17:35:33 <nickm> any other discussion topics for today?
17:37:01 <nickm> whoa, will we really be done in <40 min?
17:37:16 <isabela> !
17:37:27 <isabela> normally GeKo has to kick us out :D
17:38:03 <nickm> #endmeeting