13:32:27 <nickm> #startmeeting!
13:32:27 <MeetBot> Meeting started Wed Mar 16 13:32:27 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:32:27 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:32:37 <karsten> hello meeting
13:33:28 <nickm> hi karsten, dgoulet , isabela , asn !
13:33:32 <asn> hello people
13:33:33 <nickm> it's another fine wednesday.
13:33:39 <nickm> let's start with status updates.
13:34:14 <nickm> as for me: I'm trying to get 028 done, getting ready to help isabela with 029 triage, fixing that old 027-authorities bug, and trying to make sure that all the sponsorS EOM items get done.
13:34:38 <nickm> that latter has me somewhat focused on module isolation right now, since it falls pretty squarely as chief-architect-responsibility, as I see it.
13:35:12 <nickm> #item later we should discuss the meeting time; nearly everyone has replied to the doodle, and everybody who hasn't has received at least 2 reminders.
13:35:46 <nickm> #item I'm hoping we can discuss cooperation on 0.2.8 a little so that I have time to help with other stuff.  Nothing bad I hope.
13:35:55 <nickm> #item I hope isabela will say a few words about triage.
13:35:59 <nickm> And that's about it for me.
13:36:24 <Sebastian> I helped isabela implement the sponsor thing on trac
13:36:35 * karsten has a short update re little-t-tor: tried to find 028 tickets that need review, found one that's actually mine and that needed work, worked on that (#18460). end of status update.
13:36:39 <Sebastian> I hope that helps with sponsor triage
13:36:53 <dgoulet> Sebastian: ah you did great! (I saw the ping to late last night :S)
13:37:16 <isabela> :)
13:37:16 <Sebastian> There's a few tickets that don't fit into the categories, otherwise it should work.
13:38:13 <Sebastian> That's all for little-t related stuff I guess. I will gladly help with something small (8 hours-ish) next week, if someone has a suggestion.
13:38:32 * Sebastian done
13:38:39 <isabela> Sebastian: great we could look into the things for EOM that nickm needs help
13:39:37 <asn> i can go next.
13:39:48 <asn> hello. i've been doing prop224 spec work for the past few days.
13:40:16 <asn> specifcally touching the cell formats. i wrote a thread about some design issues here: https://lists.torproject.org/pipermail/tor-dev/2016-March/010534.html
13:40:29 <asn> i also have a git branch that i need to clean up and post, but I'd like some feedback on the thread first (dgoulet answered!)
13:40:51 <asn> also I've been wrapping up general email backlog from dev meeting, and also doing GSoC preparations (lots of people asking me for projects)
13:41:16 <asn> also, my review queue is empty so I'd gladly get stuff for review! :)
13:41:23 <asn> that's that.
13:41:33 <nickm> #item talk about stuff to do, stuff to review
13:41:41 * dgoulet can go
13:41:47 <nickm> #action everybody look at https://lists.torproject.org/pipermail/tor-dev/2016-March/010534.html
13:41:52 <nickm> go!
13:42:08 <dgoulet> I've been mostly working on prop#224 (#17238, see my dev branch ticket17238_029_01). I've reviewed some tickets also for 028 and cleaned up the "tor-hs" ticket queue also. We still have 1 open (#18332) but that's in armadev court now :).
13:42:16 <dgoulet> I plan to do a 029 HS ticket triage before Friday (will be leaving for LibrePlanet for the weekend).
13:42:35 <dgoulet> that covers it for little-t tor.
13:42:36 <dgoulet> --
13:43:15 <dgoulet> I would also love to talk about the bug I sent you all guys during IFF in Valencia... this is just sitting there for now and I'm not too happy about it
13:44:14 <dgoulet> "Re: Potential little-t tor issue"
13:44:22 <dgoulet> (discussion phase or #item)
13:44:33 <nickm> #item little t tor issue at discussion phase.
13:44:38 <dgoulet> thx!
13:45:07 <nickm> #action nickm and dgoulet see if they have time to hang out when dgoulet is around for libreplanet
13:45:10 <nickm> ;
13:45:28 <nickm> anyone else around?
13:45:33 <dgoulet> nickm: yesssssss
13:45:57 <special> around, but nothing much to report. Been busy with travel and auxiliary responsibilities :<
13:47:23 <isabela> ok I could give a short update - I sent long emails about triage :)
13:47:37 <isabela> hopefully the exercise I am asking wont be as painful as my long emails :)
13:47:54 <isabela> I also discussed releases in general with nick
13:48:03 <isabela> and I am taking notes to try to build a proposal for the team
13:48:08 <nickm> #item check in with isabela about what is/isn't answerd from her emails
13:48:27 <nickm> #item do whatever exercise Isabela is asking for. Make sure we all know what it is
13:48:36 <isabela> I hope to share with the team soon
13:48:39 <isabela> hehehe
13:48:43 <isabela> tx nickm !
13:49:10 <isabela> thats it
13:51:10 <dgoulet> cool
13:51:30 <isabela> anyone else?
13:51:31 <nickm> ok.  on to discussion.  we have a bunch o' topics.
13:52:26 <isabela> (for the exercise thing, I can just explain what it is and ppl can do it in their own time if we pick a day as the deadline.. i am on irc too and can answer questions off this meeting)
13:53:04 <nickm> http://paste.debian.net/415942/ -- here's all the stuff I said "item" about so far
13:53:29 <nickm> ok, please explain!
13:53:30 <isabela> awesome
13:54:19 <isabela> actually is on the email as well.. but I want people to review tickets and mark the sponsor tag for it (choosing btw sponsor-must and sponsor-can) I shared a spreadsheet for folks to work on
13:54:25 <nickm> afk tea 60 sec
13:55:00 <isabela> so I was thinking if ppl can do it by Friday EOD I can migrate it to the wiki and move on to the next work for the triage
13:55:18 <isabela> we are prioritizing sponsor work now, that is what we are doing
13:55:36 <dgoulet> isabela: ack (I want to do that by friday)
13:55:42 <isabela> ok
13:55:49 <asn> can do that!
13:56:02 <isabela> so Friday EOD is the deadline, anyone can ping me if you have questions, url for spreadsheet and more info is on my email
13:56:05 <isabela> done!
13:56:05 <isabela> :)
13:56:08 <nickm> I can do that.  Should we divide up by sponsor?
13:56:13 <nickm> Like, somebody take each sponsor?
13:56:39 <Enda> This is a bit buggy on my phone so apologies, currently writing up a PhD Tor proposal, was wondering is this a good place to get info? Don't want post somewhere which is being used for something else.
13:56:42 <isabela> nickm: maybe, but there is one column without any sponsors (ticket from 029 milestone)
13:56:42 <nickm> Also, does everybody understand what I mean by "sponsorY-must" vs "sponsorY-can"?  It's a little tricky.
13:56:57 <nickm> Enda: might be a good place, but we're in the middle of a meeting right now.
13:57:10 <Enda> Ah apologies I'll shh till later :)
13:57:21 <nickm> By 'sponsorY-must' I mean "We have promised this to sponsorY."
13:57:36 <nickm> and by 'sponsorY-can' I mean "We can bill this to sponsorY, but we haven't promised this specifically."
13:57:58 <asn> ack
13:57:59 <nickm> does that make sense?
13:58:07 <isabela> I also added a link to the pad I created with sponsors deliverables
13:58:07 <Sebastian> yep
13:58:16 <dgoulet> ack
13:58:17 <isabela> if anyone has questions about that I can help you
13:59:00 <isabela> it has around ~60tickets per sponsor in there
13:59:05 <isabela> sponsor S, U and R
13:59:46 <isabela> plus the table that of tickets without sponsor
13:59:46 <nickm> #action everybody fills in sponsor fields for tickets on isabela's spreadsheet, and makes sure they are accurate.
13:59:59 <isabela> tx
14:00:12 <dgoulet> oh wait you prefer the spreadsheet and not directly in trac?
14:00:13 <isabela> I think this is all we can move on, ppl can reach out to me if they have questions
14:00:26 <nickm> is there anything else from your email that we should be thinking about or working on?
14:00:47 <isabela> dgoulet: I will migrate it to trac, I prefer it for now
14:00:55 <isabela> is that ok?
14:01:13 <dgoulet> sure
14:01:59 <isabela> or you can give me csv file for the tickets you have updated
14:02:06 <isabela> you can download it from trac queries
14:02:20 <nickm> now another (hopefully) easy one.  Picking a meeting time going forward.
14:02:27 <nickm> This time is not good for everybody.
14:02:40 <nickm> Here's the doodle I circulated:
14:02:44 <nickm> http://doodle.com/poll/nvx26m4cxspryf3e
14:03:17 <nickm> I put in every time between 8am and 8pm my time.  I'm not able to go outside that range personally. :)
14:03:31 <nickm> There seems to be no time at all when everyone is free.
14:03:34 <special> (circulated where? I never saw that)
14:03:52 <nickm> special: whoops.  quick, add yourself. :)
14:03:55 <special> on it!
14:04:20 <dgoulet> (*cough* little-t@tpo distribution list *cough*) :P
14:04:31 <nickm> network-team@
14:04:34 <nickm> ?
14:04:36 <special> I'm not on network-team@
14:04:42 <nickm> I don't think there is a network-team@
14:04:44 <dgoulet> it doesn't exist to my knowledge
14:04:49 <dgoulet> nickm: yup let's do it!
14:04:50 <asn> 16:00 or 17:00 UTC on mondays seem popular.
14:04:53 <isabela> maybe we should have one
14:05:20 <dgoulet> let's open a ticket for it
14:05:26 <dgoulet> (after)
14:05:33 <nickm> #action somebody open a ticket for a network-team mailing list
14:05:53 <nickm> So, there is only one time when asn and teor are both free.
14:06:02 <nickm> if I'm reading this right.
14:06:07 <nickm> And Yawning is not available at that time.
14:06:35 <nickm> karsten is mostly metrics; while I would likke to pull him in, I think it's okay if he doesn't intersect with this schedule.
14:07:05 <special> (done)
14:07:08 <karsten> agreed! please find a time that works for people mainly working on little-t-tor.
14:07:10 <asn> and i bet even that one time is not convenient for him because it's probably like 23:00 on his timezone.
14:07:41 <nickm> asn: if you could be available one hour later, or teor could be available one hour earlier, we could get everybody at 1900 or 2000  UTC monday.
14:08:50 <nickm> alternatively, we could try 1200 UTC, but that would make Yawning, Mike, and Isabela wake up at 5am.
14:08:57 <nickm> and nobody should have to do that.
14:09:56 <nickm> we could start at 1930 and end at 2030, so everybody can make at least half of it...
14:10:22 <asn> we could try. that will be 21:30 on my TZ, which is definitely suboptimal.
14:10:39 <dgoulet> and 6:30 for teor
14:11:27 <asn> how do other teams handle this problem? this must be a very common problem of the internet era.
14:11:29 <dgoulet> so spread out in the world, this might be a loosing game to get everyone in optimal condition at the same time :S
14:11:41 <isabela> yes
14:11:48 <asn> the two meetings approach seems plausible. but also suboptimal for various reasons.
14:11:52 <isabela> that is no magical way to handle it
14:12:19 <special> in my experience you end up relying less on synchronous meetings
14:12:23 <special> which has downsides :/
14:12:38 <nickm> so, we have people on UTC-7, UTC-4, UTC, UTC+1, UTC+2 ... UTC+11.
14:12:48 <asn> nickm: oh wow :)
14:13:09 <special> (I'm in UTC+7 for the next little while)
14:14:34 <dgoulet> maybe a solution if "self organized" meetings here, for instance if nickm ever needs to know or talk to some people, they sync up, same goes for the HS team for instance or per Sponsor ?
14:14:49 <nickm> I think that having our team split up so much actually causes us problems.
14:15:04 <isabela> and it will be hard for me to follow what is going on
14:15:47 <dgoulet> fair enough
14:17:04 <nickm> maybe we _should_ aim for two events.  teor seems to be the hardest one to schedule, through no fault of his own.
14:17:36 <nickm> What if we just accept that we can't have the main meeting at a teor-compatibile time, and figure out some other way to make sure that teor stays in contact with as many of us as he finds useful?
14:18:03 <nickm> I hesitate to decide on that right now, though, since teor isn't here atm
14:18:26 <isabela> should we list these options in an email and send to the list?
14:18:39 <dgoulet> I'm pretty sure he would say that he prefers a meeting but if there are just no ways to achieve that... not much choice, as long as he is "ok" with it
14:18:39 <nickm> sounds good.  Shall I?
14:19:21 <nickm> on another channel, a friendly person suggests that we take minutes of these meetings, independent from meetbot.  That might be a smart notion.
14:19:28 <nickm> but we'd need somebody to clerk.
14:19:33 <isabela> i can
14:19:59 <nickm> did you just volunteer to clerk, or to send an email about meeting times?
14:20:37 <isabela> clerk
14:20:58 <nickm> #action isabela will write up minutes for this meeting
14:21:06 <nickm> #action nickm will send an email about meeting times.
14:21:15 <isabela> send them to tor-dev or network-team or?
14:21:32 <nickm> I'll send to tor-dev, and fwd to the folks I already asked.
14:21:48 <isabela> and my human meeting notes?
14:22:02 <nickm> tor-dev for now I think, since we don't have a network-team@ ?
14:22:07 <isabela> ok!
14:22:13 <dgoulet> public tor-dev@ yes
14:22:43 <isabela> sounds good
14:22:46 <isabela> should we move on?
14:23:02 <nickm> yes, let's.
14:23:30 <nickm> how about 0.2.8-out-the-door stuff?
14:23:58 <dgoulet> go
14:24:01 <nickm> To get an rc released, our big items are: Fix blocking issues, review their patches, do regular release diligence.
14:24:46 <nickm> I've tagged the issues that I really want us to fix with must-fix-before-028-rc:
14:25:03 <nickm> In some cases, we don't actually _have_ to, but IMO we should try.
14:25:09 <nickm> https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&keywords=~must-fix-before-028-rc&group=status&col=id&col=summary&col=keywords&col=status&col=owner&col=type&col=priority&order=priority
14:25:17 <dgoulet> one thing I thought of (maybe not on topic) but is to have a state that says "lgtm" from the reviewer because now tickets when reviewed and ack by someone stays in needs_review...
14:25:50 <nickm> do we have any  of those right  now?
14:25:59 <dgoulet> nope
14:26:46 <dgoulet> it's the "nick-review" keyword we've discussed in VLC but I feel that it should be a state
14:26:47 <isabela> +1
14:26:54 <dgoulet> needs_merge or something...
14:26:55 <nickm> in fact I think that right now 5/6 tickets in must-fix-before-028-rc are patches written by me.
14:27:00 <nickm> needs_merge would be ok with me.
14:27:15 <nickm> Also I'd like to know isabela's thoughts on release-engineering this stuff, and making broken things easier to revert
14:27:21 <dgoulet> so needs_review ticket are really in need of review and not in a "waiting state"
14:27:46 <isabela> yes
14:28:20 <isabela> nickm: i will look into it
14:28:25 <nickm> thanks
14:28:41 <nickm> so, what I'd like to advance 028 at the most is:
14:28:58 <nickm> #action if you think something is in must-fix-before-028-rc and we can let it slip, please comment on the ticket.
14:29:27 <nickm> #action dgoulet, Sebastian, teor: please take another look at the ed25519 patch and see if I fixed the issues in #18318 and #17668 ?
14:29:53 <dgoulet> nickm: ack
14:29:53 <Sebastian> ack
14:30:19 <nickm> #action let's see if we can get weasel (or somebody else) to review or test my fix for #18253
14:30:34 <nickm> dgoulet: do you need help on #18332 ?
14:30:42 <asn> me? what do I review? :)
14:30:50 <isabela> nickm: by when you want to have the final must fix list?
14:30:54 <dgoulet> nickm: I did review it and it's up to armadev to answer questiosn I guess ?
14:31:05 <dgoulet> nickm: unless we take it out of his hands?
14:31:08 <nickm> isabela: I would love to get the 028 release out next week.
14:31:13 <isabela> ack!
14:31:20 <nickm> err, the 028-rc release
14:31:39 <nickm> dgoulet: blocking on armadev is often a bad idea.  If you have open questions, let's remember to talk about them later? :)
14:32:08 <dgoulet> nickm: well the branch brokes a test and I already did some fix on that patch also... so I guess we can take it over
14:32:10 <nickm> Sebastian, teor, dgoulet: as you look at my ed25519 stuff, let me know if the issue-naming system I used works for you.  I found it very helpful.
14:32:34 <nickm> As for other stuff: there are 7 tickets in new and 3 in needs_information on that keyword.
14:32:49 <nickm> If anybody can fix any of those, or declare them safe-not-to-fix-now, that would be helpful.
14:33:17 <dgoulet> ok
14:33:22 <nickm> great!
14:33:47 <nickm> anything else for the 028 topic other than the "little t tor issue" topic?
14:34:49 <asn> maybe #17773 can be pushed out of must-fix-before-028-rc? seems like some design decisions have not been taken yet
14:35:47 <nickm> asn: please say so on the ticket? :)
14:36:04 <nickm> ok, only 2 topics left.  maybe just 1.
14:36:05 <asn> ack will do. not right now, so that I read it a bit more carefully.,
14:36:11 <asn> will do so tonight.
14:36:36 <dgoulet> (in 20 min is another meeting, I would like to take a break between those)
14:36:39 <dgoulet> much more to talk about?
14:36:42 <nickm> On the little t tor issue, athena said at the meeting last night she was working on it. I should have tried to get a time estimate on that.  I'll ask today.
14:36:55 <dgoulet> nickm: oh! ok I didn't get that
14:37:09 <dgoulet> opening a ticket then would be wise (if not a security issue)
14:37:14 <nickm> If she can't get it done by end-of-week, we should probably step in to help.
14:37:25 <nickm> I am waiting for her to tell me whether she thinks it's a security issue. :)
14:37:42 <nickm> #action nickm asks athena for ETA on bugfix.
14:38:22 <nickm> last item: I know that nobody here right now is funded through sponsorS, but we have three sponsorS deliverables by end-of-March  that are going to be eating my brain.  They are: alpha modularization framework (which I should do)...
14:38:59 <nickm> ...writing a couple controlport features from the list on #17284 (which should be not-too-hard; just pick your favorites)...
14:39:19 <nickm> ...and #17282/#17283 , which is more or less documentation and release-engineering for our testing tools.
14:39:37 <nickm> If anybody wants to jump up for those, talk to me / isabela after the meeting.
14:39:39 <nickm> sound good?
14:39:44 <nickm> isabela: anything else?
14:39:48 <isabela> nope
14:39:55 <nickm> if not I will #endmeeting in 20 seconds. :)
14:40:04 <nickm> running low on tea
14:40:06 <dgoulet> all good
14:40:19 <nickm> #endmeeting