13:30:31 <nickm> #startmeeting
13:30:31 <MeetBot> Meeting started Wed Sep  9 13:30:31 2015 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:31 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:30:34 <nickm> good morning all
13:30:37 <asn_> hello
13:30:42 <nickm> it's that lovely time again!
13:30:47 <dgoulet> hi!
13:31:03 <nickm> somebody else do  status first?
13:31:30 <asn_> ehm hello
13:31:42 <asn_> so what i've been doing the past week
13:31:50 <asn_> i worked a bit on the shared random proposal
13:32:01 <asn_> i got up to date with nick's idea of removing the SR doc.
13:32:14 <asn_> which sounds fine. especially after we spend a few days, thinking of all the complexity that an SR doc will add.
13:32:23 <asn_> i still need to wrap my head around some parts.
13:32:45 <asn_> i also opened #16943 to implement the prop250
13:32:53 <asn_> at that point i thought we were going to use an SR doc
13:33:01 <asn_> so I started refactoring the compute_consensuses() function
13:33:08 <asn_> which was too scary to add an SR doc to.
13:33:19 <asn_> now we are not going to add an SR doc after all, but maybe the refactoring is still useful.
13:33:26 <asn_> it splits that function into 4 smaller functions.
13:33:40 <asn_> my plan is to open a new trac ticket for that refactoring, since it's not going ot be very useful for prop250.
13:34:03 <asn_> then I looked a bit into the guard stuff again. i updated the guard algorithm proposal with feedback from the mailing list.
13:34:09 <asn_> and talked a bit with mikeperry on ways forward.
13:34:31 <asn_> for the past 2 days, I'm supposed to be testing the guardfraction feature.
13:34:43 <asn_> but it's not going very well. testing bw weights with chutney is very annoying.
13:34:54 <asn_> for this reason I started looking at #16386
13:35:08 <asn_> but in general, this is *very* annoying to test
13:35:25 <asn_> because bw weights are very crazy. there are some insane formulas that most of us don't understand how they work .
13:35:32 <asn_> and this guardfraction feature messes with them even more.
13:35:47 <asn_> in general, I'm not too far away from declaring guardfraction too annoying too exist.
13:35:59 <asn_> and maybe I will ask for it to get ripped off the codebase.
13:36:20 <asn_> since the problem it fixes is not that big of a problem. and we are not planning on increasing guard lifetime to 9 months.
13:36:37 <nickm> we aren't?
13:36:44 <nickm> man, nobody tells me anything ;)
13:36:47 <asn_> hehe
13:36:49 <asn_> it's on the trac page
13:37:05 <asn_> https://trac.torproject.org/projects/tor/ticket/8240#comment:50
13:37:20 <asn_> the summary is that increasing lifetime to 9 months. will give us about 7 years of protection from sybil attacks.
13:37:27 <asn_> now it's at 2-3 months. which gives us 3 years of protection.
13:37:40 <asn_> i think 3 years of protection is a lot compared to any other security guarantee that tor provides.
13:37:54 <asn_> i could be persuaded to bump it up to 4-5 months. but 9 months is a bit too much.
13:38:03 <nickm> ah interesting
13:38:19 <asn_> that's why I hate guardfraction even more. because it's like _super_ annoying feature, that requires a dirauth script and everything. just for this.
13:38:30 <asn_> anyway, I will work a bit on #16386 since it seems useful _anyhow_.
13:38:36 <asn_> and see where it takes me.
13:38:40 <nickm> ok
13:38:42 <asn_> i hope to discuss this more during the dev meeting.
13:38:53 <nickm> So, as for me, I'm trying to poke all kinds of low-hanging issues for 0.2.7
13:38:55 <asn_> so next things in my basket are #16386, SponsorR and shared random.
13:38:59 <asn_> next please! sorry for lots of text~!~!~
13:39:06 <nickm> and trying to get it actually released
13:39:18 <nickm> and trying to make sure we have sponsor S and sponsor U covered by their respective due dates
13:39:31 <nickm> and generally running around deferring too much code until 0.2.8 :)
13:40:18 <nickm> I'm trying to get into the weeds on asn_'s guard design writeup and the thread that followed from it.  I've got an idea or two on how to procede from this point, but I think my ideas need to cook a little longer
13:40:24 <nickm> and that's me
13:40:29 <nickm> next!
13:40:30 <Sebastian> I have been helping review asn and dgoulet's work, and worked a bit on fixing some bugs I uncovered recently. Patches for everything are filed and most are merged already <3 But I am not really in your team so I'll wander out again
13:40:42 <Sebastian> next :)
13:40:43 <nickm> Sebastian: you're on the team whenever you want to be!
13:40:46 <nickm> just stop by whenevs
13:41:09 <Sebastian> :)
13:42:18 <dgoulet> ok here it is:
13:42:22 <dgoulet> I've been working on tickets for 027 (code and review) in the last week or so. Lots of prop#250 also, emails, tor-dev meeting logistics and SponsorR year2 kickoff! :)
13:42:28 * dgoulet done
13:42:45 <teor> I have all the tor-side changes I want for chutney/testing merged in this release
13:42:52 <nickm> woot
13:43:10 <teor> mainly #16903 #16945 #16953
13:43:53 <teor> Now I'm trying to untangle #16069 with torrc parsing ExitPolicy lines and IPv4 and IPv6
13:44:16 <nickm> that's some hairy code written a long time ago.
13:44:21 <teor> https://trac.torproject.org/projects/tor/ticket/16069
13:44:28 <nickm> (make no assumptions that anybody sane wrote it.)
13:45:15 <nickm> anybody else with an update?
13:46:19 <nickm> ok, let's move on to discussion stuff!
13:46:28 <nickm> step up with more updates if you have 'em
13:46:44 <nickm> I think we're on track to do the hard-freeze on the 15th.
13:46:48 <nickm> if not sooner
13:46:58 <isabela> nice
13:47:20 <nickm> I think along with that I'd like to put out a beta release, fix bugs aggressively in it, and aim for an -rc some time next month
13:47:49 <nickm> I think next stop there is for me to aggressively yank "PostFreeze027" off tickets that nobody is working on and which I don't personally care much if anybody works on.
13:48:18 <nickm> Previously, it meant "I would take a patch for this if it shows up!" but if a patch isn't showing up, it's getting kinda too late for anything but the msot important 0.2.7 issues
13:48:26 <nickm> this is looking like a pretty good release to me
13:48:36 <Yawning> hm
13:48:55 <nickm> If I remove PostFreeze027 from anything you're working on, and you think we should consider it posfreeze, just put it back?
13:48:58 <nickm> hi Yawning !
13:49:00 <Yawning> hi
13:49:11 <Yawning> was showering didn't look at this window when I was done
13:50:17 <dgoulet> nickm: ack
13:50:29 <nickm> no worries; hygiene is coiol
13:50:30 <nickm> *cool
13:50:57 <nickm> any other thoughts on 0.2.7?
13:51:55 <Yawning> sec
13:53:31 <nickm> Other topics I have to discuss, and hope we can get through them without too much time:
13:53:53 <nickm> -- We need a better way to get proposals accepted/rejected/discussed/transitioned to practice.
13:54:23 <nickm> -- We should plan a retrospective evaluation of how we did on 0.2.7 so we can see what to keep for 0.2.8
13:54:24 <DonnchaC> #14846 should be ready for final review
13:54:35 <asn_> DonnchaC: nice!
13:54:58 <nickm> -- We should actually plan 0.2.8
13:55:15 <nickm> -- We should figure out what big design topics we need to be working on leading up to the dev meeting
13:55:20 <nickm> -- Gotta stay on track for S and U.
13:55:24 <nickm> Any other things?
13:55:34 <Yawning> https://github.com/Yawning/tor/compare/feature15482_fixup
13:55:37 <Yawning> can you merge that?
13:56:22 <Yawning> current code works, but the branch makes the handling of the option more consistent
13:56:28 <nickm> merged
13:56:33 <Yawning> ty <3
13:56:47 <nickm> np :)
13:56:59 * isabela thinks we could do the retrospective of 0.2.7 and planning of 0.2.8 f2f in Berlin
13:57:00 <nickm> DonnchaC: cool!  We need to get lots of code reviewed for 0.2.8
13:57:35 <nickm> isabela: neat!  I think we should maybe do a little research first though so we can remind ourselves of what we did when, what the plans were, what happened, etc
13:57:38 <dgoulet> isabela: +1
13:57:46 <nickm> isabela: does that sound plausible to do ahead-of-time?
13:58:09 <DonnchaC> nickm: Got it :)
13:58:22 <isabela> nickm: yes, and I can help organize facilitate both (triage and restrospective)
13:58:43 <nickm> cool!
13:59:07 <nickm> let's exchange some email about this, maybe on tor-dev?
13:59:16 <isabela> sim senhor
13:59:39 <nickm> #action nickm and isabela exchange email on tor-dev@ about triage for 0.2.8, retrospective for 0.2.7
14:00:12 <nickm> I think between now and the meeting, we'll have our hands full with 0.2.7, reviewing stuff that got postponed for 0.2.8, and doing S/U stuff
14:00:46 <nickm> Anybody have ideas for making sure we don't sit on proposals for so long, we evaluate them faster, and schedule them for implementation faster?
14:01:04 <dgoulet> tickets with milestone?
14:01:25 <nickm> maybe!
14:01:47 <nickm> maybe we should go over all the old ones and decide how we feel about them, and reject/accept more
14:01:59 <nickm> having anything stay "draft" after a couple of years is kinda silly
14:02:01 <isabela> spring cleaning!
14:02:06 <nickm> a ticket for each would be neat
14:02:26 <dgoulet> nickm: I agree, going over them then tickets with milestone
14:02:26 <nickm> Or instead of doing them all at once, try to prioritize
14:02:38 <dgoulet> and let'S try to avoid the ??? milestone, we'll forget about it again :)
14:02:41 <nickm> anybody want to do that this week some time?  It sounds like my kind of fun
14:02:49 <isabela> how many are there that is not implemented yet?
14:03:10 <isabela> is it more than 10?
14:03:28 <dgoulet> yes definitely
14:03:55 <isabela> they are in a git right?
14:04:09 <dgoulet> isabela: yup, torspec.git, see proposals/000-index.txt
14:04:21 <dgoulet> 27 as DRAFT
14:04:32 <isabela> ok
14:04:35 <dgoulet> 31 as OPEN
14:04:46 <nickm> see also ACCEPTED and NEEDS-REVISION
14:04:57 <dgoulet> 2 as NEEDS-REVISION
14:05:00 <dgoulet> 3 ACCEPTED
14:05:10 <isabela> draft != open?
14:06:00 <nickm> yes, though IMO they should probably be merged
14:06:39 <nickm> In proposals/proposal-status.txt in that repository is a writeup I did of the status of each proposal, a while ago, along with the date at which I updated each paragraph
14:07:25 <isabela> ok
14:07:58 * isabela can pick up this too to organize
14:08:08 <isabela> maybe we should chat more about these stuff
14:08:45 <nickm> okay, sounds good.
14:08:53 <nickm> let's chat on this one after the meeting?
14:08:58 <isabela> whatelse should be done in terms of organizing stuff and help us prioritize
14:09:04 <isabela> sure
14:09:13 <nickm> that will also probably spark the topic of "big design topics we should be working on leading up to the dev meeting" a bit
14:09:28 <nickm> the other thing to talk about for that will be to look at external deliverables for the next year in Tor
14:09:43 <nickm> final topic on my list in that case is: on-track for S and U?
14:09:57 <nickm> S seems to be wrapping up its first year nicely for Tor
14:10:13 <nickm> testing is much better, chutney is improving, integration is improving, our documentation is leading to better tests, etc etc
14:10:34 <nickm> For U OTOH, we have a lot of stuff to do for end-of-october, which will be upon us before we know it
14:11:23 <nickm> isabela: still got that who-does-what-for-Tor-for-U spreadsheet someplace?
14:11:39 <isabela> yes
14:11:42 <isabela> 1 sec
14:11:57 <dgoulet> oh would be nice to know if my name is there because i'm unaware of anything about U for me if any :)
14:11:58 <isabela> btw we have 6 weeks (if we take off this week and dev meeting week) for U
14:12:05 <nickm> yeah
14:12:28 <nickm> I'm going to be working hard on lots of stuff for U.  I am not sure I can do it all myself.  I *am* sure that if other people pick things up from me, I will have more time to help with everything
14:12:33 <Yawning> oh, right the dev meeting
14:13:07 <isabela> https://docs.google.com/spreadsheets/d/1dTva10mu-FcX8KrxRjgkFvHSyNy7aBpD9xehNuUeZ-4/edit#gid=0
14:13:21 <dgoulet> nickm: are those "things" mostly tagged in trac with SponsorU?
14:13:36 * dgoulet trying to figure out how can I pick up things
14:13:49 <nickm> see isabela's spreadsheet
14:13:54 <nickm> look in the first group of items for U ?
14:14:16 <nickm> we're farther along than that spreadsheet indicates, I believe, but we have a lot to do
14:15:24 <nickm> If I could have help with the DoS area, and the quickstart guide for new developers, that would really help a lot
14:16:02 <Yawning> hm
14:16:03 <nickm> For the improved guard node design, my current plan is to leap into the discussion of asn_ 's proposal, and to produce a python prototype of whatever the latest vesion is, and start running it an a few simulated scenarios so we can make sure it acts right
14:16:24 <nickm> and if it does, we can hack it up in C much more easily I bet
14:16:51 <nickm> but it will be great if others advance that too :)
14:17:11 <nickm> I'm going to give myself a personal repo to share my draft work on "overview of structure of tor codebase"; any suggestions for the name on it?
14:17:20 <nickm> It's getting too big to fit into a doc/INTERNALS imo
14:17:26 <Yawning> HACKING
14:17:29 <Yawning> ?
14:17:34 <nickm> too big for HACKING too
14:17:47 <dgoulet> developer guide?
14:17:53 <Sebastian> code structure.
14:18:22 <Yawning> Was-A-Deliverable-At-One-Point-Now-Out-Of-Date-Come-To-IRC.txt
14:18:54 <nickm> "a hitchhiker's guide to the tor codebase"
14:19:05 <dgoulet> there :)
14:19:14 <nickm> I have a personal repo on my home server called tor-internals.git, but that's a bit confusion-prone
14:20:57 <nickm> hm, I'll make something up I guess
14:21:10 <nickm> anybody want to help with the DoS whitepaper thing?
14:21:28 <Yawning> what sort of DoS?
14:21:35 <Yawning> HSes? relays?
14:21:38 <nickm> all
14:21:47 <Yawning> that's a lot of stuff
14:21:56 <nickm> basic idea is whitepaper enumerating DoS vectors types and whatnot, trying to classify and prioritize
14:22:04 <Yawning> and I'm already wearing my tech writer hat for the forseeable future
14:22:06 <Yawning> :/
14:22:11 <nickm> ah, then let's not wear it out.
14:22:36 <nickm> i'll just try to sketch an outline, invite others to add to it, and beg people to turn it into a whitepaper so I don't hafta
14:22:39 <nickm> should be fun
14:22:48 <nickm> anything else for today's meeting?
14:24:17 <dgoulet> nickm: what about 028 roadmap, we postpone that to Berlin or tor-dev mail ?
14:24:59 <nickm> we try to kick off with discussion on tor-dev email, and hope to firm stuff up at Berlin, along with 027 retrospective.
14:25:12 <dgoulet> sounds good
14:25:43 <nickm> anything else for the meeting?
14:26:14 <nickm> #endmeeting