13:31:06 <nickm> #startmeeting
13:31:06 <MeetBot> Meeting started Wed Sep 17 13:31:06 2014 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:06 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:31:07 <nickm> who's here?
13:31:36 * asn is here
13:31:57 * dgoulet here
13:32:01 * Yawning here
13:32:25 <nickm> I wonder if we are lucky enough to have an armadev this week.
13:32:41 <Yawning> he said something about irc access being spotty
13:32:43 <asn> armadev said that he is going to be offline for the next weeks
13:32:46 <Yawning> for the next few weeks
13:33:01 <asn> it's a pity, but that's life.
13:33:02 <nickm> I think he said "not on IRC, or at least not on backlog"
13:33:11 <asn> yeah, he said email is the best way to reach him.
13:33:17 <nickm> so there's a chance he might happen to be watching this window, I guess :)
13:33:54 <nickm> ok.  So, we released 0.2.5.7-rc, and we patched some more bugs, and I've been writing patches and merging patches.
13:34:08 <nickm> Predictably, my patches are waiting for review.
13:34:12 <asn> :)
13:34:13 <nickm> And so are other people's.
13:34:34 <nickm> I need to take a break for a day or two to work on libevent stuff soon
13:34:48 <Yawning> hey I reviewed rl1987's socks patch!  doing my part
13:34:50 <Yawning> :P
13:34:52 <nickm> probably today or tomorrow unless there's something torish where I can be really helpful
13:34:55 <nickm> thanks, Yawning !
13:36:48 <nickm> most of the interesting stuff I want to get done myself in 0.2.6 depends on the crypto hacking I did a couple of weeks back... but unfortunately, I don't know if anybody thinks they're able to review it.
13:36:58 <nickm> I _did_ test the heck out of it, I THINK
13:36:59 <asn> #8106 is in my review TODO list
13:37:01 <nickm> *think
13:37:07 <asn> which depends on the rest of the crypto stuff
13:37:24 <asn> but my TODO list is LIFO lately, and it doesn't move fast.
13:37:36 <nickm> ok. from my pov, progress on 8106 is blocking on ed25519_ref10 getting reviewed.
13:37:41 <asn> yes exactly
13:38:09 <nickm> what are other folks up to?
13:38:12 <asn> hm
13:38:14 <asn> i can go
13:38:18 <nickm> ok
13:38:23 <asn> i have been doing a few little-t-tor stuff  lately
13:38:35 <asn> i wrote a tor-dev post about the dirauth side of the guardiness stuff:  https://lists.torproject.org/pipermail/tor-dev/2014-September/007489.html
13:38:51 <asn> feedback from nickm would be great, of course. already got good feedback from sebastian
13:39:15 <asn> i'm especially looking for feedback on whether to embed stuff like "guardiness script version" and "total consensus parsed" in the dirauth votes (to improve debugging etc.)
13:39:33 <asn> i also wroet a tor-dev post about guard discovery attacks and listing some ideas: https://lists.torproject.org/pipermail/tor-dev/2014-September/007472.html
13:39:43 <asn> roger replied helpfully, and I still need to think of his reply.
13:39:47 <nickm> #action nickm should reply to https://lists.torproject.org/pipermail/tor-dev/2014-September/007489.html and https://lists.torproject.org/pipermail/tor-dev/2014-September/007472.html
13:40:14 <asn> I also wrote code for tor2web #12844. code is clean I think, and unittested.
13:40:35 <asn> while coding #12844, I found #13151 which is a fun HS bug.
13:40:47 <asn> I'm quite happy about finding #13151 :)
13:40:55 <Yawning> yeah nice catch on that
13:40:56 <asn> i also did a few erviews.
13:41:34 <asn> nickm: wrt #9321, I also posted https://lists.torproject.org/pipermail/tor-dev/2014-September/007497.html but I'm mainly waiting for feedback from NickHopper on that.
13:41:59 <asn> nickm: also it would be great, if you could take a look at my guardiness python script (#13125)
13:42:08 <asn> since that's ready for review and it won't change much anytime soon.
13:42:19 <nickm> Is there anybody else who can?  I know I'm not the only pythonista here...
13:42:27 <asn> i can try to find someone, yes.
13:42:34 <nickm> I'm happy to put it on my queue, but my queue is not a great way to actually get things done fast.
13:42:38 <asn> nickm: got it.
13:42:42 <asn> nickm: i will try to find someone then.
13:42:50 <Yawning> asn: I can do a review on that lemmie add it to my todo list
13:42:52 <nickm> maybe somebody here now? (volunteers?)
13:42:55 <nickm> thanks Yawning
13:42:56 <asn> Yawning: thanks
13:43:12 <Sebastian> I'll review it before running it. But not in the next week
13:43:23 <nickm> #action Yawning can review #13125
13:43:32 <asn> nickm: OK. I estimate around a week of work before publishing my little-t-tor #9321 changes.
13:43:33 <nickm> #action Sebastian can review #13125 , eventually.
13:43:40 <nickm> ok
13:43:43 <asn> and that's that.
13:43:50 <nickm> who's next?
13:43:50 <Sebastian> I don't have much time, can I go next?
13:43:55 <nickm> feelfree
13:44:23 <Sebastian> I worked on my routerset/bad-relays-file patch series a bit
13:44:36 <Sebastian> I've been writing down a few notes about unit tests and making the occasional patch
13:45:00 <Sebastian> Other than that, it's exam time and I didn't do much. Thanks
13:45:42 <nickm> ok, keen
13:45:44 <nickm> next?
13:45:59 <Yawning> uh, it's short
13:46:05 <nickm> ok
13:46:25 <Yawning> reviewed some stuff, mostly in project planning mode, sent arma/asn a list of stuff I want to fix in the pt/bridge code
13:46:37 <Yawning> I need to review arma's feedback
13:47:07 <Yawning> the big ones for me that I want to see done are orport less bridges and 4 hop circuits
13:47:21 <Yawning> both which have the potential to be kind of scary
13:47:27 <nickm> yah
13:47:42 <nickm> could be fun though, and would give a chance to clean up some old code
13:47:44 <Yawning> rest of my list is like "fix pt logging, make pts play nice with ipv6" and so is mostly self contained
13:48:01 <Yawning> oh and cleaning up the socks code
13:48:08 <nickm> oh hey, quick question: which pt codebases that we ship use libevent, if any?
13:48:15 <Yawning> none
13:48:27 <Yawning> obfsclient (orbot) uses libevent
13:48:33 <Yawning> but that's not strictly us
13:48:51 <Yawning> the old obfsproxy did as well iirc, but that's really deprecated at this point
13:49:13 <nickm> hm, okay.  Where's the canonical obfsclient source?
13:49:35 <Yawning> on git.tp.o
13:49:36 <Yawning> why
13:49:54 <nickm> In user/yawning/obfsclient ?
13:50:10 <Yawning> yah
13:50:30 <nickm> thx
13:50:36 <Yawning> np
13:50:48 <Yawning> some people might use the old obfsproxy still, not sure if we care
13:51:08 <nickm> Anybody else want to report?  If not, I have a couple of things I want to ask folks
13:51:17 <Yawning> I have a question as well for you
13:51:23 <nickm> ok, you first :)
13:51:38 <dgoulet> can go after, just a quick update on my situation for all of you
13:51:43 <Yawning> #13151, are we gonna back port that to 0.2.4.x?
13:51:43 <nickm> oh hey, we missed dgoulet
13:51:47 <Yawning> oops
13:51:58 <Yawning> it's a 1 byte change
13:51:58 <dgoulet> sorry :), quickly
13:52:11 <nickm> Yawning: at least some of it. "I've cherry-picked "bug13151-client" to maint-0.2.4 and merged it forward.
13:52:14 <nickm> "
13:52:18 <nickm> The client-side fix is already in
13:52:21 <Yawning> ahh ok
13:52:29 <Yawning> I should have checked before asking
13:52:31 <Yawning> ty
13:52:40 <nickm> we're still talking about whether the service-side and relay-side patches are a good idea.
13:53:37 <nickm> dgoulet: (listening)
13:53:49 <Sebastian> arma notes that the service-side fix lets you tell remotely whether the service has upgraded
13:54:05 <Yawning> (might help with the botnet garbage since that's all HS based)
13:54:07 <nickm> right.  It also lets you probe for which version of the consensus the service knows.
13:54:18 <dgoulet> It seems SponsorR is happenning and my list of stuff to work on for that passed armadev review :) thus my full time work will start at the latest November, expect a thread from armadev on some broader tasks (outside contract) that I could start with
13:54:34 <nickm> dgoulet: grand; I would love to see that
13:54:38 <Yawning> dgoulet: \o/
13:54:46 <dgoulet> for now I think as you all know, my focus will be HS stuff
13:54:50 <nickm> dgoulet: please poke me if I don't respond fast too
13:54:55 <Sebastian> but maybe it's not a big deal. I still don't think we should do it, it adds complexity, the failure mode is not so bad (hidden services mostly work), and the "I get to learn if you're on bigendian" changes to "I get to learn whether you're on littleendian and haven't upgraded"
13:55:02 <dgoulet> nickm: ok perfect thanks
13:55:27 <Sebastian> sorry dgoulet and congrats
13:55:29 <nickm> dgoulet: also, maybe consider whether you'd like to visit boston for a week or so to collaborate
13:55:38 <dgoulet> nickm: I absolutely had that in mind!
13:55:44 <nickm> great
13:55:49 <Yawning> Sebastian: yar, maybe
13:55:58 <dgoulet> nickm: once I start full time (soon) I'll for sure ping you and organize that
13:56:20 <nickm> Sebastian: ok, maybe comment on the ticket?  cpunks there deserves a response
13:56:24 <nickm> dgoulet: excellent
13:56:39 <Yawning> all y'alls should come to my corner of the world imo :P
13:56:40 <dgoulet> Yawning: armadev mention an idea on pairing each other on little-t tor stuff which basically mean I think that we can help each other and not take nickm/athena too much time for code stuff if we can figure out together
13:56:58 <Yawning> dgoulet: yeah, I saw that, sounds good to me
13:57:25 <dgoulet> Yawning: perfect so that's it for me, stay tuned for armadev email on "the creation of dgoulet TODO" :)
13:57:27 <dgoulet> thanks
13:57:51 * asn would also be interested in receiving that TODO list :)
13:57:57 <Yawning> big thing for me in doing what you just did (making a list of stuff) is balancing pt work with core tor work
13:58:01 <dgoulet> asn: ah you will no worry eheh
13:58:10 <asn> thanks :)
13:58:15 <dgoulet> asn: since I think you are also assigned to SponsorR right?
13:58:21 <asn> dgoulet: indeed
13:58:27 <Yawning> and justifying the core tor stuff that needs to happen to people that care more about pts
14:00:51 <nickm> so, one of my questions was "what should we do about 13151" and I think we've talked about that a bit
14:00:59 <nickm> another of my questions is "is 13119 a good idea?"
14:01:01 <nickm> #13119
14:01:47 * asn looks
14:02:33 <asn> i have not reviewed your branch, but it seems worth doing
14:02:39 <Yawning> ^
14:02:43 <asn> especially if you've done the coccinella work already, and it works for you
14:02:53 * asn has been using tt_* functions for a while now
14:02:56 <Yawning> I assume pending patches can also be automagically fixed up?
14:03:07 <nickm> well, that's my big issue.
14:03:26 <nickm> I can re-apply the coccinelle scripts on pending patches.  That's no problem...
14:03:47 <nickm> but if those patches make changes to the same tests that my scripts changed, we can expect merge conflicts that will need hand-resolution.
14:04:20 <Yawning> ahhh
14:04:24 <Sebastian> I think it is reasonable to expect a developer to make that change
14:04:27 <nickm> That's the only reason I'm holding back here.
14:04:52 <Yawning> meh, annoying but mechanical for the most part + what Sebastian said
14:05:01 <Sebastian> they can apply coccinelle on their tree and then generate the patch from the diff
14:06:09 <nickm> ok
14:06:17 <nickm> let's hope we don't regret this.  :)
14:07:45 <nickm> Does anybody have time to scan through the branch? I don't expect anybody to read all 11251 lines of the diff (or all 12793 lines of the git log -p), but it would be good to have a spot-check.
14:09:03 <Sebastian> I did that (scanning through it a while ago). Did it change since then?
14:09:20 <nickm> (If not, I can count coccinelle as the author and me as the reviewer. maybe.)
14:09:27 <nickm> Sebastian: since you commented on the ticket?
14:09:31 <nickm> I added one or two more commits
14:09:44 <Sebastian> oh ok. Then I don't count as a rubberstamper.
14:10:05 <Sebastian> sorry, I really need to make sure I fill my brain with a bunch of random useless facts for tomorrow now. Cheers all
14:10:10 <nickm> peace
14:10:21 <nickm> anything else for us to talk about today?
14:11:09 <Yawning> nothing from me
14:14:22 <nickm> okay then
14:14:25 <nickm> #endmeeting