13:30:33 <nickm> #startmeeting
13:30:33 <MeetBot> Meeting started Wed Aug 13 13:30:33 2014 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:33 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:30:43 <nickm> so, it's 9:30 in the morning for me.  How odd!
13:30:51 <dgoulet> o/
13:31:01 <Yawning> 22:33 local time
13:31:02 <nickm> Rather than starting out, I'll ask other folks.  How's stuff going? What are you up to?
13:31:09 <asn> I can go.
13:31:17 <asn> This week I did some work on #9321.
13:31:22 <asn> which is the guardiness stuff.
13:31:35 <asn> My script works pretty well atm, and the summary file idea seems to work.
13:31:53 <asn> Now, I'm supposed to decide on an output format for my script, and then have little-t-tor read it.
13:32:03 <nickm> cool.  Did you solve the performance issues?
13:32:12 <asn> Before proceeding to that phase, I'd like some feedback on the deployment wquestions I asked in my last comment in #9321.
13:32:15 <asn> not too many.
13:32:24 <asn> 3 months of consensuses, using summary files, can be parsed in 7 seconds.
13:32:30 <asn> it's pretty fast.
13:32:50 <nickm> seems good enough to me.  What trick did you use?
13:33:10 <asn> instead of parsing consensuses with stem, I parse  them with stem and then write them down as a compact summary file.
13:33:22 <asn> seems like parsing those things is much much faster than stem :)
13:33:33 <nickm> hm.  I wonder what stem is doing that's so slow.
13:33:35 <Yawning> oh, that's the same trick torps uses
13:33:39 <asn> it's parsing the whole consensus
13:33:41 <asn> validating options etc.
13:33:47 <asn> my summary files only contain information that I care about.
13:33:59 <asn> so yeah, I'd love some feedback in https://trac.torproject.org/projects/tor/ticket/9321#comment:22
13:34:03 <asn> so that I can proceed.
13:34:07 <asn> in the meanwhile, i'v ebeen doing other stuff.
13:34:17 <asn> i've decided to be a bit social, and wrote some ideas in [tor-dev] in case I can get some feedback.
13:34:40 <asn> specifically, I started a thread about Introduction Points and rend-spec-ng: https://lists.torproject.org/pipermail/tor-dev/2014-August/007335.html
13:34:41 <nickm> asn: what are your questions on that comment?  I see a design but not any questions there.
13:34:49 <asn> nickm: you are right.
13:34:57 <asn> nickm: i'm interested in learning if the design is sane.
13:35:06 <asn> and if it will fit well with the rest of the dirauth sysadmin work.
13:35:13 <athena> it goes; finally have an apartment starting friday, so hopefully less suffering from flaky hotel internet soon.  been testing the second revision of ioerror's #12585 patch, code review up soon.  i still don't approve of the redundancy in some of the code but the patch definitely works and is a good feature to have
13:35:25 <athena> also i have a fix for #6456 in needs_review
13:35:41 <asn> i can review #6456 athena
13:35:54 <Yawning> same
13:35:58 <asn> nickm: i'm mainly worrying about the file management part of #9321
13:36:09 <asn> nickm: that is, how you keep summary files organized. how you keep consensuses organiezed.
13:36:10 <Yawning> athena: and agree on the redundancy in the sockssocket code
13:36:21 <asn> nickm: so that you don't end up with 18 months of consensuses nad summary files and you only care about 9 months.
13:36:24 <nickm> copy-and-paste code is teh evil; let's eliminate it
13:36:33 <Yawning> I understand why it's split currently but I'm more of the opinion that it should be split later when needed
13:36:50 <Yawning> (I also reviewed the same patch I think, found some minor bugs)
13:36:52 <nickm> #action nickm should respond to comment 22 on #9321
13:36:54 <asn> nickm: so anyway, I send that email about IPs. and I just sent an email about #12595 and the network down event:  https://lists.torproject.org/pipermail/tor-dev/2014-August/007346.html
13:37:06 <athena> Yawning, nickm: agree those functions should be mergedfor now and if there's reason to split them later, it can be done then.
13:37:11 <asn> nickm: these are things that I have been thinking about lately, and maybe people from the community have good ideas about :)
13:37:11 <nickm> #action nickm should comment about file mgt on 9321
13:37:19 <asn> nickm: great :)
13:37:34 <asn> nickm: and that's that for me. my plan for the rest of the week is to continue work on #9321 and see how those threads develop.
13:37:46 <nickm> athena: cool.  Glad to hear about the apartment.  I guess you'd also like more comments on your tor-dev thing?
13:37:47 <asn> if no one comments on the issues in these threads, I will have to think of something on my own.
13:37:50 * asn is done.
13:37:56 <nickm> err
13:38:02 <nickm> athena: cool, glad to hear about the apartment
13:38:10 <nickm> asn: I guess you'd also like morecomments on the tor-dev thing?
13:38:19 <nickm> asn: Does it identify what the issues are that you have questions about?
13:38:40 <asn> nickm: comments by you in anything are generally welcome
13:38:52 <asn> nickm: however, other people could contribute in a helpful way too, if you are too busy.
13:38:53 <nickm> #action nickm and everybody else should comment on asn's tor-dev thread
13:39:14 <athena> nickm: tor-dev thing?
13:39:19 <asn> i don't remember if both threads have consise questions that need to be answered.
13:39:22 <nickm> athena: sorry that was for asn
13:39:25 <athena> oh, was that meant to be addressed to asn rather than me?
13:39:26 <asn> but they are definitely well marked discussion topics
13:39:27 <athena> ah, okay
13:39:28 <nickm> y
13:39:37 <asn> athena: https://lists.torproject.org/pipermail/tor-dev/2014-August/007346.html and  https://lists.torproject.org/pipermail/tor-dev/2014-August/007335.html
13:39:43 <athena> right, okay
13:39:45 <asn> and that's that. thanks for you attention folks.
13:40:01 <athena> i'll try to say something intelligent when i have more caffeine in my systrem :)
13:40:12 <Yawning> asn: it's hs stuff right?
13:40:25 <asn> Yawning: the IP stuff yes. the other is entry guards stuff.
13:40:25 <nickm> athena: 6456 at first skim looks decent.  How's the coverage?
13:40:46 <asn> Yawning: you could be helpful in the entry guards stuff (today's email)
13:41:12 <Yawning> mmk
13:41:18 <asn> #action asn should review #6456
13:41:18 <athena> nickm: i did 100% coverage of the two old functions before i merged them; it has 100% on the new merged function as well
13:41:42 <asn> great!
13:41:51 <nickm> ok. quick suggestion before merge: The uhnit tests should make sure that the arguments to the mock functions have the right values, I think.
13:42:18 <nickm> else the functions could pass the tests without actually parsing the transport lines correctly
13:43:39 <nickm> athena: sound ok?
13:44:20 <athena> yeah, think so.  comment to that effect on the ticket?
13:44:29 <nickm> ok
13:44:39 <nickm> thanks
13:44:51 <nickm> athena: what are your plans over the next week or so?
13:45:27 <nickm> (and who else has been up to/will be up to stuff?)
13:46:00 <Yawning> THe only little-t tor stuff I did was look at your trundle code on and off and the sockssocket review
13:46:05 <athena> find a couple more bugs to hack on, unless higher-priority matters intrude
13:46:39 <dgoulet> Yawning: trunnel ? :P
13:46:53 <Yawning> Probably going to be stuck on pt stuff to the end of the month ish, then start scoping out the pt related little-t wtor work
13:46:56 <Yawning> me spel gud
13:47:17 <nickm> athena: all: Maybe let's do more 0.2.6 triage after the meeting?
13:47:52 <nickm> I could also use a quick review on #12848 if that can happen today.  Else I'll just merge it
13:49:01 <nickm> Yawning: sounds good.  I think I am pretty close to calling trunnel v1.0 stable and not touching it any more, unless somebody finds issues.
13:49:11 <nickm> It would be neat to have some code review on trunnel, its design, its output, etc.
13:49:25 <nickm> but I think right now my verdict would be "let's use it in Tor 0.2.6"
13:49:34 <asn> nickm: may I suggest you send a mail to [tor-dev]?
13:49:43 <asn> with some links on its design, and its output?
13:50:01 <Yawning> (the pt related little t tor changes are the bridge stuffasn and I talked about at paris, and maybe looking at our socks implementation, unless more stuff shows up)
13:50:06 <nickm> #action nickm emails tor-dev about Trunnel
13:50:20 <asn> thanks.
13:50:23 <Yawning> but need to get through this obfs4 cleanup first
13:50:24 <nickm> Yawning: doing proposal 229 for the socks implementation maybe?
13:50:28 <Yawning> yah
13:50:34 <nickm> what's the bridge stuff from paris?
13:50:45 <Yawning> it's on the road map sec
13:50:47 <athena> nickm: yes to 0.2.6 triage
13:50:54 <asn> nickm:
13:50:56 <asn> remember bridge details (#12600)
13:50:56 <asn> update bridge IP from Auth (​#6010)
13:50:56 <asn> transport in normal desc (#12442)
13:50:57 <asn> Obfsbridges should hide ORPort (#7349)
13:51:06 <Yawning> ah asn beat me to it
13:51:08 <asn> and some more, I think.
13:51:23 <Yawning> some ipv6 related fixes iirc
13:51:26 <asn> yeah
13:51:45 <Yawning> I want pts to playu nice in dual stack enviornments
13:52:08 <nickm> asn: wow
13:52:12 <Yawning> I think for me the ipv6 stuff and #7349 are the high priority ones
13:52:13 <nickm> sounds like a lot of things
13:52:16 <nickm> athena: cool
13:52:36 <asn> nickm: indeed. some of them are serious projects.
13:52:40 <Yawning> but we'll see, also need to deal with pt stuffs
13:54:23 <Yawning> I still need to figure out a good way to do bridge reachability testing when bridges don't have an or port
13:55:21 <asn> Yawning: one way would be to leverage the bridge_reachability test that OONI is developing currently.
13:55:33 <asn> Yawning: and use that in the bridge auth.
13:55:42 <Yawning> hmm
13:55:49 <Yawning> could work
13:56:15 <asn> another cheap way, would be doing a TCP connect() scan on the obfsports ;)
13:56:20 <asn> but that's not nice.
13:56:47 <asn> hellais: ^
13:57:04 <asn> hellais: see above for another use case of bridge_reachability that should be taken into account IMO
13:57:13 <Yawning> I have to look into how the bridge auth currently works
13:57:38 <asn> unfortunately that's one of the least documented parts of the infra
13:58:04 <karsten> why do this at the bridge auth, not bridgedb?
13:58:28 <asn> karsten: yeah, that's a good point.
13:58:58 <Yawning> hmm yeah
13:58:59 <karsten> isis, sysrqb: ^
13:58:59 <asn> maybe bridgedb is more appropriate.
13:59:11 <Yawning> more stuff to think about
13:59:32 <nickm> Anybody else to check in?
14:00:31 <nickm> ok, I'll go then.
14:00:54 <nickm> I finished trunnel (I hope) this weekend.  I think it has the features that Tor actually wants.
14:01:09 <nickm> Also, I patched proposals prop#220 and prop#224 to not have dumb stuff trunnel can't handle. :)
14:01:30 <nickm> said dumb stuff being: a uint24, and a big list of structs terminated with the byte 0.
14:02:06 <nickm> trunnel coverage is at 99% for the generator, and 99% for  the generated code. I am pretty sure that the remaining unreached generated code is unreachable.
14:02:21 <nickm> Branch coverage is also pretty high (if you build with NDEBUG), though I forget how high
14:02:41 <nickm> I also wrote a manual for it
14:03:07 <nickm> then, monday, I got back to scheduling Tor for the next N months, and found that the notes I took from the dev meeting still seemed almost right, but I need to cross-reference everything
14:03:30 <nickm> Yesterday, cypherpunks found a bug #12848 which might be causing some trouble around #12184, though I don't think it's the root cause
14:03:41 <nickm> I also started learning coccinelle.  Has anybody else tried it?
14:04:38 <Yawning> I have not, looks neat
14:05:01 <nickm> It's a lot better than writing and testing all those patches by hand
14:05:12 <nickm> It is basically a semantic patch tool
14:06:51 <nickm> here's the first patch I wrote: http://paste.debian.net/115361/
14:07:34 <hellais> asn: yes you could indeed use the bridge reachability test for something like that. My hope is also that the collection infrastructure for the bridge reachability tests will be integrated into brigedb
14:08:09 <nickm> Do we not have tor_reallocarray? I could have sworn I added it at some point
14:10:28 * asn looks at coccinelle
14:10:38 <asn> hellais: ack
14:10:50 <nickm> asn: Basically, it lets you do automated things to rewrite C safely
14:13:19 <asn> should we #endmeeting or something?
14:13:26 <Sebastian> So, I looked through a bunch of Tor code to see if there's anything that might break if we don't use any named flags
14:13:27 <nickm> I guess so.
14:13:30 <nickm> #endmeeting