19:01:07 <rl1987> #startmeeting
19:01:07 <MeetBot> Meeting started Wed Jun 11 19:01:07 2014 UTC.  The chair is rl1987. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:07 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:34 <rl1987> don't really know how to use it myself.
19:01:41 <athena> hi meeting
19:01:43 <rl1987> #help
19:01:58 <nickm> rl1987 remember to stick around until the end of the meeting so you can say "#endmeeting".
19:02:05 <rl1987> yes.
19:02:08 <nickm> hi athena
19:02:14 <nickm> #topic 0.2.5.5
19:02:25 <rl1987> #topic 0.2.5.5
19:02:28 <nickm> hm.  that seems to be a chair only thing
19:03:22 <nickm> So, for 0.2.5.5, there are 3 tickets left to review.  None is terribly big.  I'm tempted to just merge them all.  unless athena thinks she can look at them today/tomorrow-ish?
19:05:33 <nickm> The tickets are #12184, #8746, and #12191.
19:06:31 <nickm> I am pretty sure that #12191 is correct: my only question is whether to put it in 0.2.5.  I lean yes, since it could conceivably be related to #12184 (though I doubt it)
19:07:14 <nickm> #12184 is pure diagnostic code; it should be a comparatively easy review.
19:07:24 <nickm> #8746 is process-control code, but should be fairly simple for that
19:07:44 <nickm> #12184 is something we need to fix, and better diagnostics will help us, so putting that off doesn't seem like an option
19:08:06 <nickm> and #8746 is a "send SIGINT to the wrong process" bug, so we shouldn't leave that lying around or it might hurt somebody
19:08:15 <nickm> athena: what do you think about reviewing those?
19:08:29 <athena> okay, think i agree with keeping them in 0.2.5
19:08:47 <athena> uh, can review when i've gotten closer to being awake :)
19:09:00 <nickm> think you can get through them today/tonight?
19:10:59 <athena> yeah, think so
19:11:19 <nickm> that would rock.  I think 0.2.5.5-alpha might be the last alpha in this series
19:11:25 <athena> woot
19:11:30 <nickm> depending on how well our #12184 and #8387 diagnostics work
19:12:04 <nickm> #action athena tries to review the 3 remaining 0.2.5.5-alpha needs_review tickets
19:12:38 <nickm> #action once the remaining tickets are reviewed, nickm starts the ball rolling on getting 0.2.5.5-alpha out.
19:12:46 <meejah> #commands
19:12:46 <MeetBot> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #rejected #restrictlogs #save #startmeeting #topic #unchair #undo #unlurk
19:13:21 <Yawning> #yolo #twitter #swag
19:14:10 <nickm> So, the next topic...
19:14:19 <nickm> #topic planning 0.2.6 and beyond
19:15:20 <nickm> We have a bunch of tickets in needs_review for 0.2.6
19:15:26 <nickm> and a bunch of bugs in 0.2.6
19:15:31 <nickm> and some big features we want to do "soon"
19:16:10 <nickm> and an ongoing ambition to get releases out more rapidly.
19:16:41 <nickm> I think we should probably start out by reviewing a bunch of the stuff pending in 0.2.6.
19:17:00 <nickm> seem plausible?
19:17:19 <athena> yeah, think so
19:19:08 <nickm> maybe we should start with a self-review: foreach patch that we wrote ourselves: do we still like it?  Do we still think it should go in as-is?
19:21:25 <athena> certainly seems like a good idea for things that have been hanging around long enough to look back at with fresh eyes
19:21:44 <nickm> I think for some stuff we might say "This is crap and isn't mergeable without tests"
19:21:57 <nickm> we might even say "This isn't a good idea; nothing would use it!" or "Why would you even" or something.
19:23:12 <nickm> at that point, we should also think about dev priorities.  We have some big ones (hidden services, ed25519 keys, guard node improvements) but IMO we shouldn't say "no 0.2.6 without these".
19:23:38 <nickm> They are all important, but everything is important.
19:23:49 <nickm> well, not everything.
19:24:01 <nickm> I wonder if we should set aside some time once 0.2.5.5 is out for 026-triage
19:24:19 <nickm> And IMO we should also do an 0.2.5 postmortem.
19:25:02 <nickm> like, we froze a few months ago.  Why did it take so long to get it kinda stable?
19:25:14 <nickm> did we mis-handle the freeze or what?
19:25:32 <nickm> or do we really need to plan 3 months dev, 3 months debugging for every release?
19:25:48 * armadev exists
19:25:53 <nickm> hi armadev
19:26:37 <nickm> athena: do you want to try to come up with some ideas too, looking back on our 0.2.5.5 schedule and what happened when, or do you think it would be more fruitful for me to try to do that myself?
19:30:23 <athena> nickm: probably you yourself unless you want to wait for me to be markedly more alert than at the present moment
19:30:34 <nickm> ok. then
19:30:49 <nickm> #action nickm will review what happened with 0.2.5.5 when, and see what mistakes we made.
19:31:28 <nickm> #action once we have the 3 remaining items merged to master, nickm and athena will look at our own tickets in needs_review/needs_revision for 0.2.6, and see if any are really bad ideas or need more revision.
19:31:40 <nickm> #action nickm and athena will pick a time to meet for 026 ticket triage
19:32:00 <athena> although i'm inclined to say half "yeah, plan debugging time" and half "fewer outside assholes chewing up my life (out of this damn apartment in two more weeks, yay)"
19:32:30 * isis doesn't wish to distract, but wants #12254 to have some feedback so that she can work on it for 0.2.6
19:34:41 * nickm comments on it
19:34:57 <isis> super!
19:38:28 <nickm> anything else for this meeting?
19:39:25 <nickm> isis: commented
19:40:46 <rl1987> endmeeting?
19:41:05 <nickm> sure
19:41:42 <rl1987> #endmeeting