#reproducible-builds Meeting

Meeting started by h01ger at 14:59:48 UTC (full logs).

Meeting summary

  1. welcome to this monthly meeting, please briefly introduce yourself or update us on recent or planned projects (h01ger, 15:00:04)
  2. short time slot for checkins from various projects (h01ger, 15:07:41)
  3. short time slot for checkins from various projects: DebConf21 quick infos (h01ger, 15:08:47)
  4. short time slot: Debian: snapshot.d.o mirror status update (h01ger, 15:12:15)
    1. the status is here: https://debian.notset.fr/rebuild/results/ (h01ger, 15:15:45)
    2. in-toto metadata are here: https://debian.notset.fr/rebuild/sources/ (h01ger, 15:15:55)

  5. short time slot: Debian: rebuilder status update (h01ger, 15:17:24)
  6. short time slot: Arch Linux: rebuilder status update (h01ger, 15:18:43)
    1. https://vulns.xyz/2021/08/monthly-report/ (lamby, 15:20:34)

  7. short time slot: Debian live-build (h01ger, 15:36:59)
    1. summary at https://lists.reproducible-builds.org/pipermail/rb-general/2021-August/002352.html (h01ger, 15:37:29)
    2. it looks like an android RB bug might soon be fixed: https://issuetracker.google.com/issues/195968520 (requires google login) (h01ger, 15:44:01)
    3. https://github.com/obfusk/apksigtool (h01ger, 15:48:02)

  8. short time slot: i-probably-didnt-backdoor-this (h01ger, 15:51:49)
    1. https://github.com/kpcyrd/i-probably-didnt-backdoor-this (h01ger, 15:52:08)

  9. r-b ecosystem (h01ger, 15:54:56)
    1. https://pad.riseup.net/p/rb-irc-meetings-keep (kpcyrd, 15:56:31)
    2. https://pad.riseup.net/p/rbecosystemmapping-keep (lamby, 15:56:50)

  10. r-b.o/docs/rebuilders and conflict with r-b.o/tools (h01ger, 15:59:44)
    1. https://reproducible-builds.org/docs/rebuilders/ (h01ger, 16:01:17)
    2. https://reproducible-builds.org/tools/ (h01ger, 16:01:23)
    3. ACTION: h01ger will look into adding categories to the tools page and/or linking with the rebuilders page (h01ger, 16:04:35)

  11. Where to put reproducible information (specifically for the live images) (h01ger, 16:05:45)
    1. ACTION: rclobus will contact the list and discuss the plan further. Thank you all for the input. (rclobus, 16:12:32)
    2. the plan is to put .buildinfo data in git, access it with a signed git tag (like tails) and then distribute the iso hash together with that git tag information (h01ger, 16:13:22)

  12. any other business (AOB) (h01ger, 16:15:23)
  13. any other business - anyone here involved with robotnix? (h01ger, 16:15:39)
    1. https://nlnet.nl/project/Robotnix/ (obfusk, 16:16:04)
    2. Robotnix enables a user to easily build Android (AOSP) images using the Nix package manager. (h01ger, 16:16:47)

  14. any other business - anyone here involved with ghc? (h01ger, 16:18:04)
    1. a major chunk of the remaining unreproducible packages in Arch Linux are currently haskell related (h01ger, 16:19:14)
    2. the relevant issue is https://gitlab.haskell.org/ghc/ghc/-/issues/12935 (h01ger, 16:19:21)

  15. any other business - anyone here involved with R? (h01ger, 16:21:42)
  16. any other business ??? (h01ger, 16:23:03)
  17. next meeting: last tuesday of the month, 28th september 2021, 15 UTC (h01ger, 16:38:15)


Meeting ended at 16:39:53 UTC (full logs).

Action items

  1. h01ger will look into adding categories to the tools page and/or linking with the rebuilders page
  2. rclobus will contact the list and discuss the plan further. Thank you all for the input.


Action items, by person

  1. h01ger
    1. h01ger will look into adding categories to the tools page and/or linking with the rebuilders page
  2. rclobus
    1. rclobus will contact the list and discuss the plan further. Thank you all for the input.


People present (lines said)

  1. h01ger (172)
  2. kpcyrd (48)
  3. lamby (37)
  4. obfusk (24)
  5. rclobus (19)
  6. fepitre (18)
  7. Foxboron (10)
  8. jelle (8)
  9. rgdd (7)
  10. Ariadne (5)
  11. kfreds (4)
  12. rrnewton (4)
  13. sangy (3)
  14. Cadero (2)
  15. MeetBot (2)
  16. vagrantc (1)
  17. raboof (1)


Generated by MeetBot 0.1.4.