#reproducible-builds Meeting

Meeting started by h01ger at 15:00:01 UTC (full logs).

Meeting summary

    1. https://pad.riseup.net/p/rb-irc-meetings-keep has the agenda (h01ger, 15:00:22)

  1. welcome to this monthly meeting, please briefly introduce yourself (h01ger, 15:00:45)
  2. what shall this monthly meeting be about? (h01ger, 15:11:17)
    1. h01ger has edited the next meetings agenda based on suggestions here (same url as current meetings agenda, just scroll down) (h01ger, 15:28:34)

  3. NixOS: reproducible minimal ISO (raboof) (h01ger, 15:31:33)
    1. in NixOS we recently hit the (somewhat arbitrary) milestone of having our minimal ISO image reproducible (h01ger, 15:36:09)
    2. this was somewhat unexpectedly picked up by HackerNews (https://news.ycombinator.com/item?id=27573393) (h01ger, 15:36:20)
    3. https://r13y.com/ (h01ger, 15:36:41)
    4. https://status.nixos.org/grafana/d/cUz63QLWz/reproducibility-of-nixos-unstable-iso_minimal-x86_64-linux (h01ger, 15:36:50)

  4. Debian: a brief intro to https://debian.notset.fr/snapshot/ (fepitre/h01ger) (h01ger, 15:40:41)
    1. https://debian.notset.fr/snapshot/ is a snapshot.d.o amd64 mirror (h01ger, 15:41:37)
    2. there (h01ger, 15:41:44)
    3. there's API documentation: https://github.com/fepitre/debian-snapshot#api (h01ger, 15:41:50)

  5. live-builds (rclobus) (h01ger, 15:48:58)
    1. https://lists.reproducible-builds.org/pipermail/rb-general/2021-June/002288.html (h01ger, 15:49:38)
    2. https://wiki.debian.org/ReproducibleInstalls/LiveImages (h01ger, 15:52:33)
    3. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907751 (obfusk, 15:58:24)
    4. https://github.com/bmwiedemann/reproducible-faketools/blob/master/reproducible-faketools.spec#L146 (bmwiedemann, 15:58:27)

  6. Debian: let's do a rebuilder now (h01ger) (h01ger, 16:00:16)
    1. https://github.com/fepitre/debrebuild - fepitre do you want to say few words? (marmarek, 16:02:15)
    2. https://salsa.debian.org/debian/devscripts/-/blob/master/scripts/debrebuild.pl is the one from src:devscripts so available in bullseye right now (h01ger, 16:14:05)
    3. https://github.com/bmwiedemann/reproducibleopensuse/blob/master/nachbau is the build portion of my rebuilder/verifier (bmwiedemann, 16:14:50)
    4. AGREED: we shall document the different existing rebuilder and orchestration tools for debian (h01ger, 16:17:54)
    5. AGREED: (and then probably include other distros too if the rebuilders can rebuild more than one distro...) (h01ger, 16:18:23)
    6. h01ger suggests to use https://reproducible-builds.org/docs/ (h01ger, 16:18:37)
    7. https://pad.riseup.net/p/rebuilders%2Borchestration-tools (h01ger, 16:21:52)

  7. SecureDrop (h01ger, 16:26:02)
  8. Any Other Business (AOB) (h01ger, 16:30:06)
    1. progress on reproducible alpine: https://twitter.com/sn0int/status/1408853977106718724 (h01ger, 16:36:27)


Meeting ended at 16:52:15 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. h01ger (181)
  2. obfusk (45)
  3. sangy (40)
  4. fepitre (33)
  5. vagrantc (26)
  6. rclobus (23)
  7. bmwiedemann (19)
  8. lamby (17)
  9. kushal (16)
  10. raboof (14)
  11. rgdd (13)
  12. kpcyrd (12)
  13. marmarek (8)
  14. elibrokeit (7)
  15. Foxboron (5)
  16. gchristensen (4)
  17. dongcarl (3)
  18. jelle (3)
  19. MeetBot (2)
  20. tobiaswiese (1)
  21. ericonr (1)
  22. realtime-neil (1)


Generated by MeetBot 0.1.4.