17:58:17 <h01ger> #startmeeting
17:58:17 <MeetBot> Meeting started Mon Nov 23 17:58:17 2020 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:17 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:21 <h01ger> hi! :)
17:58:38 <h01ger> #topic say hi and amend/review the agenda at https://pad.sfconservancy.org/p/reproducible-builds-meeting-agenda
18:00:28 * vagrantc waves
18:00:37 <bmwiedemann> Hi. Bernhard M. Wiedemann here
18:00:37 * vagrantc = Vagrant Cascadian
18:01:19 <vagrantc> does meetbot record the /me = NAME ?
18:01:28 <h01ger> #save
18:01:51 <h01ger> http://meetbot.debian.net/reproducible-builds/2020/reproducible-builds.2020-11-23-17.58.log.txt has them
18:02:49 * kpcyrd = kpcyrd
18:02:57 <vagrantc> just wondering if it expected any particular syntax for the introductions
18:03:07 <sangy> Santiago "sangy" Torres-Arias here
18:03:54 <h01ger> vagrantc: not really
18:04:29 <h01ger> so i guess we we are good to start the main part :)
18:04:43 <h01ger> #topic topic specific meetings: review of the last one
18:05:02 <h01ger> when was it? the topic was debugging?
18:05:50 <vagrantc> yeah, basically we had different people from different distros describe their workflow and tooling
18:06:37 <bmwiedemann> https://pad.sfconservancy.org/p/reproducible-builds-debugging has some notes, but could be extended
18:06:44 <h01ger> #info the log from that debugging meeting is at http://meetbot.debian.net/reproducible-builds/2020/reproducible-builds.2020-11-16-18.08.html
18:06:45 <vagrantc> i think we covered archlinux, debian opensuse and a little shout-out to guix
18:06:59 <h01ger> #info https://pad.sfconservancy.org/p/reproducible-builds-debugging has some notes, but could be extended
18:07:32 <h01ger> (anyone can inform meetbot about stuff to log/note by using #info)
18:07:33 <vagrantc> it was a small meeting, but i really enjoyed it :)
18:07:41 <h01ger> nice :)
18:08:01 <bmwiedemann> also, the etherpad will be deleted in a while, so we should think about a place to keep what is useful
18:08:02 <h01ger> is there any followup planned? action items?
18:08:38 <h01ger> bmwiedemann: i guess on the website under /docs?
18:08:40 <vagrantc> i think it was mostly a skillshare session, not sure we targetted anything needing followup
18:09:00 <vagrantc> other than taking some notes, perhaps :)
18:09:34 <h01ger> as bmwiedemann pointed out, the notes will vanish. so we should preserve somehow, even if only by posting them on the list
18:09:40 <bmwiedemann> sharing in a form that is useful to more people than the 3 of us
18:09:44 <h01ger> (then we can refer to them in the monthly log too)
18:09:59 <vagrantc> the log itself isn't sufficient?
18:10:08 * vagrantc looks at the notes
18:10:50 <vagrantc> ah, yes.
18:11:00 <bmwiedemann> lengthy chat logs are not my favourite read ;-)
18:11:05 <vagrantc> true enough
18:11:06 <kpcyrd> I'd like to +1 "very eduated guessing", I pretty much exclusively track down root cases with diffoscope
18:11:16 <kpcyrd> *causes
18:11:26 <kpcyrd> regardless of the distro
18:11:38 <vagrantc> true enough
18:11:50 <h01ger> bmwiedemann: can/will you take care of preserving the notes?
18:11:55 * vagrantc is stuck in a loop :)
18:12:04 <h01ger> or should i ask vagrantc? O:-)
18:12:17 <vagrantc> maybe just a post to the list with the notes, and link to the meeting summary/log that meetbot generated
18:12:21 <kpcyrd> reprotest needs quite a bit of tweaking for some build systems, for example tampering with the time breaks a lot of arch builds
18:13:35 <h01ger> the topic right now is review of the last topic meeting and the open question at hand is whether the results of that meeting should be preserved and if so how and who does it
18:14:32 <bmwiedemann> I can at least post the etherpad content to rb-general. Will do tomorrow, so if you think of more to add, you have some time
18:14:44 <vagrantc> great!
18:14:46 * jelle waves
18:15:13 <h01ger> #action bmwiedemann will post the results on the list
18:15:47 <h01ger> #topic topic specific meetings: plan the next one: pick topic(s) for future (2020-11-30?) topic-specific irc sessions
18:16:12 <h01ger> vagrantc: the date is 2020-11-30? at which time? what will the topic be?
18:16:13 <vagrantc> i think we're pretty well scheduled if you look at the bottom of the agenda
18:16:24 <h01ger> oh, ic
18:16:29 <h01ger> which time?
18:17:12 <vagrantc> the office hours i think we decided ... 17-19UTC ... it's basically just a few people committing to be there and available
18:17:26 <h01ger> #info next topic irc meeting: 2020-11-30, topic will be "open office hours Q&A session", time: 17-19 UTC
18:17:32 <vagrantc> and possibly doing that on an ongoing basis
18:17:42 <vagrantc> e.g. and hour before and after our monday meetings
18:17:48 <h01ger> #info that will be on #reproducible-builds on irc.oftc.net
18:17:50 <vagrantc> er, an hour
18:17:57 <h01ger> ic, nice!
18:18:11 <h01ger> vagrantc: will you send an announcement to the list?
18:18:13 <vagrantc> just need to do some outreach on it ...
18:18:24 <vagrantc> #action vagrant will post about office hours
18:18:28 <bmwiedemann> btw: for me later works better, but I guess, it will also work if some people are there some of the time
18:18:54 <h01ger> #save
18:18:56 <vagrantc> bmwiedemann: or maybe 17-20 (e.g. ending at 20UTC
18:20:08 <vagrantc> it's a work-in-progress how it goes and ... maybe nobody shows up ... we'll see :)
18:20:35 <h01ger> if there's no announcement, i wont be surprised if not that many people show up :)
18:20:41 <kpcyrd> I still think weekly is rather frequent
18:20:42 <vagrantc> we were also planning on a strategy meeting for the 14th
18:21:19 <vagrantc> kpcyrd: the general meetings are every other week, and the topic specific meetings the other weeks?
18:21:24 * h01ger is also a bit hmm about those weekly meetings now. we designed these as bi-weekly meetings
18:21:37 <bmwiedemann> I can write on our subreddit (with a whopping 69 members)
18:21:45 <h01ger> bmwiedemann: please do!
18:22:03 <vagrantc> not everybody has to be at every meeting ... just like at the summits ...
18:22:41 <h01ger> as they are at the same day+time, the diff also becomes blurry
18:23:10 <vagrantc> alternately, we can only schedule one topic-specific meeting per month ... or do fewer "general" meetings ...
18:23:33 <bmwiedemann> I like the cadence. Makes planning ahead much easier.
18:23:35 <vagrantc> so this has come into a bit of a meta-discussion
18:24:03 <h01ger> well, we are discussing the next meeting :)
18:24:07 <vagrantc> indeed :)
18:24:08 <bmwiedemann> and 50x1h is equivalent of 5 days with 10h of yearly summit
18:24:28 <jathan> Hi everybody. Attending and reading to learn :)
18:24:46 <h01ger> hi jathan
18:24:59 <jathan> h01ger: Hallo!
18:25:42 <h01ger> vagrantc: i'm also not sure these open office hours before and after the meetings are a good idea but we will see. (eg before i'm afraid the discussion might leak into the meeting and after the meeting i'm hungry for dinner)
18:25:50 <h01ger> but i guess we will see :)
18:26:09 <h01ger> next topic? or continue discussion?
18:26:34 <vagrantc> h01ger: it's a sneaky trick to get new people involved ... come, ask questions, stay for the meeting :)
18:26:44 <bmwiedemann> smart
18:26:57 * h01ger is not convinced.
18:27:10 <bmwiedemann> no harm in trying
18:27:11 <vagrantc> it can only hurt so much to try
18:28:06 <kpcyrd> next topic?
18:28:13 <vagrantc> sure
18:28:41 <h01ger> #topic any other business
18:29:18 <vagrantc> so, we've mostly discussed the topic-specific meetings at the last two meetings...
18:29:28 <vagrantc> we could use some other business :)
18:29:35 <h01ger> well, we also established having irc meetings again
18:29:40 <vagrantc> true
18:31:18 <h01ger> kpcyrd: you added 'running an arch linux rebuilder on r-b infra' to the topic suggestions for the topic meetings and i dont think thats a good topic. i mean, the answer is 'yes, please do & send patches'. what do you want to discuss in a meeting? :)
18:31:48 <bmwiedemann> maybe a workshop?
18:31:50 <kpcyrd> h01ger: where should I send patches?
18:32:05 <kpcyrd> rebuilderd doesn't depend on jenkins
18:32:14 <h01ger> kpcyrd: there are currently two arch rebuilders on r-b.o infra: the ci tests (currently down because of an hw issue at osuosl) and another from aparcar[m] which is work in progress (and should probably be taken down)
18:32:29 <kpcyrd> tests.r-b.org is not a rebuilder
18:32:35 <h01ger> kpcyrd: still the git repo to maintain r-b.o is the jenkins one
18:33:04 <kpcyrd> D:
18:33:09 <h01ger> kpcyrd: or put it differently: i think this needs a workshop or some work and not an irc meeting (which to me is a place to discuss things)
18:33:59 <vagrantc> i don't see why you couldn't have a topic-specific irc meeting workshop ...
18:34:03 <h01ger> kpcyrd: if you want to run rebuilderd on tests.r-b.o i'll be happy to help. we have ressources
18:34:21 <kpcyrd> there are step by step instructions in the arch wiki, so the only question is how and if this should be done, maybe I didn't understand the scope of this meeting
18:34:30 <h01ger> vagrantc: for one, because i dont like to work at 18 utc ;p
18:34:54 <kpcyrd> https://wiki.archlinux.org/index.php/Rebuilderd#Setup
18:34:55 <h01ger> kpcyrd: docs are nice but we want patches
18:34:58 <vagrantc> h01ger: we can also decided on different times for specific meetings, that's just the default
18:35:19 * h01ger is happy to meet with kpcyrd and anybody else involved in this
18:35:45 <kpcyrd> h01ger: send me a link to an ansible repo and I send you patches
18:36:02 <h01ger> kpcyrd: ...
18:36:09 <h01ger> funny. not
18:36:36 <h01ger> any other business?
18:38:00 <bmwiedemann> still looking for long term visions in the other etherpad.
18:38:25 <bmwiedemann> #link https://pad.sfconservancy.org/p/reproducible-builds-vision
18:40:13 <h01ger> so i guess we can close up this meeting now..?!?
18:40:37 <vagrantc> guess so
18:40:55 <sangy> I'd like to read that etherpad soon and see if I can contribute something...
18:41:27 <jathan> h01ger: I was thinking about in the help with some tasks regarding to Email I sent, but I think I could do some kind of pair programming and keep learning more due the questions you asked me :)
18:42:20 <jathan> Pair programming with Reproducible Builds task if someone would like to do it to could learn more in the technical way.
18:42:56 <bmwiedemann> jathan: I can do tomorrow. after 09:10 UTC
18:44:04 <jathan> bmwiedemann: Thank you! Could we use Jitsi or something you feel comfortable to talk and see screens? :)
18:44:19 <bmwiedemann> yes
18:45:11 <h01ger> coolio. i think you can resolve this outside this meeting...
18:45:26 <h01ger> thank you all for attending and hoping to see you next week (at latest! :)
18:46:20 <h01ger> #endmeeting