19:00:23 <h01ger> #startmeeting
19:00:23 <MeetBot> Meeting started Wed Mar 21 19:00:23 2018 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:23 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:31 <marianab> Hello h0lger
19:00:37 <marianab> I'm Mariana
19:00:44 <h01ger> #topic introductions / collecting the agenda
19:00:52 <h01ger> hi marianab, hi anxhelo
19:01:14 <Elio> Anxhelo is our other designer and Mariana is helping us stay on track :)
19:01:22 * h01ger is obviously here :) (please say hi or some such too, if you are present and havent done so yet
19:01:24 <h01ger> )
19:01:31 <h01ger> Elio: cool
19:02:55 <h01ger> so agenda is something like 1. introductions 2. status updates 3. work updates 4. discussion about those 5. any other business 6. next meeting
19:03:06 <h01ger> ?!? please comment :)
19:03:35 <Elio> I guess I should say hi as well. Hi, Elio here, logo designer and will further help with the style guide via OTF and Ura
19:03:49 <Elio> Sounds good to me
19:04:19 * h01ger gives it 3-5 more min so others can comment
19:04:31 <anxhelo> Hello, I'm Anxhelo, a designer at Ura and will help with the project :)
19:04:32 * h01ger looks at https://demo.identihub.co/project/reproducible-builds
19:05:10 <raboof_> o/ raboof here, interested in applying r-b to java/scala builds
19:05:57 <Elio> So Identihub is software we developed ourselves to make assets sharing easier
19:06:02 <Elio> It's AGPL
19:06:24 <Elio> and on our infrastructure, but it can be self-hosted anywhere
19:06:47 <Elio> Thought it might be a bit more convenient than the wiki for dynamic feedback rounds
19:07:04 * vagrantc waves
19:08:01 <vagrantc> might want to mention the topic of the meeting somewhere so the meetbot logs it
19:08:30 <Elio> Hi @rskikuli?
19:08:34 <Elio> rskikuli_
19:08:40 <h01ger> raboof: we're having a meeting currently about the r-b logo.. please lets talk about java/scala later
19:09:02 <rskikuli_> Hello @Elio
19:09:04 <h01ger> #info meeting about the reproducible builds project logo and styleguide
19:09:15 <h01ger> hi vagrantc, hi rskikuli_
19:09:20 <Buda> Hello Everyone!
19:09:25 <vagrantc> heya
19:09:49 <Elio> Okay, I think the whole Ura team is here now heh
19:10:18 <Guest1148> Great!
19:10:33 <h01ger> yay
19:10:43 <Elio> Okay, shall we?
19:10:47 <h01ger> yeah
19:10:56 <h01ger> #topic status updates
19:11:37 <h01ger> Elio: i think you should summarize the otf news
19:11:44 <Elio> For those who missed the last updates: OTF is funding our work for a full fledged styleguide including logo and CSS. That means Reproducible Builds doesn't need to have any budget set aside for this
19:12:18 <Elio> This means that we will implement a live style guide for RB, which includes the logo and basic CSS
19:12:35 <Elio> It's in a similar fashion to the Tor styleguide: styleguide.torproject.org
19:12:45 <Elio> (we are still working out technicalities)
19:13:12 <h01ger> #info OTF is funding Ura's work on a full fledged styleguide including logo and CSS for r-b
19:13:19 <Elio> Deciding on the logo is the first step, as that includes deciding on the icon, typography, and colors. Which would be the majority of the information needed for creating the style guide
19:13:22 <h01ger> & yay! :)
19:14:12 <Elio> While we want to get this right and have time set aside to talk with you, the community on getting this done, we should also set a timeline to set expectations for everyone and avoid bikeshedding
19:15:04 <Elio> I hope that by the end of this meeting we have a clearer vision of the logo direction
19:15:04 <h01ger> what timeline do you have in mind? we discussed using a "turn-based timeline with 3 turns" before
19:15:26 <Elio> Can you explain what that is?
19:15:34 <Elio> Ah iterations you mean
19:15:35 * h01ger sadly doest have that hope to be honest, unless more reproducible builds folks show up :/
19:15:39 <h01ger> yeah
19:15:54 <Elio> Yeah, exactly
19:15:58 <h01ger> Elio: what timeline did you have in mind? 3 months? half a year? 4 weeks?
19:16:46 <Elio> Which means that we will have a decision in the next meeting ideally. Because bikeshedding wouldn't be useful for anyone of us.
19:17:06 <Elio> We are thinking about April
19:17:27 <Elio> Because we can fully dedicate our time to this. And keeps the iterations fresh
19:17:33 <h01ger> part of the iteration based workflow was providing work updates before the meeting, i think if https://demo.identihub.co/project/reproducible-builds would have been sent to the list 24 or 48h ago, participation would be higher. but then, i also forgot to send a simple meeting reminder to the list...
19:18:02 * h01ger adds "process / timeline" to the agenda
19:18:07 <h01ger> #topic work updates
19:18:13 <h01ger> https://demo.identihub.co/project/reproducible-builds
19:18:14 <Elio> Yeah, I just got the notification today
19:18:18 <h01ger> is Elio's latest work
19:18:36 <Elio> From what I see, only 3 r-b folks are here, right?
19:19:10 * h01ger just created a todo for himself "send reminder 2 days before the next date"
19:19:33 <h01ger> Elio: yeah, or less
19:19:59 * h01ger likes https://demo.identihub.co/project/reproducible-builds as whole / demo
19:20:09 <Elio> We should really make it clear how consensus will work on your side
19:20:11 <h01ger> the fonts are available in debian main in stable, right?
19:20:28 <h01ger> Elio: lets talk about this in a sec..
19:20:30 <Elio> Because if there is not a lot of participation, it could basically be just your opinion mattering here
19:20:44 <Elio> Good question. they are OFL fonts
19:21:06 <h01ger> i think we want fonts which are in debian stable main
19:21:16 <Elio> Where can I find that list?
19:21:25 <Elio> anxhelo, you know if they are in Debian Stable?
19:21:33 <h01ger> apt-cache search $fontname
19:21:53 <anxhelo> I don't really know
19:21:55 <Elio> Yeah I'm not on Debian right now
19:22:07 <anxhelo> Debian is rather conservative on those
19:22:12 <anxhelo> and I'm on Fedora so can't check
19:22:19 <anxhelo> but there should be a list online
19:22:27 <h01ger> i think we want fonts which are in debian main, stable or unstable, we dont care
19:22:33 <vagrantc> packages.debian.org/FONTNAME
19:22:52 <vagrantc> though you might have to fiddle
19:22:56 <h01ger> sources.debian.org and then search for known filenames
19:23:02 <vagrantc> even better
19:23:42 <h01ger> #info we prefer fonts which are in debian main, stable or unstable, we dont care. else they must have a free licence
19:23:54 <h01ger> #topic timeline / process
19:24:50 * h01ger thinks deciding by april is a good goal. regarding process, i think we need to move this to mail now and then have another meeting in 1-3 weeks
19:24:54 <vagrantc> https://packages.debian.org/search?keywords=fonts-&searchon=names&suite=all&section=all
19:25:18 <Elio> Well, we only use OFL Free fonts anyway
19:25:35 <Elio> but I don't think Source Sans Pro or Montserrat is in Debian packages
19:25:41 <Elio> I can see Lato though
19:25:46 <Elio> Anyway, we can make that work
19:25:50 <h01ger> Elio: cool, but please lets move on. (and discuss this after the meeting)
19:26:09 <h01ger> re: timeline / process: /me thinks deciding by april is a good goal. regarding process, i think we need to move this to mail now and then have another meeting in 1-3 weeks
19:26:41 <h01ger> i'm not really sure how we shall decide except based on rough consensus & people not objecing / running away
19:26:41 <Elio> I'd be cool to do another meeting in a week
19:27:04 <Elio> So we can keep iterations fresh
19:27:20 <h01ger> yeah
19:27:24 * h01ger too
19:27:59 <Elio> So we can do the mail communication right again
19:28:05 * h01ger nods
19:28:23 <h01ger> other thoughts?
19:28:23 <Elio> Meeting 28th March, where we will decide for another meeting to take a final decision
19:28:28 <Elio> Sounds good?
19:28:49 <h01ger> a meeting to decide on a next meeting date? i dont think you mean this, so please clarify :)
19:29:17 <h01ger> (besides that. sounds great. just i'd like to move it to 18 UTC due to european summertime)
19:29:30 <Elio> Hah, I suppose we decide on the meeting afterwards, in the next meeting
19:29:36 <Elio> 18 UTC sounds good
19:30:32 <Elio> But I hope that we have a clear direction by the next meeting and only a few tweaks will be needed. It's very easy to end up in circles and the end result won't be better necessarily
19:31:03 * h01ger nods
19:31:07 <vagrantc> 18UTC is good for me most days
19:32:06 <h01ger> #agreed we take this to email and will have another irc meeting today in a week, so march 28th, at 18 UTC
19:32:14 <anxhelo> same for me
19:32:56 <rskikuli> sounds good
19:32:59 <h01ger> #agreed we aim to finalize our logo decision for the meeting after the next one (unless next week everybody will happy, because we'll have a great mailinglist discussion and Elio and friends will provide cool updates til then)
19:33:30 <Elio> Sounds solid
19:33:31 <h01ger> #info (this was more hinting on that we need to have this discussion between us, r-b folks.)
19:33:52 <h01ger> #topic discussion about https://demo.identihub.co/project/reproducible-builds#/
19:34:16 * h01ger likes that this is "more complete demo"
19:34:38 <vagrantc> the first thing i noticed is adding colors made me like the options more
19:34:46 * h01ger likes 2 and 4 and maybe 6
19:35:00 <Elio> vagrants, indeed, hence I added them
19:35:06 <Elio> Hang on, let me att them to the palette
19:35:24 <vagrantc> but as black-and-white only, they look a bit blocky to me
19:35:56 <vagrantc> the ones with something in the middle look very busy
19:36:04 <h01ger> and then, looking at https://wiki.debian.org/ReproducibleBuilds/Logo again now, i must say, that also compared to the demo, i know like #8 from the wiki more, because it includes "R B". those logos on the demo feel a bit "arbitrary", by adding R-B there is an immediate connection to our project
19:37:09 <Elio> I agree with that. we should keep it clean
19:37:13 <Elio> Added color palette
19:37:28 <vagrantc> shoving letters into a logo can be a bit difficult, though, no?
19:37:36 <Elio> I wouldn't do that
19:37:38 <vagrantc> for it to work at various scaling
19:37:47 <Elio> The wordmark will be visible in 99% of mediums
19:37:58 <Elio> You wouldn't fit in RB in a favicon
19:38:09 <h01ger> Elio: then please provide more demos with the words next to it
19:38:13 <Elio> The icon itself should be ICONic (pun intended)
19:38:24 <Elio> But the wordmark is separate
19:38:30 <Elio> Focus only on the icon for now
19:38:40 <Elio> Hence I did 2 examples for the feel, don't take it literally
19:38:45 <Elio> We can mix and remix those
19:39:11 <vagrantc> Elio: from our last meeting, i recalled you saing the individual elements should be roughly the same size? as compared to the logo wiki ones with arrows and dots of very different sizes ... the wiki ones look more elegant to me
19:39:34 <h01ger> Elio: i think for us to decide on a logo it will be helpful if you provide examples where < Elio> The wordmark will be visible in 99% of mediums
19:40:10 <Elio> Okay, let me explain this again. A logo, or an identity, is not a brick which is set in stone
19:40:12 <Elio> It's flexible
19:40:16 <Elio> It can be an icon
19:40:22 <Elio> it can be an icon with a wordmark horizontally
19:40:28 <Elio> It can be an icon with a wordmark vertically
19:40:34 <Elio> inverted, positive
19:40:40 <Elio> That all is still the same logo
19:40:45 <Elio> and the same brand
19:40:55 <vagrantc> stretched and distorted in various ways? :)
19:40:56 <h01ger> sure
19:41:08 <Elio> stretched and distorted?
19:41:20 <Elio> Let me add the examples now
19:41:23 <vagrantc> sure
19:41:25 <h01ger> just for us to decide, i think the logo should be shown in as many of such settings as possible
19:41:34 <h01ger> just for us to decide, i think the logos should be shown in as many of such settings as possible
19:44:20 <vagrantc> so, i guess i'm having a hard time understanding how to integrate this stuff ... i can mostly give my gut reaction, but i don't really have any design experience and obviously there are worlds of information i don't have
19:45:03 <h01ger> Elio: regarding discussing https://demo.identihub.co/project/reproducible-builds#/ - can you 'version' this or otherwise make stable? i was just thinking thats it might be a bit difficult to discuss a 'changing thing' - maybe i'm wrong..
19:45:04 <vagrantc> but i suspect i can live with just about anything, really.
19:45:26 <Elio> Yep, I can create categories for every meeting maybe?
19:45:47 <h01ger> yeah
19:46:32 <Elio> https://demo.identihub.co/project/reproducible-builds#/view/icon/element/376
19:46:34 <Elio> Added this
19:46:41 <Elio> I quite like this iteration honestly
19:46:45 <h01ger> cool
19:46:54 <Elio> It would look good on a sticker as well
19:47:12 * vagrantc is partial to the diamon-oriented variants
19:47:18 <h01ger> yup
19:47:25 <h01ger> lets move on
19:47:30 <h01ger> #topic any other business
19:48:05 * h01ger really likes icon/element/376 (except that "builds" is a different fontstyle than 'reproducible'
19:48:07 <h01ger> )
19:48:24 <Elio> It's not a different style, but different weight
19:48:30 <Elio> We could go with the same as well
19:48:40 * h01ger doesnt have anything else to add and is happy how the meeting went and already put meeting and reminder 2 days earlier in his calendar
19:48:52 <h01ger> Elio: thats what i ment (weight)
19:49:17 <vagrantc> "it looks different somehow" :)
19:49:21 <h01ger> or at make "reproducible" the bolder weight
19:49:28 <h01ger> s# at #
19:49:32 <h01ger> s# at ##
19:49:59 <Elio> Okay, so the styleguide will be created on our infrastracture (either GitHub or GitLab) for development purposes
19:50:07 <Elio> Once it's ready, I suppose you folks can migrate it
19:50:24 <h01ger> sounds good
19:50:59 <Elio> From what I gather, you are very concerned about the logo, but not so much about the style guide, right?
19:51:30 <h01ger> well, adopting the style guide will be more work ;)
19:51:31 <Elio> So we will move with the styleguide implementation and when the logo is ready, there will be a good chunk of work done
19:51:47 <h01ger> but yes..
19:51:52 <vagrantc> the style guide is basically some color, css, and .. ?
19:52:10 <Elio> vagrantc ideally we want to make it similar to styleguide.torproject.org
19:52:24 <Elio> Maybe a bit more lightweight
19:52:36 <Elio> For visual assets, Identihub can be used as well
19:52:40 <vagrantc> lightweight as in less fleshed out ... or?
19:52:56 <Elio> I don't think you need as much material as Tor, that is
19:54:56 <vagrantc> i think the icon is the most approachable thing for most of us, and maybe we're not sophisticated enough to really argue to much about the styleguide :)
19:55:16 <vagrantc> which might make it harder ...
19:55:21 <Elio> A style guide is more technical and practical
19:55:21 * vagrantc shrugs
19:55:44 <Elio> I think the styleguide is easier than the logo discussion honestly
19:56:06 <Elio> It's quite technical once you decided on the logo, color and typography
19:56:17 <vagrantc> the logo involves synthesizing everyone's internal experience
19:56:35 <Elio> That sounds dramatic but yeah, basically that
19:56:43 <Elio> But on the other hand also making it approachable to new people
19:56:57 <Elio> You don't want to make it appealing only to you, right? But also to the outside
19:57:00 <vagrantc> seems like this was a meeting
19:57:04 <vagrantc> of course :)
19:57:16 <Elio> That's why you asked me, to do the job of the audience
19:57:19 <vagrantc> a piece of visual identity that is recognizable
19:57:32 <Elio> While still keeping the internal team happy
19:57:46 <Elio> Anyway, I think this was good and fruitful
19:57:48 <vagrantc> yes, we don't want something that clashes with the existing folks
19:58:00 <vagrantc> Elio: thanks for taking it on
19:58:02 <Elio> I suppose most of the people want to stick with blueish colors?
19:58:13 <h01ger> this is the last topic, as the last topic is "next meeting" and we already agreed on this
19:58:23 * h01ger will end this meeting in a minute
19:58:33 <vagrantc> Elio: i like the green elements too
19:58:44 <vagrantc> Elio: i think blue is almost too safe ... but maybe that's fine
19:58:56 <Elio> Okay, but cold colors focused maybe
19:59:10 * h01ger is happy with this meeting as well, despite little participation from our side - and thanks for you all from Ura being here!
19:59:27 <h01ger> the current page is blue..
19:59:33 <h01ger> #topic next meeing
19:59:36 <h01ger> #topic next meeting
20:00:00 <h01ger> #agreed the next meeting to discuss the r-b logo will be held here on march 28th, 18 UTC
20:00:10 <h01ger> thank you all for attending!
20:00:12 * h01ger waves
20:00:16 * vagrantc thanks all around
20:00:37 <Elio> Thanks folks :)
20:00:51 <h01ger> #endmeeting