17:59:46 <danielsh> #startmeeting Reproducible Builds Meeting #7
17:59:46 <MeetBot> Meeting started Tue Jan 17 17:59:46 2017 UTC.  The chair is danielsh. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:54 <danielsh> #topic Introductions
17:59:59 <danielsh> who's here? :)
18:00:06 <brett> I'm here, hi everyone.
18:00:10 <vagrantc> hi
18:00:16 <mapreri> \o
18:00:19 <FauxFaux> I am, but have to leave in two minutes. Good wishes etc.
18:00:23 <h01ger> hi
18:00:27 <h01ger> where's the agenda again?
18:00:34 <danielsh> h01ger, https://pad.riseup.net/p/reproducible-irc-meeting-7
18:00:38 <h01ger> thanks
18:00:39 <mapreri> danielsh: thanks for finally using a title in #startmeeting :)
18:00:47 <danielsh> mapreri, yw
18:00:53 <danielsh> mapreri, add it to how-to-chair ;-)
18:00:55 <mapreri> #link agenda at https://pad.riseup.net/p/reproducible-irc-meeting-7
18:00:58 <emaste> hi
18:01:32 <h01ger> so we only have one topic, neato
18:01:50 <danielsh> alright,
18:01:55 <danielsh> #topic Action items from last meeting
18:02:03 <h01ger> mapreri: that link is useless as the pad will go away in a month. /me wishes for a.) permanent and b.) stable URLs for the agenda
18:02:08 <danielsh> - brett to add "reporting bugs" (or similar…) to --help output of diffoscope
18:02:14 <danielsh> status: still on my TODO, hopefully this week --brett
18:02:18 <danielsh> Anything to add here?
18:02:23 <danielsh> brett, Thanks for updating the pad ahead of the meeting
18:02:26 <brett> Not from my end.
18:02:27 <mapreri> h01ger: *shrugs*, useful for people reading minutes the next few days
18:02:27 <brett> Sure.
18:02:35 <h01ger> mapreri: sure
18:02:57 <danielsh> #action brett to add "reporting bugs" (or similar…) to --help output of diffoscope
18:03:00 <danielsh> - danielsh to mention on t.r-b.o how to file bugs using the new pseudopackage (in the footer…?)
18:03:00 <danielsh> status: done
18:03:04 <danielsh> Moving on...
18:03:12 <danielsh> - lamby to publish generic tools somewhere (future-proof URL) and to update release docs
18:03:12 <danielsh> [ed note: this is about non-debian tar.gz URLs for strip-nondeterminism, &c; requested by bmwiedemann]
18:03:23 <vagrantc> h01ger: meetbot generates the agenda of the topics actually discussed, so... which shouldn't deviate too much from the proposed agenda...
18:03:29 <danielsh> Oh, forgot the "Apologies" section.
18:03:49 <danielsh> Apologies: lamby isn't here today due to timezones.
18:03:54 * h01ger is surprised git repos and signed tags are not enough, IOW that others than Debian people also want/need tarball releasees
18:04:12 <mapreri> danielsh: checking: was the idea to put them in subpages of https://reproducible-builds.org/tools/ ?
18:04:39 <danielsh> mapreri, IIRC bmwiedemann requested that strip-nondeterminism, etc be released not just as .deb but also as tar.gz
18:04:45 <danielsh> where the URL would be mattered less.
18:05:29 <mapreri> yes
18:05:45 <danielsh> h01ger, We should ask bmwiedemann if he's considered that option.
18:05:48 <mapreri> and we're releasing .tar.gz too, just are impossible to find and not stable
18:06:03 <danielsh> "not stable"?
18:06:07 <mapreri> no real need, I agree that we should save our releases somewhere in .tar.gz only format
18:06:09 <danielsh> Do you mean the URL, or the software?
18:06:24 <mapreri> danielsh: see deb.debian.org/debian/pool/main/s/strip-nondeterminsm
18:06:39 <danielsh> mapreri, 404
18:06:45 <mapreri> the files there will go away as soon as they are superseded.  So the .tar.gz is there, but not stable.
18:06:45 <vagrantc> snapshot.debian.org probably more stable...
18:06:55 <mapreri> yeah, but it's ugly to like .debian.org anyway
18:06:56 <vagrantc> still very debian-ish
18:07:03 <mapreri> danielsh: sorry, written by hand...
18:07:03 <danielsh> mapreri, Ah, so the *URL* is not stable.  Got it.
18:07:12 <danielsh> mapreri, np, I know what the pools look like
18:07:22 <danielsh> Anyway, can we summarize this as "outstanding"?
18:07:25 <mapreri> http://deb.debian.org/debian/pool/main/s/strip-nondeterminism/
18:07:33 <mapreri> yes
18:07:46 <vagrantc> given that lamby and bw* aren't present, seems silly to discuss at length
18:07:48 <danielsh> #action lamby to publish generic tools somewhere (future-proof URL) and to update release docs
18:08:04 <mapreri> vagrantc: there is no need to discuss again, it was already said at rws2 too
18:08:05 <danielsh> - [unassigned] track reproducibility patches committed to debian but not upstreamed (danielsh)
18:08:06 <danielsh> status: no such tooling exists; filed feature request https://bugs.debian.org/851225
18:08:22 <danielsh> That was an un-#action'd item from the last meeting ^^
18:08:40 <danielsh> #851225 is a bug report to debian QA to create a generic tool for tracking debian-local upstreamable patches
18:08:57 <danielsh> infinity0, are you for the next agenda item?
18:09:08 <mapreri> let me add one point for that bug
18:09:20 <danielsh> mapreri, listening
18:09:38 <infinity0> hi, here
18:09:51 <danielsh> infinity0, hello; next agenda item (after mapreri) is SOURCE_PREFIX_MAP
18:10:01 <mapreri> that bug is against UDD, Ultimate Debian Database, which is currently maintained only by lucas; doesn't help that he recently rewrote the import machinery "recently" and nobody since them picked up.
18:10:38 <mapreri> alas, I can tell you that unless somebody from our side takes a shot at writing a patch for that (it's mostly ruby), it won't easily be done.
18:10:59 * h01ger adds it as a task
18:11:01 <mapreri> OTOH, I've got commit access on the repo, so applying isn't really a problem.
18:11:16 <danielsh> (please use \n.\n when you're done talking)
18:11:22 <mapreri> .
18:11:27 <danielsh> mapreri, thanks for the summary.
18:11:42 <danielsh> Any volunteers to teach udd about DEP-3?  Or to otherwise implement a DEP-3 "Forwarded" tracker?
18:11:47 <infinity0> i'm writing some C code and fuzzing it atm, i don't think we should do a "v0" spec
18:12:07 <danielsh> infinity0, please wait a few minutes, we're still on the preceding #topic
18:12:19 <infinity0> ah, ok sorry
18:12:26 <h01ger> danielsh: please use #topic
18:12:29 <danielsh> np, you didn't check in at roll call
18:12:35 <danielsh> h01ger, I do... we're still on the first #topic
18:13:03 <h01ger> ah, ok, then infinity0 please dont talk about new topics while the old one… :)
18:13:08 <danielsh> #help debian udd: implement DEP-3 "Forwarded" tracking #851225 (liaise with mapreri)
18:13:13 <h01ger> (+nevermind)
18:13:18 <danielsh> #topic - SOURCE_PREFIX_MAP encoding: should we support colons in path names?
18:13:27 * mapreri learnt a new word
18:13:32 <danielsh> Do I need to summarize the list thread?
18:13:45 <h01ger> regarding this topic, is anyone else besides infinity0 of the opinion that seperating by colon is not good?
18:13:55 <h01ger> (from the people around, not potential upstreams or such)
18:14:19 <h01ger> (and i'm just curious. i dont want to imply the majority is right…)
18:14:43 <danielsh> infinity0, ping
18:14:54 <infinity0> yes i'm still here
18:14:56 <danielsh> infinity0, Let's try and further the discussion - mic is yours.
18:15:06 <danielsh> (and you've got about 45 minutes...)
18:15:09 <infinity0> well i'm writing code and then i will see how the complexity is
18:15:18 <infinity0> i.e. get some real data into the discussion
18:15:55 <danielsh> infinity0, which alternatives are you getting data for?
18:16:02 <vagrantc> ok, so a live-broadcast of your screen and we watch for the rest of the meeting?
18:16:03 <infinity0> i still favour the urlencode approach, will try to see how that is in languages other than C, e.g. similar to what we already have on the SOURCE_DATE_EPOCH TimestampsProposal page
18:16:19 <infinity0> urlencode, simple split and backslash-escaping
18:16:33 <danielsh> infinity0, I think that's all the major candidates covered.
18:16:33 <infinity0> there's not much else to add, i'm writing the code
18:16:45 <infinity0> i think otherwise the discussion is a bit pointless because it's just vague opinions
18:16:49 <h01ger> infinity0: also for the colon seperation approach?
18:16:55 <danielsh> #action infinity0 write code for SOURCE_PREFIX_MAP alternatives, send data to thread
18:17:00 <h01ger> (also writing that code?)
18:17:01 <danielsh> h01ger, that's the "split"
18:17:05 <danielsh> "simple split"
18:17:09 <vagrantc> i'm not sure the v0 spec is worth doing
18:17:12 <h01ger> ah
18:17:17 <vagrantc> if it's going to change soonish
18:17:19 <danielsh> vagrantc, listening, I was just about to ask
18:17:27 <infinity0> yeah, i don't think we need a v0 one either, this will be done in a few days
18:17:31 <h01ger> "urlencode, simple split and backslash-escaping" i didnt read this as 3 different proposals… now i do
18:17:44 * danielsh awards h01ger a grammar point
18:17:49 <vagrantc> if we go through all the trouble to get people to use spec v0, and then come around a few months later and say "do it all differently", that wouldn't gve over well with most upstreams
18:18:11 <danielsh> infinity0, vagrantc:  Okay.  (You could've said so in reply to my list post too...)
18:18:12 <h01ger> we could also use a v0 to gather feedback for a "final" v1
18:18:12 <infinity0> right sure, agreed. i'll write the code, we don't need to spend further time with the discussion atm
18:18:20 <infinity0> the code is here https://gist.github.com/infinity0/1b9acca742aa09e032841fa2a9ef9fa8
18:18:31 <h01ger> #link https://gist.github.com/infinity0/1b9acca742aa09e032841fa2a9ef9fa8
18:18:36 <danielsh> #agreed Don't do a v0 SOURCE_PREFIX_MAP unless we can't agree on a v1 timelily.
18:18:40 <infinity0> after the final decision is made i'll transfer it over to alioth, then we can have some proper examples
18:18:56 <infinity0> i'm fuzzing it through AFL etc and people can run that themselves with Makefiles i'll be providing, too
18:19:03 <vagrantc> agreed?
18:19:03 * h01ger is not sure he agrees… i like the idea of asking for feedback before release 1.0…
18:19:25 <danielsh> h01ger, apologies.  Listening
18:19:33 <infinity0> i'll ask rust and gcc for feedback separately, i think there's no need to call it "v0" though
18:19:41 <danielsh> (will retract the #agreed after hearing you out)
18:19:55 <h01ger> [19:18] <      h01ger> | we could also use a v0 to gather feedback for a "final" v1
18:20:05 <infinity0> i'll just call it "draft"
18:20:13 <h01ger> k. works for me.
18:20:38 <danielsh> #agreed Solicit feedback on SOURCE_PREFIX_MAP before releasing a 1.0 spec.
18:20:47 <danielsh> Anything else on this topic?
18:20:55 <vagrantc> that sounds better
18:21:31 <danielsh> #topic Any other business
18:21:44 <danielsh> Anything else to discuss?
18:22:17 <danielsh> Thanks everyone.
18:22:19 <danielsh> #endmeeting