17:59:53 <lamby> #startmeeting
17:59:53 <MeetBot> Meeting started Tue Nov 29 17:59:53 2016 UTC.  The chair is lamby. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:53 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:58 <lamby> #topic Introductions
18:00:07 <lamby> Evening all.
18:00:11 <lamby> So, who is about?
18:00:14 <HW42> hi all
18:00:21 * emaste waves from FreeBSDlandia
18:00:27 * neverpanic for macports
18:00:50 <lamby> FreeBSDlandia sounds like a good name for a conference…
18:01:14 <lamby> emaste on twitter is a good source of interesting freebsd stuff if anyone is curious :)
18:01:54 <lamby> We'll give it a couple more moments for people to roll in…
18:01:58 * Eric[m] waves from lurkspace
18:02:12 * emaste feels like it might be a short meeting
18:02:22 <lamby> hey Eric[m], nice to see you
18:02:33 <lamby> emaste: No complaints here.
18:03:53 <lamby> Cool, let's crack on
18:04:02 <lamby> #topic Summit updates
18:04:35 <lamby> Not much to report here, except that you should reconfirm ASAP and people who have reconfirmed should have been subscribed to the ML (and have received msgs from Gunner)
18:05:10 <lamby> If you think you are missing something, please email 2016-summit-team@lists.reproducible-builds.org
18:05:28 <lamby> #info If you think you are missing something, please email 2016-summit-team@lists.reproducible-builds.org
18:05:39 <lamby> Any questions on the summit…?
18:06:09 <lamby> (I noticed we won't be far from the Computerspielemuseum…!)
18:06:10 <emaste> lamby: would be interesting to find out when folks are arriving/leaving
18:06:31 <neverpanic> emaste: sounds like a topic we could bring up on the mailing list?
18:06:42 <lamby> mmm, I think so
18:06:51 <emaste> yep
18:07:12 <lamby> Last summit, "most" people arrived Monday evening ish (we had a mini social) and left at their leisure on the Friday.
18:07:15 <neverpanic> Mo-Fr for me, probably the same for quite a few others. We could meet up Monday evening already.
18:07:58 <lamby> #idea Arrange a location for a Monday evening social gathering
18:08:41 <lamby> #topic tracker for reproducible-builds.org tasks
18:09:07 <lamby> We've moved to plain text. I see more commits, so I'm guessing its working to some degree.
18:09:10 <lamby> :)
18:09:27 <lamby> Anyone here used it? If so, any major issues worth bringing up now?
18:09:45 <neverpanic> Forgive me for the ignorance, but where would I find it? ;-)
18:10:00 <lamby> #link https://anonscm.debian.org/git/reproducible/tasks.git
18:10:25 <HW42> I saw holger using it
18:10:26 <lamby> Your subtle point that it's not advertised very well was well-made ;-)
18:10:55 <emaste> :-)
18:11:07 <lamby> #idea "Advertise" that we have a task tracker and link to it?
18:11:48 <lamby> Neat.
18:12:03 <lamby> #topic Liasing upcoming CfP deadlines
18:12:18 <lamby> Anyone planning on submitting soon? Just to avoid clashess…
18:12:56 <infinity0> hi
18:13:09 * emaste planning to submit to AsiaBSDCon, suspects nobody else here is
18:13:58 <lamby> #info emaste planning to submit to AsiaBSDCon
18:14:13 <lamby> #info We don't currently plan to have FOSDEM devroom. Will be some presentation, however.
18:14:24 <lamby> (emaste: Tokyo!)
18:14:26 <lamby> Neat.
18:14:37 <lamby> #topic Separate mailing list reproducible-bugs@ for bugs
18:15:05 <lamby> infinity0, you asked for this separate ML IIRC? If so, how's it working for you?
18:15:11 <infinity0> lovely, thanks!
18:15:31 <infinity0> i would s/bugs/non-general bugs/ or something like that, but it's ok
18:15:43 <infinity0> i think we're happy to have general bugs go on the main list
18:16:08 <lamby> I think so. They are pretty rare and need more eyeballs anyway. (eg. the debian-policy bug)
18:16:10 <infinity0> although my reprotest bugs should probably be in the -bugs list, they are only specific to reprotest. i didn't change the old CC yet
18:16:15 <infinity0> yeah
18:16:44 <lamby> I guess bugs relating to "our" packages could eventually swamp the main list, but it's not really an issue right now AFAICT?
18:17:04 <infinity0> i suppose not. i'm happy to avoid the extra paperwork :)
18:17:51 * dkg waves -- sorry to be late!
18:18:12 <lamby> #action Keep our new -bugs list, don't adjust Maintainer: fields of "our" packages
18:18:24 <lamby> #topic Wrong user-tagged bugs
18:18:26 * h01ger waves -- sorry to be basically absent
18:18:37 <lamby> deki was assigned to this, not sure if he managed to get to it.
18:18:43 <lamby> I'm sure he'll clarify after this ping
18:18:52 <lamby> :)
18:19:11 <lamby> #topic Any other business?
18:19:29 <mapreri> oh, hi, damn, got hold up by people, sorry :S
18:19:45 <neverpanic> The Yocto/OpenEmbedded/Poky people are producing some code towards reproducibility: http://lists.openembedded.org/pipermail/openembedded-architecture/2016-November/000336.html :)
18:19:55 <lamby> #link http://lists.openembedded.org/pipermail/openembedded-architecture/2016-November/000336.html
18:19:59 <lamby> nice, thanks neverpanic
18:20:12 <lamby> Eric[m]: Any queries/questions? :)
18:20:25 <emaste> llvm's also been working on patches to ferret out nonreproducibility
18:21:10 <Eric[m]> nope I waved just to wave!  I'm happy to be read-only here at the moment.  thanks though :3
18:21:15 <emaste> https://reviews.llvm.org/D26718
18:21:59 <lamby> #link https://reviews.llvm.org/D26718
18:22:01 <lamby> Nice
18:22:05 <mapreri> cool
18:22:27 <lamby> Good to get contacts in the compilers given they can affect so much stuff (eg. the ocaml folks have been really helpful, etc.)
18:23:09 <emaste> yeah, I have some good friends in the LLVM community and will try to push on them to move things along - e.g. SOURCE_DATE_EPOCH is not yet in clang
18:23:48 * h01ger has an AOB topic: please shout if you attend and if we can add your "project" to https://reproducible-builds.org/events/berlin2016/
18:23:52 <mapreri> lamby: I might be a tad out of the loop, but a question: do you know what's up with "wrong user tagged bugs"?
18:23:55 <h01ger> IOW: hi emaste! ;)
18:24:21 <lamby> mapreri: http://meetbot.debian.net/reproducible-builds/2016/reproducible-builds.2016-11-15-17.59.log.html#l-326
18:25:01 <emaste> h01ger: FreeBSD can certainly be added! bapt@ also told me yesterday he is coming, I hope he's told you too :)
18:25:06 <lamby> #action Shout if we can add your project to https://reproducible-builds.org/events/berlin2016/
18:25:31 <neverpanic> h01ger: *shout*, feel free to add MacPorts
18:25:41 <mapreri> lamby: thanks (indeed, I have been a bit out recently, sorry)
18:25:59 <ReproBird> 02gogasi_: 06New post: "Reproducible Builds: week 83 in Stretch cycle"14 https://reproducible.alioth.debian.org/blog/posts/83/ — https://twitter.com/gogasi_/status/803666363965435904
18:26:37 <lamby> h01ger: Can I action you to add FreeBSD & MacPorts? :)
18:26:56 <boklm> h01ger: you can add Tor Project
18:27:35 <lamby> I'll take it for now.
18:27:42 <lamby> #action lamby to add FreeBSD, MacPorts & Tor Project to https://reproducible-builds.org/events/berlin2016/
18:27:48 <lamby> Cool, anything else?
18:28:46 <lamby> If not…
18:28:49 <lamby> #endmeeting