17:59:54 <lamby> #startmeeting
17:59:54 <MeetBot> Meeting started Tue Nov 15 17:59:54 2016 UTC.  The chair is lamby. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:54 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:06 <lamby> Hello all, welcome to our… 4th IRC meeting.
18:00:13 <h01ger> this year
18:00:15 <h01ger> :)
18:00:17 <lamby> Who is about? :)
18:00:26 <lamby> Our agenda is here: https://pad.riseup.net/p/reproducible-irc-meeting-4
18:00:54 <lamby> Will let the dust settle and then we'll crack on ASAP; I'm sure folks have places to be.
18:01:00 * vagrantc waves
18:01:08 * deki \o
18:01:11 * HW42 
18:01:13 * neverpanic 
18:01:23 * h01ger is very tired and wants to go afk
18:01:25 <lamby> hey deki, HW42, neverpanic, emaste
18:01:29 <emaste> hello!
18:02:03 <h01ger> hi hi :)
18:02:20 <boklm> hello
18:02:30 <lamby> hey boklm
18:02:42 * lamby has tea.
18:03:04 <h01ger> can we start please?
18:03:17 <spectranaut> hi too!
18:03:28 <lamby> h01ger: Just waiting for the stragglers… for example ^
18:03:30 <lamby> hey spectranaut
18:03:46 <lamby> siamezzze:  o
18:03:58 <lamby> Cool, lets get going
18:04:13 <lamby> #topic tracker for reproducible-builds.org
18:04:34 <lamby> This is a followup to the task tracker discussion from last meeting.
18:04:55 <infinity0> hi
18:04:57 <lamby> Who added this? I'm not sure what it's *specically* about.
18:05:24 <infinity0> added what?
18:05:25 <deki> issue/task tracker?
18:05:25 <vagrantc> there was discussion about simplifying the code needed to run
18:05:36 <h01ger> its unresolved from last meeting
18:05:37 <vagrantc> e.g. all in one script rather than git hooks
18:05:49 <lamby> Who added this to the agenda? What needs to be discussed here.
18:05:59 <h01ger> its unresolved from last meeting
18:06:05 <deki> has anyone else used it since last meeting?
18:06:12 <deki> or opinions about it?
18:06:37 * h01ger wants a webbased on or one where on can commit easily plaintextz in git
18:06:42 <infinity0> i added some things, other people didn't want to use it because it runs code
18:06:44 * vagrantc wonders if future meeting agenda items shouldn't come with a point-person or be skipped
18:06:53 <h01ger> i dont care about decentralised
18:07:00 <emaste> vagrantc: good point.
18:07:23 <lamby> From a distance, and probably therefore from the point-of-view of a newbie to reproducible, it looks complicated, even if it ran no code whatsoever.
18:08:08 <lamby> (it might /not/ be complicated, but perceptions, etc.)
18:08:36 <HW42> I think a repo with .md file would do the job and can be easily generate html. but I would also not realy object to a "classic" browser/server based tracker
18:08:58 <lamby> Does this mean we want to change tech? Or keep at this one for a bit? (They will all have various downsides after all, but switching all the time is also kinda busywork.)
18:09:02 <h01ger> next topic? somebody needs to do this/something and than we can discuss again
18:09:03 <vagrantc> it really depends on how many issues we're likely to track
18:09:36 <HW42> FWIW I think a pseudo packacge in the debian BTS would also work, but IIRC the whole point was to not use the Debian BTS
18:09:50 * h01ger now tracks his urgent todo with local uncommitted modifications of TODO from jenkins.d.n.git ;) i needed *something*
18:10:11 <emaste> :)
18:10:13 <lamby> infinity0: thoughts? eg. fancy just moving to plaintext for now or taking this task (lol) for now?
18:10:25 <infinity0> moving to plaintext is fine by me
18:10:38 <lamby> infinity0: Cool. Okay to action-time you that?
18:10:57 <infinity0> sure
18:11:01 <lamby> #action infinity0 To move tasks.git to plain text
18:11:05 <lamby> thakns
18:11:23 <lamby> :)
18:11:25 <lamby> #topic DDPO & json
18:11:33 <h01ger> next, nothing happened
18:11:38 <lamby> h01ger: hm?
18:12:15 <h01ger> DDPO & json - no changes since last week, the todo+status is on the list
18:12:24 <lamby> cool, thanks
18:12:25 <h01ger> DDPO & json - no changes since last week, the todo+status is in the last meetings log
18:12:51 <lamby> #topic Upcoming events/presentations
18:12:59 <lamby> first, libreplanet
18:13:03 <vagrantc> i seem to be collecting events
18:13:13 <lamby> vagrantc, you were going to talk with spectranaut? How's that going?
18:13:30 <vagrantc> spectranaut: was there anything more you wanted to add?
18:13:41 <vagrantc> spectranaut: last i checked in with you you just said to write it up
18:13:43 <spectranaut> nope I'm not submitting!
18:13:53 <spectranaut> think I said..
18:13:55 <vagrantc> i've got till tomorrow to do that
18:13:59 <lamby> Aw.
18:14:25 <lamby> Okaley, well nothing to co-ordinate, so…
18:14:31 <vagrantc> with all three of these, if anyone would be available for some review, that'd be great
18:14:31 <infinity0> ok done, switched to plain text
18:14:31 <lamby> Next. Scale
18:14:42 <lamby> vagrantc: yours ^
18:14:43 <lamby> * ?
18:14:51 <vagrantc> scale is due *today*
18:14:51 <emaste> I will probably submit a Reproducible FreeBSD talk to AsiaBSDCon 2017 ,  Tokyo Mar 9-12
18:15:09 <vagrantc> scale: i've submitted a talk, but probably should fleh out the long description more
18:15:17 <vagrantc> hep greatly appreciated
18:15:19 <vagrantc> help
18:15:26 <emaste> I will probably submit a Reproducible FreeBSD talk to AsiaBSDCon 2017 ,  Tokyo Mar 9-12
18:15:28 * vagrantc can't even type it's so urgent
18:15:35 <lamby> I believe these are agenda items when they require liasing with people. Otherwise, just go ahead and submit!
18:15:43 <lamby> ie. is there anything to discuss about SCALE?
18:15:55 <vagrantc> i could really use a hand writing up a longer description
18:16:10 <lamby> vagrantc: Can you send a link, etc to the ML?
18:16:26 <vagrantc> maybe i'll start a pad or soemthing, and link to the list
18:16:30 <lamby> Cool
18:16:45 <lamby> #action vagrantc to send a link to SCALE (etc.) draft to the ML for help
18:16:48 <spectranaut> I'd look at it to, vagrant -- related I'm giving a talk to the local users group on reproducible builds tomorrow :)
18:16:52 <lamby> Same with ELC.
18:17:03 <spectranaut> local linux users group*
18:17:15 <vagrantc> sounds good
18:17:16 <lamby> Anything else needing discussion on submitting talk stuff?
18:17:28 <vagrantc> figured i'd let people know about the events i was looking at to coordinate
18:17:35 <lamby> *nod*
18:17:50 <lamby> Cool.
18:17:53 <HW42> vagrantc: maybe add them to the website or blog
18:18:16 <vagrantc> i should probably use the list to mention which talks i'm thinking about
18:18:16 <lamby> #topic Summit updates
18:18:24 <vagrantc> don't want to add to website/blog till they've been confirmed
18:18:27 <lamby> h01ger: fancy providing an update? ^  :)
18:18:43 <HW42> vagrantc: I meant the events, not you talks
18:18:50 <HW42> *your
18:19:03 <vagrantc> HW42: well, if there's nothing r-b related, why mention?
18:19:11 <HW42> point
18:19:23 <h01ger> there not really much news
18:19:48 <h01ger> if someone still wants to come, please do talk to me, we still have free seats
18:20:01 <lamby> Neat. Did you reping people who did not yet reply?
18:20:06 * h01ger looks much forward to the summit and see you (all!) there! ;-)
18:20:14 * vagrantc too
18:20:28 <lamby> Dhole - come to the summit :3
18:20:36 <HW42> h01ger: did you asked the Yocto people?
18:20:42 <neverpanic> HW42: See mail on the list
18:20:45 <h01ger> lamby: i'm tired. there not really much news. i need rest. now.
18:20:51 <h01ger> HW42: yes
18:20:58 * emaste has been completely swamped, but will come
18:21:02 <HW42> h01ger: nice
18:21:10 <HW42> neverpanic: the mail was the reason to ask
18:21:17 <lamby> h01ger: I'm not chastising you, merely curious.
18:21:31 <HW42> neverpanic: but yeah now I read that they talked to h01ger
18:21:39 <HW42> nvm
18:22:01 <lamby> Cool.
18:22:15 <lamby> #topic disorderfs
18:22:21 <lamby> (Who added this?)
18:22:34 <h01ger> its disabled because unmounting caused problems
18:22:36 <lamby> Background is that we disabled it a while ago as it was causing some FTBFS. We should probably just fix it.
18:22:47 <h01ger> which led to disk filled up and thus ftbfs
18:22:56 <deki> but then we no longer have 91% :>
18:23:06 * h01ger added this (FWIW)
18:23:13 <neverpanic> Is there a ticket descibing what the problem is?
18:23:22 <h01ger> neverpanic: conviniently no
18:23:41 <h01ger> my idea is to enable it on i386 only, so that the impact of the ftbfs will be low
18:23:49 <h01ger> patches doing that much welcome
18:23:54 <deki> on i386/armhf there are fileordering variations anyway
18:23:58 <deki> even without disorderfs
18:24:06 <lamby> deki: how so?
18:24:24 <deki> different kernels/filesystems or so
18:24:25 <h01ger> see jenkins.d.n.git/hosts/profitbricks-build2-i386/etc/pbuilder/rebuild-hooks/D01_modify_environment
18:24:30 <lamby> h01ger: Sounds like a plan.
18:24:45 <h01ger> deki: i believe only on armhf, or also on i386?
18:24:51 <deki> h01ger: also on i386
18:24:55 <h01ger> nice
18:25:04 <h01ger> ah
18:25:23 <lamby> In that case, it's tempting just turn it on everywhere…
18:25:39 <lamby> Simpler patch too; more likely to get done, etc. :3
18:25:40 <h01ger> armhf+i386 has /srv/workspace on ext3 while its on tmpfs on amd64
18:25:49 <deki> ah :)
18:25:55 <h01ger> lamby: no. amd64 builds too fast
18:26:08 <lamby> I blame profitbricks.
18:26:11 <h01ger> so better enable it on i386 and migate the impace^w^w^wfind a fix there
18:26:17 <h01ger> lamby: no funny
18:26:21 <lamby> Okay.
18:26:51 <lamby> I'd like to #action something here. "Someone" should write a patch isn't that great.
18:26:54 <h01ger> why do you blame nice people out of the blue for things they have nothing to do with?
18:27:07 <vagrantc> ext4 on armhf, fwiw
18:27:12 <lamby> h01ger: Eh?It was a joke…
18:27:23 <h01ger> lamby: sigh
18:27:38 <lamby> I don't understand, sorry.
18:27:40 <h01ger> people might actually read the log and not get that
18:27:48 <vagrantc> well, now it's explicit
18:27:57 <h01ger> yup
18:27:59 <h01ger> haha
18:28:05 <emaste> profitbricks is too good to us
18:28:32 * vagrantc guesses the joke was they're so good to us providing such fast builders that we have problems resulting from such fast builds
18:28:44 <h01ger> (enabling disorderfs is on my urgent todolist, so we can move on…)
18:29:07 <h01ger> vagrantc: oh, thanks. now i get the joke. (i said was tired)
18:29:11 <lamby> h01ger: Can I #action you on that?
18:29:17 <h01ger> no
18:29:27 <lamby> Okay, let's move on.
18:29:36 <lamby> #topic Logo
18:29:52 <lamby> I added this as a placeholder reminder to try and think of more logos and/or sources of more logos.
18:29:56 <lamby> That's all really.
18:30:08 <vagrantc> should we put out a call for logos?
18:30:32 <lamby> vagrantc: I have to various people. If there's a more general way of doing that, sure, go ahead.
18:30:33 <emaste> I think we should
18:30:37 <deki> has it been posted on twitter yet?
18:30:49 <lamby> deki:  Good point
18:30:52 <h01ger> whats the logo url again?
18:30:58 <emaste> I posted it to twitter
18:31:01 <h01ger> https://wiki.debian.org/ReproducibleBuilds/Logo
18:31:22 <emaste> but, we should pick a closing date and make it an explicit call for logos
18:31:35 <lamby> emaste: That idea was rejected last meeting FYI
18:32:00 <lamby> Folks can edit the wiki and send out calls separate to this meeting, so unless we want to open the logo deadline discussion again (?).
18:32:18 * h01ger would really prefer we wait for a logo we like
18:32:24 <h01ger> instead of working with a deadline here
18:32:39 <vagrantc> it could be a soft deadline for proposals, even if we don't *decide* on one
18:32:45 <emaste> I thought it was a pre-summit deadline that was rejected, not a deadline in general
18:33:05 <vagrantc> i think submissions are more likely to come with a deadline, at least from the general public
18:33:22 <emaste> right
18:33:36 <emaste> it doesn't have to be a deadline for us to choose, just a deadline for us to solicit
18:33:43 <h01ger> and then we are forced to decide because we set a deadline
18:33:52 <lamby> Nah, we could always re-solicit. )
18:33:55 <h01ger> and then we'll pick something bad because we said we would
18:34:23 <emaste> no, if nothing good gets submitted we don't pick any
18:34:28 <h01ger> we did well for 2y without a logo
18:34:45 <h01ger> emaste: i dont believe that will happen. some people will like crap and pick that.
18:34:50 <h01ger> and say, hey, its great
18:35:10 <vagrantc> and some people will reject perfectly good and useable logos and never pick anything ...
18:35:14 <h01ger> sorry to be an elitist artist here ;-p
18:35:16 <vagrantc> so, whatever
18:35:39 <emaste> indeed, so no deadline then. but let's be explicit that we're soliciting submissions
18:36:02 <lamby> emaste: explicit where?
18:36:15 <emaste> on the wiki
18:36:20 <lamby> cool, i'll add a big banner
18:36:35 * vagrantc proposes a deadline of 2092-12-31
18:36:38 <lamby> #action lamby to make it very explicit we're solititing submissions (w/no deadline)
18:36:40 <h01ger> or, we go with logo v0.1 and make it explicit that this is a first version of the logo ;)
18:36:54 * h01ger trying to be less of an elitist artist and more fun
18:37:11 <lamby> Let's move on.
18:37:13 <emaste> lamby: i.e., how could someone who's not a wiki.debian.org account holder submit a logo
18:37:14 <vagrantc> cheers
18:37:16 <emaste> yes
18:37:19 <lamby> #topic debrebuild
18:37:25 <vagrantc> emaste: get someone to proxy submit
18:37:26 <lamby> (Who added this?)
18:37:28 <HW42> I
18:37:31 <h01ger> emaste: mail it to us. i'll happily add it to the wiki…
18:37:45 <lamby> HW42: Cool, go ahead :)
18:37:53 <HW42> I added this, josch made a nice tool currently called debrebuild
18:38:07 <HW42> it's an improved version of srebuild
18:38:07 <emaste> h01ger: right, I mean let's mention that (emailing) on the wiki
18:38:14 <lamby> emaste: (ack, will do)
18:38:18 <h01ger> emaste: please go ahead
18:38:30 <HW42> currently it lives in the linked mail thread.
18:38:35 <h01ger> HW42: where's the git repo? is it in sid? ah.
18:38:38 <h01ger> HW42: link?
18:38:49 <h01ger> https://lists.alioth.debian.org/pipermail/reproducible-builds/Week-of-Mon-20161107/007577.html
18:39:11 <HW42> it was my suggestion to make it not sbuild specific
18:39:33 <HW42> but now we need either a Maintainer or josch will merge it back into sbuild
18:39:46 <h01ger> HW42: josch liked the suggestion (AIUI) but was not captable to work on it
18:39:52 <h01ger> HW42: how about you? ;)
18:40:31 <HW42> I certainly can help, but IIUC the main point was a Debian maintainer
18:40:44 <deki> can't it be added to devscripts or so?
18:40:57 <h01ger> HW42: how about you become one? or as a first stop, forward that mail to the bts, eg as a bug against devscripts?
18:41:07 <lamby> HW42: Why do we need a Debian maintainer specifically? To upload it…?
18:41:52 <HW42> so if I understand you correctly your are fine to put it in a git repo and we will later look who uploads a package?
18:41:53 <vagrantc> if someone needs upload rights, surely there's a handful of people in this group ablle to sponsor uploads :)
18:42:08 <HW42> IIUC the point was to get it fast into the Debain acrhive
18:42:20 <lamby> HW42: Yep. I'm very happy to upload/sponsor stuff…
18:42:33 <vagrantc> devscripts seems a plausible candidate, then
18:42:47 <HW42> ok, I will respond to joschs mail with this
18:42:52 <lamby> HW42: great, thanks!
18:42:53 <HW42> (after all he did the work)
18:42:54 <vagrantc> if you don't want an entirely separate package
18:43:00 <h01ger> HW42: as vagrantc said, i'd be more than glad to sponsor packages you say are good for the archive! (where sponsor means review _etc_ and then sign+upload ;)
18:43:22 <lamby> #action HW42 to respond to joschs mail re. sponsorship of a new package and/or adding to devscripts or similar
18:43:51 <lamby> Thanks, will be nice to see the ball rolling on that
18:44:09 <lamby> #topic separate mailing list reproducible-bugs@ for bugs?
18:44:20 <lamby> Someone want to claim this? :)
18:44:26 * h01ger would like that
18:44:42 <deki> for what bugs?
18:45:12 <vagrantc> x-debbugs-cc? maintainer (e.g. diffoscope)?
18:45:32 <lamby> It would be nice if whoever added this would make the case for it. Any takers?
18:46:04 <infinity0> oh this was me
18:46:12 <lamby> I'm guessing the issue is excessive x-debbugs-cc from patches/ftbfs is annoying. They could go to another list, presumably ending in -bugs.
18:46:18 <lamby> infinity0: hi. go ahead.
18:46:26 <infinity0> yeah, it's just making discussions take more time to follow and find
18:46:34 <infinity0> discussion threads, i mean
18:47:07 <lamby> Okay. Do you have a proposal?
18:47:08 <infinity0> easier to get an overview of the outstanding discussions if they're not split view-wise by 20 bugs to small packages in between them
18:47:12 <HW42> is there an easy way to also get the follow up mails to this ML
18:47:42 <infinity0> yes, we create a reproducible-bugs@lists.alioth.debian.org and put new bugs there. or i guess it's easier to move the discussions to another list (since the BTS already contains the current ML)
18:48:01 <h01ger> the "proposal" part of this topic is actually quite hard. the "yes, the idea is good" part is easy
18:48:13 <lamby> We can easily move the usertags to a new list, it would be harder to move the discussions.
18:48:20 <h01ger> reproducible-bugs@lists.alioth.debian.org sounds like a good name.
18:48:21 <deki> infinity0: you don't use a mail client with threading? :)
18:48:26 * h01ger nods lamby
18:48:40 <lamby> The problem is mostly the x-debbugs-cc; for that we just need to a) create the list and b) change the template(s)
18:48:48 <infinity0> i do but the overview list looks like "discussion A \n bug 1 \n bug 2 \n ... \n bug 20 \n discussion B"
18:48:55 <deki> ah ok
18:49:17 <h01ger> deki: while i agree in theory, in practice not everybody is good at filtering. our list is too full
18:49:23 <infinity0> it's not urgent, we can think about it some more. atm i am highlighting the "important" threads with local colours
18:49:36 <lamby> I think we all agree its an issue
18:49:39 <HW42> when we have moved this to r-bugs@ is there an easy way that the BTS sends also the follow-up mails
18:49:52 <HW42> I'm always wondering how many bugs get responses
18:50:07 <lamby> HW42: Followup mails go to the submitter anyway, so that's an orthogonal issue.
18:50:09 <deki> is there even an interest in the x-debbugs-cc? maybe if it's too noisy we can also just drop that
18:50:14 <h01ger> HW42: thats a deficiency of the bts, submitters are not automatically subscribed…
18:50:22 <h01ger> deki: i love them
18:50:27 <h01ger> (and read them)
18:50:34 <lamby> I'm very interested in x-debbugs-cc, but… yeah. Swamping the others.
18:50:54 <lamby> How about I action myself to a) create the list and b) change the template(s) to point x-debbugs-cc to that?
18:50:56 <h01ger> switching to reproducible-bugs@lists.alioth.debian.org seems like it could work?
18:51:05 <h01ger> lamby++
18:51:10 <deki> sounds good
18:51:12 <lamby> That would appear to solve 99%, if not all of the issue.
18:51:12 <HW42> +1
18:51:19 <lamby> infinity0: what do you think?
18:51:24 <infinity0> cool, yeah thanks!
18:51:27 <h01ger> lamby: and c.) move all the bugs
18:51:37 <h01ger> and d.) send patches for j.d.n.git :)
18:51:41 <deki> why move the bugs?
18:51:42 <HW42> lamby: c) write a short mail, so people update their personal template
18:51:48 <infinity0> does that include the existing bugs? i could probably write a script for the user-tags, but not sure about the CC-headers
18:51:52 <h01ger> deki: the usertags
18:52:03 <deki> h01ger: can't we keep the usertags as they are?
18:52:05 <lamby> #action lamby to create new -bugs list, etc., update usertags/templates, etc.
18:52:20 <deki> usertags don't create mails
18:52:21 <lamby> Actually, yeah, no need to move usertags.
18:52:23 <h01ger> which reminds me, i have a related topic
18:52:33 <h01ger> wrong user tagged bugs
18:52:40 <lamby> h01ger: Please keep for "any other business" :)
18:52:41 <h01ger> lamby: topic please
18:52:48 <h01ger> it would fit perfectly
18:52:52 <h01ger> and its short
18:53:00 <lamby> (Sure, just 1 moment)
18:53:34 <lamby> Do we want to change the usertag? I'm not sure we do. Just want to change the -cc
18:53:41 <h01ger> current usertagged bugs are visible here:
18:53:47 * deki agrees with only changing -cc
18:54:00 <h01ger> lamby: right, we dont want to, i just see i was wrong.
18:54:03 <h01ger> https://udd.debian.org/cgi-bin/bts-usertags.cgi?user=reproducible-builds%40lists.alioth.debian.org
18:54:09 <h01ger> are all usertagged bugs
18:54:13 <lamby> deki: Cool, okay. Well, we can always move them later.
18:54:20 <h01ger> https://udd.debian.org/cgi-bin/bts-usertags.cgi?user=reproducible-builds%40lists.debian.org is a mistyped bug
18:54:27 <lamby> #action (lamby to not update usertags)
18:54:31 <h01ger> https://udd.debian.org/cgi-bin/bts-usertags.cgi?user=reproducible-builds%40alioth.debian.org are three more mistyped bugs
18:54:39 <h01ger> https://udd.debian.org/cgi-bin/bts-usertags.cgi?user=Reproducible-builds%40lists.alioth.debian.org another one
18:54:41 <lamby> #topic wrong user tagged bugs
18:54:44 <lamby> h01ger: go ahead
18:54:47 <h01ger> can some one please clean that up=
18:54:48 <h01ger> ?
18:55:10 <deki> i will do it
18:55:11 * h01ger is already done with this little subtopic and closes 4 tabs here and says "thank you", whoever picks this
18:55:13 <h01ger> deki: danke
18:55:29 <lamby> #action deki to clean up usertags
18:55:46 <h01ger> https://udd.debian.org/cgi-bin/bts-usertags.cgi?browse=users is awesome, btw
18:56:02 <lamby> Any other business? Mention it and I'll #topic it up…
18:56:37 <h01ger> #topic aob
18:57:05 <h01ger> lamby: ^
18:57:05 <vagrantc> looks like meetbot only respects lamby
18:57:23 <lamby> Well, seems like there is no AOB so let's just call it a night :)
18:57:26 <lamby> #endmeeting