18:29:09 <sumpfralle2> #startmeeting
18:29:09 <MeetBot> Meeting started Wed Aug  1 18:29:09 2018 UTC.  The chair is sumpfralle2. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:29:09 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:29:37 <sumpfralle2> #chair TheSnide h01ger be0rn kenyon chteuchteu
18:29:37 <MeetBot> Current chairs: TheSnide be0rn chteuchteu h01ger kenyon sumpfralle2
18:29:45 <sumpfralle2> Welcome!
18:30:30 <sumpfralle2> let's see who was able to escape the sun today ...
18:33:12 <sumpfralle2> #topic Bits from the last week
18:33:53 <sumpfralle2> I just added some munin-nodes to the setup of demo.munin-monitoring.org.
18:34:14 <sumpfralle2> Now it should represent a usual setup (>10 hosts).
18:35:00 <sumpfralle2> currently there are two host groups visible, that will probably disappear quite soon. I did some renaming ...
18:35:14 <sumpfralle2> disappearing ones: "minions" and "other"
18:35:14 <TheSnide> hi
18:35:17 <sumpfralle2> hello
18:35:54 <sumpfralle2> regarding the renaming of groups: do you think, they will disappear in a pre3 installation?
18:36:13 <TheSnide> nice!
18:36:56 <sumpfralle2> I could add some more routers from our local wireless community, but I guess, more of them would be boring ...
18:37:08 <TheSnide> no. which is on purpose... but now it looks weird indeed.
18:37:26 <TheSnide> so, i'll have to rethink it a little.
18:37:51 <sumpfralle2> ah - ok - so there is currently no concept of "expiry" of the database items?
18:37:55 <TheSnide> (that is the whole point of *using* munin)
18:37:58 <sumpfralle2> (or nodes / groups / datasets ...)
18:38:00 <TheSnide> nope
18:38:02 <sumpfralle2> ok
18:38:16 <sumpfralle2> so: should I clean the items from the database manually?
18:38:20 <sumpfralle2> or just remove it?
18:38:24 <TheSnide> my idea was "removal" shall be done by a human
18:38:41 <sumpfralle2> ok - if we offer a tool for that, it should be ok
18:39:05 <sumpfralle2> a few months of expiry would also feel ok to me - but I do not mind
18:39:08 <TheSnide> now, it becomes clear that we need a 'munin-adm' tool
18:39:31 <sumpfralle2> hehe - this can get a bit overwhelming, maybe :)
18:39:40 <sumpfralle2> let us for now start with "just remove the database"?
18:39:48 <TheSnide> yep.
18:39:49 <sumpfralle2> (this is acceptable, I think)
18:40:28 <sumpfralle2> How was your week? Anything munin related?
18:41:15 <TheSnide> munin-adm wont be ready for 3.0 anyway
18:41:41 <sumpfralle2> I could even imagine, that we will get away without such a tool.
18:41:54 <TheSnide> nope, back to work for me. so quite packed :(
18:41:55 <sumpfralle2> (it would be nice for the simplicity of things)
18:42:03 <sumpfralle2> buh :(
18:42:29 <sumpfralle2> #topic other things
18:42:54 <sumpfralle2> Currently I owe h01ger an update of my Debian packaging proposal for 2.0.
18:42:59 <sumpfralle2> I think, I will do this today.
18:43:21 <sumpfralle2> And - since I just tackled the demo server - I would install the plugin gallery there.
18:43:43 <sumpfralle2> In a perfect world, I would let it get updated regularly from the git repository.
18:43:44 <TheSnide> +1
18:44:01 <sumpfralle2> But this would involve running external scripts (the one from the repository) unattended.
18:44:08 <sumpfralle2> I would do this in a local user account.
18:44:15 <sumpfralle2> Is that acceptable from your point of view?
18:44:25 <sumpfralle2> Or do we prefer a manual "git pull"?
18:44:40 <TheSnide> i usually prefer a manual thing
18:45:16 <sumpfralle2> I slightly prefer automatization :)
18:45:23 <sumpfralle2> you decide
18:46:02 <sumpfralle2> ugh: "automation"
18:46:02 <TheSnide> but if you feel you can secure it enougth i'm okay
18:46:49 <sumpfralle2> the security would be: non-root user permissions and our diligence when checking merge requests
18:46:56 <TheSnide> ie: require a signed tag to execute it
18:47:04 <sumpfralle2> hm - ok - manual :)
18:47:49 <sumpfralle2> someone recently proposed a "how many git commits behind origin" munin plugin - we could use that to trigger alarms, when our checkout gets outdated ...
18:48:06 <TheSnide> i'm also in deep favor for automation. but here it is from a public git. so...
18:48:13 <sumpfralle2> ok
18:48:31 <sumpfralle2> #action sumpfralle2 install gallery on demo - with manual update process
18:48:40 <TheSnide> +1 for that plugin. as it would dogfood
18:48:48 <sumpfralle2> yeah
18:49:09 <TheSnide> it would also be nice to use it on demo.mm0 ;)
18:49:29 <sumpfralle2> but we use the Debian package - that does not work?
18:49:37 <sumpfralle2> or would you like to use a source installation?
18:50:06 <TheSnide> it should be able to track a random remote branch
18:50:42 <TheSnide> i'd hack it, but it is in Py.. so i'll leave to you :-p
18:50:54 <sumpfralle2> my pleasure :)
18:51:29 <sumpfralle2> #topic epel packaging
18:51:42 <sumpfralle2> bcg: how is the packaging?
18:51:47 <sumpfralle2> (just in case you are here)
18:52:02 <TheSnide> it could use the version of a deb package, and use it as the tag
18:52:04 <bcg> Slow progress this week.
18:52:17 <sumpfralle2> TheSnide: I will think about that.
18:52:25 <TheSnide> more ideas outside meeting
18:52:33 <sumpfralle2> bcg: no need to hurry - I am just curious
18:52:40 <bcg> Dipohl is running my rpms already, but I want to do some small cleanup still.
18:52:43 <sumpfralle2> I was amazed by the amount of practical feedback you provided!
18:53:11 <TheSnide> yeah, bcg is usually pretty amazing ;)
18:53:25 <bcg> So I hope it will hit to epel testing next week, stable in two weeks.
18:53:36 <sumpfralle2> yeah!
18:53:44 <TheSnide> \o/
18:54:26 <sumpfralle2> and then we will start the "who packages a new release first?" game between epel and Debian :)
18:54:39 <bcg> If anybody wants to test them now, go to https:/b.bbbs.net/m/
18:54:59 * TheSnide will always win ... with tgz :-))
18:55:00 <sumpfralle2> #info please proposed test EPEL packages: https:/b.bbbs.net/m/
18:55:04 <sumpfralle2> :)
18:55:23 <sumpfralle2> #topic release handling
18:55:29 <sumpfralle2> may I switch the topic?
18:55:38 <sumpfralle2> aka: are we finished with epel?
18:55:43 <bcg> finished.
18:55:56 <sumpfralle2> fine
18:55:57 <TheSnide> .ooO( you just did )
18:56:04 <sumpfralle2> jaja - too quick fingers :(
18:56:14 <TheSnide> hehe
18:56:24 <sumpfralle2> in the documentation there are currently quite outdated release descriptions
18:56:28 <sumpfralle2> something with svn, I think
18:56:36 <TheSnide> huhu
18:56:39 <sumpfralle2> should I rewrite that our would you (TheSnide) want to?
18:57:05 <sumpfralle2> hidden side question: how is the process of upload the tgz?
18:57:09 <TheSnide> well, i cannot offer any SLA
18:57:41 <sumpfralle2> you mean: time between tag and release? :)
18:57:41 <TheSnide> the process is fully automated ... on my laptop ;)
18:58:20 <sumpfralle2> there is more to it than: make tgz && do_sign && rsync FOO ?
18:58:31 <TheSnide> not really
18:58:53 <sumpfralle2> personally I like to document this for myself in the public release description :)
18:59:28 <sumpfralle2> so if you send me your script - I will translate it
18:59:38 <sumpfralle2> (just lacking the permissions for the actual upload - which is OK)
19:02:09 * sumpfralle2 received the recipe on a side-channel and is happy
19:02:38 <sumpfralle2> I will prepare a merge request for an updated release description
19:04:12 <sumpfralle2> any other topics?
19:04:46 <TheSnide> not really, sorry
19:05:08 <sumpfralle2> hehe - we had 30 minutes - more than enough :)
19:05:17 <sumpfralle2> (or just the perfect time)
19:05:21 <sumpfralle2> great
19:05:36 <sumpfralle2> so - have a good and non-overwhelming week! :)
19:05:45 <TheSnide> +1
19:05:47 <sumpfralle2> #endmeeting