19:28:48 <sumpfralle2> #startmeeting
19:28:48 <MeetBot> Meeting started Wed Jul 18 19:28:48 2018 UTC.  The chair is sumpfralle2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:28:48 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:29:11 <sumpfralle2> #chair dipohl TheSnide h01ger chteuchteu be0rn kenyon
19:29:11 <MeetBot> Current chairs: TheSnide be0rn chteuchteu dipohl h01ger kenyon sumpfralle2
19:29:19 <sumpfralle2> Welcome!
19:30:13 <sumpfralle2> Do we have some topics? Or just a review of the last week?
19:30:44 <dipohl> #topic epel package
19:31:09 <dipohl> it seems that will not come
19:31:26 <dipohl> no one took the bugzilla ticket
19:31:35 <sumpfralle2> what a pity!
19:31:59 <dipohl> yes
19:32:26 <sumpfralle2> I had a bit of contact with the package, due to an issue opened by a user. There I noticed, that their package contained two or three small fixes for things, that we can integrate.
19:32:33 <sumpfralle2> Just minor stuff, but worth taking.
19:32:45 <sumpfralle2> But that is not relevant to the packaging question itself.
19:32:47 <dipohl> https://bugzilla.redhat.com/show_bug.cgi?id=1575261
19:33:27 <dipohl> Assigned To:              Orphan Owner
19:33:29 <sumpfralle2> Do you remember, who in this channel stepped up for taking a look at that?
19:33:38 <sumpfralle2> I think, there were two people.
19:33:52 <dipohl> the old maintainer is fenris02
19:34:11 <dipohl> but he dropped the job
19:34:42 <dipohl> I said, that I will try to install the new Munin version from source package
19:34:56 <dipohl> but I have to much other urgent things to do at the time..
19:35:44 <dipohl> perhaps we should write a "help needed" mail to munin-users ML?
19:35:59 <sumpfralle2> sounds good!
19:36:04 <sumpfralle2> would you do that?
19:36:17 <dipohl> yes will do in the next time
19:36:45 <sumpfralle2> #action dipohl Send a request for help for EPEL packaging to the munin-user list.
19:37:10 <sumpfralle2> next topic?
19:38:19 <dipohl> #topic Plugin Gallery
19:38:30 <sumpfralle2> ha - that is me, I guess :)
19:38:44 <sumpfralle2> be0rn gave me access to a server, we could use a few weeks ago.
19:38:45 <dipohl> I saw that your improved version is not installed at the time
19:38:58 <sumpfralle2> But I did not do it up to now.
19:39:06 <sumpfralle2> Good reminder - that will happen til next week.
19:39:20 <sumpfralle2> #action sumpfralle2 Setup new gallery server.
19:39:22 <dipohl> \o/
19:39:56 <sumpfralle2> we are quick with the topics and handing out with tasks :)
19:40:05 <dipohl> :-)
19:40:51 <dipohl> #topic demo server
19:40:52 <dipohl> http://demo.munin-monitoring.org/
19:41:06 <dipohl> ^^ not the recent developer version
19:41:17 <sumpfralle2> oh - I will take, that, too.
19:41:24 <dipohl> This page was generated by Munin 		version 2.999.7
19:41:39 <sumpfralle2> I have access and I think, I proposed once, that I will take care for it.
19:41:52 <sumpfralle2> #action sumpfralle2 Update demo server.
19:42:11 <sumpfralle2> This should probably remove a lot of cron-mails that are currently trickling into my inbox :)
19:42:19 <dipohl> ;-)
19:42:38 <sumpfralle2> Any more missions? :)
19:43:01 * dipohl is finished with her todo list
19:43:38 <sumpfralle2> hehe - you are quite organized :)
19:44:03 * sumpfralle2 is browsing throug my list, too ...
19:44:42 <sumpfralle2> there is nothing specific on my list ...
19:45:00 <sumpfralle2> #topic What happened recently?
19:45:20 <sumpfralle2> I did - as usual - a bit of plugin improvements.
19:45:31 <sumpfralle2> I think, TheSnide is busy working on the 3.0 branch.
19:45:34 <sumpfralle2> (master)
19:46:11 <sumpfralle2> I prepared Debian packaging updates, that are happily waiting for a review by h01ger.
19:46:24 <sumpfralle2> That's it from my side.
19:46:56 <dipohl> thanks for all your work on this!!
19:47:16 <sumpfralle2> I have fun :)
19:47:23 <dipohl> thats fine :-)
19:47:42 <sumpfralle2> I wanted to dive into Debian packaging anyway - and this was a very good starting point for a lot of details.
19:47:47 <dipohl> #topic munin future
19:48:09 <sumpfralle2> "future" sounds big :)
19:48:22 <dipohl> I read the irc protocol from your discussion about munin 3.0
19:48:45 <dipohl> I cannot say that I understood all the things
19:48:58 <dipohl> do we have a concept paper for 3.0?
19:49:19 <sumpfralle2> I do not think so.
19:49:40 <dipohl> I am especially interested to know about the role that DB will play in the future
19:49:53 <sumpfralle2> Since we are still a (more-or-less) one-man-development team with regards to the munin internals, this is an acceptable situation, I guess.
19:50:13 <sumpfralle2> I understand the DB as a cache and state storage.
19:50:37 <dipohl> and now change from sqlite to pgsql?
19:50:42 <sumpfralle2> Thus it can be thrown away / reset whenever wanted - just at the cost of a bit of persistence for the alarms or similar.
19:50:56 <sumpfralle2> It is supposed to be configurable.
19:51:10 <sumpfralle2> The commit message is misleading, if I remember correctly.
19:51:16 <sumpfralle2> Default: sqlite
19:51:21 <sumpfralle2> Configurable for pgsel
19:51:23 <sumpfralle2> sql
19:52:30 <sumpfralle2> It looks reasonable and healthy, I think. And it should clear a lot of hard to read code with regards to previous data structure access.
19:53:25 <sumpfralle2> I think, the end of the discussion put a good perspective on the position of munin in the monitoring eco system.
19:53:38 <sumpfralle2> (if it was that specific discussion)
19:54:01 <sumpfralle2> Light and easy - with low-level extensibility ...
19:58:01 <dipohl> thanks for the explanations!
19:59:01 <dipohl> Anyhow I would be happy if version 2.0 will live further on for some years, as it is sufficient for my needs
19:59:36 <sumpfralle2> It looks like it will survive for at least one more Debian release.
19:59:58 <sumpfralle2> And it is basically in maintenance mode now for quite some years - without a lot of effort.
20:00:17 <sumpfralle2> Thus I think, it can live for a bit longer.
20:00:25 <sumpfralle2> (even after the magic 3.0 release)
20:00:34 <dipohl> :-)
20:02:31 <sumpfralle2> Do you have more topics?
20:02:37 <dipohl> I don't
20:03:21 <sumpfralle2> Same for me.
20:03:32 <sumpfralle2> So we can jump back to the other funny things :)
20:03:43 <sumpfralle2> Have a good evening!
20:03:49 <dipohl> same 2 U!
20:03:54 <sumpfralle2> #endmeeting