19:35:38 <dipohl> #startmeeting
19:35:38 <MeetBot> Meeting started Wed Sep 28 19:35:38 2016 UTC.  The chair is dipohl. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:35:38 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:38:26 <dipohl> ssm: I created the pull request for hddtemp_smartctl yesterday
19:38:57 <dipohl> can you commit the changes to stable2.0?
19:42:26 <ssm> dipohl: I can do the merge
19:42:50 <h01ger> hi
19:42:59 <ssm> 'ello
19:43:14 <dipohl> hi h01ger!
19:43:27 <h01ger> https://bugs.debian.org/cgi-bin/pkgreport.cgi?include=tags%3Apatch&exclude=tags%3Apending&pend-exc=done&repeatmerged=no&src=munin has five more patches for 2.0.x
19:45:16 <dipohl> h01ger: all commits that we do now will be released in 2.0.27 in a few months, right?
19:46:28 <h01ger> dipohl: i rather hope days
19:46:41 <dipohl> will we create a 2.0.26.something release soon?
19:46:47 <h01ger> (or maybe a weeks. but why not in days :)
19:46:57 <ssm> dipohl: 2.0.27 is the next stable-2.0 release
19:46:57 <h01ger> dipohl: see topic. 2.0.26 has been released
19:47:49 <dipohl> then I would propose, we take a few weeks and get more things done with it
19:47:50 <h01ger> 2.0.26-1 is in Debian sid (unstable) and will enter Debian Stretch (testing) tomorrow, which means we can upload it to jessie-backports (stable-backports) tomorrow too
19:48:12 * h01ger mumbles "release early, release often"
19:48:39 <dipohl> hmm, as you like - I am not against it :)
19:49:20 <dipohl> It's a pity that TheSnide don't join the meeting today..
19:49:26 <ssm> I've made a 2.0.27 milestone.  Assign issues and bugs to that milestone if relevant. When all are fixed and merged, we are ready for release.
19:50:25 * h01ger suggests no new features, just core bugfixes and plugin updates
19:51:14 <dipohl> #topic plugin licenses
19:51:48 <dipohl> h01ger: thanks for the list of plugins with "UNKNOWN" License
19:52:49 <dipohl> https://clbin.com/E5TLH
19:53:08 <h01ger> thats a 3.0 topic, right?
19:53:23 * dipohl don't know..
19:53:40 * h01ger firmly thinks so
19:54:19 <h01ger> i also think that all munin contributions are GPL2 by default because thats the munin licence since 2001 (or however old munin is)
19:54:38 <ssm> 2001 is the import from CVS to SVN, I think. :)
19:54:50 <ssm> I did not have history before that when I converted from SVN to git
19:55:16 <dipohl> sources for plugins were Munin-Exchange, then the Django Website of an external, now GIT
19:56:08 <ssm> that's the "contrib" plugin repo, right?
19:56:09 <dipohl> I don't know if in all these the reference to GPL 2 was clearly addressed..
19:56:19 <dipohl> ssm: yes
19:56:27 <h01ger> dipohl: so you assume the worst. sigh.
19:56:28 <ssm> . o O { there be dwagons }
19:57:00 <h01ger> and as ssm hints, plugins with dubious licences have been added to contrib…
19:58:32 <dipohl> for the future we should communicate clear rules
19:58:50 <dipohl> I would like to restrict to popular licenses
19:59:55 <ssm> if someone wants to use an unpopular license, we do not need to host it, and they can distribute the plugin themselves?
20:00:45 <dipohl> it is not needed to restrict to GPL, right?
20:00:49 * ssm looks at https://wiki.debian.org/DFSGLicenses as an OK set of licenses. I'm sure there are others.
20:02:21 <dipohl> h01ger: yes I fear we have some worst case plugins in the core
20:02:52 <h01ger> dipohl: please name them
20:03:00 <h01ger> file bugs
20:03:08 <dipohl> I remember to have seen some trac tickets where Nicolai said that the author is unknown
20:03:13 <h01ger> if they are undistributable we need to remove them.
20:03:33 <h01ger> merely unknown author i wouldnt remove
20:03:56 <dipohl> but in this case we cannot ask for permission to set to GPL
20:04:02 * h01ger sighs
20:04:11 <h01ger> we can assume GPL unless otherwise stated
20:04:15 * h01ger sighs
20:04:30 <dipohl> concerning our contributions
20:04:35 <h01ger> dipohl: if you want to demotivate munin development, you should continue this path
20:04:36 <ssm> plugins/node.d/mailman, for instance.  I documented all the plugins at one time, adding "License unknown" to those I could not find the author or license for
20:05:10 <dipohl> I am willing to put time in the plugin issues
20:05:37 <dipohl> if we say it is a 3.0 topic we have some time left
20:06:11 * dipohl hopes to motivate Munin development this way
20:06:13 <dipohl> ;)
20:07:27 * h01ger shakes head… (i think your hopes are very wrong…)
20:07:37 <h01ger> s#wrong#unfounded#
20:07:53 <ssm> there are a small handful of plugins with unknown license.  Most should be trivially rewritable.  The documentation in almost all plugins are written by me, and can be re-used in any new gpl2+ or bsd or mit based plugin.  The actual lines of code should be minimal for those plugins.
20:08:02 <dipohl> h01ger: Please elaborate on that
20:08:23 <h01ger> dipohl: engaging in something which i believe is a waste of time is not fun
20:08:55 * ssm is talking about the core plugins now, by the way.
20:08:57 <h01ger> its useless busywork
20:09:18 <dipohl> h01ger: I would like to combine it with further improvements
20:09:19 <ssm> h01ger: alternatives are "ignore" or "delete"?
20:09:21 <h01ger> we can assume GPL2. sigh.
20:09:29 <ssm> or "assume gplv2"
20:09:45 <h01ger> ssm: ignore if merely unkown and delete if the licence clearly says "do not distribute"
20:09:56 <ssm> works for me
20:10:06 * dipohl is not against it
20:10:19 <h01ger> (ignore means assuming gplv2)
20:10:22 <dipohl> but concerning the plugins I see more thins to improve
20:10:42 <dipohl> meet demands for "vetted plugins"
20:10:59 <dipohl> improve / add perldoc sections
20:11:05 <dipohl> and graphs to the gallery
20:11:07 <h01ger> dipohl: another demotivating factor: it will delay 3.0 further
20:11:47 <dipohl> I would like to work on stable 2.0 as I have time
20:12:12 <dipohl> then also check in to devel
20:12:25 <dipohl> I would say it's not a blocker
20:12:33 <dipohl> but continuous wor..
20:12:34 <dipohl> k
20:13:25 <dipohl> as we lived with this issue for more than a decade ..
20:14:00 <h01ger> then mark it for 3.1 please so its obvious its not needed for 3.0
20:14:32 <dipohl> do we need a roadmap for it?
20:15:02 <dipohl> as we have only few resources I would say it's a general aim to improve the situation
20:15:22 <dipohl> and not a roadmap issue
20:15:43 <dipohl> that would be to ambitious for the small crew
20:16:14 <dipohl> do you agree?
20:21:26 <dipohl> #todo: investigate authors and licenses of all core plugins, set to GPL2 where not otherwise declared
20:22:54 <dipohl> h01ger, ssm: do you agree to this plan?
20:23:20 <h01ger> i'm not sure i would bother
20:24:08 <dipohl> h01ger: so you think it's not an issue / unimportant?
20:24:25 <dipohl> I will not bother if not needed
20:25:12 <dipohl> and a general statement concerning "inherit GPL2" is enough
20:29:57 <dipohl> ssm, h01ger: are you still here?
20:30:27 * ssm is here
20:30:33 * h01ger is awaiting ssm to comment :-)
20:30:44 <ssm> not sure I have anything to add
20:31:06 <dipohl> I would like to close this topic, but with a decision on the plugin issue ~
20:31:44 <ssm> I investigated authors and license on all plugins in 2009. It took a lot of time. I really don't want to do it again. :)
20:32:05 <ssm> but if anyone else wants to, I'm not going to stand in the way...
20:32:25 <dipohl> ssm: how then comes, that there are so many plugins left with UNKNOWN license?
20:32:44 <dipohl> https://clbin.com/E5TLH
20:33:13 <ssm> probably the plugins I could not track the origin of at that time
20:35:05 <dipohl> ok, then another proposal on this issue
20:35:24 <dipohl> we concentrate on better conditions for the future
20:35:46 <dipohl> setup contribution rules for plugins
20:36:55 <dipohl> I already started on "well known categories" more than a year ago
20:37:16 <h01ger> keep the rules short to keep the fun in!
20:39:44 <dipohl> #topic collaboration, participation, information concerning the Munin Developer Team
20:40:21 <dipohl> ssm: TheSnide said to my proposal to found a munin-devel mailing list
20:40:46 <dipohl> that we will not need it, he said we can use the munin-user list for that
20:41:26 <ssm> ok
20:41:47 <dipohl> do you know if all developers are subscribed there?
20:42:09 <ssm> no idea, I don't read it
20:42:16 <dipohl> perfect!
20:42:37 <dipohl> so I will talk to no one relevant there..
20:42:39 <h01ger> lol
20:43:17 * h01ger reads it but its pretty low traffic
20:43:49 <h01ger> so yeah, i think i'm also in favor in just using this list and thus make it more relevant
20:43:58 <ssm> looks like gmane carries it, I added it from there
20:43:59 <h01ger> and not to create another list
20:44:18 <h01ger> ssm: so you now will be reading it?
20:45:01 <h01ger> (8 mails in september so far)
20:45:23 <ssm> does not look too bad signal/noise wise either
20:46:02 * h01ger nods
20:46:11 <h01ger> dipohl: do you know if TheSnide is reading it?
20:46:31 <ssm> first mail gmane has regards munin 1.2.2, in 2005
20:46:35 <dipohl> at least in earlier times he wrote there
20:47:10 <dipohl> I would suppose that I am one of the top 10 posters there ;P
20:48:10 <dipohl> Nicolai Boern and me hat a lot of talk during the time I wrote the Munin Book
20:49:46 <dipohl> ssm: do we have a channel to invite all the developers from github to subscribe if not done already?
20:52:27 <ssm> we have irc, the tools github provides, and the old trac instance we'll be replacing with the test website at https://munin-monitoring.github.io/ as soon as it contains enough useful information, and seems to work ok.
20:53:13 <ssm> we'll be keeping the existing domain for the new web pages, the github.io domain is for development of the new website.
20:53:47 <dipohl> I meand: To Invite them now after this meeting
20:54:39 <dipohl> I think the mailing list will be better as communication platform thenthe meetings here
20:55:10 <dipohl> as there are a lot of supporters / developers that don't join the IRC meetings
20:58:17 <ssm> that's the channels we have.  One can also extract mail addresses from git commits and send a polite email requesting interested parties to join the mailing list.
20:59:07 <dipohl> ssm: do you have mail addresses of the most active members already?
20:59:33 <dipohl> then it would be nice if you can send the invitation
21:00:03 <dipohl> and perhaps add an invitation here in the header of the channel?
21:01:09 <TheSnide> hi. got delayed
21:01:11 <ssm> 'git shortlog -s -n --all --email' in the munin repo is a good start
21:01:15 <ssm> TheSnide: 'evening :)
21:01:23 <dipohl> ah! Hi TheSnide :)
21:01:47 <ssm> but now, I _really_ need to leave.  I'll read the rest of the meeting notes on the meetbot web pages.
21:02:15 <dipohl> I have to go also (got an emergency call per phone some minutes ago..)
21:02:17 <TheSnide> all: thx for starting without me
21:02:30 <kjetilho> dipohl: Gmane is still in flux, so a new mailing list would not be mirrored there
21:02:37 <kjetilho> ... for some time
21:02:42 <ssm> kjetilho: true, dat.
21:03:11 <ssm> . o O { poor larsi }
21:04:06 <dipohl> TheSnide: Shall I say endmeeting or is it also possible later for you?
21:04:29 <TheSnide> i'll do it
21:08:24 <h01ger> hola TheSnide !
21:17:33 * TheSnide reads backlog
21:22:46 <TheSnide> ok, so.
21:22:53 <TheSnide> about the plugin thing.
21:23:11 <TheSnide> in core, i do not really know.
21:23:39 <TheSnide> in contrib, i decided to move *every* plugin to gpl2 unless noted something else.
21:24:09 <TheSnide> ... and act on good faith if the author wants something else afterwards.
21:24:52 <TheSnide> i mean, plugins aren't *that* complicated to rewrite if the need _really_ arise.
21:26:33 <kjetilho> agreed
21:31:08 <TheSnide> for core ones, i'd avocate to do the same. And either :
21:31:10 <TheSnide> a) assign authorship to "munin" in case of uknown author
21:31:15 <TheSnide> b) rewrite it
21:31:18 <TheSnide> c) drop it
21:31:37 <TheSnide> ... and again, act on good faith if the author wants something else afterwards.
21:32:22 <TheSnide> about communications
21:32:32 <TheSnide> IRC is the only medium that works.
21:33:08 <TheSnide> ML died some time ago, and IRC sparkled some teamwork.
21:33:45 <TheSnide> github does work for plugins contributions.
21:34:31 <TheSnide> i don't know about the traffic on the guide nor the website that isn't bot-related.
21:35:34 <TheSnide> about the "mail addresses of the most active members" i guess they are all here
21:36:19 <kjetilho> TheSnide: activity here is not Google-friendly, though
21:36:29 <TheSnide> kjetilho: indeed.
21:36:58 <TheSnide> but i'm not really in web forums :)
21:37:34 <kjetilho> mailing lists are archived and indexed
21:38:00 <TheSnide> indexing needs content to index.
21:39:05 <TheSnide> i won't argue in anyone trying to ressurect the ML
21:39:40 <TheSnide> i just won't bet on it :) ... yet i'd be *VERY* glad to be proved wrong.
21:40:33 <TheSnide> so, if you feel I can help you in setting something up, feel free to ask. I'll help you the best i can
21:40:36 <h01ger> TheSnide: i disagree on the IRC thing in general. you might mean: IRC is the only thing which works for you.
21:41:17 <TheSnide> h01ger: yes.
21:42:06 <TheSnide> but since i'm well aware of the "self fullfilling theory", i'm open to any initiative
21:42:50 <TheSnide> #action TheSnide will resume the announces on the ML
21:43:29 <TheSnide> who is subscribed to it ?
21:43:35 * TheSnide is
21:44:39 <TheSnide> about attractive devs
21:45:11 <TheSnide> Perl is actually repelling most of the dev wanting to fix something
21:46:01 <TheSnide> that, and the fact that I didn't triage all the PR in github :(
21:46:12 <TheSnide> #action TheSnide will triage the PR in github
21:46:48 <dipohl> re (emergency call answered and closed now)
21:46:56 <h01ger> TheSnide: https://bugs.debian.org/cgi-bin/pkgreport.cgi?include=tags%3Apatch&exclude=tags%3Apending&pend-exc=done&repeatmerged=no&src=munin
21:46:56 <TheSnide> dipohl: \o/
21:48:06 <TheSnide> h01ger: from what i saw, every patch should apply to stable-2.0, right ?
21:48:45 <TheSnide> #action TheSnide will apply all the pending patches from debian that apply to stable-2.0.
21:49:12 <h01ger> yes
21:50:20 <dipohl> TheSnide: I made a pull request for changes in hddtemp_smartctl also to master, as Munin-Protocol for V.3 is not different than V.2, right?
21:50:36 <TheSnide> ok, sounds like a plan until next week.
21:50:40 * dipohl does not test under v.3 since now..
21:50:51 <TheSnide> nope, v3 is mostly same
21:50:57 <kjetilho> TheSnide: you really think Perl is repelling?  compared to what?
21:51:19 <TheSnide> kjetilho: JS, python. Even C has more adepts !
21:52:21 <TheSnide> i don't say we should change.
21:52:24 * kjetilho is dubious.  except possibly JS.  not that it matters much, though.
21:52:42 <TheSnide> (hint: it's a *bad* idea to rewrite in another language)
21:53:34 <kjetilho> :)
21:54:03 <dipohl> shall I end the meeting?
21:54:04 <TheSnide> what i'm saying is that Perl will set the contributor back. and the lack of activity will defintiely make him turn seek something else.
21:54:26 <TheSnide> dipohl: you may. thanks
21:54:34 <dipohl> #endmeeting