19:32:21 <TheSnide> #startmeeting
19:32:21 <MeetBot> Meeting started Wed Mar 25 19:32:21 2015 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:32:21 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:33:21 <TheSnide> hi all
19:33:51 <ssm> 'ello
19:33:56 <chteuchteu> Hi!
19:33:57 <TheSnide> #info 2.1.11 is out.
19:34:09 <ssm> and there was much rejoicing
19:34:14 <be0rn> Yaaay
19:34:42 <chteuchteu> :D
19:34:56 <ssm> Any highlights for the 2.1.11 release?
19:35:00 <chteuchteu> Do you know approximatively when it will be available on main distros?
19:35:15 <ssm> munin-cgi-* is dead, long live munin-httpd?
19:36:24 <ssm> chteuchteu: I've spent some time on the packaging.  It'll take a bit more time to get all the packaging metadata (Depends, Breaks, Conflicts, Build-Depends) right, as there also will be more munin-plugins-* packages.  Smooth upgrades from previous versions must  also work
19:37:16 <ssm> Separate packages for munin-plugins-{core,snmp,postgresql,mysql,whatever,ilikeminions,extras}
19:39:07 <TheSnide> #info 2.1.11 contains munin-httpd that *replaces* allcgi.
19:39:28 <ssm> . o O { and there was much rejoicing }
19:40:01 <ssm> I think the cgi scripts have been the primary source of confused users on this channel :)
19:40:10 <TheSnide> as it was based on the field feedback that cgi was nice to have, but hard to configure
19:40:18 <ssm> indeed
19:41:07 <TheSnide> now it just takes going to http://localhost:4948/ to enjoy everything
19:41:39 <TheSnide> #info munin will not (for the forseeable future) have ssl nor acl in httpd
19:42:08 <ssm> what about http/2? ^.^
19:44:48 * ssm was not entirely serious about http/2…
19:45:02 <ssm> (it got quiet)
19:46:49 <be0rn> So we're aiming for the enterprise approach
19:47:14 <be0rn> = if you want security, add it somewhere else ;-)
19:48:17 <be0rn> (For reference, I totally agree - munin-httpd is not the place for these mechanisms)
19:48:18 <TheSnide> i might add some filtering, to choose the nodes you want to see
19:48:57 <ssm> for security, listen on a UNIX domain socket (in the future) and proxy to that
19:49:04 <TheSnide> which might just be vhost based, as it's tje easiest
19:49:12 <be0rn> Some views could be nice, and then those views could be limited in the proxying httpd.
19:49:18 <TheSnide> that's planed, yes.
19:49:31 <be0rn> Cue: rejoicing
19:49:32 <ssm> not a bad idea, really.  Easy to configure views based on user or vhost.
19:50:05 <TheSnide> if user then http basic
19:50:17 <ssm> just pick a really hard-to-use configuration format to keep our reputation intact.  m4 anyone?
19:50:42 <be0rn> json-based m4.
19:51:32 <TheSnide> xslt for enterprise readiness
19:51:33 <ssm> just pick a http header to trust from the forwarding proxy.  Then you instantly get x509 and kerberos authentication and authorization for graph access.  That is enterpricy :D
19:51:43 <be0rn> xslt of course, how could I miss that
19:52:00 <ssm> brain deleted it in self-defense
19:52:47 <TheSnide> k, solved
19:53:16 <ssm> :)
19:56:43 <TheSnide> note that i saw a product that configured itself with xslt. defaults where provided as the input xml, and an identity xslt.
19:57:33 <TheSnide> (obviously java based)
19:58:00 <TheSnide> anyway... next step is 2.1.12
19:58:19 <be0rn> So 2.1.12 will be java based
19:58:21 <TheSnide> and ssm & I wrote some issues on GH
19:58:22 <be0rn> *make notes*
19:58:27 <be0rn> (Sorry, I will stop now)
19:58:33 <TheSnide> ;)
19:59:06 <TheSnide> i think it's a great way to use gh.
19:59:34 <TheSnide> all the gh interactions are now notfied here on irc.
19:59:42 <chteuchteu> Hey! Don't joke about Java, ok? :D
19:59:45 <TheSnide> (even spammy ones)
20:00:21 <TheSnide> chteuchteu: *if* rewrite then *C*.
20:00:52 <ssm> bikeshed! :)
20:01:38 <TheSnide> ... but many did already write partial rewritrs in various languages, on various licensing terms
20:02:07 <chteuchteu> Do they really work?
20:02:28 <TheSnide> i don't think any got much hype, but it means 2 things :
20:02:42 <TheSnide> - the ecosystem is real
20:03:08 <TheSnide> - there have all some interesting features to steal ;)
20:04:00 <TheSnide> chteuchteu: they are all mostly maas. (muni  as a service)
20:05:23 <chteuchteu> ok!
20:05:55 <TheSnide> ... note that the dynazoom was our killer feature, and did some harm to them, as it's quite difficult to replicate efficiently.
20:06:21 <TheSnide> (i struggled enugh to agree)
20:06:49 <TheSnide> multigraph was the second. now that 2.1 heavily uses it.
20:07:45 <TheSnide> some feature where never implemebted in copycats.
20:08:15 <TheSnide> such as .sum and .total
20:08:23 <ssm> .cdef?
20:08:36 <TheSnide> (which are missing from 2.1)
20:09:06 <TheSnide> cdef has some alternates, .sum has none.
20:09:28 <TheSnide> .cdef works in 2.1
20:10:02 <TheSnide> i'd like to rewrtiz the only ruby plugin
20:10:09 <TheSnide> (tomcat)
20:10:54 <TheSnide> i'd like to rewrtie the py based also, to limit deps, but it's less an issue.
20:12:07 <ssm> any c based plugins in use?
20:12:11 <TheSnide> py is used at *build* time for the guide. but should not be required at *runtime*
20:12:58 <TheSnide> my multi1sec rewrtie in C got some attention ( i recieved 5 emails abojt it )
20:13:07 <ssm> for plugins in contrib, requirements are not as strict :)
20:14:19 <TheSnide> indeed
20:14:48 <TheSnide> munin-run-c is missint
20:15:15 <chteuchteu> About multicpu1sec, how comes it isn't available by default? It should, it is great!
20:15:37 <chteuchteu> It's my favorite plugin. It has great colors for screenshots!
20:16:55 <TheSnide> #action TheSnide will *promote* the perl version of multi1sec to core, along with if1sec_
20:17:49 <TheSnide> i'm wondering about a cpu1sec, diskstat1sec & memory1sec.
20:18:02 <ssm> interpreter stats: https://gist.github.com/ssm/3e7b9cdfd66feb480b56
20:18:36 <TheSnide> having system 1sec plugin in core would be a nice marketing move for 2.1
20:19:13 <TheSnide> perl -w :(
20:19:25 <ssm> yup
20:19:31 <ssm> lots of low hanging fruit in there
20:19:39 <TheSnide> moving them to "use warnings" ?
20:19:45 <ssm> yes
20:20:15 <TheSnide> and /usr/local/bin/bash o_O
20:20:23 <ssm> that's the HP-UX plugins
20:20:29 <TheSnide> ... in core ;)
20:20:29 <ssm> bash lives there when installed
20:20:41 <TheSnide> oh, makes sense ;)
20:21:00 * ssm has no hp-ux machine to test those on
20:21:30 * be0rn should get his SunBlade up and running
20:22:14 <be0rn> Then again, I guess a VM could take care of that.
20:37:48 <TheSnide> so, i ran out of subjects
20:38:08 <chteuchteu> I actually bought myself a new Raspberry Pi 2
20:38:30 <chteuchteu> So I'm planning to work on pages layout soon
20:38:37 <chteuchteu> (making things more responsive mainly)
20:40:41 <chteuchteu> That's it for me :)
20:41:25 * ssm has nothing else to mention
20:42:02 <TheSnide> nice ;)
20:42:15 <TheSnide> ok
20:42:26 <TheSnide> #endmeeting