20:15:21 <TheSnide> #startmeeting
20:15:21 <MeetBot> Meeting started Tue Aug 12 20:15:21 2014 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:15:21 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:15:50 <TheSnide> MeetBot: pingall meeting started late
20:15:50 <MeetBot> meeting started late
20:15:50 <MeetBot> AbyssOne AbyssOne_ agrajag anordby asio bauruine be0rn blueyed bzed cae Champi cnu Croccydile dickon dipohl DzAirmaX edong23 eyck federico3 fenris02 funnel ggherdov Grauwolf GrumpyFux h01ger helmut ingvar ivan`` jmccrohan kenyon kjetilho lbft LBo m-r-b magnush
20:15:50 <MeetBot> meepmeep MeetBot Nightmare olasd OliveBeau Patang rosander1 RoyK RoyK^Work Scharrel1 See- simchosi ssm strohi swiftkey swizgard_ TheSnide thu ToBeFree tore trippeh Ttech vinky wens zembutsu zerick zwiebelbot
20:15:50 <MeetBot> meeting started late
20:17:48 <federico3> huh?
20:20:52 * dipohl is here
20:26:26 <dipohl> TheSnide: Meeting or no meeting?
20:42:54 <TheSnide> meeting ;) short & fast
20:43:28 <TheSnide> nothing new here.
20:43:40 <TheSnide> #topic plugins contrib
20:43:58 <TheSnide> dipohl: here you go
20:45:21 <dipohl> I would like to have a sort of "plugins gallery"
20:45:57 <dipohl> since the munin exchange platform died, we have only the plugins sources in github
20:46:34 <dipohl> but only few plugin portraits (implemented via readme.md)
20:47:05 <dipohl> I think we should use the munindoc info for the portraits
20:47:19 <TheSnide> actually, i agree that the github way does not encourage screeshots
20:47:28 <dipohl> and add subdirectories in the github for screenshots
20:48:05 <TheSnide> how would you use munindoc ?
20:48:18 <dipohl> I am just setting up a server of my own and have plans to experiment there
20:48:48 <dipohl> but if it works I would like to see the gallery on munins project server
20:48:59 <dipohl> will that be possible?
20:49:31 <dipohl> concering the idea of implementing it
20:49:57 <dipohl> 1. sync plugin directories to my server
20:50:26 <dipohl> 2. run script that executes munindoc for each plugin and export to HTML format
20:50:55 <dipohl> 3. insert sreenshots in the portraits if existent
20:52:22 * TheSnide does like convention over config
20:52:54 <dipohl> what do you mean in concrete?
20:53:22 <TheSnide> just import a plugin_(1-9).png next to plugin
20:54:06 <TheSnide> no need for subdirs, they can be optional
20:54:54 <dipohl> I thought the subdirectories will help to exclude from distribution build
20:57:29 <dipohl> and will avoid the /garbage/ in dir listing for people who scan for plugin source files
20:57:50 <TheSnide> 1 subdir pzr plugin ?
20:58:06 <dipohl> no per plugin dir
20:58:40 <TheSnide> oh, a common imng/ ?
20:58:49 <TheSnide> img/
20:58:56 <dipohl> yes or "screenshot"
20:59:41 <TheSnide> and have an external cronjob that autogen the .mrst ?
20:59:49 <dipohl> or "example-graph"
21:01:48 <dipohl> .mrst?
21:03:07 <TheSnide> .rst sorry
21:07:35 <dipohl> I do not understand. Please explain it's function
21:08:07 <dipohl> Index with Links to the portrait pages or what?
21:12:53 <dipohl> TheSnide: Concerning the naming convention I vote for <plugin_name>-(1-9).png as the underscore can be part of the plugins name but the dash not
21:14:30 <dipohl> some plugin names end with an underscore.. that will lead to strange names of the images, but not a big problem (none for the regexp at least ;)
21:15:09 <dipohl> e.g.: smart_-1.png, smart_-2.png, ..
21:16:25 <TheSnide> hmmm
21:16:30 <dipohl> we could also identify the time period if we set the rule
21:16:48 <TheSnide> .1.png ?
21:17:12 <dipohl> <plugin_name>.(d|w|m|y)(1-9).png
21:17:30 <TheSnide> yup something like that
21:18:08 <dipohl> and let us call the subdir "example-graphs"
21:18:49 <TheSnide> i'd like a very short name, but ok
21:19:16 <TheSnide> so let's resume
21:19:56 <TheSnide> #agreed a to-be-defined naming scheme will be in effect on contrib.git
21:20:22 <TheSnide> #agreed it will be used to autogen a plugin gallery.
21:20:40 <TheSnide> (havjng to go sorry)
21:20:50 <TheSnide> #endmeeting