18:30:04 <TheSnide> #startmeeting
18:30:04 <MeetBot> Meeting started Tue Dec 31 18:30:04 2013 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:30:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:30:19 <TheSnide> GrumpyFux: late. but present.
18:32:08 <TheSnide> #topic 2.2
18:32:24 <TheSnide> MeetBot: pingall (forgot)
18:32:24 <MeetBot> (forgot)
18:32:24 <MeetBot> agrajag alarig anordby_ asio bauruine be0rn blueyed bzed cae carnil ceed cnu CoalBessy Croccydile dickon DzAirmaX edong23_ errstr EugeneKay eyck fenris02 Flameeyes Grauwolf GrumpyFux h01ger helmut ingvarha_ jgeboski jmccrohan joat kenyon krm Kvisle_ lbft LBo
18:32:24 <MeetBot> magnush MaliutaLap masudak meepmeep MeetBot Nightmare olasd pbn pretec sbadia Scharrels See- simchosi skaby SoboL Spitfire ssm tawm TheSnide thulle ToBeFree trippeh Ttech tuxcrafter Underbyte uovobw vst zwiebelbot
18:32:24 <MeetBot> (forgot)
18:33:13 <TheSnide> #info sql branch was merged today. along with the 2.1.4 release, which contains it.
18:35:26 <TheSnide> as announced on the ML, this release contains a partial cgi for html,  as it is a full rewrite.
18:36:46 <TheSnide> this is a _regression_, but the cron part works as expected. TBH, I didnt advocate CGI HTML anymore on wellsized installs.
18:36:49 * h01ger wishes a great 2014 :-D
18:37:41 <TheSnide> so, it should not be a big issue.
18:38:24 <TheSnide> h01ger: 2.1.4 is dedicated to you. indirectly.
18:38:37 <h01ger> \o/ +what?
18:38:39 <h01ger> :)
18:39:46 <TheSnide> we are getting slowly more pull reqs for munin.git, in various areas.
18:40:05 <TheSnide> that is a very nice thing. (more on that later)
18:40:56 <TheSnide> i hope that by following h01ger's advice to release often it will increase further.
18:42:38 <TheSnide> h01ger: look at the 2.1.4 email :)
18:45:03 <TheSnide> #topic other
18:45:11 <GrumpyFux> TheSnide: did you manage to improve the testing-from-git procedure?
18:46:57 <TheSnide> GrumpyFux: could you explain ?
18:47:25 <GrumpyFux> A few weeks ago, I wanted to test sql branch. But failed to install munin from git
18:50:43 <TheSnide> GrumpyFux: well, you should use the dev_scripts/
18:51:00 <TheSnide> GrumpyFux: but i agree it isnt optimal.
18:53:12 <TheSnide> #info for now the best way to install munin is the scripts in dev_scripts/
18:53:50 <TheSnide> #action TheSnide has to write a short doc about how it works, as it is quite simple to use it.
18:54:28 <TheSnide> #undo
18:54:28 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x1258c90>
18:55:11 <TheSnide> #action TheSnide has to write a short doc about how dev_scripts/ works, as it is quite simple to use it.
18:55:19 <GrumpyFux> +1
18:55:35 <TheSnide> (contextualized actions are better)
18:56:09 <TheSnide> other than that, building a package works surprisingly well also
18:56:24 <TheSnide> ... as it was my main testing workflow
19:04:10 <TheSnide> I'm thinking again about changing the default templates, and i think it would be better to offer a very easy way to change them, instead of force push by default.
19:05:03 <TheSnide> time will tell if we should change the default, and that way we also might have holy wars such as deb /sbin/init :)
19:05:50 <TheSnide> #info mustrap will not be default for 2.2. too disruptive, too little time to test.
19:07:25 <TheSnide> also, one of my goals is to dumb down the code. that would enable much easier contributions along to lower the headache required for fixing bugs.
19:13:10 <TheSnide> to have a feeling about my style, just have a look at the new html cgi in devel.
19:13:39 <GrumpyFux> Will do
19:14:00 <TheSnide> it's very PoP oriented.
19:14:15 <TheSnide> (plain old perl)
19:14:15 <GrumpyFux> The code style of GraphOld is really painful, und I constantly feel the urge to completely refactor it
19:14:35 <TheSnide> GrumpyFux: i know that feeling, trust me.
19:15:31 <TheSnide> and, btw, if anyone has some rants, please do.
19:16:19 <GrumpyFux> The usual "could somebody please take care of open tickets" only
19:16:27 <TheSnide> ... as I often say that i'm a rant freak http://blog.pwkf.org/post/2008/05/26/Why-Negative-comments-are-better-than-positive-ones
19:18:56 <TheSnide> ok... nothing much to say.
19:19:55 <TheSnide> #endmeeting