17:00:37 <TheSnide> #startmeeting
17:00:37 <MeetBot> Meeting started Tue Sep 17 17:00:37 2013 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:37 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:47 <TheSnide> hi
17:00:52 <scn> can I suggest washing some bugs? (unless things have changed significantly since last time I checked)
17:00:52 <be0rn> :)
17:01:34 <TheSnide> #info meeting has started, so it is logged now
17:01:53 <TheSnide> #topic 2.2
17:02:28 * h01ger waves to be in the logs ;)
17:02:29 <TheSnide> progress on the SQL part is going better than anticipated.
17:02:47 <cnu> what's the SQL part? SQL instead of datafile?
17:02:52 <TheSnide> I managed to have a incremental plan
17:02:53 * h01ger would be interested in a 2.0.18 release, not sure if this is on todays agenda
17:02:57 <TheSnide> cnu: yep
17:03:14 <TheSnide> h01ger: oh, that can be done
17:04:10 <TheSnide> #action TheSnide has to craft a .18 soonish
17:05:00 <TheSnide> #info sql datafile will be in 2.2 release.
17:05:27 <TheSnide> #info ... but it will be sqlite only, and quite hacky.
17:05:52 <scn> :)
17:06:11 <kjetilho> the code is only on your laptop so far?
17:07:19 <TheSnide> kjetilho: nope, it is on munin-dev.git:sql
17:07:46 <kjetilho> cool
17:08:00 <TheSnide> #info code is on my github and our dev git
17:09:00 * TheSnide is quite open for review
17:09:45 <TheSnide> #topic else
17:10:19 <TheSnide> now is the time to bring any topic
17:11:00 <scn> bugwash
17:11:11 <TheSnide> #topic bugwash
17:11:36 <TheSnide> yes ? :)
17:11:40 <scn> is this the correct list? http://munin-monitoring.org/report/9
17:13:00 <scn> 313 open bugs, enhancements here and there. I motion that this should be reduced so it is possible to have an overview.
17:13:56 <kjetilho> ouch, lots of work to triage all those 1.x bugs
17:13:59 <TheSnide> scn: i am guilty of mostly looking at the debian bug list
17:14:39 <scn> maybe not having multiple bugtrackers can be a start
17:15:24 <GrumpyFux> discipline to forward each Debian bug to trac should suffice
17:15:45 <TheSnide> GrumpyFux: +1
17:16:05 <GrumpyFux> besides, could somebody kill #1376?
17:16:20 <TheSnide> but, an email api to trac bugs would be awesome
17:17:01 <scn> if you move the bug tracker to github issues, you get a lot of things for free
17:17:09 <scn> (and of course lose some things)
17:17:24 <GrumpyFux> Ugh, discussing bugtrackers is a separate issue.
17:17:41 <GrumpyFux> The current tools might be not the best but they are there.
17:17:48 <kjetilho> scn: that seems risky -- are you sure you will be able to export the data if we want to migrate?
17:17:55 <kjetilho> GrumpyFux: +1
17:18:10 <scn> I agree, sorry.
17:19:16 <scn> ok, what I wanted when I proposed a bugwash was to run through maybe 10-15 bugs and either close or assign them
17:19:59 <GrumpyFux> scn: top-down I guess?
17:21:43 <scn> sounds good. How do you feel about this, TheSnide ?
17:22:20 <TheSnide> #agreed Changing bugtrac is not a good idea.
17:22:43 <GrumpyFux> #1205 bothers me that much and that often I'm inclined to work on it
17:23:07 <TheSnide> #agreed deb maintainers should fwd to trac
17:23:43 <TheSnide> #action scn will organise a bugwash on the trac, to make usable again.
17:23:58 <scn> please don't assign tasks without discussing it first.
17:24:25 <TheSnide> scn: oh, i misunderstood
17:26:25 <TheSnide> scn: can you propose a process to bugwashing ?
17:26:40 <kjetilho> who has access to do triaging?
17:26:57 <scn> TheSnide: I propose that a part of this meeting is spent running through a small set of bugs, and figuring out who will solve them.
17:26:58 <kjetilho> (not surprisingly) I do not have access currently
17:27:23 <scn> running=going
17:28:29 <TheSnide> scn: yeah, could work. nice idea
17:29:20 <TheSnide> scn: could chair that part ?
17:29:51 <TheSnide> no need to be here *every* meeti ng
17:29:57 <scn> I'm usually busy on tuesdays :(
17:30:30 <TheSnide> oh, we could have a separate bug meeting
17:30:44 <TheSnide> but not longer than 15 min
17:31:31 <TheSnide> what timings would suit ppl best here ?
17:31:40 <TheSnide> (normal and/or bug)
17:32:33 <TheSnide> ideally, i'd prefer to have only 1 meeting on tue, but that's my pref :)
17:33:40 <helmut> sorry, I was interrupted, trying to catch up
17:34:54 <TheSnide> scn: what would be awesome is if you could preselect bugs
17:35:11 <TheSnide> scn: i'll chair the bug-part
17:35:30 <TheSnide> preselection is an async task
17:36:13 <TheSnide> ... async, and distributed : if anyone wants a particular bug to be discussed
17:37:12 <TheSnide> #action TheSnide will go through spam bugs
17:37:58 <kjetilho> TheSnide: can you give me access to TICKET_ADMIN?
17:38:11 <TheSnide> kjetilho: ok, will do
17:38:12 <kjetilho> I can do some menial labour
17:38:13 <GrumpyFux> *sigh* Most of the red ones in <http://munin-monitoring.org/report/9> are ugly and/or lack information
17:38:43 <TheSnide> so, we agree on the bugpart in the meetings
17:38:48 <TheSnide> ?
17:38:49 <helmut> question: is there some bug syncing tool between deb and trac in place? for sf.net once a bug is forwarded correctly, the debian bts will automatically notice fixed status.
17:39:51 <helmut> otherwise forwarding bugs to track is a maintenance nightmare
17:39:59 <helmut> *trac
17:40:34 <kjetilho> helmut: shouldn't the relationship be the other way around?
17:40:35 <TheSnide> if the upstream field is filled, bts knows.
17:40:58 <GrumpyFux> Pointers would be sufficient and are availbe on both sides. Important thing is not to oversee some when looking at trac
17:41:45 <helmut> kjetilho: the debian bts should pull status updates from trac, not the other way round.
17:41:53 <kjetilho> exactly.
17:42:03 <kjetilho> but no need to make this complicated.  closing tickets is a manual business anyway, so if BTS is mentioned in the bug report comments, take a look?
17:42:36 <TheSnide> brb (sorry)
17:43:11 <TheSnide> helmut: closing in trac is enough, if bts has the upstremam url
17:43:54 <helmut> TheSnide: thx
17:48:20 <TheSnide> #agreed next meeting will have a bug review. details to be defined.
17:48:59 <TheSnide> #info closing in trac also closes in bts, if upstream url.
17:49:58 <TheSnide> so, anything to add ?
17:52:19 <TheSnide> #endmeeting