13:58:54 <russdeffner> #startmeeting Activation Working Group June 22, 2018
13:58:54 <MeetBot> Meeting started Fri Jun 22 13:58:54 2018 UTC.  The chair is russdeffner. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:54 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:03 <russdeffner> Welcome everyone
13:59:16 <russdeffner> Here is the trello link...
13:59:25 <russdeffner> #link https://trello.com/b/ogU4Wjd6/hot-activation-wg
14:00:01 <russdeffner> There's always more than we can cover in an hour, so let's jump right in
14:00:10 <BlakeGirardot> Hi
14:00:11 <hot_slack_bot> <p.ulbrich> :slightly_smiling_face:
14:00:16 <hot_slack_bot> <p.ulbrich> Hi all
14:00:19 <russdeffner> Please, first take a look over last meeting minutes...
14:00:39 <russdeffner> #topic Review Minutes & Unfinished business
14:01:09 <russdeffner> #link https://trello.com/c/aG8SlkdK/22-previous-meeting-summaries - card for previous meeting minutes/summaries
14:02:49 <russdeffner> I'm sure everyone (including me) did a thorough review of the curriculum content? :D
14:03:15 <russdeffner> or do we need to carry that over?
14:03:47 <russdeffner> definitely shouldn't get lost, but I haven't looked at the gitbook since the content has been ported
14:04:40 <hot_slack_bot> <p.ulbrich> hmm - carry over...?
14:05:55 <russdeffner> Blake, what is your thoughts on this? Should we maybe try to review one course per meeting or something, have a feeling I'm not going to organically start reviewing that stuff anytime soon without a 'schedule'
14:07:11 <russdeffner> and could see this just being an item we never really get anywhere if we just push-till-next-time (over and over)
14:07:44 <hot_slack_bot> <p.ulbrich> agree
14:08:08 <russdeffner> My other thought is that the protocol, curriculum and courses really need a 'project manager' to get a thorough review, update and 're-implementation'
14:08:47 <russdeffner> So, let me action myself on this anyway...
14:09:15 <russdeffner> #action Russ to draft proposal/estimate for Disaster Mapping Program refresh
14:10:01 <russdeffner> I doubt I will get that done before the next meeting; but will shoot for before State of the Map
14:10:35 <russdeffner> Anything else on protocol, curriculum or courses?
14:12:06 <BlakeGirardot> yes, maybe we could do that russ
14:12:19 <russdeffner> ok, I'm just quickly looking through the unfinished biz card...
14:12:26 <russdeffner> #link https://trello.com/c/b2h8Is4D/30-unfinished-business
14:12:37 <BlakeGirardot> I hate to do things twice so maybe we could just take one module and agree to review/revise it before next meeting?
14:13:02 <BlakeGirardot> the review/revise at the same time thing is what I hope to do.
14:13:21 <russdeffner> cool, maybe we should start with the general HOT "Missing Manual" course (although I think you said that hasn't been copied yet?)
14:13:42 <BlakeGirardot> #link https://bgirardot.gitbooks.io/hotosm-activation-curriculum/
14:14:01 <BlakeGirardot> Ya, no I did not do that one cuz it was not part of the activation stuff
14:14:11 <russdeffner> I still want to get a more 'formal' "strategy" for updating the entire program
14:14:41 <russdeffner> Slack wasn't even a thing for us when we did the initial development
14:14:55 <russdeffner> and lots of more important things have changed
14:15:32 <BlakeGirardot> We need to be as non specific as possible so it doesn't have to be updated/fixed everytime somehting shiney comes along and we switch to that like we tend to do :)
14:16:15 <russdeffner> Yes, a more important one would be the Community CoC vs. Membership Code (which doesn't 'live' on the website anymore/currently)
14:16:33 <BlakeGirardot> Aye.
14:17:45 <russdeffner> So in general, I think we could be more effective just looking at one course at a time, while working on a broader strategy for update, upkeep and making it more useful for all
14:18:45 <hot_slack_bot> <russell.deffner> @smit1678 are you available to discuss Imagery Coordination with AWG now?
14:19:25 <russdeffner> So, the other thing that I see us falling towards continually kicking the can down the road...
14:19:30 <russdeffner> Imagery Coordination
14:19:54 <russdeffner> but this is pretty much out of my knowledge bubble
14:20:11 <russdeffner> so need someone/some people to take lead on
14:21:58 <russdeffner> My take is, during disaster, I just need a way to make a request, know that I will get a yes/no answer and that if it's yes I will be able to get the imagery to the mappers in a reasonable time
14:22:01 <BlakeGirardot> There are a few issues tehre really
14:22:27 <BlakeGirardot> The yes/no part we do not have much input into
14:22:28 <hot_slack_bot> <p.ulbrich> what does is it need?
14:22:43 <BlakeGirardot> imagery to the mappers, we should have some control over.
14:23:18 <russdeffner> in my opinion it needs a 'protocol'/standard practice for imagery needs/requests
14:23:52 <russdeffner> bigger issue might be human resources
14:24:13 <russdeffner> but now I'm just guessing becuase it is out of my wheelhouse
14:24:23 <hot_slack_bot> <r_aytoun> I would like to be a part of Imagery Coordination. Even if it so that I can begin to understand what is going on. So many of the Projects are vague as to the actual imagery set that all other imagery needs to be aligned to.
14:25:21 <russdeffner> Great Ralph, let me action you something...
14:25:22 <hot_slack_bot> <p.ulbrich> could we write down the steps, so the responsibility can be shared?
14:26:07 <hot_slack_bot> <r_aytoun> OK Russ
14:26:08 <russdeffner> #action Ralph to connect with Nate, Cristiano and/or Blake to begin exploring a more formalized imagery coordination process
14:26:24 <BlakeGirardot> That is a bit of a seperate issue Ralph... imagery coordination is generally about obtaining imagery, the issue you raise is just not good project creation or instructions
14:27:07 <BlakeGirardot> and again, I just want to stress... obtaining imagery is one issue, getting imagery onto oam so we can use it is another.
14:27:14 <russdeffner> I think a gdoc covering both existing/default imagery and new/requested imagery would be a good start
14:27:29 <BlakeGirardot> and poor instructions is a 3rd, not really related to coordination of imagery
14:27:40 <russdeffner> And, really all of this should eventually become the Imagery role curriculum
14:27:53 <hot_slack_bot> <p.ulbrich> i guess it's also about contacts with providers?
14:28:12 <hot_slack_bot> <r_aytoun> That is why I said I want to try and understand. If I can listen in and see what the problems and processes are then I can better explain it to validators.
14:28:47 <russdeffner> Yes, and Blake and I can tell you that our contacts are not well established
14:29:23 <hot_slack_bot> <p.ulbrich> ok
14:29:30 <russdeffner> Oh, on side note though, did anyone else see the DG imagery for Ebola?
14:29:58 <russdeffner> Haven't looked myself, just noting in case there is interest...
14:30:21 <BlakeGirardot> They did not release any that I know of.
14:30:42 <BlakeGirardot> They did just yesterday release their own ML generated building footprints for the affected area.
14:30:48 <hot_slack_bot> <p.ulbrich> (thinking out "aloud":) what would help to motivate providers?
14:31:02 <russdeffner> Oh, actually it's building footprints too https://www.digitalglobe.com/opendata/ebola-response-democratic-republic-of-the-congo/vector-data
14:31:17 <BlakeGirardot> There is no imagery that is see russ
14:31:31 <BlakeGirardot> that i see *
14:32:06 <russdeffner> ya, think you're right but the site says "The released imagery and vector data can be viewed here."
14:32:23 <BlakeGirardot> And the building footprints are not up to OSM standards really. Very typical ML based output
14:32:26 <russdeffner> just ignore the imagery part ;)
14:33:47 <russdeffner> Ok, well we'll get the exploritory part going with Ralph and I'm sure whomever else wants to help
14:34:01 <russdeffner> shall we move on to current responses?
14:34:41 <russdeffner> silent consent :)
14:34:50 <hot_slack_bot> <p.ulbrich> :+1:
14:34:55 <russdeffner> #topic Current Disaster Responses
14:35:16 <russdeffner> Blake, Gita...?...?
14:35:29 <russdeffner> Eua imagery ugh...?
14:35:41 <BlakeGirardot> I give up
14:35:52 <russdeffner> I 100% support that effort to give up
14:36:24 <hot_slack_bot> <p.ulbrich> groundhog day...?
14:36:24 <BlakeGirardot> I did get some steps from Cristiano, but they were still just a bit beyond me
14:36:47 <russdeffner> It is archived...
14:37:00 <BlakeGirardot> 1. Batch download tiles for one scene
14:37:00 <BlakeGirardot> 2. Gdaltindex to create VRT
14:37:00 <BlakeGirardot> 3. Gdal_translate to convert to single GeoTIFF file
14:37:00 <BlakeGirardot> 4. Lookup metadata on discover.digitalglobe.com
14:37:00 <BlakeGirardot> 5. Upload to OAM
14:37:27 <BlakeGirardot> I got stuck at 2 :)
14:37:31 <hot_slack_bot> <p.ulbrich> Blake, that refers to the protocol?
14:37:37 <hot_slack_bot> <p.ulbrich> imagery?
14:37:48 <BlakeGirardot> No, that is the process to get DG open data imagery to OAM
14:37:59 <hot_slack_bot> <p.ulbrich> ok
14:38:18 <russdeffner> #Info AWG has decided to conclude Cyclone Gita response without completing Eua Island because imagery issues could not be resolved.
14:39:06 <russdeffner> I'll look and see if there are any other loose ends on that, but I don't think so
14:39:10 <russdeffner> Feel better already
14:40:31 <russdeffner> #Info Ebola in DRC - From Jorieke, Thank You! we have completed the areas requested, however there will be a few more projects to help OSM-CD fill in gaps/complete the entire districts
14:41:24 <russdeffner> For Guatemala, I think we can conclude this as well...
14:42:01 <russdeffner> We have fulfilled the request from NASA Disasters Program, and I haven't heard from them since, so don't expect anything further
14:42:13 <BlakeGirardot> I agree. Having looked at the landslide risk areas, seems like we had it pretty well covered
14:42:49 <russdeffner> The areas heavily impacted on the east slope, I haven't heard any need/use case for mapping them prior to the eruption...
14:43:11 <russdeffner> in theory we could get asked to map post-impact, but think that probability is low
14:43:41 <russdeffner> and it's really not a lot of mapping, so could just be done in the background
14:44:35 <russdeffner> #action Russ/Blake phase-3/conclude Fuego Volcano Activation
14:45:45 <russdeffner> #Info Sri Lanka Floods - This will likely continue for many more weeks
14:46:06 <BlakeGirardot> The floods or the projects or both?
14:46:19 <russdeffner> I still haven't heard back from Sutha about reducing the AOI
14:46:28 <BlakeGirardot> aye, that was my next question.
14:46:38 <russdeffner> Just looking that we are doing about 1 project per week, 9 projects total...
14:46:39 <BlakeGirardot> We are making decent progress on them considering the size of the AoI
14:47:14 <russdeffner> Yes, it is going well but especially when other disasters 'take the spotlight' so go our volunteers
14:47:18 <BlakeGirardot> Thankfully it is pretty easy mapping.
14:47:47 <russdeffner> I've asked the Communications WG to help ramp up the messaging, and hope to get some local use case text/pics/etc.
14:48:29 <russdeffner> oh, important side-note...
14:49:19 <russdeffner> #Info Validators have been doing amazing during all these responses! Happy #ValidationFriday!
14:49:48 <russdeffner> I really thought we'd have fallen way behind with these back to back events, but we haven't yet
14:50:15 <russdeffner> So thanks also to the project managers and everyone recruiting more validators
14:50:47 <russdeffner> And to make sure we talk about Japan...
14:51:37 <russdeffner> #Info Osaka Earthquake - we have been supporting OSM-Japan and CrisisMappers Japan
14:52:20 <russdeffner> Things seem to be going pretty smooth, I haven't actually mapped a task there yet; anyone know how they are?
14:52:23 <BlakeGirardot> This one has multiple projects queued up, but we are still on the first one.
14:52:37 <BlakeGirardot> They are pretty easy to map because there is drone imagery
14:52:43 <BlakeGirardot> but super dense
14:53:15 <BlakeGirardot> meaning a lot a lot of buildings. but even with the density, with the good imagery, mapping is not too bad, just a lot ofit.
14:53:42 <russdeffner> cool, I'll try to spend a validation friday moment there
14:53:43 <hot_slack_bot> <r_aytoun> Mapping is of a good standard.
14:53:52 <BlakeGirardot> Not sure how well we will fare with the projects beyond this initial one.
14:54:18 <BlakeGirardot> approx 60k buildings so far, 250 contributors.
14:54:34 <hot_slack_bot> <r_aytoun> Watch out for their use of layer=-1 on the rivers. This clashes with the road tunnels that are also tagged as layer=-1
14:54:36 <russdeffner> Yes, I could see Sri Lanka and Japan both dragging on and hampering each other along the way...
14:55:21 <BlakeGirardot> Hopefully Taichi will have more information after this initial project is completed and perhaps the need for the remaining projects is significantly lower.
14:56:15 <russdeffner> So, it would be good to have another person or three that could help with keeping up-to-date stats, maybe umaps or wikis - basically the things that make it easier for the comms people to do their thing
14:56:54 <BlakeGirardot> The TM needs to replace umaps and wiki asap
14:57:02 <BlakeGirardot> how much work would that save
14:57:27 <BlakeGirardot> sorry off topic i know, but I just can not help mentioning it when the topic comes up.
14:57:48 <russdeffner> But I know I'm talking to the few people that are already doing stuff, just tossing it out there for people later perusing IRC logs
14:58:08 <russdeffner> So we're basically at the hour...
14:58:15 <russdeffner> #topic Any Other Business
14:58:35 <russdeffner> but before ending, any final issues, etc...?
14:58:55 <BlakeGirardot> Oh, i have one thing
14:59:04 <BlakeGirardot> not really new, but let me get this links in there.
15:00:02 <hot_slack_bot> <blake_hot> @r_aytoun These link help explain one of the current issues with imagery
15:00:26 <BlakeGirardot> #link GitHub Issue that describes DG Premium switching to older imagery when zoomed in: https://github.com/openstreetmap/iD/issues/2492
15:01:17 <BlakeGirardot> #link 4 mins video on the issue of DG Premium switching to older imagery - using JOSM disable auto-zoom to avoid the problem https://youtu.be/vfP_hXGb3cM
15:02:02 <BlakeGirardot> That is all from me, sorry could not find them when it was more on topic.
15:02:17 <russdeffner> While Blake's doing that, I'll just say - thanks for coming today; I think we are moving in the right direction there's just a whole lot to do and not a whole lot of us
15:02:19 <hot_slack_bot> <r_aytoun> Thank you Blake
15:02:39 <BlakeGirardot> Thank you russ for everything!
15:02:42 <russdeffner> Thanks All! See you in 2 weeks!
15:02:53 <hot_slack_bot> <p.ulbrich> Have a good weekend all!
15:03:08 <russdeffner> #endmeeting