17:18:46 <unknown_lamer> #startmeeting
17:18:46 <MeetBot> Meeting started Sun Mar 27 17:18:46 2011 UTC.  The chair is unknown_lamer. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:18:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:18:50 <unknown_lamer> #topic Role Call
17:19:06 <unknown_lamer> Please Write `#info $hcoop-username` if you are here
17:19:11 <unknown_lamer> #info clinton
17:19:13 <Smerdyakov> #info adamc
17:19:16 <bipt> #info bpt
17:19:19 <Kuril> #info ryan
17:19:20 <darst> #info rkd
17:19:21 <specksynder> #info shadowfax
17:19:44 <Smerdyakov> (P.S., it's "roll call". :))
17:19:57 <unknown_lamer> I uh ... uh... badgers
17:20:04 <Smerdyakov> Wow, everyone so far using a different nick and username.
17:20:19 <docelic> #info docelic
17:20:24 <Smerdyakov> Aha! :D
17:21:01 <specksynder> the exception that proves the rule!
17:21:13 <unknown_lamer> ok, anyone else around? ntk?
17:21:47 <unknown_lamer> #info 4/5 board members in attendance, frank is missing
17:21:50 <Smerdyakov> I met an HCoop member in person surprisingly about a week ago.  Sorry to distract with that, but it's "sastry", if anyone cares. :)
17:22:10 <unknown_lamer> Good enough, now onto the the first actual topic I guess
17:22:23 <unknown_lamer> #topic Status report on transfer of treasurer duties from adamc to rkd
17:22:40 <unknown_lamer> so, Smerdyakov and darst, how goes darst taking over the day to day treasurer tasks?
17:22:43 <darst> so far I've been doing routine things
17:22:56 <Smerdyakov> #info There's nothing concrete left to do before getting darst set up with bank access.
17:23:12 <darst> and I can do all of the routine stuff fine
17:23:32 <unknown_lamer> The one thing I saw last time I asked for an update was dealing with our upstream bills, have you had a chance to do that yet?
17:23:51 <darst> however, stuff that is done less frequently than monthly: haven't done yet and don't know much about
17:23:59 <Smerdyakov> I saw he processed the Incorp charge.
17:24:16 <Smerdyakov> But some other pieces I've generally done by looking at the bank statement.
17:24:27 <unknown_lamer> the main thing is paying peer1 and whatnot, or do they automagically debit us?
17:24:37 <Smerdyakov> They automatically debit us.
17:24:43 <unknown_lamer> does rsync.net do the same?
17:24:44 <bipt> hi nevetski
17:24:53 <Smerdyakov> Yes.
17:24:53 * nevetski waves cheerfully
17:24:58 <unknown_lamer> awesome
17:24:59 <Smerdyakov> There are no regular bills to pay.  Some yearly things.
17:25:12 <darst> so those typees of charges, I would still need to see to learn how to deal with
17:25:18 <iriefrank> oh goodness me i'm sorry to be late
17:25:23 <unknown_lamer> darst: you better win a board seat next year!
17:25:26 <docelic> Hey iriefrank, all good
17:25:36 <darst> not seeing the bank statements, it's hard to update those
17:25:55 <darst> unknown_lamer: heh, yes... but at least it is documented well now
17:26:00 <unknown_lamer> ok, it seems that darst now has the skills required to be the treasurer
17:26:07 <unknown_lamer> moving forward...
17:26:22 <darst> I am sure I'll keep asking for advice from adam
17:26:23 <Smerdyakov> (I just added the latest Peer 1 bill in the portal.)
17:26:29 <unknown_lamer> #topic What must be done to transfer bank account access to the new treasurer
17:26:47 <Smerdyakov> #info I suppose I need to get in touch with Wells Fargo.
17:27:00 <darst> #link http://wiki.hcoop.net/TreasurerInstructions lists what I do
17:27:20 <unknown_lamer> the main thing here is -- do we want to give darst access now and mail him the debit card and such or do we want to wait until after the election since it starts in four days?
17:27:23 <Smerdyakov> They have no branches within 89 miles of me.
17:27:47 <Smerdyakov> I'd say wait for the election.  Don't know that I could orchestrate it all before then, anyway.
17:28:17 <unknown_lamer> so, am I right here: we just need to add darst  to some list of authorized persons and send him the debit card?
17:28:24 <darst> yeah, may as well wait...
17:28:25 <Smerdyakov> Probably true.
17:28:38 <unknown_lamer> ok then, let's vote:
17:28:38 <Smerdyakov> I can probably give him write access to the web site without talking to humans.
17:28:43 <Smerdyakov> I could at least give ntk read-only access that way.
17:28:50 <darst> right now I am doing the manual work so adam doesn't have to, which is the most important part
17:29:08 <unknown_lamer> The next board will deal with transfering the bank account to the new treasurer at their first meeting
17:29:11 <unknown_lamer> +1
17:29:15 <Smerdyakov> +1
17:29:17 <darst> +1
17:29:21 <iriefrank> +1
17:29:30 <Smerdyakov> Otherwise known as a "pass the buck" vote.
17:29:51 <Smerdyakov> docelic, any opinion?
17:29:52 <unknown_lamer> #agreed The next board will deal with transfering the bank account to the new treasurer at their FIRST MEETING
17:30:09 <unknown_lamer> Smerdyakov: well, we're on the board at least so ... and presumably everyone likes darst enough to reelect him ;)
17:30:25 <docelic> +1
17:30:49 <unknown_lamer> #topic Monthly Income vs Expenses Report
17:31:09 <unknown_lamer> The usual boring... how much do we get in dues vs how much we have to pay other people
17:31:18 <unknown_lamer> the other boring details are available via the money audit page
17:31:43 <darst> our last payment cycle collected $805 in dues
17:31:46 <unknown_lamer> #link https://members.hcoop.net/portal/money?audit=1
17:31:52 <unknown_lamer> darst: can you #info that
17:32:03 <darst> #info our last payment cycle collected $805 in dues
17:32:16 <Smerdyakov> We can dry-run darst giving as much info as he can. :)
17:32:21 <Smerdyakov> #info The bank account balance is $2,451.72.
17:32:54 <Smerdyakov> I think darst should have access to all the rest of the info.
17:33:05 <darst> #info peer1 is deducting $680 per month
17:34:00 <darst> #info incorp $99/year
17:34:01 <unknown_lamer> darst: what is in paypal and google checkout?
17:34:42 * darst searches for monthly income
17:34:44 <docelic> Don't forget to count tech.coop
17:34:47 <darst> wait, the $805 is monthly income
17:34:52 <docelic> We have prepaid some amount, but still
17:35:06 * darst not sure where most of this stuff is
17:35:13 <Smerdyakov> Yes, Tech Co-op is a yearly charge.  I forget how much.
17:35:27 <Smerdyakov> All expense info should be here: https://members.hcoop.net/portal/money?cmd=primary
17:35:44 <docelic> IIRC, after the switch of outpost.hcoop.net to the more cost efficient hosting in the US, the monthly charge is $22.5 (compared to $40-something previously)
17:35:47 <unknown_lamer> our prepayment IIRC ended up being more than a year because we switched to a less expensive vps for outpost
17:35:51 <Smerdyakov> With exchange rate from CAD, our last (and first) Tech Co-op payment was $553.56 per year.
17:36:25 <darst> #info rsync.net deducting -$61.60 monthly
17:36:43 <unknown_lamer> darst: since you will probably be the treasurer in 2-3 weeks can you contact drewc and get clarification on how long we have until we need to pay tech.coop again?
17:37:24 <darst> #action darst contacts drewc at tech.coop to check on payment status for the coop
17:37:32 <Smerdyakov> Last payment was almost exactly a year ago.
17:38:50 <unknown_lamer> so, is that the basic summary of expenses and 'income'?
17:38:58 <unknown_lamer> bleak as ever :( We need more members blech.
17:39:40 <Smerdyakov> We're at least "making money," right? :)
17:39:43 <unknown_lamer> I tricked...convinced two people into joining hcoop in the last six months
17:39:48 <darst> I think we are at least making money, yes
17:39:55 <darst> maybe around 20-30 per month
17:40:04 <unknown_lamer> if we assume there are no non-recurring expenses, and still only with the pledges we have
17:40:35 <unknown_lamer> darst: could you check the paypal and checkout balances? (have you been transferring those to the bank account regularly?)
17:40:46 <unknown_lamer> because we have a > $1k discrepancy between the portal and bank account balance
17:40:49 <darst> google checkout is automatically transfered after some number of days
17:40:59 <darst> Paypal balance: $1,093.93 USD
17:41:05 <unknown_lamer> oh yeah you might want to transfer that
17:41:20 <unknown_lamer> I am NOT comfortable with keeping that much money in paypal since they are known to freeze accounts
17:41:22 <Smerdyakov> I would say it shouldn't be allowed to go above the yearly Tech Co-op charge plus $50.
17:41:31 <unknown_lamer> my account was frozen late last year it took about 8 weeks to resolve
17:41:52 <darst> i'm withdrawing all but $100 from paypal now
17:42:00 <unknown_lamer> if paypal did that to us ... yech. Someone would need to send in papers &c
17:42:01 <Smerdyakov> We're probably about due to pay the next Tech Co-op bill, so it might make sense to leave enough for that in there, though maybe in general we want to transfer to the bank account.
17:42:02 <darst> assuming the web interface "withdraw to your bank account" works
17:42:08 <unknown_lamer> #info  Paypal balance: $1,093.93 USD
17:42:09 <Smerdyakov> darst, yes.
17:42:17 <Smerdyakov> darst, I would say wait.
17:42:24 <Smerdyakov> darst, until we know when Tech Co-op is due.
17:42:41 <Smerdyakov> darst, since there may be an extra fee, or at least a delay, from paying with a source besides a PayPal balance.
17:42:42 <unknown_lamer> ok, the discrepancy between the portal and bank account is lowered, but we still need to perform an audit eventually...
17:42:43 <docelic> Sure not earlier than a couple months
17:42:48 <unknown_lamer> Smerdyakov: I suppose you aren't up to do that eh?
17:43:10 <darst> #action darst waits until tech.coop bill is known, then transfers all but $50+tech.coop bill to our bank (and keeps the paypal balance low in the meantime)
17:43:12 <Smerdyakov> unknown_lamer, I'd rather not.  It's not hard to do.
17:43:13 <specksynder> did we summarise our 'income' and 'expenses' to know what's left at the end?
17:43:20 <darst> (I mean, keeps it low from here on out)
17:44:02 <Smerdyakov> specksynder, beats me, but all the info needed was above, I think.
17:44:05 <unknown_lamer> Smerdyakov: unless I am really off base here, the fee for doing a bank transfer when paying over paypal is the same as paying from paypal itself and just as fast *if* you have a backup method (which amusingly enough can be a CC# attached to the same account)
17:44:46 <unknown_lamer> darst: can you do a quick addition of the expenses (assume tech.coop is $22.50, an incorp is $99/12)?
17:44:49 <unknown_lamer> then we will move on
17:45:22 <unknown_lamer> we're still in perilous financial condition and definitely need to do some serious brainstorming about attracting new members but I am bad at that
17:45:35 <darst> #info monthly dues is $805, monthly expenses are $772.35
17:45:38 <unknown_lamer> any time I hear anyone looking for hosting HCOOP NOW OR DIE but otherwise
17:45:57 <Smerdyakov> I still think the best way is to ditch distributed systems as much as possible and shard members across large all-purpose servers, but that's been definitively rejected in the past. :P
17:46:00 <unknown_lamer> ok, at least we won';t implode tomorrow
17:46:24 <unknown_lamer> Smerdyakov: I like afs :( especially now that it is working well now...
17:46:41 <Smerdyakov> unknown_lamer, I know you do, but I don't think most people would rationally arrive at a liking based on their needs.
17:46:46 <docelic> I've been checking out glusterfs
17:46:57 <unknown_lamer> in theory we could bring a new members machine online with an afternoon of work by one admin
17:46:59 <Smerdyakov> Distributed filesystems are bunkem for most people.
17:47:12 <Smerdyakov> Distributed version control is enough for me.
17:47:22 <darst> I could say domtool is the biggest barrier, too
17:47:31 <unknown_lamer> if we ditch domtool I am resigning ;)
17:47:33 <Smerdyakov> darst, probably also true.
17:47:48 <unknown_lamer> I'm ok with maintaining it and I am NOT going to do admin work on a system with ad-hoc configuration...
17:47:55 <darst> not that I am proposing changing anything
17:48:09 <unknown_lamer> anyways, we're getting off topic so I will use the must maintain order gavel
17:48:22 <unknown_lamer> #topic Does FrankBynum have time to manage the election?
17:48:46 <unknown_lamer> iriefrank: ok, with your current circumstances do you have time to announce the actual election start, set up the poll, &c?
17:48:52 <unknown_lamer> iriefrank: or should I assume that I need to do it?
17:49:24 <iriefrank> well
17:49:35 <unknown_lamer> it is not explicitely specified that the secretary has to do things (ntk just always handled it) so I am OK with doing it (it doesn't exactly require much effort)
17:49:50 <iriefrank> well it needs to be done by when?
17:50:21 <unknown_lamer> Nominations may continue until March 31, 2011, 11:59 PM UTC. Voting on all candidates who have accepted their nominations shall begin on April 4, 2011 at midnight UTC and continue for one week through April 11, 2011 at midnight UTC.
17:51:31 <iriefrank> ok, i'll be out of town and away from the computer in that timeframe, so could you do it clinton?
17:51:31 <unknown_lamer> so probably a message to hcoop-announce or -discuss today notifying everyone that the nomination period is almost over, then another announcement when the election starts + setting up the poll on the portal
17:51:34 <unknown_lamer> ok
17:51:49 <unknown_lamer> #agreed clinton will handle election details this year
17:51:51 <docelic> Folks I should be on my way in 5 to 10 minutes. Is there anything on the Agenda that requires my presence? I see there are some sysadmin tasks on the list, but I've got nothing to say about them, except that assigning them to me should be the last option, given my current lack of time.
17:51:52 <Smerdyakov> I should mention that I'm traveling a majority of the time from now till early May.
17:51:55 <ntk> that is an interesting omission, the by-laws should say who is responsible for conducting the election
17:52:18 <unknown_lamer> ntk: you wrote them I blame you
17:52:22 <ntk> whoever drafted them must have been incompetent
17:52:35 <Smerdyakov> We should also have a policy of expecting board meetings to last 2 hours, so board members can schedule accordingly. :P
17:52:46 <unknown_lamer> docelic: unless you want to volunteer to write a purge-user script and update the portal to store member departure dates I don't think so
17:53:10 <unknown_lamer> actually, there is one thing
17:53:23 <docelic> Departure dates are to be handled by domtool/portal, right? Not my area.
17:53:37 <docelic> Purge-user, I can do. It's very simple after the user is already disabled.
17:53:42 <unknown_lamer> ok, I think this is sufficiently resolved for the time being we can revise the bylaws to command the secretary to handle the election after the election
17:53:57 <unknown_lamer> docelic: can I take that as you volunteering then?
17:54:00 <docelic> Yes
17:54:02 <unknown_lamer> (I'll note it later in the meeting)
17:54:03 <unknown_lamer> werd
17:54:10 <unknown_lamer> ok next topic, the last one I think we need docelic for
17:54:21 <unknown_lamer> #topic Transfer of hcoop.net from adamc to hcoop itself
17:54:39 <unknown_lamer> The time has come to actually do this
17:54:58 <Smerdyakov> Goodie goodie.
17:55:04 <unknown_lamer> So, first, who wants to volunteer to coordinate with adam to do the hcoop side of the transfer?
17:55:26 <unknown_lamer> this would just involve setting up a registrar account and dealing with the domain transfer magic
17:56:12 <unknown_lamer> no takers? :(
17:56:23 <darst> hm
17:56:32 <Smerdyakov> If I had been a betting man, I might have made some money off of predicting this. :)
17:56:41 <unknown_lamer> I could do it but I'd rather not :(
17:56:56 <Smerdyakov> Meta-question: Who do we have now with significant commitment to admin tasks?
17:57:01 <unknown_lamer> me
17:57:35 <Smerdyakov> Is that the effective complete answer?
17:57:40 <unknown_lamer> I spend ~2h/day 5ish days a week for all of march working on things and I intend to continue at a slightly reduced pace (picked a bit more work so my time contracted again)
17:57:43 <unknown_lamer> I think so :(
17:57:52 <Smerdyakov> If so, then this meta problem needs a meta solution.
17:57:53 <darst> my time is dwindling and I am picking up on debconf work again...
17:58:04 <Smerdyakov> darst, can you at least keep doing treasurer stuff?
17:58:13 <unknown_lamer> specksynder: will you have any time for sysadmin work in the near future?
17:58:18 <darst> yes, treasurer so far I can do
17:58:23 <Smerdyakov> darst, OK, great.
17:58:25 <bipt> i can at least do the domain transfer, if i don't need to be a sysadmin to do it
17:58:37 <darst> I am becoming accountant for debconf, so at least there is sharing of knowledge there
17:58:40 <specksynder> yes - I can.
17:58:50 <Smerdyakov> bipt, I suppose you don't.  You would probably store the registrar info in a private AFS place that only admins can peek into.
17:59:05 <unknown_lamer> hrm, do we want a non-boardmember to do this?
17:59:10 <Smerdyakov> darst, BTW, how long do you project until you graduate?
17:59:16 <darst> 1.5 years
17:59:25 <Smerdyakov> unknown_lamer, I see it as an admin task, which have always been decoupled from board membership.
17:59:46 <unknown_lamer> I at least trust bipt to handle things and not steal hcoop.net
17:59:51 <unknown_lamer> if he does I know where he lives >:O
17:59:56 <unknown_lamer> I'll feed one of his rats to my cat
17:59:57 <Smerdyakov> unknown_lamer, it's definitely a downside that we have so much admin/board overlap as things stand.  Maybe one person besides the main people-planner on the board should be an admin, but I wouldn't suggest much more than that.
18:00:30 <Smerdyakov> He may also be a board member in a week or so....
18:00:33 <specksynder> clinton: I have the time, if someone could let me know the tasks and the process
18:00:39 <unknown_lamer> definitely, I'd much rather be doing programming/sysadmin and not be on the board... but with 100 members to choose from what are you going to do...
18:01:02 <unknown_lamer> ok then
18:01:15 <Smerdyakov> bipt and specksynder must duel for the privilege!
18:01:20 <docelic> Ok folks, I'm signing out. My Board term is ending soon as I'm not running again, so thanks everyone
18:01:31 <Smerdyakov> docelic, thanks for all your contributions over the years!
18:01:33 <darst> thank you, docelic
18:01:35 <unknown_lamer> docelic: so long and thanks for all of the fish
18:01:48 <docelic> On a side note, http://hcoop.net/board/ should be extended to list the Board meetings since 2008, or the meeting links should be removed altogether
18:01:49 <specksynder> thanks docelic!
18:01:52 <ntk> yes thanks dude, you had a good long run
18:01:53 <docelic> unknown_lamer, I plan to stay around ;-)
18:01:54 <unknown_lamer> docelic: and especially thanks for keeping primary admin duties until I figured all of this kerberos and afs stuff out
18:02:11 <unknown_lamer> I should put afswizard on my resume now
18:02:14 <ntk> unknown_lamer: presided over a REN FAIRE WEDDING amirite?
18:02:23 <unknown_lamer> docelic: can you vote on one last thing before you dip out?
18:02:26 <Smerdyakov> I think it's worth assigning the registrar stuff to someone who is also on board for a significant chunk of general admin duties.  No point in spreading the trust around otherwise.
18:02:27 <docelic> Yes
18:02:58 <unknown_lamer> #info vote: bpt will coordinate with adamc over hcoop-sysadmin to transfer hcoop.net to an hcoop controlled registrar account
18:03:13 <unknown_lamer> or not
18:03:14 <Smerdyakov> Is bipt volunteering to do more admin stuff?
18:03:21 <unknown_lamer> ok, ... I'll do it then
18:03:40 <unknown_lamer> it should take more than 15-20 minutes x 2 and replying to some emails
18:03:41 <Smerdyakov> unknown_lamer, in the long term, it's critical to get more active admins.
18:03:46 <unknown_lamer> definitely
18:04:01 <Smerdyakov> unknown_lamer, but I'm fine with any solution that doesn't spread around privileges needlessly, if someone can commit to doing it.
18:04:05 <unknown_lamer> the admin volunteer stuff I see as non-board related
18:04:08 <docelic> unknown_lamer, ok, so you are doing it?
18:04:14 <unknown_lamer> may as well
18:04:25 <unknown_lamer> first off... I guess we should at least vote that we want to do this ;)
18:04:32 <Smerdyakov> +1
18:04:34 <docelic> +1
18:04:35 <unknown_lamer> +1
18:04:36 <darst> +1
18:04:46 <unknown_lamer> #agreed hcoop.net will be transferred to hcoop itself asap
18:04:55 <unknown_lamer> #action clinton will coordinate with adam to get this done
18:05:06 <docelic> Ttyl folks
18:05:09 <unknown_lamer> Do we want to just deal with pickign a registrar on hcoop-sysadmin or -discuss?
18:05:13 <unknown_lamer> docelic: später
18:05:28 <Smerdyakov> unknown_lamer, I'd say hcoop-discuss, but I'm not sure why. :)
18:06:28 <unknown_lamer> ok then I guess we are agreed enough, we'll get this done
18:06:51 <unknown_lamer> Smerdyakov: just be warned I am waiting a few pending payment so it'll be 5+ days before I have enough cahs on hand to pay for a registration D:
18:07:24 <Smerdyakov> unknown_lamer, 5+ days before you have $20 on hand?  You seem to be in some amount of financial trouble.
18:07:29 <unknown_lamer> yes
18:07:34 <ntk> ?!
18:07:39 <unknown_lamer> I am lax with actually invoicing...
18:08:00 <unknown_lamer> so then it's like oh right you owe me this $ridiculous-sum
18:08:05 <nevetski> unknown_lamer: I'd be happy to front the cash for it
18:08:10 <Smerdyakov> Ever heard of "emergency fund"?
18:08:20 <unknown_lamer> Smerdyakov: yes, that is next on my todo list as part of being a real adult
18:08:53 <Smerdyakov> OK.  Fine.  hcoop.net expires May 13.  As long as we get this done by then, I'm happy, more or less.
18:09:02 <nevetski> tell me where to point it and I'll pull the tigger today
18:09:19 <nevetski> with my moneygun
18:09:29 <unknown_lamer> in any case we can get the registrar discussion going and I can set that up, I imagine by the time either the tumbleweed stops rolling or the dust settles everything will be OK
18:09:44 <Smerdyakov> Yes, the discussion might take a week, anyway.
18:10:05 <unknown_lamer> after this I should never be broke again unless the western economy collapses at least
18:10:22 <unknown_lamer> ok, next topic
18:10:27 <unknown_lamer> #topic Data Retention Policy Details
18:10:45 <unknown_lamer> Last year we agreed to an actual data retention policy of six months by default unless requested when closing the account
18:11:09 <unknown_lamer> of course nothing ever happened with that, and I even forgot we agreed to that until I found our old meeting logs which are not where they should be
18:11:20 <unknown_lamer> so pretty much we have two issues:
18:11:37 <unknown_lamer> 1. What do we do with all of the deactivated volumes that we have now?
18:11:53 <unknown_lamer> I am in favor of just nuking them from orbit since we have no info on how long they have been inactive
18:12:10 <unknown_lamer> but I'd like to go ahead with that only with the consent of the board ;)
18:12:26 <darst> how many months since we first talked about a data retention policy?
18:12:29 <Smerdyakov> Another option is to make a note of them now and use that for an assured-OK nuking N months from now
18:12:50 <darst> I was thinking something along teh lines of what Smerdyakov suggested
18:12:51 <unknown_lamer> probably a better option
18:12:54 <darst> (unless we need space now)
18:12:58 <unknown_lamer> sort of
18:13:22 <unknown_lamer> during the fritz squeeze upgrade which should happen within the next 3 weeks (I have a few minor tasks remaining and then I want to give the members a full week notice and do it on a weekend night...)
18:13:42 <unknown_lamer> I did want to make ro copies of all volumes on deleuze so that web serving doesn't go down
18:13:53 <unknown_lamer> if we purged the deleted volumes I think we have enough room
18:13:59 <unknown_lamer> otoh I could just move the .d volumes to fritz instead
18:14:20 <unknown_lamer> so I guess is this reasonable:
18:14:51 <unknown_lamer> clinton will note all currently deactivated volumes in a bugzilla bug and remove then 6 months from now?
18:14:55 <unknown_lamer> or should it be another time
18:14:58 <Smerdyakov> I thought we'd radically upped our disk space so that this isn't an issue.
18:15:05 <unknown_lamer> yes
18:15:10 <unknown_lamer> but deleuze still has limited space
18:15:41 <unknown_lamer> which normally is not an issue except in the above case of making ro clones of volumes from fritz onto it to keep things running (at least for anything that doesn't require writing) when fritz is offline
18:15:57 <unknown_lamer> since we've been paying the effort tax of keeping afs and whatnot up we may as well take advantage of it!
18:16:14 <Smerdyakov> If our policy was wait 6 months before deletion, then I can definitely approve the wait-6-months-after-noting strategy.
18:16:27 <unknown_lamer> ok, let's vote on me noting and purging in six months then
18:16:29 <unknown_lamer> +1
18:16:34 <Smerdyakov> +1
18:16:41 <darst> +1
18:16:48 <unknown_lamer> iriefrank: ?
18:17:31 <unknown_lamer> 3/4 ain't bad
18:17:43 <Smerdyakov> I'd say keep moving.  He can jump back in about it later if he cares.
18:18:00 <unknown_lamer> #agreed clinton will record the names of all deactivated volumes in afs and purge them six months from now
18:18:23 <unknown_lamer> So then to actually implement the retention policy there are two other issues (woops, make that a total of three)
18:18:38 <unknown_lamer> we need to *record* the date of departure so we can know when to purge
18:18:51 <darst> yes
18:19:02 <unknown_lamer> and then we probably need an HcoopPolicy page about it
18:19:19 <Smerdyakov> The first one is so easy that it almost isn't worth making it an agenda item. :P
18:19:20 <darst> in part I could search my mail to find when people requested to leave, if they did
18:19:45 <Smerdyakov> Just change the portal's retire member logic to save data in a new column of WebUser.
18:19:48 <unknown_lamer> darst: it is not an issue for old things, anyone who has departed before today -> volumes will be gone in six months
18:20:04 <unknown_lamer> #action clinton will update the portal database and portal to record departure date of members
18:20:17 <unknown_lamer> #action docelic will write a purge-user script within six months to actually purge users
18:20:37 <unknown_lamer> so who wants to volunteer to write the actual policy page?
18:21:00 <unknown_lamer> it shouldn't be too long, just something to let members know their data will be retained for six months unless they request otherwise
18:21:21 <Smerdyakov> Not me, which is probably obvious by now. :)
18:21:22 <specksynder> I volunteer for writing the page
18:21:32 <specksynder> what's the timeline, and who should I run it by for edits?
18:21:55 <unknown_lamer> specksynder: excellent. within the next week should be ok
18:22:15 <specksynder> although, I should let you know that my design/CSS skills are poor...
18:22:16 <Smerdyakov> I'd say put it up on the wiki and just don't link it from an "official" place at first.
18:22:31 <unknown_lamer> specksynder: under the policies you should create a new page DataRetention and make sure to mark it as a DRAFT (the board itself does have to vote on the final text, but we can do that via a poll)
18:22:44 <unknown_lamer> specksynder: luckily this all goes on the wiki so no skill is required ;)
18:22:49 <unknown_lamer> in the html/css area
18:22:53 <specksynder> Cool
18:23:10 <unknown_lamer> #action shadowfax volunteers to draft the policy document on data retention
18:23:15 <unknown_lamer> hooray, actual volunteers ;)
18:23:28 <unknown_lamer> I guess that is resolved sufficiently?
18:23:49 <unknown_lamer> #topic Terms of Service Revision
18:23:50 <darst> sounds good
18:24:06 <unknown_lamer> I took a look at the TOS recently and uh ... it mentions that interserver TOS ...
18:24:29 <unknown_lamer> so someone needs to edit that to remove Interserver, add any policy from tech.coop, and ensure we are linking to the correct peer1 TOS/AUP
18:24:36 <unknown_lamer> a board member in this case
18:25:04 <Smerdyakov> And then probably notify the member base over hcoop-announce.
18:25:05 <darst> this page?: http://hcoop.net/tos.html
18:25:09 <unknown_lamer> yes
18:25:20 <Smerdyakov> "Members will be provided at least one week's notice before any changes are made, to be conveyed to their e-mail addresses on record. "
18:25:30 <Smerdyakov> Which is what hcoop-announce does
18:26:46 <Smerdyakov> This task sounds so easy that a dead muffin could do it.
18:26:48 <unknown_lamer> so basically, someone hopefully $not-me and I assume not-adam needs to double check the external TOS/AUPs, make that minor revision and bring it to a board vote, and then make an announcement after we vote on it 7 days before enacting the change
18:27:13 <darst> http://www.tech.coop/terms-and-conditions
18:27:40 <unknown_lamer> #link http://www.tech.coop/terms-and-conditions tech.coop TOS
18:28:13 <unknown_lamer> darst: can you handle making a copy of the text and emailing board@ with that? I can set up the poll and make the announcement + copy the final tos live
18:28:26 <unknown_lamer> but if I have to handle this it'll be ~7 days before I can look at it all
18:28:31 <darst> sure
18:28:41 <darst> http://www.peer1.com/aboutus/legal.php
18:28:56 <unknown_lamer> #action darst will collect our current upstream provider agreements, update the tos, and bring it before the board for voting
18:29:03 <ntk> i think this is a clerical change, not a policy change. if you must have a board vote on it then make a note to include this change simultaneous to any future agreements with other providers, or vote that any future agreements with other providers imply a corresponding change to our tos
18:29:10 <darst> can I edit the page directly, or should I only edit another copy ?
18:29:25 <darst> and then update after a vote?
18:29:26 <unknown_lamer> ntk: can you #info that, thanks for the advice
18:29:31 <unknown_lamer> darst: copy the file in this case
18:29:42 <darst> ok
18:30:12 <ntk> #info board should vote in future to change HCoop ToS simultaneous with any future contracts with other providers
18:30:23 <ntk> or something
18:30:40 <unknown_lamer> ok, we'll tack that onto the tos revision then... just in case
18:30:51 <unknown_lamer> ok, that is dealt with so we are aaaaalmost done
18:31:03 <unknown_lamer> #topic Conflict of Interest Policy
18:31:07 <unknown_lamer> iriefrank: are you around?
18:31:10 <Smerdyakov> P.S.: just added another agenda item to the end of http://wiki.hcoop.net/IrcMeetings/20110327
18:31:30 <unknown_lamer> iriefrank: since you agreed to draft the policy :(
18:31:45 <unknown_lamer> ok, I guess iriefrank is not actually watching IRC presently so we will skip this now
18:32:12 <unknown_lamer> I have nil legal expertise and right now am the only one with any conflict-of-interest wrt our vendors and that is known and dealt with so we can punt on this again I guess
18:32:50 <unknown_lamer> Does anyone care about revisiting the volunteer policies now? Personally I am OK with the 48 ACK time ('tho 72h for board things might be better since they are less time sensitive generally)
18:33:03 <Smerdyakov> I am OK with it.
18:33:10 <unknown_lamer> it = ?
18:33:21 <unknown_lamer> revisiting or punting again ;)
18:33:26 <specksynder> I am not sure what kind of conflicts of interest can arise with HCoop...
18:33:29 <Smerdyakov> Obviously we've had many recent cases of the policy not being followed, so there may be a need to think of how to avoid that in the future, but the policy as written seems good to me.
18:34:06 <unknown_lamer> #info frank is not around so the board skipped discussion of the conflict of interest policy
18:34:27 <unknown_lamer> #topic Volunteer Policies
18:34:48 <unknown_lamer> specksynder: well, e.g. we have a VPS with tech.coop. I happen to do some contract work with tech.coop
18:35:11 <unknown_lamer> Smerdyakov may eventually have some conflict of interest if e.g. his supersecretawesomestartup offers hosting, &c
18:35:37 <Smerdyakov> I'm already using Linode with a customer rather than HCoop.
18:35:44 <unknown_lamer> we have things clarified right now with me such that I just don't vote on or discuss anything related to tech.coop
18:35:47 <specksynder> Clinton: oh, ok. Thanks for sharing that.
18:35:48 <Smerdyakov> I don't know if that's a "conflict of interest" kind of thing.
18:36:03 <unknown_lamer> Smerdyakov: probably not. vps vs shared hosting and all
18:36:11 <darst> hm
18:36:14 <unknown_lamer> as long as you don't start actively poaching hcoop members ;)
18:36:33 <Smerdyakov> I don't think there's anything to discuss about either policy.  If unknown_lamer has something in particular to propose, he should come out with it. :)
18:36:42 <unknown_lamer> not really
18:36:56 <unknown_lamer> I was going to ask just that... we might want some policy on long term tasks
18:37:05 <unknown_lamer> I guess we have the status quo of 'please email if you can'
18:37:10 <unknown_lamer> t do it' that works OK
18:37:17 <Smerdyakov> It works if people follow it.
18:37:25 <unknown_lamer> or, well, not OK since things are clearly dysfunctional at present but I'm not sure an official policy would fix that
18:37:32 <Smerdyakov> Currently we have about a 50% success rate of board members really adopting that rule. :P
18:38:10 <unknown_lamer> darst: do you have anything to say on the matter? If not we'll move onto the last topic and call it quits
18:38:13 <Smerdyakov> But I move to leave this agenda item behind.
18:38:44 <unknown_lamer> #topic Check-in with election nominations and acceptances
18:38:57 <Smerdyakov> Anyone who's here and hasn't been nominated want to  be?
18:39:09 <Smerdyakov> You can see the low standards of interest-level that would take you beyond some of our present board members. ;)
18:39:26 <unknown_lamer> at least this time around we have four people running
18:39:37 <unknown_lamer> I am somewhat concerned about meeting quorum... hcoop-discuss has been eerily silent
18:39:42 * darst in scrollack trying to think/understand
18:39:47 <Smerdyakov> nevetski?  specksynder?
18:39:55 <unknown_lamer> Smerdyakov: nevetski is stevekillen
18:39:56 <nevetski> and I'm content in any case to ramp up actual activity.
18:40:00 <Smerdyakov> Oh, OK.
18:40:01 <darst> I don't have a solution to the volunteer policies now
18:40:25 <Smerdyakov> specksynder, any interest in running for the board?
18:40:27 <darst> except that barriers to involvement should be fewer, not more
18:40:33 <darst> wrt admin stuff
18:40:42 <nevetski> specksynder: worst case you lose and still get to help :)
18:40:54 <specksynder> No, Not this year, I would like to involve myself more with the sysadmin work this year.
18:40:58 <unknown_lamer> darst: one issue with that now is that we have a lot of people with root but few using it...
18:41:02 <specksynder> next year I guess :)
18:41:06 <Smerdyakov> OK.
18:41:19 <unknown_lamer> well, I guess that is it then eh?
18:41:39 <darst> unknown_lamer: yes, part of that would have to be faster to take away what people aren't using...
18:42:22 <Smerdyakov> It does seem that we are done.
18:42:37 <specksynder> how does one nominate people? I don't see a link to nominate other than a page that says who's been nominated. Is it over email?
18:42:52 <Smerdyakov> specksynder, just edit the wiki page.
18:43:05 <unknown_lamer> #endmeeting