17:21:49 <unknown_lamer> #startmeeting
17:21:49 <MeetBot> Meeting started Sun Dec  5 17:21:49 2010 UTC.  The chair is unknown_lamer. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:21:49 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:22:07 <unknown_lamer> #topic Final Agenda
17:22:17 <unknown_lamer> anyone want to add anything to the agenda before we begin?
17:22:22 <unknown_lamer> oh wait I forgot rolecall
17:22:25 <unknown_lamer> #topic roll call
17:22:26 <Kuril> I'm here by accident :-p
17:23:01 <unknown_lamer> Everyone attending please send a message with your hcoop username
17:23:03 <unknown_lamer> clinton
17:23:07 <docelic> docelic
17:23:10 <Kuril> ryan
17:23:16 <iriefrank> frank
17:23:17 <Smerdyakov> adamc
17:23:48 <unknown_lamer> I guess that's everyone paying attention at least
17:23:53 <unknown_lamer> ok then, now actually
17:23:58 <unknown_lamer> #topic Final Agenda
17:24:04 <unknown_lamer> Any additional agenda topics?
17:24:22 <docelic> Nothing from me
17:24:37 <Smerdyakov> We should also agree on which don't need darst's presence.
17:24:52 <Smerdyakov> I think treasurer, cables, and sysadmin report do.
17:25:01 <Smerdyakov> Not the rest
17:25:07 <unknown_lamer> I also want to add updating the meeting logs on hcoop.net/board
17:25:10 <docelic> I think all except first two are ok without him
17:25:32 <Smerdyakov> docelic, well, he will be the one connecting the cables, and he has pending sysadmin tasks.
17:25:54 <unknown_lamer> Ok, how about we discuss cables and the treasurer duties as the final topics of the meeting?
17:25:59 <docelic> unknown_lamer, good one, also, the board page should list current officers and duties. And I believe it did for a long time, wonder why it's not any more
17:26:12 <unknown_lamer> Did we need to vote on agenda items and whatnot I forgot :-X
17:26:17 <Smerdyakov> unknown_lamer, I don't think so.
17:26:32 <Smerdyakov> I'm down with that ordering suggestion, BTW.
17:26:57 <Smerdyakov> I also propose a voice call to darst at 12:30, if he hasn't arrived yet.
17:27:04 <Smerdyakov> (12:30 my time [US Eastern])
17:27:22 <unknown_lamer> who wants to do that?
17:27:37 <Smerdyakov> I don't want to, but I will if needed.
17:27:38 <docelic> unknown_lamer, you or iriefrank
17:28:06 <unknown_lamer> I may or may not hate telephones
17:28:17 <Smerdyakov> Let's simplify this and say I'll do it.
17:28:29 <unknown_lamer> also, we may as well call him now instead of waiting two minutes :)
17:28:34 <Smerdyakov> OK, I'll call now.
17:29:47 <unknown_lamer> while we're waiting, everyone feel free to make use of #info/#action/#idea for anything you say of importance
17:31:04 <Smerdyakov> He says here's here now.
17:31:09 <darst> sorry... alarms went off, I was aronud and then fell asleep again
17:31:13 <unknown_lamer> woops
17:31:26 <darst> so sorry...
17:31:45 <unknown_lamer> do we still want to move the cables and treasurer items to the tail of the meeting?
17:31:53 <docelic> no
17:32:16 <unknown_lamer> ok I guess then ... is everyone happy with the agenda and ready to start the meeting-meeting?
17:32:23 <docelic> yes
17:32:24 <Smerdyakov> darst, no worries.
17:32:47 <unknown_lamer> #info Added 'Updating the hcoop board area' to the agenda
17:32:58 <unknown_lamer> #topic Finances
17:33:11 <Smerdyakov> Here's the summary:
17:33:24 <Smerdyakov> Real-world accounts:
17:33:25 <Smerdyakov> Wells Fargo:  3618.08
17:33:25 <Smerdyakov> PayPal:   265.05
17:33:25 <Smerdyakov> Checkout:    96.00
17:33:25 <Smerdyakov> Total:  3787.13
17:33:38 <Smerdyakov> Balances in the portal:
17:33:39 <Smerdyakov> Members:  6209.54
17:33:40 <Smerdyakov> Co-op: -2258.91
17:33:40 <Smerdyakov> Total:  3950.63
17:33:57 <Smerdyakov> So there's a slight discrepancy, which I haven't invested any time in how to explain.
17:34:16 <Smerdyakov> As always, I remind everyone of the audit view, from which I got this data: https://members.hcoop.net/portal/money?audit=1
17:34:34 <docelic> Smerdyakov, this is a total discrepancy? Since we've been dragging some for a while, I'll quickly compare it to last meetings report
17:34:44 <Smerdyakov> Monthly expenses are $680 for Peer 1, $62.50 for rsync.net.
17:34:59 <Smerdyakov> docelic, that is the current total state, yes.
17:35:25 <unknown_lamer> #info read world balances $3787.13, in portal $ 3950.63
17:35:28 <Smerdyakov> As you can see here ( http://hcoop.net/dyn/members.html ), we have 112 members.  Definitely a downward trend.
17:35:31 <unknown_lamer> #info Monthly expenses are $680 for Peer 1, $62.50 for rsync.ne
17:35:38 <unknown_lamer> #info  As you can see here ( http://hcoop.net/dyn/members.html ), we have 112 members.  Definitely a downward trend.
17:35:41 <unknown_lamer> oi
17:36:07 <unknown_lamer> -9
17:36:52 <Smerdyakov> With the exchange rate we got at our last (and first) yearly payment to Tech Co-op, that cost was $553.56.  I guess it will be lower given our change of colo location?
17:36:53 <docelic> That's 10 members less than from March 2010 status report
17:37:18 <unknown_lamer> Ah yes
17:37:42 <unknown_lamer> Did anyone ever clarify how many months the payment for the old VPS would get us on the new VPS?
17:37:47 <unknown_lamer> If not I'll ask drewc
17:37:53 <Smerdyakov> Registered agent is $100/year.
17:38:05 <Smerdyakov> Those are the main predictable expenses.
17:38:31 <Smerdyakov> I just remembered an agenda item.
17:38:45 <Smerdyakov> #info Suggested agenda item: Transfer of hcoop.net domain to a separate HCoop registrar account
17:38:58 <Smerdyakov> So far, I've always been the sole owner of hcoop.net and hcoop.org, and the sole person footing the bill.
17:39:14 <Smerdyakov> I'll add this to the wiki now.
17:39:45 <Smerdyakov> Done.
17:39:57 <Smerdyakov> And I think that's the end of the treasurer's report, too.
17:39:58 <unknown_lamer> ok
17:40:11 <docelic> unknown_lamer, double. Old price per month was 553/11 (since we got 1 month free for a year's worth of prepayment). In reality, that was $46 for us monthly, and the new price is $22.5 monhtly
17:40:22 <unknown_lamer> Aha
17:40:28 <unknown_lamer> but has anyone confirmed this?
17:40:50 <unknown_lamer> All I remember is a "let;s deal with it later" email from tech.coop
17:40:51 <docelic> We can confirm, but this is directly from the pricelist given by Drew and repeated by us
17:40:56 <Smerdyakov> I suggest an action item for unknown_lamer to ask Drew, like he suggested.
17:40:59 <unknown_lamer> Ok, I'mm do the confirmation
17:41:06 <docelic> ok unknown_lamer , please do then
17:41:34 <Smerdyakov> It's interesting that this VPS is about $2.50 above the going rate for the smallest Xen VPSes.
17:41:59 <Smerdyakov> Are we getting anything beyond the lowest Linode/Slicehost plans beyond the "political" benefit of a co-op provider?
17:42:46 <unknown_lamer> #action clinton will confirm how many months of hosting we get from tech.coop for our last yearly payment
17:43:00 <unknown_lamer> As this pertains to tech.coop things I can't discuss
17:43:37 <docelic> Smerdyakov, we have 512 MB Ram and 10 GB disk
17:44:05 <Smerdyakov> docelic, strictly worse than Linode.
17:44:42 <docelic> Disk is $0.25 per gigabyte, and we purposely took 10 GB as the old outpost's disk usage was 2G
17:44:44 <Smerdyakov> I'm not necessarily suggesting a change.  I just want to understand if there is any technical advantage.
17:45:05 <darst> linode prices here: http://www.linode.com/
17:45:22 <darst> drewc has been pretty good on support, at least it seems
17:45:43 <Smerdyakov> Linode is probably better.
17:46:32 <Smerdyakov> They probably even have a significantly more active community of users-helping-users than either HCoop or Tech.coop has.
17:47:23 <docelic> Smerdyakov, our total discrepancy has shrunk a bit which is good. Also, is the expense of purchasing Fritz included in this report?
17:47:24 <Smerdyakov> If anyone knows any reason why Tech Co-op is more desirable, I'd just like to hear it.  If not, we at least go forward realizing we are staying with a suboptimal provider.
17:47:44 <iriefrank> how far ahead are we prepaid with tech.coop?
17:47:55 <Smerdyakov> The recent downtime with Tech Co-op was just crazy by for-profit provider standards.
17:48:34 <unknown_lamer> iriefrank: 18-24 months (have to confirm because we paid for a year at ~2x our current rate)
17:48:35 <Smerdyakov> iriefrank, we paid for a year in March.
17:48:40 <iriefrank> ok
17:49:12 <Smerdyakov> OK, so it seems like no one but me is willing to acknowledge that Tech Co-op is a clearly inferior provider, so I'm going to assume you all agree.
17:49:48 <unknown_lamer> I can neither agree nor disagree!
17:49:49 <Smerdyakov> The price difference is small and it's for a low-importance machine, so I'm not suggesting any immediate action.  I'd say move on to the next agenda item.
17:50:02 <docelic> Smerdyakov, apart from the downtime you mentioned, I think it's "good enough" and any more capacity would not improve quality of service of outpost, so....
17:50:15 <Smerdyakov> When did we buy fritz stuff?
17:50:22 <Smerdyakov> All the expenses should be in the portal.
17:50:33 <docelic> Smerdyakov, we included it in the March report, link:
17:50:41 <unknown_lamer> docelic: I am pretty sure fritz is why we have a coop balance of -$2k
17:50:56 <docelic> http://wiki.hcoop.net/IrcMeetings/20100314
17:51:23 <unknown_lamer> Next topic?
17:51:35 <docelic> unknown_lamer, according to Smerdyakov's report above, if fritz is included in that calculation, we basically don't have any balance deficit except $150
17:52:20 <Smerdyakov> docelic, on that page, I don't see any reference to the costs of fritz or when they were incurred.
17:52:40 <unknown_lamer> docelic: I think fritz still counts as as deficit producing expense
17:52:54 <unknown_lamer> nice that our deficit from not taking in enough to cover monthly expenses is mostly gone, but ...
17:52:56 <Smerdyakov> There it is.  2009-12-21: Dell server: $1902.05
17:53:10 <darst> I just found it too there
17:53:23 <Smerdyakov> I want to remind everyone that a "deficit" of the kind we're talking about here results solely from accounting errors.
17:53:23 <unknown_lamer> We still need more members and blech
17:53:31 <Smerdyakov> It has no connection to what people usually mean by "deficit."
17:53:55 <unknown_lamer> noted
17:53:58 <Smerdyakov> In the more usual sense, we're about $2k in the hole.
17:54:25 <Smerdyakov> In other words, if all members asked for their balances back, we'd need to find an additional $2k or so to cover it all.
17:54:25 <unknown_lamer> not good, but as long as we can figure out some way to bring on more members we won
17:54:26 <unknown_lamer> 't die
17:54:39 <docelic> Smerdyakov, why is this not reflected in real word accounts vs. member balances report you gave earlier?
17:54:44 <Smerdyakov> docelic, it is.
17:54:59 <Smerdyakov> docelic, you'll notice a nice big negative number there.
17:55:11 <docelic> Ah, right
17:55:34 <docelic> Ok, we can proceed to next topic
17:55:35 <Kuril> I recommend, to keep current members, be a bit more nimble on implementing new infrastructure.  I love new infrastructure but not when it sits around, doing nothing, for months.
17:56:00 <unknown_lamer> oi
17:56:40 <Smerdyakov> Yes, I don't want to be an ass, but it remains true that no other volunteer has yet taken this stuff 1/10 as seriously as I did when I was implementing new stuff, with the exception of docelic 1+ years ago before he got so busy with work.
17:56:43 <docelic> Kuril, fritz has been fully-loaded for a while now, in any case we'll give an overview of the situation among the last agenda items
17:57:14 <Smerdyakov> Right now, there is not a single person working on the technical side of HCoop who comes anywhere close to what I would expect of every core volunteer of a service I would sign up with.
17:57:37 <unknown_lamer> Smerdyakov: you aren't being an ass when it is true, I'll freely admit that I have slacked way harder than is acceptable
17:57:40 <docelic> Smerdyakov, I agree, we can discuss this as well under the sysadmin-related agenda items
17:58:01 <unknown_lamer> ok, any final words on finances before we move onto the next item?
17:58:02 <Kuril> docelic: yeah, it got all set up almost at the time that I had considered pulling my membership over that project languishing
17:58:09 <Kuril> docelic:  so I'm happy about that.
17:58:26 <Smerdyakov> My final words were already delivered.
17:59:01 <unknown_lamer> #topic Electing a New Treasurer
17:59:14 <unknown_lamer> Ok, Smerdyakov, do you want to vacate the position of treasurer?
17:59:16 <docelic> Smerdyakov,  :)
17:59:23 <Smerdyakov> I bet everyone read that linked post and thought it sounds like hell, huh?
17:59:29 <Smerdyakov> unknown_lamer, yes, I do.
18:00:03 <unknown_lamer> darst: did you still want to volunteer to be treasurer?
18:00:37 <darst> I'll do my best at it...
18:01:04 <docelic> I think we currently don't have anyone on the Board who could diligently work on this task, which requires both monthly and during the month attention, when members payments arrive
18:01:19 <unknown_lamer> My once concern is that ... the treasurer is a /bit/ important
18:01:22 <Smerdyakov> darst, if you can't commit to handling transactions several times a week, e-mailing several delinquent members a month, and so on, then you'd be doing more harm than good by volunteering, unless you're also going to build new accounting software.
18:01:49 <darst> are most action items pushed to you via email ?
18:02:02 <Smerdyakov> This job comes out to important things to do not much less frequently than every day, on average.
18:02:46 <Smerdyakov> darst, payment notifications are.  Interfacing with delinquent members isn't.  I currently have myself trying to remember on my own to do some important things, like charge monthly dues and contact delinquent members.
18:03:11 <docelic> and also to keep track of what was agreed with each member, if any individual conversation was had
18:03:24 <Smerdyakov> There's also a fair amount of time answering inquiries from people about _how_ to close their accounts, then handling the bugs they file.
18:03:59 <Smerdyakov> Disappearing for a month because something comes up in your life could conceivably destroy the co-op.  Just think on that. :)
18:04:53 <darst> usually peopel will trust me to keep on top of things like this
18:04:56 <unknown_lamer> Smerdyakov: is there code other than the portal that deals with the balances &c
18:05:01 <darst> does anyone else want to do it?
18:05:22 <Smerdyakov> unknown_lamer, the reminder script is in the same CVS repo, though you might consider it separate.  That's it.
18:05:36 <unknown_lamer> ok
18:05:53 <Smerdyakov> darst, I just remember there was that summer when you said you couldn't do HCoop stuff.  Such a hiatus is incompatible with this job.
18:06:03 <unknown_lamer> I was thinking to help automate some of this /someone/ (probably me) could hack up something to process paypal IPNs and the google equivalent
18:06:24 <unknown_lamer> more or less automating payments (with a monthly reconciliation)
18:06:32 <darst> that was summer 2010 of DebConf
18:06:36 <Smerdyakov> unknown_lamer, and setting up automated recurring billing would also be great.
18:06:53 <unknown_lamer> hrm I wonder if peer1 can do that
18:06:56 <docelic> darst, also, you officially took the role of being the main "HCoop prodder", and nothing came out of it
18:07:47 <Smerdyakov> unknown_lamer, I'm sure PayPal supports it; I just never tried to set it up.
18:08:05 <darst> yeah, I was prodding debconf
18:08:24 <unknown_lamer> My concern with replacing Adam as treasurer is ... I *could* do it, but at that point I'd be unable to commit to much sysadmin wise (beyond maintaining domtool and working on things I don't need to spend days reading manuals for)
18:08:38 <darst> you all should be the ones to decide who does this job
18:08:39 <Smerdyakov> I'm satisfied with darst taking on these kinds of jobs.
18:08:58 <unknown_lamer> docelic is in another country so getting him the debit card might be challenging, frank is legally forbidden from being treasurer, and I know darst wants to but ...
18:09:08 <unknown_lamer> it is the most essential task to the coop not imploding in the near future
18:09:19 <darst> and u_l and docelic are most important for sysadmin work
18:09:38 <docelic> Smerdyakov, do you agree to keep up with the treasurer duties until a suitable solution is found? An action plan might be to poll the member base for any volunteers, and see who the candidates are
18:10:03 <Smerdyakov> docelic, that was where we left things last time, modulo the poll, which would necessitate a change in the board composition, per our bylaws.
18:10:07 <Kuril> won't help anyone now but after I graduate, I might finally have time for outside projects/volunteer work (e.g., treasurer).
18:10:21 <unknown_lamer> I would be more comfortable with declaring that at the next meeting we will definitely elect a new treasurer /or else/ (ala: I'm not maintaing domtool anymore for real this time)
18:10:22 <Smerdyakov> docelic, I think I might need to safeguard my own priorities by letting HCoop die if no one takes over treasurer very soon.
18:10:55 <Smerdyakov> Kuril, good to know.  I'd vote for you. :)
18:11:04 <docelic> Smerdyakov, till the next board meeting? (April)
18:11:20 <docelic> that way we'd take care of restructuring the board via regular election
18:11:21 <Smerdyakov> docelic, I could do it, but I'd want to make some very clear expression of disgust on the record. :P
18:11:39 <Smerdyakov> Summer 2011 is the point of no return.
18:11:40 <Kuril> Smerdyakov: thanks.
18:12:01 <unknown_lamer> Smerdyakov: do you intend to run for the board again?
18:12:06 <Smerdyakov> I hope to be starting as a tenure-track professor, in which case I'll burn you all if I need to, to get enough time to stay on track to get tenure.  No offense. :P
18:12:33 <Smerdyakov> unknown_lamer, yes.
18:12:36 <unknown_lamer> I think that's a *bit* more important than hcoop treasurer
18:12:41 <Smerdyakov> unknown_lamer, hopefully not the following year.
18:12:48 <unknown_lamer> ok
18:12:53 <unknown_lamer> so, how about this:
18:13:49 <unknown_lamer> We have a meeting in 45 days and elect a new treasurer no matter what?
18:13:52 <Smerdyakov> Spring 2011 is already extremely painful for me, since I hope to be doing a lot of traveling to interview for positions.
18:14:13 <unknown_lamer> in the meantime I can work on the paypal IPN and at least getting rsync.net and peer1 to automatically debit our accounts
18:14:30 <Smerdyakov> unknown_lamer, oh, you understood the problem in the wrong direction.
18:14:39 <Smerdyakov> unknown_lamer, rsync.net and Peer 1 get direct-billed to our bank account.
18:14:44 <Smerdyakov> unknown_lamer, the problem is payments _from_members_.
18:14:54 <Smerdyakov> (which are much more numerous)
18:14:57 <unknown_lamer> ah ok
18:15:15 <unknown_lamer> so IPN + automatic shuffling of money from paypal/google -> checking?
18:15:37 <Smerdyakov> I'm not sure what that means.  The problem is getting member payments into our checking account.
18:15:40 <unknown_lamer> I checked a few months ago and you can indeed automate such things
18:15:45 <Smerdyakov> And keeping track of who paid and when.
18:16:10 <unknown_lamer> instant payment notification (-> tables in the portal db recording this) -> when balance = $N transfer to checking
18:16:23 <unknown_lamer> that can all be automated with paypal, not entirely sure about the latter with google
18:16:28 <Smerdyakov> So this 45-day delay is suggested based on how long you think it will take you to implement this?
18:17:06 <Smerdyakov> And that will determine who is eligible to take over treasurer, where we're basically admitting that no one else is willing to commit to do what I do now, or could be trusted..?
18:17:25 <unknown_lamer> I think we should go forward assuming darst will be treasurer, but rather than "here is the treasurer hat good luck" we see what can be done to ease the duties of treasuruer and transition a bit more smoothly
18:17:46 <Smerdyakov> That seems reasonable to me.  We view the delay as a chance to see how simple the whole package of the job can be made.
18:17:52 <unknown_lamer> the fact that you have to interact with members manually every day is a *problem*
18:17:54 <Kuril> I think a transition would be less choatic if things didn't change until after the transition is completed.
18:17:55 <darst> that sounds good
18:18:22 <unknown_lamer> One thing is that if I commit to this (I hope I've been better at this lately) I will have to fence exim off onto someone else
18:19:26 <Smerdyakov> I personally don't want to get involved in the details of running HCoop.  I just want to know how long I have to keep treasurer-ing and what I should do to help a transition.
18:19:45 <Smerdyakov> In other words, I leave it to the rest of you to weigh the pros and cons of allocating unknown_lamer's time differently.
18:20:04 <darst> though the most valuable feature for me would be emails on various actions that need attention
18:20:04 <unknown_lamer> I will be honest... I am a much better programmer than sysadmin
18:20:22 <unknown_lamer> I also find it a wee bit more engaging
18:20:45 <unknown_lamer> I propose a vote:
18:20:52 <Kuril> I'd only be concerned that coding up a new finances system could be completed within a reasonable time
18:20:53 <Smerdyakov> darst, that is 100% already in place.  Everything that doesn't already trigger an e-mail happens at a set time each month.
18:20:54 <docelic> unknown_lamer, sec.
18:21:09 <unknown_lamer> ok I'll wait
18:21:20 <darst> Smerdyakov: ah.  ok, I thought you said not.  so that's good
18:21:39 <docelic> I will vote against transferring treasurer duties to anyone else at this point. I simply think no one is up to the task. I do however agree with a deadline, to say that Adam will be relieved of this duty on a certain date no matter what, with HCoop having or not having a replacement. If darst is serious about taking over this task, I suggest he does it from this or the next month and a few following months, under Adam's supervision, both te
18:21:40 <docelic> chnical and response-time wise
18:21:43 <unknown_lamer> Kuril: this isn't entirely new -- what I am thinking is more like a short program that writes some data into the portal db and then minor changes to the portal to support that
18:22:22 <darst> normally I would be happily volunteering, i'm just purpously not volunteering too hard for any more tasks these days
18:22:29 <darst> however I know someone _has_ to take it on
18:22:30 <Smerdyakov> In my record of e-mail from the last month, I have 22 e-mails related to treasurering.
18:22:37 <Smerdyakov> Almost all are automated from PayPal or Checkout.
18:22:57 <Smerdyakov> 4 are manual conversations with people.
18:23:22 <unknown_lamer> any opinions iriefrank?
18:23:25 <Smerdyakov> (In 3 different threads.  I'm impressed; these often run longer. :])
18:23:29 <docelic> darst, correction: someone _has_ to take it on, and be diligent with it. that are two requirements.
18:23:58 <iriefrank> i agree with docelic
18:24:31 <unknown_lamer> My only issue with docelic's proposal is that we can only have one treasurer and the bylaws state that only the treasurer himself can perform those duties
18:24:34 <iriefrank> we need to let adam off but make concrete transitional plans. i think darst would do wellautomating a lot of the job.
18:24:37 <Smerdyakov> It's good that we don't have any official promises of payment-related response time posted anywhere.
18:24:42 <unknown_lamer> unless he is allowed to delegate (not sure on the legal aspects of that)
18:24:47 <iriefrank> and i trust his organizational skills and dependability from watching debconf10 happen
18:25:13 <unknown_lamer> Yes
18:25:14 <unknown_lamer> so about how this:
18:25:17 <Smerdyakov> So, if I'm taking a week to process things for most of spring, there wouldn't be any official grounds for complaint.
18:25:30 <unknown_lamer> 1. I work with both Smerdyakov and darst to automate what Smerdyakov is doing now
18:26:14 <unknown_lamer> 2. We have a board meeting before the end of January to elect (hopefully) darst as treasurer, or I can do it but then you will lose me for almost all sysadmin things assuming the work load is as high as it is
18:26:34 <unknown_lamer> it is -> it seems to be
18:26:43 <Smerdyakov> unknown_lamer, the biggest downside of this is that it seems like it will further extend this "set up a new server" task that has been stretching our for what feels like a year, despite the fact that I would expect a professional to complete it in a day or two.
18:27:02 <Kuril> Smerdyakov: my concern too
18:27:19 <unknown_lamer> Smerdyakov: we have only a few small tasks left for fritz and they seem more manageable now that I am not intimidated by the domtool source
18:27:46 <darst> given that there are emails on actions, I don't have any worries on the level of automation anymore
18:27:55 <Smerdyakov> Don't get me wrong.  I'm only concerned with the quality of service at HCoop insofar as staying put or going down might create a run on the bank that makes my treasurer job harder.
18:28:47 <unknown_lamer> if there is a run on the bank as it were the only real option is to fold hcoop and distribute the final assets... but that would be a PITA for everyone so I think avoiding that is a high priosity
18:28:48 <Smerdyakov> So I want to leave decisions about allocating volunteer time to the rest of y'all, if possible.
18:28:53 <unknown_lamer> ok
18:28:56 <unknown_lamer> so I propose a vote then:
18:29:16 <unknown_lamer> We will replace Adam as treasurer before February 1st
18:29:38 <unknown_lamer> the rest we can figure out in the interim (depending on how much darst would like automated &c)?
18:30:04 <Smerdyakov> BTW, I'll be traveling Jan. 25-31.
18:30:23 <Smerdyakov> So don't expect any fancy handover actions then.
18:30:30 <darst> how much could I start doing now under Smerdyakov's supervision so that someone can watch??
18:30:30 <unknown_lamer> Ok, how about February 6th then?
18:30:40 <darst> could both of us start getting emails now?
18:30:51 <Smerdyakov> darst, yes, that's easy.  We would just add you to an alias.
18:30:54 <Smerdyakov> docelic, you're on payment@, right?
18:30:57 <docelic> darst, yes, I've been getting those emails too, let me add you right away
18:30:58 <unknown_lamer> darst: either all or none depending on what "The Treasurer shall handle" means
18:31:16 <Smerdyakov> unknown_lamer, good point! :-O
18:31:25 <darst> heh
18:31:39 <unknown_lamer> ok iriefrank since you are the only one versed at all in legalese is Smerdyakov permitted to delegate tasks?
18:32:01 <iriefrank> yeah he can
18:32:06 <unknown_lamer> If he is then I think... ok, let's just let Adam delegate duties to darst and once things are in good shape have the formal election
18:32:27 <unknown_lamer> I was operating under the assumption he wasn't permitted to delegate. Ok this makes life less painful
18:32:36 <Smerdyakov> Seeing which e-mails come in should be useful in any case.
18:32:36 <Smerdyakov> The biggest thing in my mind is the old world-style hand-off of bank account rights, including a debit card.
18:32:42 <docelic> Smerdyakov, there is also alias payment.admin, to which only you are subscribed. is that one used at all?
18:32:59 <unknown_lamer> Smerdyakov: that I think would be the final actually electing darst as treasurer task
18:33:00 <Smerdyakov> docelic, it's probably legacy from when the portal did support tickets.
18:33:35 <docelic> darst, when domtool reconfigures, you should be on the payment@hcoop.net alias
18:33:44 <unknown_lamer> Ok ... so that we can actually move onward
18:33:49 <darst> ok, great
18:33:56 <Smerdyakov> There's this pain-in-the-ass situation that our bank is Wells Fargo, which, despite being combined with some other bank recently, manages to avoid branches near me or darst, as far as I know.
18:34:20 <Smerdyakov> Or maybe that was just near me, after the combination.
18:34:21 <darst> Smerdyakov: how how about when the first messages start coming in, I'll ask you what to do and do it
18:34:30 <unknown_lamer> I want to vote on: Before February 5th we will have a meeting to elect a new treasurer, but in the meantime Adam will begin delegating tasks to darst
18:34:58 <Smerdyakov> Good, Wachovia is all over NY, so that should work out well.
18:35:14 <docelic> unknown_lamer, could you also post an inquiry to the mailing list and poll for trustworthy candidates?
18:35:32 <Smerdyakov> docelic, remember, we would need to hold a board election for that to amount to anything.
18:35:33 <unknown_lamer> docelic: we'd need to have a board election and one of us would have to go...
18:35:50 <Smerdyakov> It seems silly to delegate to someone who can't soon take over the official position.
18:36:08 <docelic> I don't have a problem with that, if a suitable person is found I would have no problem releasing the board position
18:36:09 <unknown_lamer> I think darst is trustworthy enough (see: debconf), what I didn't like was an absolute handoff (which I think would be a disaster for anyone)
18:36:30 <unknown_lamer> ok
18:36:34 <Smerdyakov> It couldn't hurt to have another thread letting people know that there is room for volunteers to do things in general.
18:36:55 <unknown_lamer> #action clinton will email hcoop-discuss inquiring if any members would like to join the board and become treasurer
18:36:56 <Smerdyakov> This treasurer possibility could be listed among others.
18:37:11 <Smerdyakov> I don't want to start thinking about delegation until about a week from now.
18:37:18 <Smerdyakov> But I support the proposal in broad terms.
18:37:23 <unknown_lamer> Yes, I did want to send a general "hello silent members please yell at me for being the worst president ever and tell us what you want so you won't be mad at hcoop anymore"
18:37:28 <docelic> #action docelic will email hcoop-sysadmin inquiring if any members would like to take on sysadmin volunteer duties
18:37:48 <Smerdyakov> It does seem important to think about the form of clinton's e-mail.
18:37:57 <unknown_lamer> docelic: I think -discuss is better for that since not everyone is on -sysadmin
18:38:03 <unknown_lamer> Smerdyakov: I'll send a draft to the board, naturally
18:38:04 <Smerdyakov> Anyone who understands our bylaws will assume that we want to kick out some specific person but are trying to be secretive about it.
18:38:11 <docelic> unknown_lamer, sysadmins are, the rest are not important
18:38:36 <unknown_lamer> ok that stuff we can deal with later
18:39:06 <unknown_lamer> but for now can we vote on absolutely electing a new treasurer by february 6th (unless anyone doesn't like that date) and then move on with the board meeting?
18:39:15 <Smerdyakov> +1
18:39:20 <iriefrank> +!
18:39:21 <unknown_lamer> I feel that adam starting to delegate tasks to darst is sufficient resolution
18:39:23 <iriefrank> 1+1
18:39:28 <unknown_lamer> +1
18:39:31 <darst> +1
18:39:32 <docelic> +1
18:39:53 <Smerdyakov> And we remember that I'm busy and won't think about delegation until about a week from now.
18:40:01 <unknown_lamer> #agreed The board will meet to elect a new treasurer by February 6th, 2011
18:40:18 <unknown_lamer> #agreed Adam will begin delegating treasurer related tasks to Richard in the near future
18:40:31 <unknown_lamer> ok then!
18:40:39 <unknown_lamer> #topic Filing Forms
18:40:44 <darst> Smerdyakov: should we talk by irc or email ?
18:40:53 <Smerdyakov> darst, e-mail.  I'll contact you when I'm ready.
18:40:55 <iriefrank> i'll take care of filing the forms by the end of the year
18:41:02 <unknown_lamer> We need to file a form with PA and with the IRS
18:41:14 <unknown_lamer> Smerdyakov: we didn't make more than $25k last year did we?
18:41:17 <Smerdyakov> I was trying to run an SQL query to check that we meet the low-enough-receipts criterion, but I don't think I know how to get console access to Postgres databases anymore.
18:41:24 <unknown_lamer> I am pretty sure not, but ntk seemed to have concerned
18:41:37 <unknown_lamer> Smerdyakov: psql -h postgres (the rest is as per usual)
18:41:48 <unknown_lamer> Smerdyakov: if you do it as whatever user runs as the portal on deleuze it will Just Work (tm)
18:41:59 <Smerdyakov> psql: FATAL:  no pg_hba.conf entry for host "69.90.123.67", user "hcoop", database "hcoop_hcoop", SSL off
18:42:08 <unknown_lamer> lemme double check that
18:42:15 <unknown_lamer> the portal works so it has to work!
18:42:56 <Smerdyakov> Oh, I see.  I have to pretend to be www-data.
18:42:57 <Smerdyakov> Not hcoop.
18:43:05 <unknown_lamer> yeah
18:43:32 <unknown_lamer> 'The Treasurer shall submit a proposed budget in December for the following year, and shall be responsible for filing government tax forms.'
18:43:33 <Smerdyakov> I'm in.  I can write/run the query now or keep watching the channel, but not both.
18:43:48 <unknown_lamer> I guess run the query and come back?
18:43:59 <Smerdyakov> Well, my proposed budget follows the expenses I listed earlier.  I suppose a little wiggle room for hardware would also be good.
18:44:08 <Smerdyakov> OK, I'll write this query.
18:44:23 <unknown_lamer> Smerdyakov: my concern was just with frank filing the tax forms instead of you, but ntk has been doing it so...
18:44:53 <unknown_lamer> assuming 'responsible for' implies 'can be delegated, but responsibility falls upon the treasurer if the delegated task is not complete'
18:46:34 <Smerdyakov> Interestingly, the total for all PayPal payments we have ever received is just slightly over the limit for 2009 alone/.
18:46:48 <Smerdyakov> Same for Checkout.
18:46:55 <Smerdyakov> I'll just run the final query that includes a date filter.
18:47:18 <Smerdyakov> Just to double check, this report is really for 2009 like the wiki page says, not 2010, right?
18:47:49 <unknown_lamer> I assume so since we have to file the e-postcard thing by the end of the year (how can you know your receipts for the year before the year ends?)
18:48:06 <unknown_lamer> iriefrank: 2009 right?
18:48:11 <iriefrank> yes
18:48:14 <iriefrank> iirc
18:48:49 <docelic> lol :)
18:48:53 <Smerdyakov> OK.  I found all 2009 transactions with descriptions containing "PayPal" or "Checkout".  The total is under $7k.
18:49:01 <unknown_lamer> ok then
18:49:04 <iriefrank> great
18:49:31 <unknown_lamer> #info vote: frank will file the IRS e-postcard and annual report with PA listing the new board members by December 31, and report back to the board once this is complete
18:49:34 <Smerdyakov> iriefrank, if you need any more factoids for what you will send, let me know.
18:50:09 <iriefrank> ok
18:50:30 <Smerdyakov> Item done?
18:50:42 <unknown_lamer> well, once we vote to make sure we can hold iriefrank to it ;)
18:51:17 <unknown_lamer> or I guess that doesn't really need a vote
18:51:26 <Smerdyakov> BTW, I also ran another sanity check, summing all 2009 transactions with positive amounts.  It's still under the limit, even though it is double-counting a lot.
18:51:42 <unknown_lamer> docelic: darst: are you both ok with this resolution?
18:51:43 <Smerdyakov> It seems like a natural, assumed secretary duty.
18:51:48 <unknown_lamer> ok
18:51:48 <darst> agreed, sounds good
18:52:00 <unknown_lamer> #agreed Frank will file the IRS e-postcard and annual report with PA listing the new board members by December 31, and report back to the board once this is complete
18:52:05 <docelic> +1
18:52:12 <Smerdyakov> I don't think we're voting. :)
18:52:15 <unknown_lamer> #topic Purchasing cables to attach fritz to the kvm
18:52:45 <unknown_lamer> the cables are listed on the agenda (or: http://www.newegg.com/Product/Product.aspx?Item=N82E16812101117 / http://www.newegg.com/Product/Product.aspx?Item=N82E16812107101)
18:53:25 <unknown_lamer> I think it is financially reckless right now to spend $300-500 on a console server, and so I really think getting fritz attached the kvm is ... important
18:53:42 <Smerdyakov> I agree on the reckless part!
18:53:46 <darst> and i'll buy them myself and get my account credited (or not)
18:53:55 <Smerdyakov> darst, that would be the easiest.  Thanks!
18:53:59 <unknown_lamer> ok so
18:54:08 <unknown_lamer> docelic: iriefrank: is this acceptable?
18:54:12 <iriefrank> yes
18:54:15 <unknown_lamer> if so,
18:54:28 <Smerdyakov> Let the votin' begin!
18:54:29 <Smerdyakov> +1
18:54:34 <darst> +1
18:54:41 <unknown_lamer> #info vote: darst will purchase KVM cables for fritz and the board will reimburse him for the purchase
18:54:42 <unknown_lamer> +1
18:54:55 <docelic> +1
18:55:07 <unknown_lamer> #agreed : darst will purchase KVM cables for fritz and the board will reimburse him for the purchase
18:55:22 <unknown_lamer> moving along
18:55:28 <unknown_lamer> #topic Updating the hcoop board area
18:56:04 <Smerdyakov> Some inconsistent hyperlinking to directors' home pages.... ;)
18:56:21 <unknown_lamer> mostly, iriefrank can you upload the election results and meeting minutes to be a bit more recent than 2008?
18:56:32 <Smerdyakov> unknown_lamer, s/upload/update/ ?
18:56:39 <unknown_lamer> update yes
18:56:43 <iriefrank> ok where are meetbot logs?
18:56:54 <darst> meetbot.debian.net
18:56:57 <iriefrank> ok cool
18:57:14 <Smerdyakov> A link to the board/meetings wiki pages would also be nice.
18:57:22 <iriefrank> i can get those up and talk to ntk about getting his old ones
18:57:24 <unknown_lamer> if you need any help finding stuff I guess email everyone
18:57:27 <Smerdyakov> We'd of course rather put everything there, except for the issue of random people modifying it.
18:57:58 <darst> (total kvm cable price is $18.68)
18:58:17 <unknown_lamer> was that it for updating the board pages?
18:58:20 <Smerdyakov> darst, uh oh.  I guess that means you will have to fill something out in triplicate. ;)
18:58:22 <iriefrank> yup
18:58:31 <unknown_lamer> #agreed Frank will update the board member pages
18:58:38 <Smerdyakov> I think the issue is just in general making them truly up-to-date. :)
18:58:55 <unknown_lamer> #topic Transfer hcoop domains from Adam to HCoop itself
18:59:00 <unknown_lamer> ok, what do we need to do this?
18:59:12 <Smerdyakov> Someone besides me would set up a HCoop account at some registrar.
18:59:15 <unknown_lamer> Setup a registrar account for something@hcoop.net and have Smerdyakov initiate a transfer?
18:59:44 <Smerdyakov> Might be best delayed until after treasurer transfer, but I want to keep it in people's minds. :)
19:00:01 <unknown_lamer> it shouldn't take much work
19:00:19 <iriefrank> oh yeah that'll be easy
19:00:34 <unknown_lamer> just pick a registrar, volunteer someone to set the account up (making the owner board@hcoop.net?) and then ping you when it is time to transfer
19:00:41 <darst> iriefrank: re: logs: I have been copying them to http://hcoop.net/~rkd/hcoop/logs/ too, for hcoop-local keeping.  I could put them under board/
19:00:50 <Smerdyakov> There's also the issue of payment with the new registrar, which probably involves our debit card.
19:01:01 <Smerdyakov> Making it a natural treasurer activity.
19:01:06 <unknown_lamer> Yeah
19:01:13 <Smerdyakov> Which means it seems best to avoid having it done by a treasurer who will be leaving soon.
19:01:34 <unknown_lamer> ok, I guess we can defer that until replacing the treasurer?
19:01:41 <Smerdyakov> Yes.
19:01:49 <unknown_lamer> works for me if it works for you
19:02:04 <Smerdyakov> It does.
19:02:14 <unknown_lamer> #agreed We will transfer hcoop domains from Adam to HCoop around when we switch treasurers
19:02:21 <unknown_lamer> #topic Sysadmin Status
19:02:45 <unknown_lamer> I wasn't sure what docelic wanted to do, but darst and I agreed that we should just have a coordination meeting after we finish the board meeting
19:02:55 <unknown_lamer> which should be soon since it appears no members other than Kuril are watching
19:02:58 <iriefrank> ok or just grant me read permission in afs
19:03:36 <Smerdyakov> I'd appreciate a basic idea of what the hold up is on this mythical hardware reconfiguration that will make performance normal.
19:03:45 <Smerdyakov> I'm also wondering what's up with darst and backups.
19:03:56 <unknown_lamer> Yes backups are the major undone thing right now
19:04:05 <docelic> iriefrank,  you have read access on /afs/hcoop.net/user/h/hc/hcoop/public_html/board
19:04:14 <docelic> unknown_lamer, ++ for fixing dbtool
19:04:23 <unknown_lamer> otherwise services are stable, and deleuze is down to just serving a few web services, imap, exim, and master dns (which I could move to fritz this week realistically)
19:04:24 <darst> yeah, backups are my problem
19:04:39 <unknown_lamer> darst: can you expect to have those resolved within a week?
19:04:42 <Smerdyakov> darst, I think it's been months since the date when you said you'd look into it, and we haven't heard anything else from you.
19:04:55 <unknown_lamer> We are paying rsync.net for them to not back our data up, and we are definitely not backing up some important data
19:04:55 <darst> i'll start working on it now, and ask any questions here
19:05:08 <Smerdyakov> darst, why did we have to ask you, when you already gave a specific date when you would attempt it?
19:05:43 <darst> right now the backups go through deleuze
19:05:52 <darst> (well, i'll ask this after the meeting)
19:05:53 <Smerdyakov> If you can't handle it, it's better to be clear about that than to put all the members' data on the line.
19:06:02 <darst> Smerdyakov: because i'm not perfect?
19:06:35 <Smerdyakov> OK.  I think it's important that we agree that anyone can bow out of any responsibility at any time.
19:06:36 <docelic> darst, you're being unreasonable here... during this meeting, we've pointed out three things you volunteered to do, only to not do them in the end
19:06:53 <Smerdyakov> However, it's also important that the group is notified in every such case.
19:06:58 <docelic> and your explanations such as "but it was debconf" or "because I'm not perfect" are unacceptable
19:07:12 <Smerdyakov> I really only see surprise life-and-death situations as providing excuses for not sending out a notification that you're going off schedule.
19:08:02 <darst> I understand and if you'd rather someone else do things, I am ok with that
19:08:04 <docelic> we are all aware that tasks at hcoop (unfortunately) have a tendency to prolong for a long time, but I'm amazed by your response "because I', not perfect?"
19:08:28 <Smerdyakov> darst, I don't think any of us want to be hard on you for its own sake.  The factors in keeping a group like this running are surprising, so we often find we need to be explicit about rules that have evolved as part of our culture.  So now we've done that.
19:08:50 <unknown_lamer> darst: it's not that, it's just that (I'm included in this) we have a tendency to say "I'll do it by ..." and then that dates goes by and no one else is working on it
19:08:56 <docelic> it may seem that I'm a bit harsh towards you in this meeting, and I may well be, since you would have volunteered for the treasurer if I/we didn't stop you
19:09:34 <Smerdyakov> Just be aware that we will take silently dropping a task pretty seriously.  I know many other all-online, volunteer-driven organizations have different policies, which is why it's worth saying explicitly.
19:09:41 <unknown_lamer> so I think now ... for internal sysadmin policy if you can't get something done Smerdyakov's recommentation that we at least notify the list is reasonable
19:10:00 <darst> you aren't being too harsh... and there's nothing I can say besides actually actually doing what i've said
19:10:19 <Smerdyakov> unknown_lamer, yeah, I'm not sure we've ever made this Official, but it deserves to be.
19:10:22 <docelic> darst, yes, or saying you won't do it... there's absolutely no problem in you doing so
19:10:31 <darst> sounds good
19:10:32 <unknown_lamer> Smerdyakov: board or admin policy?
19:10:37 <Smerdyakov> unknown_lamer, I say for all volunteers.
19:11:02 <unknown_lamer> ok I guess ... we need a new HCoopPolicy?
19:11:09 <Smerdyakov> Sounds good.
19:11:17 <Smerdyakov> Should we vote on it?
19:11:48 <darst> all tasks need a date, and if a task isn't done by a date, an email must be sent?
19:11:48 <Smerdyakov> Something like this: Any volunteer who agrees to perform some task by a specific date should notify the board if the task is not completed by then.
19:12:21 <darst> I'd say s/board/relevant parties/
19:12:26 <unknown_lamer> I think it might be better to email about this so that we can have more than a one sentence policy
19:12:33 <Smerdyakov> unknown_lamer, OK.
19:12:44 <docelic> I don't know if this will change anything, since if we don't hear from someone, it's obvious the task has not been done
19:12:46 <Smerdyakov> darst, that introduces some ambiguity which could be problematic.
19:12:47 <unknown_lamer> revisiting the response policy seems like a good idea in this context as well
19:13:06 <Smerdyakov> docelic, yes, the problem may also involve a significant component of not setting hard deadlines.
19:13:09 <docelic> and also we don't have the manpower to say "if not done, the task automatically goes onto another volunteer"
19:14:02 <Smerdyakov> Hm.  Did the board meeting end? :)
19:14:05 <unknown_lamer> I think the general idea is reasonable--are we agreed that we need to draft a policy on dropping volunteer tasks and revisit the response policy?
19:14:10 <unknown_lamer> well, this is the last item
19:14:19 <unknown_lamer> and the secretary is responsible for policies so
19:14:20 <Smerdyakov> unknown_lamer, yes.
19:14:53 <unknown_lamer> if darst and docelic agree that we should start a board@ (or hcoop-discuss in this case?) discussion on volunteer policies then ...
19:15:00 <Smerdyakov> It would be best if one responsible person kept track of everyone's tasks and deadlines.
19:15:13 <Smerdyakov> I think I would have done that back in the day; I don't know if anyone on the board now would do it.
19:15:16 <unknown_lamer> In theory we have a wiki page for that
19:15:26 <unknown_lamer> in reality adam megacz and michael olson still have tasks assigned to them
19:15:39 <Smerdyakov> Those are ongoing tasks, if I know which page you mean.
19:15:50 <Smerdyakov> I'm talking about one-shot tasks.
19:16:01 <unknown_lamer> I wonder if there is task tracking software for the web anywhere
19:16:19 <Smerdyakov> Absolutely.  Tons of 'em, though I can't name many names.
19:16:40 <Smerdyakov> We should be able to use Bugzilla, but it's just so bulky and ugly.
19:16:46 <Smerdyakov> It has deadlines, though.
19:16:47 <unknown_lamer> in theory bugzilla could work for this (tasks have optional deadlines, and I think it can email the results of custom queries)
19:17:03 <unknown_lamer> ok so
19:17:08 <Smerdyakov> Perhaps a switch to a different issue tracking system is appropriate.
19:17:33 <unknown_lamer> docelic and darst : are we agreed that we should discuss the volunteer policy on the mailing lists?
19:17:42 <darst> yes
19:17:54 <unknown_lamer> I think defect tracking system falls under general sysadmin stuff the board doesn't need to be *too* concerned about
19:18:09 <Smerdyakov> I think the most critical steps are getting a computing platform that you're happy with and then using that quality of service to motivate new volunteers to take on more of this work.
19:18:14 <Smerdyakov> unknown_lamer, I agree.
19:18:15 <docelic> yes
19:18:16 <unknown_lamer> but I really would prefer something like OTRS to bugzilla... (since we don't really fit the model of software defect, but more service defect)
19:18:52 <unknown_lamer> #agreed The board will create a policy for volunteers dropping tasks, and revisit other volunteer policies in the near future
19:18:57 <docelic> Im fine with bugzilla... not that I am amazed by it, but it's tolerable and doesn't get in the way too much
19:19:05 <Smerdyakov> I just want to punch someone when I remember who much of our decision to choose Bugzilla came from megacz's idiosyncratic feature demands.
19:19:12 <unknown_lamer> #topic Feedback from members / Any other business
19:19:13 <Smerdyakov> s/who much/how much/
19:19:30 <unknown_lamer> docelic: me too, but only because -- who will setup another system?
19:19:55 * Smerdyakov looks at Kuril for this topic. ;)
19:20:04 <unknown_lamer> I'll look for ticketing systems (I know a few folks who swear by OTRS) and it is trivial to install, sure, but otherwise ... it'd be another tasks that may never get done
19:20:13 <unknown_lamer> Feedback members?
19:20:22 <unknown_lamer> If not, I think we can move to end the meeting
19:20:37 <Smerdyakov> Exciting lurkers, reveal yourselves now!
19:20:53 <unknown_lamer> no one loves us
19:21:16 <Smerdyakov> It seems like every meeting has fewer participants.  Not cool.
19:21:20 <unknown_lamer> yeah
19:21:37 <unknown_lamer> part of why I want to email -discuss to see what exactly is up with the completely silent membership
19:21:46 <Smerdyakov> Sounds reasonable.
19:21:46 * bipt is here
19:21:51 <docelic> Can we end the meeting and continue offtopic?
19:21:51 <unknown_lamer> once upon a time someone at least whines every few weeks
19:22:03 <unknown_lamer> board members: end the meeting?
19:22:04 <unknown_lamer> +1
19:22:07 <Smerdyakov> +1
19:22:07 <docelic> +1
19:22:12 <unknown_lamer> #endmeeting