#emdebian Meeting

Meeting started by zumbi at 19:59:06 UTC (full logs).

Meeting summary

    1. HELP: (ibr, 19:59:34)
    2. http://wiki.debian.org/Emdebian/Meetings (zumbi, 20:03:11)

  1. Introduction (zumbi, 20:03:32)
  2. Squeeze release goals for emdebian (zumbi, 20:05:21)
    1. http://wiki.debian.org/Emdebian/SqueezeReleaseGoals (zumbi, 20:05:44)

  3. Multiarch (zumbi, 20:08:51)
    1. https://wiki.ubuntu.com/MultiarchCross (GyrosGeier, 20:09:56)
    2. ACTION: GyrosGeier zumbi to push :native support for dpkg-cross and make sure it is there before squeeze (release goal) (zumbi, 20:17:57)
    3. http://lists.debian.org/debian-embedded/2009/11/msg00043.html (GyrosGeier, 20:23:24)
    4. ACTION: GyrosGeier moves multiarch todo list to wiki (zumbi, 20:24:45)

  4. Which cross tools do we want for Squeeze? (zumbi, 20:27:39)
    1. ACTION: zumbi to upload armel cross tools to Debian. Current layout + multiarch patch enabled (zumbi, 21:04:44)
    2. AGREED: armel cross tools goes to Debian and the rest of tools will live in debian-ports.org in a new suite called 'crosstool' (zumbi, 21:05:30)
    3. ACTION: zumbi resolves how to proceed in one big metapackage or small ones (zumbi, 21:07:32)

  5. Toolchain bootstrap (zumbi, 21:08:06)
  6. Phasing out dpkg-cross over the next two years (zumbi, 21:08:34)
  7. Grip 2.0 (zumbi, 21:09:20)
    1. ACTION: ask codehelp (Neil Williams) for Grip bits (zumbi, 21:14:17)

  8. Crush 2.0 (zumbi, 21:15:02)
    1. http://www.emdebian.org/crush/ (zumbi, 21:17:02)
    2. ACTION: update crush wiki pages and write a roadmap (zumbi, 21:24:09)
    3. http://wiki.debian.org/EmdebianCrush (GyrosGeier, 21:24:18)

  9. Development framework: Tools integration (zumbi, 21:26:57)
    1. http://afflict.kos.to/ (zumbi, 21:40:09)
    2. AGREED: we don't support clearcase (zumbi, 21:51:04)
    3. AGREED: to support -dev-*-cross schema and chroot one (zumbi, 21:56:54)
    4. ACTION: emdebian folks to play with development frameworks (zumbi, 21:58:29)

  10. Interesting packages for cross (zumbi, 22:00:56)
    1. things that need to happen in dpkg (GyrosGeier, 22:02:55)
    2. dpkg-checkbuilddeps to support -a (either multiarch or -*-cross package suffices) (GyrosGeier, 22:03:35)
    3. dpkg-checkbuilddeps to support :native qualifier (GyrosGeier, 22:04:17)
    4. dpkg-buildpackage to call dpkg-checkbuilddeps for cross builds (GyrosGeier, 22:04:32)
    5. ACTION: GyrosGeier set up our own source repo, and have the autobuilder work on that (zumbi, 22:07:54)
    6. http://wiki.debian.org/EmdebianCodeAudit (zumbi, 22:10:58)
    7. ACTION: GyrosGeier to improve EmdebianCodeAudit (zumbi, 22:13:26)

  11. uclibc support (zumbi, 22:14:55)
    1. ACTION: zumbi to build uclibc cross compilers (zumbi, 22:24:03)


Meeting ended at 22:28:39 UTC (full logs).

Action items

  1. GyrosGeier zumbi to push :native support for dpkg-cross and make sure it is there before squeeze (release goal)
  2. GyrosGeier moves multiarch todo list to wiki
  3. zumbi to upload armel cross tools to Debian. Current layout + multiarch patch enabled
  4. zumbi resolves how to proceed in one big metapackage or small ones
  5. ask codehelp (Neil Williams) for Grip bits
  6. update crush wiki pages and write a roadmap
  7. emdebian folks to play with development frameworks
  8. GyrosGeier set up our own source repo, and have the autobuilder work on that
  9. GyrosGeier to improve EmdebianCodeAudit
  10. zumbi to build uclibc cross compilers


Action items, by person

  1. GyrosGeier
    1. GyrosGeier zumbi to push :native support for dpkg-cross and make sure it is there before squeeze (release goal)
    2. GyrosGeier moves multiarch todo list to wiki
    3. GyrosGeier set up our own source repo, and have the autobuilder work on that
    4. GyrosGeier to improve EmdebianCodeAudit
  2. zumbi
    1. GyrosGeier zumbi to push :native support for dpkg-cross and make sure it is there before squeeze (release goal)
    2. zumbi to upload armel cross tools to Debian. Current layout + multiarch patch enabled
    3. zumbi resolves how to proceed in one big metapackage or small ones
    4. zumbi to build uclibc cross compilers
  3. UNASSIGNED
    1. ask codehelp (Neil Williams) for Grip bits
    2. update crush wiki pages and write a roadmap
    3. emdebian folks to play with development frameworks


People present (lines said)

  1. GyrosGeier (272)
  2. zumbi (205)
  3. ibr (28)
  4. shifuimam (16)
  5. suihkulokki (15)
  6. p2-mate (5)
  7. MeetBot (4)
  8. olasd_ (1)
  9. sgnb (1)


Generated by MeetBot 0.1.4.