21:30:34 <zobel> #startmeeting
21:30:34 <MeetBot> Meeting started Tue Feb 15 21:30:34 2011 UTC.  The chair is zobel. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:30:34 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:30:49 <zobel> #chair symoon Rhonda Kaare
21:30:49 <MeetBot> Current chairs: Kaare Rhonda symoon zobel
21:31:00 <zobel> Rhonda: now it's yours
21:31:38 <Rhonda> Alright, let's get started.
21:31:42 <MadameZou> Rhonda: here's the agenda -> http://wiki.debian.org/Teams/Webmaster/TODO
21:31:52 <Rhonda> #link http://wiki.debian.org/Teams/Webmaster/TODO
21:32:32 <Rhonda> #topic Template and README for other projects to pull from
21:33:04 <Rhonda> From what I understood the gitweb thing is pretty close to that, right?
21:33:42 <symoon> should it be under www cvs, or a different common place under git ?
21:33:49 <kanru> hi
21:34:13 <Rhonda> The only thing we need here is a more common css file that is not gitweb related.
21:34:32 <zobel> Rhonda: from what i understood, people want some sort of templates. a mixture of http://wiki.debian.org/DebianWebdesign and git.deb.at.
21:34:44 <Rhonda> I guess we want to put this into some git so people can easily pull it and merge or similar.
21:35:11 <symoon> not only css then, a basic wml template, basic ikiwiki template, etc. ?
21:35:33 <zobel> symoon: yes.
21:35:40 <kalle> A repo with debian.css, Pics folder with necessary images and possibly and empty subdomaindeb.css file would be good
21:35:51 <Rhonda> ikiwiki is already pretty specific, and we should have that as seperate topic.
21:36:36 <kalle> Rhonda: yes the ikiwiki should be a special ready to use css file
21:36:39 <rv_> maybe better provide a html dummy with comments as example that can be adapted to what ever they use(wml, wiki, ...)?
21:37:12 <symoon> I could have say ikiwiki like a blog engine peole want to theme, for blog.d.o for instance, it's just about wondering if an already adapted theme for a specific enging should be made available ther
21:37:19 <rv_> the css should be splittet into one for header, footer and menu and one for the content
21:37:21 <Rhonda> Yes, something along that lines with easy markers to replace for the top navigation to fill in.
21:37:34 <Rhonda> rv_: That's actually what gitweb does already
21:38:13 <kalle> Rhonda: it's actually the html that is split in three with only two css files
21:38:16 <rv_> do the other "sites" know where this is?
21:38:19 <symoon> to be moved under alioth under debian-www group ?
21:38:26 <Rhonda> kalle: In three? Not in two?
21:38:45 <kalle> Rhonda: two + gitweb content
21:39:06 <symoon> so it's clear for everyone that no site should link content from www.d.o or someother place, but just merge from time to time ?
21:39:13 <Rhonda> kalle: content is not part of the template. :)
21:39:32 <kalle> Rhonda: Most correct!
21:39:43 <Rhonda> symoon: Yes, merge (or cherry-pick or similar) is definitely what we want to encourage.
21:40:04 <symoon> common logo to avoid people re-re-re-re-loading the same (or not) debian logo ?
21:40:29 <symoon> or nothing at all, just merge it (more convenient when https is used for example)
21:40:50 <Rhonda> kalle: A guide for what html tags to use in the content part? I don't think we need to make people use specific span or style tags, it should be possible to deduce that from inheritance?
21:40:53 <rv_> css and laouty/design graphics should be on a single place for all debian sites. maybe a own subdomain ci.debian.org?
21:40:54 <kalle> rv_: the idea with a dummy html file "showcasing" the css elements is very good and should be included in the css repo
21:41:17 <zobel> Rhonda: ond it is mostly explained on http://wiki.debian.org/DebianWebdesign
21:41:54 <CIA-3> debian-www: 03kaare * 10webwml/english/users/edu/chnu.wml: Department of Land Tenure, Yuriy Fedkovych Chernivtsi National University, Ukraine
21:41:55 <rv_> and all pages use them. this reduce different version in use -> not ci(corporate identity)
21:41:55 <symoon> rv_: that reminds me the Rhonda's argument: avoid single point of failure
21:42:05 <symoon> so no content should be linked
21:42:12 <kalle> zobel: I was thinking to produce a more detailed one. But rv_ suggestion with a commented html file sounds better actually
21:42:43 <Rhonda> Right, then we take that content into the general template and add it to the README part for it.
21:42:52 <Rhonda> #link http://wiki.debian.org/DebianWebdesign
21:42:53 <symoon> can we agree on moving the templates to alioth debian-www ?
21:43:07 <zobel> #info kalle thinks that rv_ suggestion with a commented html file sounds better then to enhance the wiki page http://wiki.debian.org/DebianWebdesign
21:43:08 <symoon> even the whole git history
21:43:08 <Rhonda> Either debwww or webwml group, yes.
21:43:39 <Rhonda> #agreed move the templates to alioth from rhonda's private git repository
21:44:01 <Rhonda> symoon: of course including the history, everything else would be simply stupid :)
21:44:04 <symoon> Rhonda: you can take care of it ?
21:44:17 <rv_> symoon: e.g IMG's src and css url function values are links to images in ....debian.org if they are layout
21:45:16 <Rhonda> #action Rhonda moves the git projects to alioth
21:45:38 <symoon> now linking content or not.
21:45:52 <symoon> do we trust people to update the che
21:46:07 <rv_> che?
21:46:08 <symoon> do we trust people to update the checkout, or we don't care if they don't ?
21:46:41 <symoon> versus: assuming www.d.o is *always* available, link content from here
21:46:50 <symoon> of leave both options available
21:46:53 <rv_> use one place for the basic css and images will reduce traffic and speed up the page rendering
21:47:02 <Rhonda> We can't "force" them to update their checkouts, but I guess it would be nice if we could have them add their sites to the wiki page to be able to check from time to time to send them information about updates.
21:47:33 <Rhonda> symoon: Even linking content (css and pics) from www won't get them template fixes/updates
21:47:56 <zobel> symoon: if they would use www.d.o/debian.css and we change somehting there, chances are good we break their layout.
21:48:10 <rv_> the templats must modified to the template htey use on there site
21:48:20 <zobel> symoon: eg. see keyring.d.o
21:48:22 <kalle> zobel: exactly, but that would force some rigour and through when changing it
21:48:35 <rv_> this should be keep in a version traking system like cvs, svn or git
21:48:45 <SynrG> isn't the way this is handled for content delivered via google's cdn (e.g. jquery) to version it?
21:49:08 <MadameZou> and we wouldn't free to modify our css if a lot of sites depends of it
21:49:18 <symoon> rv_: that would be git on alioth
21:49:24 <SynrG> then you don't break people's layouts because the versioned stuff is guaranteed to stay the same
21:49:27 <Rhonda> zobel: keyring didn't apply the full template, that's a different story, they thought taking the css is enough?
21:49:48 <rv_> MadameZou: the basic css is only for header, footer and menu
21:50:04 <zobel> Rhonda: no, they changed nothing, they use link css href=www.d.o/debian.css
21:50:13 * Rhonda . o O ( and they are fixed now )
21:50:21 <zobel> Rhonda: which broke their page when we changed the css
21:50:28 <kalle> rv_: basic css includes typography, admonitions, lists etc. etc
21:50:30 <symoon> kalle: does it sound reasonable for you, for a simple page, to just include a css made available
21:50:36 <zobel> Rhonda: yes
21:51:00 <rv_> MadameZou: they are free to add more css files in there pages to handle specific design
21:51:01 <kalle> symoon: not quite sure what you mean?
21:51:22 <zobel> rv_: yes
21:51:42 <kalle> The idea is that debian.css should be the same *always* and file for each site adds tweaks.
21:52:18 <kalle> This suggests linking to the same css is possible but it has the single point of failure and the enforced conservatism issues
21:52:37 <kalle> debian.css is not yes "stable" :)
21:52:48 <SynrG> so, versioning is not something you want to consider?
21:53:12 <SynrG> gives stability to those who link to the versioned one
21:53:19 <Rhonda> I think we can agree that we want a template that requires as little changes to the content part of the pages, and a header/footer template with easy to spot markers to fill in for the navigation/contact information.
21:53:38 <symoon> yes
21:53:41 <rv_> yes
21:53:57 <kalle> Rhonda: yes that how it should work
21:54:10 <MadameZou> yes
21:54:41 <rv_> let's make a wiki page with a descript how to adapt the template for pages
21:54:44 <kalle> Versioned sounds ok as long as it doesn't slow things down, people can upgrade when ready
21:55:17 <symoon> SynrG: we can have stable branch for the css/templates, but anyway, zobel's point is that it won't guarantee it doesn't break a website using it
21:55:37 <Rhonda> #agree Template with standard css file + header/footer template with easy to spot markers to fill navigation/contact, including README for basic information
21:55:50 <SynrG> symoon: ok
21:56:21 <Rhonda> Who wants/can take the lead on that task?
21:56:36 * kalle 
21:56:36 <kanru> symoon: versioned css like the google cdn guarantee it doesn't change if using the same url
21:56:37 <rv_> symoon: reduce the markup to semantic only will help to avoid conflict/breaking layout
21:56:56 <SynrG> kanru: right. that's what i was thinking of
21:57:11 <symoon> rv_: what do you mean ?
21:57:21 <Rhonda> #action kalle is main contact for the basic template and tracks status
21:57:40 <Rhonda> #topic Layout issues
21:57:45 <SynrG> i can see how that's important for jquery. not quite sure our css layout is the same thing
21:57:54 <Rhonda> Alright, let's move on with the agenda.
21:58:07 <Rhonda> Did someone look into the RTL issue?
21:58:08 <zobel> please, yes
21:58:22 <rv_> yes me
21:58:37 <rv_> here a to pages with rtl and broken layout
21:58:44 <rv_> http://www.debian.org/index.ar.html
21:58:51 <rv_> http://www.debian.org/index.he.html
21:59:14 <rv_> in the ar page the [ and ] are sometimes mixed with the date
21:59:32 <rv_> and the list elements are to far in the right
21:59:53 <rv_> on the he page also some of the english text is left align
22:00:19 <rv_> this hide some text or is hard to read(left align)
22:00:30 <zobel> on the .he. page, the breadcrums look really broken
22:00:37 <Rhonda> Actually http://www.debian.org/intro/about.he.html doesn't look too wrong, actually
22:00:51 <symoon> and on .he the logo is broken as well
22:00:56 <Rhonda> Though yes, the / should probably be a \ on .he
22:01:03 <rv_> we should use a horizontal symetric layout and change the align to the right for rtl langeages
22:01:13 <Rhonda> And the whole topnav should also be switched around …
22:01:16 <zobel> Rhonda: the logo still looks broken
22:01:33 <Rhonda> Right, totally white
22:01:46 <zobel> okay, who could work on this?
22:01:46 <symoon> do we have/had input from "RTL" people ?
22:01:48 <kalle> the .ar page might have a problem with the <q> tag
22:02:04 <symoon> so that we can check with them everything is ok ?
22:02:23 <kanru> i saw the footer “Have you found a problem with the site layout” isn't rtl..
22:02:23 <Rhonda> I guess we need to get someone native from that languages on board to properly work on that.
22:02:48 <kalle> Rhonda:  would help
22:02:53 <Rhonda> kanru: Most probably because it isn't translated, looks awkward.
22:03:03 <rv_> lets start with the easy part horizontal symetric layout
22:03:09 <dam> call for help
22:03:10 <MadameZou> mm the ar page is complicated because of titles of DSA and News aren't translated
22:03:13 <Rhonda> kalle: I would even say it's a precondition to get that tackled.
22:03:26 <MadameZou> so are displayed in english and ltr
22:03:34 <Rhonda> Unless someone is specificly willing to give it a try without knowing what's actually going on
22:04:05 <symoon> rv_: is your 'lets start' just a shy '#action "? :)
22:04:14 <zobel> #action call for help on RTL issues
22:04:37 <Rhonda> zobel: action should contain a person.
22:04:41 <kalle> the he pages has special css that breaks the logo
22:04:56 <rv_> this a question if kalle accept to rework the design to be symetric. if yes i will be heppy to help
22:05:05 * Rhonda is willing to push that to dam if he likes to pick it up, to get in contact with the translation coordinators?
22:05:30 <symoon> dam and/or rv_ ?
22:06:05 <Rhonda> rv_: If you mean with "symetric" to make the swirl be on both sides I'm not too certain, but having the white margin on both sides actually makes a lot sense to me.
22:06:38 <MadameZou> if noone want the task, I can try to do it ;)
22:06:43 <symoon> mmm swirl on both side I'd say "I'm certain not"
22:06:50 <rv_> border margin and padding shlould have the same values for left and right -> symetric
22:06:57 <symoon> and with blanks on both side, eee pc users will cry
22:06:58 <dam> MadameZou: my hero!
22:07:22 <kalle> rv_: what is horisontally symmetric? that would need two logos?
22:07:28 <taffit> symoon: s/eee pc/phone/
22:07:39 <MadameZou> dam: LOL
22:07:40 <zobel> those too, yes.
22:07:47 <SynrG> heh
22:07:50 <Rhonda> #action MadameZou gets in contact with arabic/hebrew translators to work on the RTL issue
22:07:53 <rv_> a other solution , non symetric , is to invers all css for rtl in its own css
22:08:24 <rv_> kalle: border margin and padding shlould have the same values for left and right -> symetric
22:08:26 <kalle> eh I'm a bit slow, checking to much html not enough irc
22:08:39 <Rhonda> #topic Layout issues: planet
22:08:41 <kalle> rv_: can't see how that helps?
22:09:00 <rv_> kalle: look at the lists
22:09:02 <zobel> kalle, rv_: can you work that out after the meeting?
22:09:09 <SynrG> but seriously, cellphone should be a different layout in that case
22:09:32 <symoon> ok so planet, we have some overlapping of the content on the list of blogs
22:09:34 <SynrG> (i mean, if we're really worried about wasted space)
22:09:42 <Rhonda> I think we can agree that the allcaps on the names isn't really appreciated, likewise with the big red bar surrounding the names.
22:10:01 <zobel> ack
22:10:10 <symoon> I ack for the allcaps on names
22:10:19 <symoon> for the red bar, I don't care
22:10:33 <zobel> we have too much complains on the red bar
22:10:47 <zobel> people don't like that, we should accept that.
22:10:52 <Rhonda> Isn't there some smallcaps css style that we can give a try if we want to make it special?
22:10:53 <kalle> Rhonda: allcaps on names is supernormal http://nytimes.com
22:10:53 <MadameZou> Rhonda: w.r.t planet there's also a specific bug #612444, on people names hard to read
22:11:05 <rv_> the swirl on planet point to planet.debian.org not w.d.o
22:11:34 <rv_> the red bar planet have no link
22:11:40 <kalle> zobel: working on redbar, started looking at column but not yet resolved
22:11:45 * dam would drop allcaps and make the names right-aligned (next to the heads); keep the red bar
22:11:53 <Rhonda> kalle: As subpart to the title, on planet we use it differently though.
22:12:10 <kalle> Rhonda: no as byline = Author name
22:12:19 <zobel> dam: nack, i think we tried that during VIE meeting (or i did) it looks ugly.
22:12:34 <symoon> http://people.debian.org/~spaillard/kdesign/small-caps.png for the normal caps
22:13:16 <Rhonda> kalle: Yes, but then you have the big title there. I don't think it can be compared.
22:13:21 <SynrG> not everyone has a head. there's nothing reliable to align them to anyway
22:13:34 <SynrG> (images are all different sizes too)
22:13:36 <dam> zobel: I tried it and liket it :)  I guess we like different things
22:13:47 <symoon> can we already agre on not upercasing names ?
22:13:55 <zobel> ack
22:14:08 <SynrG> indifferent
22:15:24 <Rhonda> kalle: Please don't take this personal - but it seems to disturb more people than who consider it a good idea. I've been there too and considered it a personal critic instead of one based on the actual technical level.
22:15:34 <MadameZou> .oO( "not everyone has a head" sounds like my new signature )
22:15:45 <SynrG> haha
22:16:28 <MadameZou> symoon: ack
22:16:29 <symoon> #agree planet.d.o: no longer uppercase names (h2.planet-title)
22:16:30 <dam> SynrG: missing heads is not a real problem as the bars are not next to each other (IMHO)
22:17:06 <Rhonda> symoon: Actually I would have wanted to wait for kalle for that #agree, to be honest.
22:17:15 <symoon> oh sorry
22:17:26 <kalle> Rhonda: It's fine to use normal text. The problem is that its  non issue and there will be *many* such issues. And overall it's likely to grind things down a bit
22:17:29 <kalle> #agreed
22:17:32 <zobel> symoon: there is hash-undo
22:17:43 <symoon> #agree-undo planet.d.o: no longer uppercase names (h2.planet-title)
22:18:05 <Rhonda> dam: If you click on the - in the bars they start to be next to each other :)
22:18:32 <Kaare> is it related to the layout that large pictures on the planet overlaps the navigation thingy to the right in narrow browser windows?
22:18:34 <SynrG> dam: well, depends on the size of display and length of article
22:19:01 <kalle> the problem with the planet is all the crazy stuff people post. I would actually prefer to remove the list
22:19:03 <SynrG> not to mention how fast you're scrolling (eyes would be scanning the names to find one)
22:19:04 * dam sees no - in the bar. bummer
22:19:13 <Rhonda> dam: noscript?
22:19:20 <dam> ja
22:19:37 <zobel> anyone against of speeding a bit up? we are at TOP 3 of the agenda, and 45 already past....
22:19:48 <zobel> +minutes,
22:20:00 <Rhonda> About the red bar?
22:20:01 <SynrG> ahh
22:20:28 <kalle> was the h2 unagreed after me agreeing ?
22:20:29 <symoon> kalle: just to close the planet point, you had a look at the overlapping issues alraedy ?
22:20:43 <kalle> symoon: yes, a couple of options
22:20:44 <symoon> kalle: as I typed the wrong command, then you agree, it's ok :)
22:20:45 <Rhonda> zobel: Right, sorry. Not too much distraction talk, rather try to stick to the things we can agree and put action items to and postpone the rest when it starts to take longer.
22:21:28 <Rhonda> Let's try to get with the red bar back to the original proposal, a slim red line below the name?
22:21:31 <symoon> #action kalle is laready looking at options to solve overlapping issues with small fonts settings
22:21:34 <kalle> 1 remove left list/place at bottom of page with link at top 2. fix width = ugly word wrap for largefonters 3. tell people to change their min-font size
22:21:35 <symoon> kalle: ok ?
22:21:47 <Rhonda> Though, the more I look at the red bar, the more I like it.  %-/
22:21:48 <kalle> Rhonda: Got it done locally
22:21:57 <SynrG> hmm, "Ritesh Raj Sarraf" can't be fully folded
22:22:04 <Rhonda> Especially in relation to the red subject line.
22:22:30 <Rhonda> But this is an item that a fair amount of people seem to feel strongly about.
22:22:47 <Rhonda> kalle: Ah, great. So we can close the planet topic! \o/
22:22:57 <symoon> Rhonda: not yet, just a sec
22:23:20 <kalle> can I explain the planet issue?
22:23:21 <symoon> #info only first blog item per author can be fold
22:24:15 <Rhonda> symoon: Oh, right. Good catch!
22:24:18 <SynrG> ah. got it
22:24:19 <kalle> symoon: folding seems nonsensical as you have to fold all individually
22:24:32 <symoon> Rhonda: actually SynrG catch :)
22:24:32 <kalle> hard work with that list ;)
22:24:57 <SynrG> folding is tedious. and the + jumps around depending on how long the name is
22:24:59 <CIA-3> debian-www: 03kaare * 10webwml/english/users/com/mealsnap.wml: MealSnap, USA (no non-mobile URL is available for now, so leaving it out)
22:25:08 <SynrG> which further slows you down
22:25:33 <Rhonda> kalle: One does fold a certain author to not get them displayed anymore.
22:25:53 <Rhonda> Wasn't the +- at one point _before_ the name?
22:25:56 <rv_> SynrG: then insert them before the name
22:26:09 <kalle> Rhonda: but only till next reload?
22:26:13 <Rhonda> Anyway, I think we start to get side-tracked again from the agenda. :/
22:26:22 <Rhonda> kalle: No, it's stored in a cookied IIRC
22:26:35 <symoon> yes, please create bugs reports for issues you noticed
22:26:36 * kalle cookiless :(
22:26:49 * symoon sends cookies by mail to kalle :)
22:26:59 <kalle> :)
22:27:07 <SynrG> sorry. i'm seeing this for the first time, and will reserve further comments for after :)
22:27:22 <Rhonda> So, symoon, continue?
22:27:35 <symoon> #topic languages switch improvement
22:27:48 <symoon> so languages switch improvement and issues
22:28:01 <Rhonda> Who did put that one in and knows what it should refer to?
22:28:09 <dam> maybe me
22:28:17 <kalle> I've seen positive comments, but it works slightly oddly
22:28:18 <Rhonda> Is it about the usual "I want to stick with english when I click english in the selection"?
22:28:21 <symoon> (don't know) basically we have overlapping issues of the language switch with packages.d.o at least
22:28:32 <dam> issue one: unusable with keyboard only
22:28:39 <rv_> the current line is  confus
22:28:49 <symoon> http://bugs.debian.org/612772
22:28:54 <dam> issue two: overlaps on the right on packages.d.o
22:28:58 <rv_> you need hover to see wiche language are available
22:29:07 <kanru> and hard to find
22:29:09 <symoon> #info unusable with keyboard only
22:29:12 <kalle> So back to the list? or a redir cgi?
22:29:31 <symoon> #info overlaps on the right on packages.d.o http://bugs.debian.org/612772
22:29:32 <rv_> but by reading the line, one think one must change the settings
22:30:00 <rv_> redir cgi  with the select element
22:30:01 <Rhonda> #link http://bugs.debian.org/612772
22:30:44 <symoon> dam: do you have ideas in mind to solve this issues ? (if yes, we can just jump to the other topic)
22:31:03 <symoon> (oh damn en_FR)
22:31:08 <dam> going back to the plain list would solve both, I think
22:31:35 <symoon> dam: or css overflow with lower index for the language switch (for the pdo one)
22:31:39 <symoon> ?
22:31:42 <dam> (or form + select + a button + a CGI, but that is more complicated)
22:31:56 <rv_> http://bugs.debian.org/612772 this was solved with "clear: both;" in css for the footer
22:31:57 <dam> symoon: me is not that much into css :)
22:32:33 <rv_> p.d.o use a old css
22:32:34 <Rhonda> Go back to the plain list and experiment further in a non-production site?
22:32:35 <taffit> form is not really handy for switching
22:32:35 <kalle> we should add a clear: both to debian.css that would sort it
22:32:48 <rv_> Rhonda: ack
22:32:53 <symoon> rv_: you mean it's commidted to pdo git but not used ?
22:32:58 <Rhonda> dam: Would that work for you?
22:33:06 <dam> Rhonda: sure
22:33:17 * kalle outasync again :(
22:33:22 <kanru> plain list +1
22:33:33 <dam> #action dam reverts language selector to the plain list (on packages.d.o too)
22:33:34 <Rhonda> #action dam experiments with the language selection off-site and switches back to plain list
22:33:38 <symoon> (plain list is just 'pain list' with epiphany webkit)
22:33:49 <rv_> symoon: the footer ovelap was also on http://www.debian.org/vote/ . and there it was fixed by kalle
22:33:58 <Rhonda> #undo
22:33:58 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x108ded0>
22:34:06 <rv_> p.d.o use a css from before this fix
22:34:55 <Rhonda> p in planet or packages?
22:35:51 <SynrG> or people for that matter. i find it very confusing :)
22:36:18 <Rhonda> Yes. Please use non-ambigious abbreviations.
22:36:23 <rv_> packages.d.o
22:36:40 <symoon> rv_: can you take care for applygin the fix ? (ask rhonda or me to make it live on packages.d.o)
22:37:46 <symoon> for the keyboard naviguation on mid-term, dam is on it anyway for what I understood
22:37:53 <kalle> someone on packages.d.o needs to wget http://debian.org/debian.css
22:38:03 <kalle> I belive that's the fix :)
22:38:05 <rv_> kalle: ack
22:38:21 <Rhonda> #topic BRs
22:38:23 <dam> kalle: not for the keyboard-only access problem
22:38:24 <rv_> or include the debian.css from w.d.o
22:38:24 <Rhonda> About the buglist in the agenda, going through every item in there will explode the meeting time needed. Is there anything specific that is important enough to discuss in this meeting?
22:38:37 <symoon> #action symoon update packages.d.o debian.css with the www.d.o one (fix 612772)
22:39:10 <kalle> started 612244 will make avaliable
22:40:02 <symoon> nothing special IMO
22:40:03 <kalle> 612577 easy delete of line in css fine for me to go ahead
22:40:27 <zobel> Rhonda: just on shot: 612447 is about the top menu moving into two-lines if window too small, and breadcrums then not aligned with the debian-logo
22:40:46 <Rhonda> Can we agree on: "The BRs will be addressed, we'll keep them in the TODO list and bring them up in next meeting if they aren't fixed by then."
22:41:00 <zobel> Rhonda: ack.
22:41:03 <symoon> I will just mark confirmed on live the bug we agree on th fix
22:41:06 <rv_> ack
22:41:09 <MadameZou> Rhonda: ack
22:41:14 <Rhonda> The BRs will be addressed, we'll keep them in the TODO list and bring them up in next meeting if they aren't fixed by then.
22:41:17 <zobel> everyone here, please take one of those BRs.
22:41:17 <Rhonda> #agree The BRs will be addressed, we'll keep them in the TODO list and bring them up in next meeting if they aren't fixed by then.
22:41:22 <symoon> or pending, better
22:42:01 <Rhonda> #topic "Report it!" logfile handling
22:42:17 <zobel> i put that on the list.
22:42:38 <zobel> we need voluteers to go through that files.
22:42:45 <Rhonda> It was mentioned regulary to me that what's happening now is unexpected, people expect to have a way to add comments.
22:42:52 <symoon> people except to be asked to provide input
22:43:27 <Rhonda> And personally I think the collected data might be rather unusable. zobel, did you count the amount of entries in the log, or can do so quickly?
22:43:49 <zobel> no, not yet... too much EREALLIVE
22:43:56 <rv_> zobel: where is this log file?
22:43:57 <kanru> how large is the backlog now?
22:44:00 <Rhonda> Excused. :)
22:44:11 <symoon> rv_: on www-master
22:44:12 <taffit> wasn't the purpose of this button to have feedback? Isn't feedback already happenning vi BR, -www@lda and IRC?
22:44:13 <Rhonda> rv_: On wolkenstein
22:44:20 <zobel> i would like to not make them too publicly available, but they are 644, so if we have voluntueers, and webmasters are okay with it, we could give those persons access to wolkenstein.
22:44:58 <symoon> zobel: I can remove IPs before
22:45:08 <symoon> if it's your concern
22:45:17 <Rhonda> Right on that. We though really need an input box for them to fill in.
22:45:34 <zobel> symoon: also okay with me, but that would break trail maybe.
22:45:50 <zobel> #action zobel should pass the logfile-annonymizer to symoon
22:46:08 <rv_> split this file per day and provide only the not current files?!?
22:46:09 <kanru> replace the IPs with a hash
22:46:24 <zobel> kanru: that is exactly what my script does
22:46:51 <symoon> an input box means an input spam box, amend the message a bit to make clear what it's supposed to do, and tell people they can report us details as a bug against www.debian.org
22:47:21 * dam counts 285 lines in the report log
22:47:40 <rv_> but then they need reportbug. for me under ubuntu it is broken since 1 week
22:47:43 <Rhonda> symoon: We could though filter out spam more easily than accidental clicks
22:47:47 <symoon> so if people want to give more input they can: there is the BTS barrier to avoid too many ones (as a typical form would lead to)
22:47:52 <zobel> symoon, Rhonda: i think we can drop the "Further apache.conf tweaks" for now, symoon and me already worked on some parts before the meeting.
22:47:55 <taffit> rv_: an MTA is fine enough
22:48:07 <BTS> Opened #613594 in 12www.debian.org by 11Ben Armstrong <synrg@sanctua...> «planet.debian.org: Folding only applies to first article by an author». http://bugs.debian.org/613594
22:48:19 <Rhonda> SynrG: Thanks.
22:48:56 <rv_> taffit: then change the button to a link with mailto: scheme
22:48:57 <Rhonda> Alright, it might be that I need to log off soonish.
22:48:58 <symoon> the easy way now is to remind on that page how to report issues to us
22:49:35 <Rhonda> Yes, the thanks page should definitely get expanded, likewise with the 404 page, btw.
22:49:38 <symoon> rv_: on the thanks displayed instead ?
22:49:47 <symoon> any volonteer for that ?
22:50:36 <rv_> symoon: where every you like
22:51:11 <symoon> #action symoon expand devel/webwml/thanks message, redirect to mail and BTS
22:51:24 <Rhonda> #topic BR status on BTS
22:51:26 <rv_> symoon: but i was thinking of the botton in the footer
22:51:37 <Rhonda> I want to pull that one to front because I want to drop a quick comment on it.
22:51:49 <zobel> Rhonda: you use an outdated version of the wiki page? :)
22:52:04 <zobel> ah.
22:52:10 <Rhonda> if you edit the page while we have the meeting it's not my fault :P
22:52:27 <zobel> Rhonda: no, i did like 30min before.
22:53:02 <Rhonda> Anyway, usertagging is a good idea, though on general: I want to have all outstanding bugreports to be marked as "confirmed" if we have an idea that we want to have this fixed eventually.
22:53:24 <Rhonda> So that it's easy to check wether a bugreport has been looked at by someone already.
22:53:47 <Rhonda> Also, please make use of the "owner" command if you plan to work on a bugreport, to reduce potential duplication.
22:54:00 * zobel would volunteer to draft something for usertagging.
22:54:15 <Rhonda> About what usertagging we might use - so far we only used "packages" as usertag, and we have a view for that already.
22:54:25 <symoon> which usertags ? beside packages.d.o (might deserve a dedicated pseudopackage ?), zobel mentionned layout, content, etc.
22:54:26 <Rhonda> I think I dropped the link on the mailinglist a few times.
22:54:55 <Rhonda> And yes, moving packages.d.o to its own pseudo package would also be a good idea.
22:55:11 <zobel> Rhonda: the link should be on wiki.d.o/Teams/Webmaster IMHO
22:55:14 <Rhonda> But now I really have to go, sorry.  %-/
22:55:25 <Rhonda> zobel: Will dig it up and add it there tomorrow
22:55:28 * Rhonda logs off
22:55:29 <symoon> bye Rhonda, have a good night
22:55:44 <SynrG> gnight
22:55:45 <MadameZou> g'night Rhonda and thanks for the meeting :)
22:55:52 <kalle> good night
22:56:02 <symoon> zobel: anything to add about the ideas you have in mind ?
22:56:20 <zobel> no, i will draft something, and mail that to -www@l.d.o
22:56:29 <symoon> #action zobel volunteer to draft something for usertagging
22:56:46 <symoon> #idea moving packages.d.o to its own pseudo package would also be a good idea
22:56:52 <zobel> hehe ;-)
22:56:57 <symoon> :)
22:57:17 <symoon> do we all agree about good usage of confirmed and owner ?
22:57:32 <kanru> yes
22:57:33 <SynrG> yeah
22:57:36 <zobel> symoon: just move on, i think yes, we do
22:57:36 * dam sees only benefits
22:57:54 <symoon> #agree "confirmed" if we have an idea that we want to have this fixed, "owner" if you plan to work on a BR
22:57:56 <MadameZou> this could be useful, on usertagging and specifically packages.d.o -> http://lists.debian.org/debian-www/2009/12/msg00049.html
22:57:57 <symoon> ok
22:58:10 <symoon> #link http://lists.debian.org/debian-www/2009/12/msg00049.html
22:58:20 <symoon> (I seem to play with meetbot)
22:58:32 <symoon> #topic UTF-8 conversion
22:59:00 <symoon> UTF-8, we have seen recently greek, italian, russian, korean moving to UTF8
22:59:22 <symoon> MadameZou: did you update the list of remaining languages ?
22:59:38 <symoon> maybe less than 10 ? :)
22:59:48 <symoon> #link http://bugs.debian.org/567781
23:00:00 <symoon> MadameZou: taffit ?
23:00:05 <taffit> 11
23:00:24 <MadameZou> no, but I'll do :) btw, if I can keep in contact with armenian and hebrew we can utf-8ize them
23:00:29 <taffit> chinese croatian czech english indonesian korean lithuanian polish portuguese spanish swedish
23:00:31 <kanru> chinese will wait the squeeze upgrade
23:01:08 <symoon> I though korean was done, anyway
23:01:12 <Kaare> I can communicate with the swedish translator about moving his pages to utf8 (I can also verify the conversion)
23:01:28 <symoon> #action Kaare communicate with the swedish translator about moving his pages to utf8
23:01:41 <symoon> #action MadameZou keep in contact with armenian and hebrew we can utf-8ize
23:01:46 <symoon> free action here
23:02:18 <MadameZou> yay!
23:02:34 <symoon> kanru: did you already test the candidate makefile for squeeze ?
23:03:45 <symoon> and charles plessy proposed his help to move english to UTF8
23:04:13 <kanru> symoon: I have a local build, though some makefiles hide under english/ need to be find out..
23:04:16 <taffit> croatian czech indonesian korean are not big, and lithuanian is pretty small
23:04:32 <symoon> that need to be done with care (especially gettext), I guess other wml/scripts are already utf8-proof, as proved by other languages alreadu in utf8
23:04:54 <symoon> taffit: are they active ?
23:05:03 * taffit is not sure at all
23:05:21 <Kaare> we should try to get hold of Joy regarding croatian
23:05:22 <MadameZou> hebrew and armenian are already utf-8
23:05:41 <symoon> IMO we should not move to utf8 without native speakers able to verify
23:05:42 <taffit> that's why I raised them (other are active)
23:05:55 * zobel wanders off to bed, i need to stand up at 4am UTC.
23:06:04 <symoon> n8 zobel
23:06:05 * kanru was shocked that some Makefiles under english/ have chinese specific hacks
23:06:11 <MadameZou> g'night zobel
23:06:18 <symoon> it's a risk to break the website while the content is jept the same
23:06:19 <kanru> g night zobel
23:06:21 <symoon> kanru: me too :)
23:06:28 <SynrG> zobel: sleep well
23:06:45 <kalle> night
23:06:46 <MadameZou> symoon: yes, I've read your mail and I think you're right
23:06:47 <symoon> so we agree utf8 migration should be done only with the l10n team agreement ?
23:06:53 <MadameZou> symoon: ack
23:06:55 <symoon> and actually *with them* ?
23:07:03 <kanru> ack
23:07:08 <MadameZou> symoon: ackack :)
23:07:09 <Kaare> they need to verify at least
23:07:29 <SynrG> pfft
23:07:54 <symoon> SynrG: ?
23:07:55 <MadameZou> SynrG: why are you pffting?
23:08:11 <Kaare> I'll get hold of Joy regarding croatian - he also drops by here sometimes
23:08:24 <symoon> #agree move to utf8 need each language team agreement (or might break website translation)
23:08:35 <SynrG> sorry, slipped into Bill the Cat for a moment
23:09:09 <MadameZou> and fcestrada says that he'll speak about utf-8 conversion to l10n-spanish team
23:09:24 <symoon> #action kanru prepares move of chinese to utf8, much work on the plate and need squeeze
23:09:37 <kanru> thanks
23:09:50 <symoon> last but not least, english case
23:10:32 * kanru laptop runs out of battery, cya
23:10:42 <MadameZou> o/ kanru
23:10:43 <symoon> I think we can accept the help from Charles Plessy, and wait from results
23:10:53 <Kaare> #action Kaare will get hold of Joy regarding croatian migration to utf8
23:11:25 <symoon> #info english move to UTF8: care about gettext
23:12:06 <taffit> are there non-ASCII charachter on englixh side of gettext?
23:12:41 <symoon> taffit: maybe it's supposed to be iso8859-1
23:13:46 <symoon> #info accept Charles Plessy help about engligh move to utf8
23:14:01 <symoon> #topic Debcamp
23:14:13 <symoon> #link http://lists.debian.org/debian-www/2011/01/msg00110.html
23:14:57 <symoon> does anyone have ideas about items to be discussed during debcamp/debconf ?
23:15:06 <symoon> (on top of the ones mentionned on the list ?)
23:15:27 <MadameZou> nope
23:15:32 <zobel> symoon: lets discuss that when DC registration is open?
23:16:02 <symoon> fine with me
23:16:44 <symoon> any other topic that *NEED* to be discussed now, or can we wish a good night to meetbot ?
23:17:01 * MadameZou is for goodnight ;)
23:17:07 <symoon> (everyone sleeping :)
23:17:11 * zobel as well
23:17:16 <rv_> where can i find the data of meetbot from this meeting?
23:17:24 <symoon> #endmeeting