#debian-rust Meeting

Meeting started by f_g at 18:58:56 UTC (full logs).

Meeting summary

  1. meeting agenda (f_g, 18:59:37)
    1. Fabian, mostly working on toolchain stuff and associated crate packaging (rustc, cargo, debcargo) (f_g, 19:02:35)
    2. James, mainly working on alacritty and tree-sitter related crates, but try to help out with things in general and sponsor when I have free cycles. (jamessan, 19:03:01)
    3. Blair, at the beginning general stuff that I found useful, now starting on the toolchain (ncts, 19:04:09)
    4. Matthias, mainly working on the gtk-rs stack and dependencies for GTK rust apps (count_omega, 19:04:24)

  2. rust toolchain updates (f_g, 19:09:21)
    1. rustc 1.64-1.66 are in experimental (f_g, 19:09:41)
    2. 1.64 is prepared for unstable, but not yet uploaded (f_g, 19:09:57)
    3. ACTION: mjt Sylvestre should figure out who does the upload (f_g, 19:10:18)
    4. ACTION: f_g will monitor the situation and prepare the next uploads (f_g, 19:10:33)
    5. 1.67 is up for review (thanks ncts!) (f_g, 19:10:44)
    6. upstream is already at 1.70, so there are three more versions to update/review/upload (f_g, 19:11:07)
    7. ACTION: f_g look at gbp pq or other tools for managing the patch queue(s) to have a single, unified format that works for everyone (f_g, 19:12:21)
    8. ACTION: ncts will prepare 1.68 update once 1.67 has been reviewed (f_g, 19:14:28)
    9. ACTION: f_g ncts brainstorm improvements for rustc packaging helpers (f_g, 19:18:50)
    10. ACTION: f_g jamessan do a walkthrough of src:cargo updating (f_g, 19:23:40)
    11. ACTION: ncts also offers help for cargo update work (f_g, 19:26:55)

  3. debcargo maintainership (f_g, 19:28:52)
    1. ACTION: ask infinity0 to give two team members access (count_omega, 19:34:53)
    2. ACTION: f_g write to Ximin+CC about details of transfer/expansion of ownership (f_g, 19:43:39)

  4. debcargo changes (f_g, 19:43:44)
    1. jamessan already mentioned the MSRV translation that is up for review (f_g, 19:44:01)
    2. mjt proposed an alternative encoding of dependency ranges (f_g, 19:44:28)
    3. semver_suffix changes need to be implemented in debcargo proper (Breaks+Replaces issue with Provides/virtual packages) (f_g, 19:45:05)
    4. ncts proposed feature-less packages that encode feature information not in package name but in d/control field (ncts, 19:45:23)
    5. ACTION: count_omega potentially will take a look at DH compat changes in debcargo (f_g, 19:49:26)
    6. ACTION: f_g will review jamessan MSRV translation MR, which got updated since the last feedback (f_g, 19:49:42)
    7. ACTION: f_g write more documentation for debcargo integration tests (f_g, 19:54:51)
    8. ACTION: unbreak debcargo integration tests (f_g, 19:55:00)
    9. ACTION: ncts write up proposal for more fundamental changes in packaging work flow (f_g, 19:55:27)
    10. ACTION: ncts might explore a "generic semantic toml patching" feature for debcargo, to allow replacing/adding Cargo.toml (f_g, 20:04:08)

  5. debcargo-conf tooling/improvements (f_g, 20:04:21)
    1. ACTION: jamessan remove "update" functionality from release.sh (jamessan, 20:09:48)
    2. ACTION: count_omega (time permitting) will look at release.sh generating/dputting the right kind of changes files (f_g, 20:13:12)
    3. ACTION: count_omega will take a look at ITP filing assistance in August, if nobody else does it before that (f_g, 20:24:02)
    4. ACTION: jamessan will push some improvements to the chain build script by ncts (f_g, 20:26:33)

  6. ongoing and upcoming transitions (f_g, 20:27:35)
    1. base64 seems to be going well, plugwash did most of the heavy lifting (f_g, 20:27:51)
    2. rust-cargo will happen in the next weeks, and might involve some other transitions as well (f_g, 20:28:31)
    3. https://salsa.debian.org/rust-team/debcargo-conf/-/issues/43 (count_omega, 20:31:36)
    4. ACTION: ncts will look at aes transition (f_g, 20:33:00)
    5. wayland 0.30 would break winit/alacritty, waiting on upstream developments (f_g, 20:33:29)
    6. ACTION: jamessan will nudge alacritty upstream to update (f_g, 20:33:46)
    7. ACTION: jamessan and count_omega will keep wayland transition issue uptodate on salsa (f_g, 20:35:20)
    8. https://release.debian.org/transitions/html/rust.html is also not looking too bad (f_g, 20:37:47)
    9. gtk transition still has some arch related issues to iron out (f_g, 20:42:04)
    10. zbus is waiting for zbus-1 in NEW (f_g, 20:42:16)
    11. syn also looks to be on track (f_g, 20:42:23)

  7. future meetings (f_g, 20:44:27)
    1. ACTION: f_g send out mail with links to meeting notes and call for finding next date (f_g, 20:57:49)


Meeting ended at 20:58:34 UTC (full logs).

Action items

  1. mjt Sylvestre should figure out who does the upload
  2. f_g will monitor the situation and prepare the next uploads
  3. f_g look at gbp pq or other tools for managing the patch queue(s) to have a single, unified format that works for everyone
  4. ncts will prepare 1.68 update once 1.67 has been reviewed
  5. f_g ncts brainstorm improvements for rustc packaging helpers
  6. f_g jamessan do a walkthrough of src:cargo updating
  7. ncts also offers help for cargo update work
  8. ask infinity0 to give two team members access
  9. f_g write to Ximin+CC about details of transfer/expansion of ownership
  10. count_omega potentially will take a look at DH compat changes in debcargo
  11. f_g will review jamessan MSRV translation MR, which got updated since the last feedback
  12. f_g write more documentation for debcargo integration tests
  13. unbreak debcargo integration tests
  14. ncts write up proposal for more fundamental changes in packaging work flow
  15. ncts might explore a "generic semantic toml patching" feature for debcargo, to allow replacing/adding Cargo.toml
  16. jamessan remove "update" functionality from release.sh
  17. count_omega (time permitting) will look at release.sh generating/dputting the right kind of changes files
  18. count_omega will take a look at ITP filing assistance in August, if nobody else does it before that
  19. jamessan will push some improvements to the chain build script by ncts
  20. ncts will look at aes transition
  21. jamessan will nudge alacritty upstream to update
  22. jamessan and count_omega will keep wayland transition issue uptodate on salsa
  23. f_g send out mail with links to meeting notes and call for finding next date


Action items, by person

  1. count_omega
    1. count_omega potentially will take a look at DH compat changes in debcargo
    2. count_omega (time permitting) will look at release.sh generating/dputting the right kind of changes files
    3. count_omega will take a look at ITP filing assistance in August, if nobody else does it before that
    4. jamessan and count_omega will keep wayland transition issue uptodate on salsa
  2. f_g
    1. f_g will monitor the situation and prepare the next uploads
    2. f_g look at gbp pq or other tools for managing the patch queue(s) to have a single, unified format that works for everyone
    3. f_g ncts brainstorm improvements for rustc packaging helpers
    4. f_g jamessan do a walkthrough of src:cargo updating
    5. f_g write to Ximin+CC about details of transfer/expansion of ownership
    6. f_g will review jamessan MSRV translation MR, which got updated since the last feedback
    7. f_g write more documentation for debcargo integration tests
    8. f_g send out mail with links to meeting notes and call for finding next date
  3. jamessan
    1. f_g jamessan do a walkthrough of src:cargo updating
    2. f_g will review jamessan MSRV translation MR, which got updated since the last feedback
    3. jamessan remove "update" functionality from release.sh
    4. jamessan will push some improvements to the chain build script by ncts
    5. jamessan will nudge alacritty upstream to update
    6. jamessan and count_omega will keep wayland transition issue uptodate on salsa
  4. ncts
    1. ncts will prepare 1.68 update once 1.67 has been reviewed
    2. f_g ncts brainstorm improvements for rustc packaging helpers
    3. ncts also offers help for cargo update work
    4. ncts write up proposal for more fundamental changes in packaging work flow
    5. ncts might explore a "generic semantic toml patching" feature for debcargo, to allow replacing/adding Cargo.toml
    6. jamessan will push some improvements to the chain build script by ncts
    7. ncts will look at aes transition
  5. UNASSIGNED
    1. mjt Sylvestre should figure out who does the upload
    2. ask infinity0 to give two team members access
    3. unbreak debcargo integration tests


People present (lines said)

  1. f_g (146)
  2. ncts (60)
  3. count_omega (53)
  4. jamessan (38)
  5. MeetBot (2)
  6. capitol (1)


Generated by MeetBot 0.1.4.