19:02:39 <silwol> #startmeeting
19:02:39 <MeetBot> Meeting started Wed Nov 25 19:02:39 2020 UTC.  The chair is silwol. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:39 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:49 <silwol> Agenda is on https://salsa.debian.org/rust-team/debcargo-conf/-/wikis/IRC-Meeting-Agenda - somebody wants any additional topics on the list?
19:08:34 <stappers> Previous meeting did learn me there is something like "co chair the meeting", now looking how to activate that  ...
19:09:52 <silwol> Let's try…
19:10:24 <silwol> MeetBot addchair stappers
19:10:24 <MeetBot> silwol: Error: You don't have the admin capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
19:10:36 <silwol> :-(
19:11:59 <silwol> #chair stappers
19:11:59 <MeetBot> Current chairs: silwol stappers
19:12:04 <silwol> :-)
19:13:53 <stappers> http://meetbot.debian.net/Manual.htmlhttp://meetbot.debian.net/Manual.htmlhttp://meetbot.debian.net/Manual.htmlhttp://meetbot.debian.net/Manual.html
19:13:56 <stappers> iie
19:14:18 <stappers> Oops, sorry for the noise
19:14:52 <silwol> stappers: no problem.
19:15:04 <silwol> Seems like not a lot of people are on atm.
19:16:27 <stappers> Which is OK.   :-)      This IRC-channel has activity outside  meetings.
19:18:58 <stappers> #topic Status regarding the upcoming freeze
19:21:18 <stappers> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=975657  debcargo: Debcargo, cargo, and other Rust packaging tools are NOT in testing
19:21:33 <stappers> is about topic
19:23:36 <stappers> IRC nicks  plugwash and Sylvestre  are participating in bugreport #975657
19:24:04 <silwol> looks like this is worth fixing before the freeze. haven't read into the details, but might be able to help.
19:24:32 <silwol> seems like some of the packages have features depending on not(-yet)-packaged crates.
19:26:10 <silwol> (can't upload anything before december though, had to create a new subkey after the previous expired)
19:26:59 <stappers> Thing I don't understand, thing that possible needs clarification, is https://tracker.debian.org/pkg/rust-cargo versus https://tracker.debian.org/pkg/cargo
19:27:33 <silwol> cargo is the real cargo binary, and rust-cargo is packaged for crates that depend on it as a library.
19:27:34 <stappers> Or should rust-cargo be removed from the archive?
19:28:10 <nicoo> silwol: I'm vaguely on, but can't stay: I have a 7.30am appointment, so this DD is going down for halt NOW! (Message from nicoo@pty-1)
19:28:21 <stappers> Gonna mark that for meeting minutes
19:28:21 <nicoo> Have a good meeting everyone
19:28:39 <silwol> you too, nicoo
19:28:57 <stappers> nicoo  enjoy your appointment
19:29:26 <silwol> stappers: not sure the rust-cargo package is really in use. dev/list-rdeps.sh cargo does not list anything except librust-cargo*
19:29:54 <silwol> so it might not be necessary, but that may just as well be a false negative.
19:31:01 <stappers> #action stappers ask what  rust-cargo  does
19:33:32 <silwol> also on that topic, process-viewer doesn't build properly atm due to an api-incompatible upload of sysinfo. I prepared a patch, but can't upload the crate before december due to my new subkey waiting.
19:34:37 <silwol> the version is actually not that new, but newer versions would require newer gtk, and I assume we'll wait with that until after the release.
19:36:47 <stappers> silwol: stappers is a DD that is new to Rust in Debian.  My previous chance for learning to build, sign and upload a rust package went an other way as planned.
19:37:23 <stappers> Thanks to Sylvestre has ed_ package pleaser now being uploaded.
19:38:34 <stappers> silwol: could we do some jitsi sessie with screen share while uploading `process-viewer`?
19:38:51 <silwol> stappers: of course.
19:39:26 <silwol> just pm me
19:39:37 <stappers> #action: stappers and silwol make an appoint for package rebuild, sign and upload.
19:39:45 <stappers> silwol: will do   ;-)
19:41:32 <silwol> anything else on the freeze topic?
19:47:54 <silwol> I think we can finish, any objections?
19:48:14 <stappers> ;-)
19:48:42 <stappers> #topic granting salsa privileges
19:49:32 <silwol> What's the questioning about that topic?
19:49:44 <stappers> the IRC backlog did learn me that we are happy to grant salsa privileges.
19:49:58 <silwol> true.
19:50:20 <stappers> But somehow are people shy / humble   to request.
19:50:45 <stappers> How could we improve the status?
19:51:00 <silwol> In my perception many prefer to get some feedback in MRs before pushing on their own.
19:51:39 <silwol> but imho that doesn't conflict, even with push privileges one can open an MR and ask for feedback.
19:51:48 <silwol> No idea how to improve though.
19:52:47 <jannic> Reviews are definitely helpful for newcomers! And by the way, thanks for granting me salsa privs and thanks to Sylvestre for reviewing some of my MRs!
19:53:21 <silwol> Maybe people don't expect to receive permissions so fast.
19:53:57 <stappers> #idea repeating "we are willing to grant privilege, it doesn't conflict codereview with merge requests"
19:55:03 <Sylvestre> jannic, welcome :)
19:55:41 <silwol> It's getting crowded ;-) Welcome jannic and Sylvestre
19:56:05 <stappers> :-)
19:56:36 <jannic> The infrastructure provided by debcargo is a little bit intimidating. While all those scripts are extremely helpful (and I wouldn't want to miss them), there is a lot of magic going on.
19:57:16 <stappers> jannic++   # for expressing observation
19:57:37 <fdr> o/ one more here, if still possible to join
19:58:03 <Sylvestre> jannic, agreed
19:58:04 <stappers> fdr: sure
19:58:18 <Sylvestre> and you haven't dealt with massive upgrades yet
19:58:30 <Sylvestre> I broke a bunch of stuff with my upload of digest yesterday :'(
19:58:59 <Sylvestre> silwol, so, freeze is on the agenda ?
19:59:27 <silwol> Sylvestre: it already was, but we can switch back to it imo
19:59:39 <stappers> Sylvestre: Things we could learn / should from the exprience?
19:59:55 <stappers> #topic Status regarding the upcoming freeze
20:01:00 <silwol> Sylvestre: what broke?
20:01:25 <Sylvestre> I think we should define a date from which we don't upgrade core crates (futures, crossbeam, etc)
20:01:42 <Sylvestre> silwol, let's chat later about it :)
20:02:22 <Sylvestre> and, about the freeze, we should ensure that all of our binaries can be rebuilt and have all their deps in testing
20:02:28 <Sylvestre> and this, asap
20:02:44 <Sylvestre> debcargo and process-viewer have been the biggest offender for a while
20:03:35 <silwol> process-viewer has a patch in the repo and is ready to upload
20:04:10 <silwol> I had to upload a new gpg subkey due to expiry of the previous, it should become active by december.
20:04:34 <stappers> Quoting "Winter^Wfreeze is coming":  On 12 January 2021 we're hitting the first milestone of the bullseye release: the Transition and (build-)essentials Freeze.
20:04:53 <Sylvestre> silwol, champagne ! do you want me to upload it for you ?
20:05:01 <stappers> ;-)
20:05:09 <silwol> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954613#15 - so yes ;-)
20:05:10 <stappers> Please doe
20:05:31 <Sylvestre> Missed that email, sorry
20:05:38 <silwol> i hope it doesn't have digest in its dep chain ;-)
20:05:45 * stappers will find other learning opportunities
20:06:22 <silwol> Sylvestre: I interpreted your silence on the topic as consent
20:06:51 <Sylvestre> silwol, my silence is usually "I have too many emails" :)
20:06:56 <silwol> so I haven't taken any further action.
20:06:57 <silwol> :-)
20:07:04 <Sylvestre> stappers, wat ? :)
20:07:20 <silwol> for managing / uploading rust crates, I assume.
20:08:14 <Sylvestre> stappers, not sure what you mean ? you would like to upload new stuff or update other ?
20:08:38 <silwol> Sylvestre: stappers offered me to do the upload of process-viewer in a jitsi session
20:08:48 <Sylvestre> oh, please go ahead :)
20:08:55 <stappers> dito
20:09:15 <Sylvestre> it has been broken for months, it can wait for a few more days :)
20:10:59 <stappers> OK, back to this meeting
20:11:43 <stappers> Topic  the upcoming freeze
20:12:02 <silwol> Sylvestre: your proposal of a date to stop upgrading core crates, what date do you imagine?
20:12:39 <Sylvestre> the date above for example ?
20:13:05 <silwol> asap?
20:13:16 <Sylvestre> nah, Jan 13 ?
20:13:43 <Sylvestre> ouch, lucas reported a bunch of bugs, I did broke a lot of things yesterday :'(
20:13:48 <silwol> isn't that nearly freeze date?
20:14:13 <stappers> silwol: 12 Jan is first milestone of freeze.
20:14:18 <Sylvestre> this is the first freeze
20:14:21 <silwol> ah, milestone 1 - transition and (build-)essentials freeze, ic.
20:16:00 * stappers feels the need to  '#agree    2020-01-12  freeze for rust core packages'
20:16:00 <silwol> Mentally, I already switched to "no more big core-crates updates" anyway.
20:16:18 <Sylvestre> stappers++
20:16:36 <stappers> #agree    2020-01-12  freeze for rust core packages
20:16:56 <Sylvestre> silwol, yeah, I should have, I was trying to unbreak grcov, which needed a new verison of md-5, which needed digest, which needed generic-array :(
20:17:50 * jannic thinks this will be a recurring pattern packaging rust stuff.
20:18:20 <Sylvestre> jannic, s/will/is/g
20:18:25 <silwol> jannic: this pattern already has secured its place in history.
20:18:37 <stappers> yes, we call it  release cycles      8^)
20:19:48 <Sylvestre> and we even didn't start updating crossbmean or tokio (or stuff like clap or rayon)
20:21:05 <Sylvestre> I guess we will have to be more flexible in different versions of the same crate in the  archive (like java)
20:21:15 <silwol> I think we will have to expect some breakage when updating that. We can try to identify what will break and prepare these crates, but I don't think it can be done without any problems.
20:21:15 <fdr> are there clear rules for multi version os those  kind of core craits
20:21:19 <fdr> ?
20:21:35 <fdr> s/craits/crates
20:21:52 <silwol> fdr the packaging model actually allows to package older crate versions in parallel to the latest, but that had some problems in the past.
20:22:17 <Sylvestre> fdr, do it when you might break too many things
20:22:22 <stappers> fdr: your question has be seen, please hold your horses until after the meeting
20:22:23 <Sylvestre> I did it for cfg-0.1
20:22:33 <fdr> silwol:  yes, I know , I even made one already. My point is if we do have clear rules 'when' to use that
20:22:42 <silwol> ah, ok.
20:23:53 <fdr> stappers: my bad, I dont know the protocol for the meetings
20:24:06 <stappers> fdr: my apology for being unaware that you are contributing to the #topic  freeze status
20:24:37 <fdr> stappers:  :)
20:24:53 <Sylvestre> about the freeze topic, I have some CI building these rust-based binaries twice a day
20:24:54 <Sylvestre> bat cbindgen debcargo dfrs difference exa fd-find grcov hexyl hyperfine kmon nitrocli pleaser process-viewer ripgrep rusty-tags sequoia-sop sequoia-sqv sniffglue spotify-tui zoxide
20:25:05 <silwol> afaik we don't have any rule, I for myself decided to avoid it whenever possible and attempt patching things that depend on it.
20:25:34 <Sylvestre> do we have anything other binaries that we are planning to ship in bullseye that I didn't listed ?
20:25:35 <silwol> so on your list, it's just process-viewer and debcargo that are broken atm?
20:25:50 <fdr> silwol:  but i think this approave is more dangerous for things like crosbeam, rayon , and, specially, tokio
20:26:04 <Sylvestre> silwol, + grcov (broken for a while)
20:26:24 <Sylvestre> I broke sequoia + sniffglue with my upload
20:26:28 <Sylvestre> which I am working to fix
20:26:47 <Sylvestre> I will try to get rust/coreutils but probably experimental only for bullseye
20:27:57 <silwol> Sylvestre: the whole list?
20:28:13 <silwol> or just as far as you manage to get it done?
20:28:19 <silwol> (sounds ambitious)
20:28:51 <stappers> we don't known how large the CI build farm is ...
20:29:16 <Sylvestre> silwol, this is the list of what I am testing automatically
20:29:27 <Sylvestre> before my upload of yesterday, we had only 3 failing
20:29:45 <silwol> Sylvestre: I mean you'd like to upload the whole list of coreutils for bullseye?
20:29:46 <Sylvestre> stappers, takes less than 3 minutes per build :)
20:30:14 <Sylvestre> silwol, nah, I am planning to upload coreutils as just one package with all the binaries
20:30:23 <silwol> ok
20:30:24 <stappers> OK, twice a day    easilys
20:30:46 <stappers> OK, twice a day    easily
20:31:03 <stappers> OK, twice a day    easy
20:31:48 <Sylvestre> easy ;)
20:31:55 <Sylvestre> besides that, anything else about the freeze ?
20:32:28 <silwol> not that I know, I don't plan to get anything uploaded.
20:32:43 <silwol> but I hope we can push forward after the release.
20:33:12 <Sylvestre> with the library repo, if NEW rules for new binary are relaxed, it will be much easier
20:33:13 <silwol> (anything meaning any crates with executables)
20:33:34 <fdr> I would like to try to get alacritty in shape before freeze
20:33:57 <silwol> yes, I'm really looking forward to that moment. and I hope to finish my DD application by then.
20:34:34 <silwol> fdr what's left to be done for alacritty?
20:35:04 <fdr> some dependencies  , from what I saw, nothing very hard
20:35:35 <silwol> sounds promising, best of luck!
20:36:01 <Sylvestre> fdr, you have only a couple of weeks left if you want it in testing
20:36:26 <fdr> Sylvestre: yes , had some busy weeks at work...
20:36:47 <fdr> Sylvestre: but I should have more time for that now
20:37:08 <fdr> Sylvestre: how many weeks ?
20:37:22 <Sylvestre> fdr, 2 i would say
20:37:39 <Sylvestre> upload + new + fixing autopkgtest + bug + regression
20:38:31 <fdr> mmm ... i ll check .. they release 0.6 this week .. I was thinking on targeting that .. but it would mean upgrading some crates I did already package
20:38:45 <silwol> fdr already released 21 hours ago
20:39:46 * fdr did release ..  missed the past tense, sorry
20:39:55 <silwol> :-)
20:40:35 <Sylvestre> fdr, if these crates aren't used in Debian, this is trivial work
20:40:42 <fdr> but, I ll try to get it done in 2 weeks .. I think its doable
20:40:52 <fdr> most of them are new , so , should be easy
20:41:18 <stappers> Further input for meeting topic "status freeze"?
20:41:40 <fdr> Sylvestre: yes, now I already feel I do have more practice to do it in a organized way , and avoid problems with ftp masters
20:42:01 * fdr says no from me
20:42:38 <Sylvestre> stappers, I am good, thanks :)
20:42:49 <silwol> nothing from my side.
20:43:10 <Sylvestre> stappers, do you want a summary ?
20:43:24 <stappers> OK
20:44:23 <stappers> OK as in "yes it is OK to provide a summary"
20:45:55 <Sylvestre> so, here it is: "no more big crates update from Jan 12th, we will do our best to fix existing broken binary crates in the archive, ok to try to upload new stuff but no promises"
20:46:00 <Sylvestre> is that good enough?
20:46:08 <stappers> Sylvestre++
20:46:31 <stappers> #topic status mailinglist debian-rust@lists.debian.org
20:46:48 <stappers> No news from listmasters
20:46:57 <stappers> #topic closing meeting
20:47:36 <silwol> ftr: Next IRC meeting Wednesday 2020-12-30 19:00 UTC
20:48:18 <stappers> silwol++
20:49:11 <stappers> #endmeeting