#debian-rust Meeting

Meeting started by stappers at 18:58:41 UTC (full logs).

Meeting summary

    1. ACTION: ftpteam to talk about a build-only archive and talk to release team about it (stappers, 19:59:20)
    2. https://salsa.debian.org/rust-team/debcargo-conf/-/wikis/IRC-Meeting-Agenda (wookey, 20:00:11)
    3. ACTION: (silwol and f_g) investigate features/versions/provides/bin package reduction, implement PoCs (stappers, 20:00:24)

  1. Avoiding Section: FIXME (stappers, 20:07:42)
    1. AGREED: lintian check before upload (stappers, 20:10:29)
    2. IDEA: make ./release.sh more robust w.r.t. lintian errors (stappers, 20:10:57)
    3. AGREED: that '#agreed lintian check before upload' was too fast ... (stappers, 20:12:24)
    4. ACTION: ./release.sh should refuse uploading if there are lintian error (stappers, 20:12:55)

  2. Current packaging projects requiring coordination/help (stappers, 20:29:55)
  3. Upcoming freeze and things to keep an eye out for (stappers, 20:37:21)
  4. Toolchain updates (/ rustfmt / clippy) (stappers, 20:46:59)
  5. last minute entries (stappers, 20:59:18)
  6. mailinglist debian-rust (stappers, 21:03:16)
    1. ACTION: stappers does another retransmit to express we want/need a discussion ML beside the auto-generated traffic mailinglist (stappers, 21:04:52)


Meeting ended at 21:05:28 UTC (full logs).

Action items

  1. ftpteam to talk about a build-only archive and talk to release team about it
  2. (silwol and f_g) investigate features/versions/provides/bin package reduction, implement PoCs
  3. ./release.sh should refuse uploading if there are lintian error
  4. stappers does another retransmit to express we want/need a discussion ML beside the auto-generated traffic mailinglist


Action items, by person

  1. f_g
    1. (silwol and f_g) investigate features/versions/provides/bin package reduction, implement PoCs
  2. stappers
    1. stappers does another retransmit to express we want/need a discussion ML beside the auto-generated traffic mailinglist
  3. UNASSIGNED
    1. ftpteam to talk about a build-only archive and talk to release team about it
    2. ./release.sh should refuse uploading if there are lintian error


People present (lines said)

  1. f_g (76)
  2. stappers (72)
  3. Ganneff (57)
  4. wookey (25)
  5. hntourne (11)
  6. waldi (9)
  7. MeetBot (2)


Generated by MeetBot 0.1.4.