16:41:47 <utkarsh2102> #startmeeting
16:41:47 <MeetBot> Meeting started Fri Jun  5 16:41:47 2020 UTC.  The chair is utkarsh2102. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:41:47 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:41:57 <utkarsh2102> #topic rollcall
16:42:01 * utkarsh2102 waves
16:42:10 <bhe[m]> Hey..
16:42:11 <kanashiro> sorry, I did not have time to check the agenda
16:42:18 * kanashiro waves again
16:43:18 <srud> o/
16:43:55 <utkarsh2102> #topic setting up agenda
16:44:02 <utkarsh2102> the current agenda is here: https://wiki.debian.org/Teams/Ruby/IRCMeetings
16:44:27 <utkarsh2102> let's probably wait for 5-7 minutes to see if people want to add something more to it?
16:44:44 <utkarsh2102> please add anything that you'd like to discuss! \o/
16:46:21 <kanashiro> I have no topic to discuss, maybe just check if someone is still interested on working on ruby 2.7 blog post
16:46:57 <PiratePraveen[m]> we could just look at rails 6
16:47:13 <PiratePraveen[m]> kanashiro any update from redmine or obs?
16:47:28 <PiratePraveen[m]> gitlab is still stuck in NEW
16:47:29 <utkarsh2102> please talk about it during that topic :)
16:47:39 <utkarsh2102> alright, let's begin with that
16:47:48 <utkarsh2102> #topic rails 6
16:48:02 <utkarsh2102> #info gitlab is still stuck in NEW
16:48:38 <utkarsh2102> Pirate ‍ Praveen: yeah, the NEW queue has become very long now
16:49:29 <PiratePraveen[m]> its a bit frustrating they consider binNEW the same way as a NEW package
16:49:34 <kanashiro> PiratePraveen[m]: obs was not released yet with rails 6 support nor redmine
16:49:49 <georg> neither schleuder
16:50:06 <PiratePraveen[m]> gitlab was reviewed twice already, first time in main, then moving gitlab-common to contrib
16:50:47 <PiratePraveen[m]> but we have a lot of work to do if we want rails 6 in bullseye
16:50:53 <PiratePraveen[m]> so eventually we got to do it anyway
16:50:59 <PiratePraveen[m]> the sooner, the better
16:51:22 <georg> we should probably, at some point in time, get rails 6 into unstable
16:51:25 <kanashiro> PiratePraveen[m]: have you tried to rebuild reverse dependencies to have an idea of what will break?
16:51:50 <utkarsh2102> Pirate ‍ Praveen: I've pinged them internally for gitlab
16:52:09 <kanashiro> apart from apps
16:52:44 <PiratePraveen[m]> I have not looked closer recently
16:53:17 <PiratePraveen[m]> https://salsa.debian.org/ruby-team/rails/-/wikis/Transition-to-Rails-6-for-Debian-Bullseye
16:53:26 <utkarsh2102> does it call for..
16:53:30 <utkarsh2102> rails sprint? :)
16:53:48 <kanashiro> I think we could do that in the meantime, while apps do not support it yet
16:53:58 <PiratePraveen[m]> because of the check dependencies test, most will need an update I guess
16:55:00 <kanashiro> if they need changes we can start to stage them in experimental (or even in unstable if they do not break many things)
16:55:33 <utkarsh2102> #link https://salsa.debian.org/ruby-team/rails/-/wikis/Transition-to-Rails-6-for-Debian-Bullseye
16:56:28 <utkarsh2102> that's too long a list though :o
16:57:03 <terceiro> it seems that this rails 6 transition is dragging for too long
16:57:07 <PiratePraveen[m]> some are duplicates there
16:57:22 <utkarsh2102> ah
16:57:43 <utkarsh2102> fwiw, there's regression with latest upload of rails already
16:58:01 <kanashiro> but I agree, we can wait a bit more for apps to support rails 6 but at some point we will need to upload it to unstable if we want it ready for bullseye
16:58:11 <utkarsh2102> should we just take advantage of this situation and start the rails 6 transition? :p
16:59:21 <terceiro> IMO if it's to break, break now and not closer to the freeze
17:00:09 <terceiro> I think we have discussed the rails 6 transition for what, the last 2-3 meetings?
17:00:17 <utkarsh2102> yes
17:00:18 <terceiro> people had enough lead time
17:00:22 <utkarsh2102> all 3
17:00:47 <terceiro> make sure all the big things (redmine, obs etc) are ok in testing, then break sid
17:01:25 <terceiro> but before, please report bugs against everything that breaks
17:01:29 <terceiro> and then break them
17:02:03 <terceiro> maybe send an ultimatum to the ML ("beware: rails 6 in unstable in X weeks") ASAP
17:02:34 <utkarsh2102> any takers^?
17:03:19 <PiratePraveen[m]> I could do the rebuilds and send mails, but we need to decide on the time
17:03:32 <PiratePraveen[m]> 8 more weeks good enough lead time?
17:03:56 <utkarsh2102> more than enough I think :)
17:04:02 <terceiro> that is plenty, yes
17:04:25 <PiratePraveen[m]> kanashiro ?
17:04:42 <kanashiro> PiratePraveen[m]: yep, sounds good to me
17:04:54 <utkarsh2102> #info Pirate ‍ Praveen to do rebuilds and send mails in 8 weeks time
17:05:15 <PiratePraveen[m]> ok I will send a mail to the list now
17:05:32 <PiratePraveen[m]> utkarsh2102 send mail now, that in 8 weeks we will upload rails 6 to unstable
17:05:43 <utkarsh2102> yeah
17:06:04 <utkarsh2102> #info Pirate ‍ Praveen to send mail now about the ultimatum
17:06:07 <utkarsh2102> fixed^
17:06:46 <utkarsh2102> anything more here?
17:06:53 <utkarsh2102> can we proceed?
17:07:55 <kanashiro> yes
17:08:06 <terceiro> yes
17:08:20 <utkarsh2102> oh wait.
17:08:33 <utkarsh2102> #action Pirate ‍ Praveen to send a mail about the ultimatum
17:08:38 <utkarsh2102> :)
17:08:43 <utkarsh2102> while at it, we can also talk about..
17:08:55 <utkarsh2102> #topic ruby sprints
17:09:08 <utkarsh2102> someone sent a mail to the list 2 months back I think
17:09:18 <utkarsh2102> that 3.0.0~preview1 will be out soon
17:09:31 <utkarsh2102> now the question is, do we want to have 3.0.0 in bullseye?
17:09:36 <utkarsh2102> is it worth trying?
17:09:55 * terceiro checks release timeline
17:10:30 <terceiro> 2021-01-12      - Milestone 1 - Transition and (build-)essentials freeze
17:10:30 <terceiro> 2021-02-12      - Milestone 2 - Soft Freeze
17:10:30 <terceiro> 2021-03-12      - Milestone 3 - Hard Freeze - for key packages and
17:10:30 <terceiro> packages without autopkgtests
17:10:31 <terceiro> To be announced - Milestone 4 - Full Freeze
17:10:45 <terceiro> I don't think there's enough time, at least not to switch the default
17:10:58 <kanashiro> nah, we should ship 2.7
17:11:39 * PiratePraveen[m] sent the ultimatum mail to the list
17:12:15 <kanashiro> we can have 3.0 in experimental to play with it and plan a transition after bullseye release
17:12:20 <utkarsh2102> #info Pirate ‍ Praveen is very quick and sent the ultimatum already
17:12:25 <utkarsh2102> so no sprints for now?
17:12:37 <utkarsh2102> can we put this off for further meetings then?
17:12:42 <terceiro> sprints are not only to do transitions
17:13:24 <terceiro> we can plan one for late august if people think it's useful
17:14:52 <utkarsh2102> sounds good to me
17:14:58 <kanashiro> I think it can be useful when we start to break things due to rails 6 :P
17:15:18 <utkarsh2102> basically there should be 2 sprints -> 1) rails 6   2) ruby3.0
17:15:37 <srud> kanashiro: yes.. That would be a good idea
17:17:28 <kanashiro> late August might be the right time to do it as terceiro proposed
17:17:39 <utkarsh2102> #idea plan sprints for ruby3.0 in late august or so
17:18:06 <terceiro> not for ruby3.0?
17:18:11 <kanashiro> utkarsh2102: you mean rails 6, right?
17:18:33 <terceiro> BTW MeetBot supports #undo
17:18:58 <utkarsh2102> ah, I am clearly not fully awake; apologies all
17:19:02 <utkarsh2102> #undo
17:19:02 <MeetBot> Removing item from minutes: <MeetBot.items.Idea object at 0x108b590>
17:19:44 <utkarsh2102> #idea plan sprints for rails 6 in late august or so
17:19:57 <utkarsh2102> good enough!?^
17:20:34 <kanashiro> yep
17:21:03 <utkarsh2102> do we have anything more?
17:22:29 <PiratePraveen[m]> utkarsh2102 is any more rails 5 updates planned in sid, from security perspective?
17:22:32 <utkarsh2102> should I wrap up if not?
17:22:42 <PiratePraveen[m]> there is a babel 6 to babel 7 change in rails 6 currently
17:23:11 <utkarsh2102> #topic rails 5
17:23:44 <utkarsh2102> Pirate ‍ Praveen: I am not sure yet, but I think there won't be more. Depends on how many CVEs are reported :)
17:23:51 <PiratePraveen[m]> it'll help with babel 6 removal
17:24:04 <PiratePraveen[m]> but we are stuck with yarnpkg so its not very urgent
17:24:21 <utkarsh2102> ah, great! we can do this in August itself, no?
17:24:43 <PiratePraveen[m]> if you plan to update rails 5, take the updated patch for rollup.config.js from rails 6 branch
17:25:10 <PiratePraveen[m]> if rails 6 goes to unstable before we fix yarnpkg, then no issues
17:25:33 <PiratePraveen[m]> but if yarnpkg gets fixed before we can upload rails 6 to unstable, I'd like rails 5 to be fixed as well
17:26:08 <utkarsh2102> sure, that can be worked out
17:27:14 <utkarsh2102> the latest upload (that is, 5.2.4.1 --> 5.2.4.3) caused regression which has something to do with activestorage. I did not look closely yet, but if someone can figure out a fix, that'd be awesome!
17:27:40 <utkarsh2102> fwiw, the fix for that regression would be simply to fix the autopkgtest of rails itself.
17:28:24 <PiratePraveen[m]> then it is possibly the javascript part
17:28:25 <PiratePraveen[m]> because activestorage uses rollup for its js component
17:28:53 <PiratePraveen[m]> actually errors in rails build does not cause ftbfs
17:29:02 <PiratePraveen[m]> I think we need to fix that too
17:29:28 <utkarsh2102> yeah, that's funny and weird
17:29:59 <utkarsh2102> this: #919478
17:31:04 <utkarsh2102> can someone look into rails' autopkgtest?
17:31:36 <utkarsh2102> RFH \o/
17:32:20 <utkarsh2102> #info errors in rails build does not cause FTBFS
17:32:24 <utkarsh2102> #link https://bugs.debian.org/919478
17:32:41 <kanashiro> that's weird
17:33:14 <utkarsh2102> terceiro: that's also cloned to gem2deb, btw^
17:33:39 <terceiro> utkarsh2102: RFH
17:33:41 <terceiro> :)
17:33:51 <utkarsh2102> lovely!
17:34:29 <utkarsh2102> #action $someone to take a look at autokpkgtest of rails
17:34:49 <utkarsh2102> #action utkarsh2102 will send a mail for the bug as RFH to the list
17:35:05 <utkarsh2102> do we have anything more?
17:36:16 <kanashiro> nothing from me
17:36:52 <PiratePraveen[m]> nothing from me too
17:37:34 <bhe[m]> kanashiro:  mentioned about 2.7 blog post ?
17:37:43 <utkarsh2102> oh yeah
17:37:49 <bhe[m]> *ruby2.7
17:37:52 <utkarsh2102> #topic ruby2.7 blog post
17:37:52 <kanashiro> ah yes! thanks bhe[m] :)
17:37:58 <utkarsh2102> where are we on it?
17:38:12 <kanashiro> here: https://pad.riseup.net/p/ruby2.7-in-debian-keep
17:39:05 <kanashiro> zeha did some small changes but no one else got interested on it I think
17:39:05 <utkarsh2102> #link https://pad.riseup.net/p/ruby2.7-in-debian-keep
17:40:21 <kanashiro> RFH again :)
17:40:39 <kanashiro> to collect some data
17:41:19 <utkarsh2102> #info RFH: help collect some data for ruby2.7 blog post
17:41:36 <kanashiro> I've been busy with other stuff and did not have time to play with UDD or some other sources of data
17:41:37 <utkarsh2102> kanashiro: maybe send another gentle ping on the list?
17:42:05 <kanashiro> utkarsh2102: ok, I can do that
17:42:50 <utkarsh2102> #action kanashiro to send RFH for ruby2.7 blog post
17:42:56 <utkarsh2102> okay, anything more?
17:43:26 <utkarsh2102> (I think we should wrap up, it's been nearly an hour)
17:43:56 <kanashiro> good call :)
17:43:58 <zigo> Yeah.
17:44:05 <zigo> Puppet 6 ...
17:44:20 <zigo> I wonder if any of you could give help with packaging it in Sid.
17:44:27 <zigo> Issue is: it fails with Ruby 2.7.
17:44:39 <utkarsh2102> heh, RFH \o/
17:44:39 <zigo> Any volunteer ? :)
17:44:55 <utkarsh2102> #topic Puppet 6
17:45:16 <kanashiro> zigo: I have filed some bugs upstream regarding ruby 2.7 and I think it is in the review stage or already landed, need to check
17:45:33 <zigo> nice !
17:45:40 <utkarsh2102> #info puppet 6 fails to build against ruby2.7
17:45:54 <zigo> Do you have the URL handy?
17:46:23 <utkarsh2102> #info kanashiro filed some bugs upstream regarding ruby 2.7 and he thinks they are in the review stage or already landed, need to check
17:47:27 <kanashiro> let me try to find the url
17:47:48 <utkarsh2102> can I wrap up the meeting meanwhile? :)
17:47:56 <zigo> Sure !
17:47:59 <zigo> Thanks.
17:48:03 <utkarsh2102> great, thanks! :)
17:48:08 <utkarsh2102> and also, hi :)
17:48:13 <utkarsh2102> #topic next meeting
17:48:15 <zigo> :)
17:48:26 <utkarsh2102> Next meeting is on July 3rd, 1630 UTC.
17:48:42 <kanashiro> so far I have these: https://tickets.puppetlabs.com/browse/PUP-10391 and https://tickets.puppetlabs.com/browse/PUP-10535
17:48:48 <kanashiro> zigo: ^
17:49:05 <zigo> gr8 thx!
17:49:07 <kanashiro> I need to revisit it, maybe there are more
17:49:25 <utkarsh2102> #agreed iext meeting is on July 3rd, 1630 UTC.
17:49:39 <utkarsh2102> #info link to agenda: https://wiki.debian.org/Teams/Ruby/IRCMeetings
17:49:47 <utkarsh2102> #endmeeting