#debian-ruby Meeting

Meeting started by terceiro at 16:35:44 UTC (full logs).

Meeting summary

  1. roll call (terceiro, 16:36:02)
  2. ruby2.7 transition - next steps (terceiro, 16:46:20)
    1. https://wiki.debian.org/Teams/Ruby/InterpreterTransitions (terceiro, 16:48:14)
    2. https://udd.debian.org/cgi-bin/bts-uhttps://udd.debian.org/cgi-bin/bts-usertags.cgi?user=pkg-ruby-extras-maintainers@lists.alioth.debian.org&tag=ruby2.7-transitionsertags.cgi?user=pkg-ruby-extras-maintainers@lists.alioth.debian.org&tag=ruby2.7-transition (terceiro, 16:51:34)
    3. ACTION: kanashiro open ruby2.7-default transition ASAP, and after RT gives go ahead, upload to unstable (terceiro, 16:55:24)

  3. rails 6 transition (terceiro, 16:58:58)
    1. gitlab already has rails 6 support (terceiro, 17:06:02)
    2. redmine does not have rails 6 support yet (terceiro, 17:06:11)
    3. ACTION: kanashiro check status of obs wrt rails 6 (terceiro, 17:06:31)
    4. AGREED: rails 6 will not be uploaded to unstable just yet. we'll re-raise this topic in the next meeting (terceiro, 17:06:58)

  4. ruby2.7 transition - RM requests (terceiro, 17:09:19)
    1. https://lists.debian.org/debian-ruby/2020/03/msg00034.html (kanashiro, 17:09:37)
    2. https://lists.debian.org/debian-ruby/2020/03/msg00006.html (kanashiro, 17:09:47)
    3. https://lists.debian.org/debian-ruby/2020/03/msg00011.html (kanashiro, 17:09:55)
    4. AGREED: we'll remove packages that are actually broken, not ones that are just old (terceiro, 17:18:51)

  5. ruby-aws-sdk (terceiro, 17:20:38)
    1. ACTION: terceiro to clarify the consensus in the 2020 ruby sprint about ruby-aws-sdk (terceiro, 17:34:25)

  6. next meeting (terceiro, 17:35:27)
    1. AGREED: meetings on every first Friday of the month, at 16:30 UTC (terceiro, 17:44:50)
    2. utkarsh2102 is volunteering to make us not forget it (terceiro, 17:45:06)


Meeting ended at 17:47:11 UTC (full logs).

Action items

  1. kanashiro open ruby2.7-default transition ASAP, and after RT gives go ahead, upload to unstable
  2. kanashiro check status of obs wrt rails 6
  3. terceiro to clarify the consensus in the 2020 ruby sprint about ruby-aws-sdk


Action items, by person

  1. kanashiro
    1. kanashiro open ruby2.7-default transition ASAP, and after RT gives go ahead, upload to unstable
    2. kanashiro check status of obs wrt rails 6
  2. terceiro
    1. terceiro to clarify the consensus in the 2020 ruby sprint about ruby-aws-sdk


People present (lines said)

  1. terceiro (94)
  2. kanashiro (35)
  3. PiratePraveen[m] (22)
  4. utkarsh2102 (13)
  5. utkarsh2102[m] (7)
  6. srud[m] (4)
  7. MeetBot (3)
  8. gwolf (2)
  9. bhe[m] (1)
  10. hacksk[m] (1)


Generated by MeetBot 0.1.4.