21:58:55 <boutil> #startmeeting
21:58:55 <MeetBot> Meeting started Tue Mar 11 21:58:55 2014 UTC.  The chair is boutil. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:58:55 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:59:08 <boutil> Hi everybody!
21:59:22 <boutil> welcome to the second IRC Debian Ruby meeting
21:59:30 <boutil> say hi :)
21:59:46 <hggh> hi! :)
22:00:01 <boutil> #chair hggh
22:00:01 <MeetBot> Current chairs: boutil hggh
22:00:11 <boutil> is zeha_ around?
22:00:19 <boutil> is paulvt around?
22:00:24 <sbadia1> hi
22:00:25 <boutil> hi sbadia1
22:00:30 <boutil> #chair sbadia1
22:00:30 <MeetBot> Current chairs: boutil hggh sbadia1
22:01:44 <boutil> ok, so the list of topics for today's meeting was supposed to be:
22:01:50 <boutil> - Debian Ruby policy
22:01:55 <boutil> - Coordination with Ubuntu for Trusty 14.04 LTS
22:02:00 <boutil> - Quick glance through RC bugs
22:02:06 <boutil> - Status of ruby1.8 and ruby1.9.1 removal
22:02:11 <boutil> - Status of 2.0-default, 2.1
22:02:55 <boutil> are there any other topics that people present would like to discuss, while waiting for the others?
22:03:06 <hggh> gitlab :)
22:03:14 <boutil> gitlab!
22:03:30 <boutil> great, I've just regenerated my dependency graph
22:03:38 <boutil> #topic Gitlab packaging
22:04:11 <hggh> the big problem is as said, the redis em stuff
22:04:12 <boutil> here is the latest graph:
22:04:14 <boutil> http://people.debian.org/~boutil/gitlab/gitlab_deps20140311.pdf
22:04:35 <hggh> ruby-em-http-request is available in Git, but tests fails
22:04:36 <hggh> ruby-em-synchory (ITP: #705578) needs ruby-em-http-request
22:04:36 <hggh> ruby-redis (ITP: #712048) needs ruby-em-synchory
22:04:52 <boutil> gwolf: hi!
22:05:31 <hggh> ruby-redis holds 5 packages, perhaps I can get ruby-em-http-request running with some tests disabled, because of https://github.com/igrigorik/em-http-request/issues/263
22:05:50 <hggh> and ... thanks to my super sponsor boutil :))
22:05:58 <gwolf> boutil: o/
22:06:07 <gwolf> being on the phone sucks...
22:06:20 <gwolf> more so while on wait...
22:06:50 <boutil> hggh: please deactive all failing tests, and continue packaging these ruby-em-*
22:07:14 <boutil> eventmachine currently has its test suite disabled, because of failing tests
22:07:39 <boutil> we cannot expect to be able to run all those test suites perfectly..
22:07:43 <hggh> boutil: ok, I will do it next week, all redis/em stuff beeing at linux day in chemnitz this weekend
22:08:20 <boutil> nice
22:08:26 * zeha_ on phone
22:08:32 <hggh> I have also prepared ruby-axiom-types, and ruby-rack-mount (not yet in git)
22:08:38 <hggh> zeha_: *wink*
22:08:40 <boutil> gwolf: we are discussing gitlab packaging
22:09:16 <boutil> I have worked a bit on state-machine, but it needs still some polishing
22:09:33 <hggh> nice. what's about gemoji?
22:09:59 <hggh> https://github.com/github/gemoji/blob/master/LICENSE
22:10:04 <gwolf> boutil: I'm not even a newbie at gitlab :)
22:10:33 <boutil> hggh: need to be dropped
22:10:41 <hggh> gna :(
22:10:48 <boutil> as well as github-markup
22:11:20 <boutil> (it has a two-year old pull request to add a valid license, which hasn't been accepted...)
22:11:41 <boutil> We need to speak seriously with upstream about that and all those gitlab-* gems
22:11:59 <hggh> yes that also. but that's the problem with -markup?
22:13:33 <boutil> I'm trying to find the link for this gem
22:14:06 <boutil> that's it: https://github.com/isaacs/github-flavored-markdown
22:15:15 <hggh> ah I see. perhaps we can ask github for gemoji
22:15:41 <boutil> but I have issues when I try to open it. Anyway, as is, it is not distribuable/modifiable, and has been deprecated by upstream
22:16:09 <boutil> hggh: ok. Are you volunteering to interact with gitlab upstream?
22:16:17 <hggh> yes
22:16:22 <boutil> great!
22:16:41 <boutil> #info hggh volunteered to interact with Gitlab's upstream
22:16:54 <hggh> I will create a list of issues and we can discuss it on ruby-debian ml and then send it to upstream
22:17:28 <sbadia1> we need some help on packing side ?
22:17:35 <sbadia1> I'm a lurker for about 2 months :-)
22:18:06 <hggh> yes packaging help is welcome, see http://people.debian.org/~boutil/gitlab/gitlab_deps20140311.pdf
22:18:06 <boutil> yes, we do
22:19:36 <hggh> so next topic?
22:20:51 <sbadia> erf sorry
22:20:56 <sbadia> better here
22:21:53 <sbadia> ok well (ok for packaging)
22:21:59 <boutil> sbadia: so the rule is that you can pick anything black or orange on the graph
22:22:07 <boutil> we win when everything is green
22:22:50 <sbadia> boutil: ok ;-)
22:23:11 <boutil> the orange correspond to ITPs. Many of them have been filed long time ago, and no work has been so far, so they are more like RFP.
22:23:35 <boutil> anything to add on gitlab?
22:23:41 <hggh> no
22:23:49 <boutil> ok.
22:23:50 <sbadia> no for me
22:24:17 <boutil> #topic status of ruby1.8, 1.9.1, 2.0 2.1
22:24:32 <boutil> too bad that terceiro and zeha are missing
22:24:38 <zeha_> well
22:24:45 <boutil> ah!
22:25:14 <zeha_> 1.8 is still in testing
22:25:34 <zeha_> were waiting for dns323-firmware-tools to migrate
22:25:40 <hggh> oh? because of what package?
22:25:43 <zeha_> then we can ask for removal
22:25:51 <boutil> wonderful!
22:25:55 <hggh> nice!
22:25:55 <zeha_> dns323-fw-t is a b-d of d-i
22:26:28 <zeha_> to get 1.9/2.0/2.1 to migrate we need to remove 1.8
22:27:03 <hggh> so tomorrow dns323 will be migrate, you can fill the removal bug?
22:27:04 <boutil> and the switch to 2.0 as default will happen in unstable when the current version enter testing
22:27:09 <boutil> is that correct?
22:27:12 <zeha_> plus there are rc bugs against 1.9 and 2.0 open and the interpreter maintainers would like your help
22:27:28 <zeha_> basically the same bug, ssl stuff
22:27:39 <zeha_> dont have the bug# here
22:28:16 <zeha_> i'd like to delay 2.0-default until 1.8/1.9/2.0 is sorted in testing
22:28:37 <zeha_> otherwise well create an even larger unmigrateable mess
22:28:44 <zeha_> thats it basically
22:28:46 <hggh> why not switch from 1.8 to 2.1 default?
22:29:00 <boutil> zeha_: ok.
22:29:50 <boutil> #info help is needed to fix rc bugs on interpreters
22:30:17 <boutil> #info switch to 2.0 as default will happen when those bugs are fixed and the corresponding packages migrate to testing
22:30:32 <zeha_> i think its not feasible to directly go to 2.1
22:30:37 <hggh> ok
22:30:56 <boutil> what are the main blockers for the removal of 1.9.1?
22:31:15 <boutil> (expect ruby-qt/korundum)
22:31:22 <zeha_> qt
22:31:33 <zeha_> and again dns323-fw-tools
22:31:38 <hggh> :)
22:31:57 <zeha_> and some random packages that need NMUs, but not a lot of them
22:32:07 <boutil> ruby-qt is blocked by the fact that CMake doesn't know about ruby versions higher that 1.9 and/or multiarch
22:32:14 <zeha_> bugs have been filed, but at sev. normal
22:32:28 <zeha_> there is a usertag, but i forgot the name
22:32:39 <zeha_> we'd also like help there ;)
22:33:25 <boutil> zeha_: is that ruby-defaults-2.0?
22:33:49 <zeha_> it might be
22:33:59 <zeha_> (on a phone, sorry)
22:34:24 <zeha_> if you find the bug against qt and obexftp, they have the tags
22:34:38 <boutil> yeah, that's it
22:34:40 <boutil> https://bugs.debian.org/cgi-bin/pkgreport.cgi?users=debian-ruby@lists.debian.org;tag=ruby-defaults-2.0
22:35:05 <boutil> ok. something else about the interpreters?
22:35:12 <zeha_> i think ill write a mail tomorrow outlining what needs to be done
22:35:19 <boutil> great
22:35:21 <zeha_> and where we could use help
22:35:50 <zeha_> apart from 'everywhere'
22:36:21 <boutil> is there an alioth list receiving the mails from all the interpreters?
22:36:41 <boutil> or do we have to subscribe to the PTS to get the info?
22:36:54 <boutil> for every interpreter version?
22:37:13 <zeha_> dont have a list i think
22:37:36 <zeha_> d-ruby is it for the most part
22:37:57 <boutil> ok.
22:38:00 <boutil> next topic?
22:38:22 <hggh> yes
22:38:25 <boutil> #topic coordination with Ubuntu
22:38:41 <hggh> is any member of debian ruby also in Ubuntu?
22:38:54 <boutil> terceiro wrote that it was too late to change the default version for 14.04
22:39:28 <boutil> paulvt had something else in mind I think when he mentionned this topic last time.
22:39:33 <hggh> so 14.04 LTS will be shipped with 1.8?
22:40:12 <boutil> I guess so.
22:40:37 <boutil> but the ruby1.8 is probably not part of the LTS core set of packages
22:41:30 <zeha_> iirc its out of core yes
22:41:56 <boutil> I think paulvt was thinking about changes about metadata or related, like rubygems-integration they couldn't get in the last LTS
22:42:31 <boutil> anyway.
22:42:34 <gwolf> So it's not terribly relevant for their LTS
22:42:46 <hggh> so next topic :)
22:43:15 <boutil> so we have left: Debian Ruby policy and glance through RC bugs
22:43:27 <boutil> #topic Debian Ruby policy
22:43:51 <boutil> The Ruby policy needs to be updated and uploaded to the archive.
22:44:25 <hggh> is it available in git?
22:44:38 <boutil> hggh: yes, there is a ruby-policy git repo
22:45:13 <boutil> I will have a look at it.
22:45:25 <boutil> let's see how far I can get at the next meeting :)
22:45:45 <boutil> #action boutil update Debian Ruby policy with the help of the team
22:46:00 <boutil> something else about the policy?
22:46:31 <boutil> #topic glance through the RC bugs
22:46:50 <hggh> too much RCs :-/
22:46:56 <boutil> the current status: http://udd.debian.org/dmd.cgi?email=pkg-ruby-extras-maintainers%40lists.alioth.debian.org
22:47:09 <boutil> many of them are fake I guess
22:47:41 <boutil> there were those caused by the tilt upgrade.
22:48:01 <boutil> zeha_: those should be fixed, right?
22:48:58 <boutil> there is an ugly bug in ruby-multi-xml on i386
22:49:04 <gwolf> Oh, a very specific quirk I don't understand in the PTS... It's not precisely an RC, but it's a strange hiccup
22:49:36 <gwolf> http://packages.qa.debian.org/r/ruby-gnome2.html still mentions the package "will soon be part of the ruby1.8-removal transition", and all depending pkgs are blocked from testing
22:50:05 <gwolf> I understand Gnome2 is gone, but I see this package was recently updated (feb 20), and no longer requires 1.8 stuff...
22:50:10 <gwolf> ...so... dunno!
22:52:49 <boutil> isn't the message about transition about packages in testing?
22:54:16 <gwolf> Right, but it's still mentioning the 1.8 transition - I understand it's because of packages it in turn depends on
22:54:38 <gwolf> (I'm sorry, as I've been quite disconnected, I might be saying many things that are alreadty part of the known state :) )
22:55:22 <boutil> I also have difficulties sometimes to make sense of those messages on the PTS...
22:56:04 <boutil> but it has improved (or maybe I am just a little bit more used to it?)
22:57:06 <zeha_> boutil, tilt bugs can be closed/downgraded
22:57:17 <boutil> zeha: thanks
22:57:45 <zeha_> notes about being part of the 1.8 transition can be ignored for the most part
22:58:11 <boutil> I have the fealing that the bugs on ruby-multi-xml, ruby-strong-parameters and ruby-jbuilder are related and caused by some strangeness of libxml on i386, but it needs some investigation
22:58:14 <gwolf> zeha_: ok, so I will just ignore that :) thx
22:59:28 <boutil> #737649 is easy to fix (missing dependency)
23:00:00 <sbadia> i can take this :-)
23:00:22 <hggh> #info sbadia will take care of #737649
23:00:28 <sbadia> (for my first contribution in the team)
23:00:33 <boutil> sbadia: thanks!
23:01:27 <hggh> #info hggh will take #725571 (em-http-request)
23:02:50 <boutil> I tried once to reproduce the bug ruby-bootstrap-sass, and failed
23:02:50 <hggh> about ruby-amrita why not remove it?
23:03:40 <boutil> sbadia: if you want to make your TODO list longer, you can add this bug to it, and check if it is reproducible, and possibly close it
23:04:23 <sbadia> boutil: for #737649 ?
23:04:40 <boutil> sbadia:  #738375
23:05:12 <sbadia> ok
23:05:25 <sbadia> #info sbadia will take care of #738375
23:05:41 <boutil> does anybody know anything about ruby-gettext-rails?
23:06:27 <boutil> or ruby-gettext-activerecord?
23:06:48 <hggh> no clue about it
23:07:03 <gwolf> I should, as I said I would look at it
23:07:09 <gwolf> but I have been unable to :(
23:07:29 <gwolf> (FWIW I have not yet upgraded any of my Rails 2.x systems yet :-| )
23:07:36 <boutil> ah :)
23:08:22 <boutil> and jekyll will be updated, so this should fix the bug it has now
23:08:30 <boutil> ok, I think that's it
23:08:46 <boutil> #topic misc
23:09:02 <boutil> anything else you want to add?
23:09:20 <hggh> about emoji: https://github.com/Genshin/PhantomOpenEmoji
23:09:54 <hggh> svg emoji, so it's distributable
23:09:59 <boutil> nice!
23:10:38 <boutil> let's close the meeting, then
23:10:44 <boutil> Thanks everybody for coming
23:10:59 <boutil> see you next month!
23:11:05 <boutil> (and I hope earlier)
23:11:14 <boutil> #endmeeting