#debian-ruby Meeting

Meeting started by boutil at 21:58:56 UTC (full logs).

Meeting summary

  1. ruby1.8 removal (boutil, 22:05:07)
    1. https://release.debian.org/transitions/html/ruby1.8-removal.html (boutil, 22:05:53)
    2. http://bugs.debian.org/cgi-bin/pkgreport.cgi?users=debian-ruby@lists.debian.org;tag=ruby18-removal (boutil, 22:06:10)
    3. ACTION: terceiro will ask for a giveback of ruby1.9.1 on powerpc and hope it builds (terceiro, 22:11:29)
    4. ACTION: boutil fix and upload ruby-gnome2 (boutil, 22:12:57)
    5. ACTION: terceiro start dialogue with RT about actually removing ruby1.8 from jessie ASAP (terceiro, 22:17:44)
    6. ACTION: NMU graphviz (boutil, 22:22:19)

  2. ruby2.0 as default / ruby2.1 status (boutil, 22:23:12)
    1. one can install ruby from experimental to test ruby2.0 as default (boutil, 22:24:47)
    2. ACTION: hggh will try to build graphviz with ruby 1.9 (hggh, 22:25:52)
    3. ACTION: zeha will ask -ftp to get 2.1 out of NEW (zeha, 22:26:42)

  3. ruby1.9 removal (boutil, 22:30:42)
    1. http://people.debian.org/~zeha/rubyremoval/html/ruby191-removal.html (zeha, 22:31:16)
    2. http://people.debian.org/~zeha/rubyremoval/html/ruby191-removal.html (boutil, 22:31:32)
    3. ACTION: terceiro ask for a ruby1.9.1-removal tracker on release.debian.org (terceiro, 22:31:35)
    4. ACTION: file important bugs against packages hard-coding ruby1.9.1 in dependencies (boutil, 22:32:57)
    5. http://people.debian.org/~zeha/rubyremoval/html/ruby191-removal.html updated (zeha, 22:39:31)

  4. gitlab packaging? (boutil, 22:44:47)
  5. gitlab packaging (boutil, 22:44:53)
    1. http://people.debian.org/~boutil/gitlab/gitlab_deps20140128.pdf (boutil, 22:45:25)
    2. http://people.debian.org/~boutil/diaspora/diaspora_deps20140128.pdf (boutil, 22:47:40)
    3. ACTION: hggh will have a look at the gitlab deps (hggh, 22:49:37)
    4. ACTION: boutil mail debian-ruby@ about gitlab packaging initiative (boutil, 22:52:46)
    5. ACTION: boutil mail debian-ruby@ about the state of the team repo (boutil, 22:53:36)

  6. rubygems-integration (boutil, 22:56:09)
    1. http://people.debian.org/~zeha/rubyremoval/html/ruby191-bd.html this is probably the "ugly" set (zeha, 22:56:24)
    2. http://people.debian.org/~boutil/diaspora/README found it here (hggh, 23:01:48)


Meeting ended at 23:08:43 UTC (full logs).

Action items

  1. terceiro will ask for a giveback of ruby1.9.1 on powerpc and hope it builds
  2. boutil fix and upload ruby-gnome2
  3. terceiro start dialogue with RT about actually removing ruby1.8 from jessie ASAP
  4. NMU graphviz
  5. hggh will try to build graphviz with ruby 1.9
  6. zeha will ask -ftp to get 2.1 out of NEW
  7. terceiro ask for a ruby1.9.1-removal tracker on release.debian.org
  8. file important bugs against packages hard-coding ruby1.9.1 in dependencies
  9. hggh will have a look at the gitlab deps
  10. boutil mail debian-ruby@ about gitlab packaging initiative
  11. boutil mail debian-ruby@ about the state of the team repo


Action items, by person

  1. boutil
    1. boutil fix and upload ruby-gnome2
    2. boutil mail debian-ruby@ about gitlab packaging initiative
    3. boutil mail debian-ruby@ about the state of the team repo
  2. hggh
    1. hggh will try to build graphviz with ruby 1.9
    2. hggh will have a look at the gitlab deps
  3. terceiro
    1. terceiro will ask for a giveback of ruby1.9.1 on powerpc and hope it builds
    2. terceiro start dialogue with RT about actually removing ruby1.8 from jessie ASAP
    3. terceiro ask for a ruby1.9.1-removal tracker on release.debian.org
  4. zeha
    1. zeha will ask -ftp to get 2.1 out of NEW
  5. UNASSIGNED
    1. NMU graphviz
    2. file important bugs against packages hard-coding ruby1.9.1 in dependencies


People present (lines said)

  1. boutil (103)
  2. paulvt (102)
  3. terceiro (71)
  4. zeha (64)
  5. hggh (33)
  6. MeetBot (5)
  7. spk` (2)


Generated by MeetBot 0.1.4.