19:09:45 <elbrus> #startmeeting
19:09:45 <MeetBot> Meeting started Wed Sep 22 19:09:45 2021 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:45 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:09:55 <elbrus> #topic Admin
19:10:10 <elbrus> #info Previous minutes:  http://meetbot.debian.net/debian-release/2021/debian-release.2021-06-23-19.28.html
19:10:20 <elbrus> #info elbrus had an action to draft a bits => done
19:10:30 <elbrus> #topic Transitions
19:10:38 <Sebastinas> .oO(3 months since the last meeting)
19:11:06 <elbrus> that's your cue Sebastinas
19:11:22 <Sebastinas> glibc migrated, so a bunch of stuff got unblocked
19:11:50 <elbrus> ack
19:12:11 <Sebastinas> Otherwise it's the usual bunch of small uncoordinated transitions that mostly cause no issues, and some ongoing ones.
19:12:34 <Sebastinas> And then there's r-base and r-api-bioc with a vast amount of autopkgtest failures
19:13:02 <Sebastinas> People working on r-api-bioc seem to take care of regressions in their packages
19:13:18 <elbrus> yes I think ginggs spotted the issue with some of those the day before yesterday
19:13:27 <Sebastinas> But r-base just dropped without anyone taking care of it as far as I can see
19:13:57 <ginggs> yeah, apparently some rebuilds are needed for r-base
19:14:48 <ginggs> but it wasn't stated exactly which
19:15:07 <ginggs> i'm hoping the autopkgtests will show us
19:15:52 <ginggs> i am keeping an eye on it
19:16:05 <Sebastinas> Thanks
19:16:24 <Sebastinas> Maybe r-api-4.0 should have been bumped
19:17:37 <ginggs> according to upstream, not
19:17:52 * ginggs looks for a mail..
19:18:39 <elbrus> what shall we do with the python removal trackers? seems like mostly a lot of cruft RM bugs need to be filed...
19:19:30 <elbrus> is anybody still chacing that?
19:19:35 <tumbleweed> I would expect those to have bugs
19:19:45 <elbrus> that == the remainder
19:19:54 <ginggs> https://lists.debian.org/debian-r/2021/09/msg00083.html
19:20:11 <ginggs> see the bit about "rebuild for graphics devices"
19:20:18 <elbrus> tumbleweed: you mean the remainer, or the cruft?
19:21:05 <elbrus> e.g. ola is listed for the unversioned one but I don't see a bug
19:21:07 <tumbleweed> elbrus: remainder. I think python2-rm and unversioned-python-rm both had MBFs
19:21:42 <tumbleweed> but yeah, I see that re ola
19:21:56 <elbrus> I'd expect them to be of severity serious and they would have been kicked out of testing long time ago
19:22:06 <Sebastinas> ACK
19:22:08 <elbrus> the packages with their bug
19:22:57 * bunk wonders whether bookworm will still ship 2.7 for pypy
19:23:14 <tumbleweed> bunk: safe to say yes, at least as a B-D for pypy3
19:23:23 <jmm_> elbrus: I have started to send a first batch of RM bugs, will keep an eye on further things
19:23:55 <elbrus> jmm_: thanks
19:24:23 <elbrus> which means we should keep the trackers for now :)
19:24:39 <elbrus> Sebastinas: anything else regarding transitions?
19:25:09 <elbrus> #topic roll call
19:25:15 <Sebastinas> No
19:25:26 <ginggs> no roll call? :)
19:25:31 <elbrus> LOL
19:25:36 <Sebastinas> Except that we should probably also raise all the llvm-toolchain-9 bugs to serious to get llvm-9-toolchain removed.
19:25:50 <Sebastinas> ;)
19:25:57 <elbrus> Sebastinas: go-go-go (I say without checking)
19:26:04 <ginggs> agreed
19:26:29 <ginggs> so roll call, i'd like to send the mail soon
19:26:38 <ginggs> we should decide on the deadline
19:26:44 <ginggs> last time was very short;
19:27:04 <ginggs> mail was sent on 2020-11-02 and deadline was 2020-11-27
19:27:48 <elbrus> three months?
19:27:56 <elbrus> with two reminders?
19:28:11 <ginggs> sounds good to me
19:28:35 <elbrus> you'll take care of drafting/sending the mail (like last time)?
19:28:40 <ginggs> i will
19:28:58 <elbrus> #action ginggs: send roll call
19:30:42 <elbrus> #topic key packages (popcon)
19:31:16 <elbrus> last year we agreed to change the criteria of popcon for key packages
19:31:40 <elbrus> but didn't do the actual change because of the freeze
19:31:41 <Sebastinas> Can you remind us what we decided?
19:32:03 <ginggs> http://meetbot.debian.net/debian-release/2021/debian-release.2021-01-27-19.07.html
19:32:28 <Sebastinas> Right, thanks
19:32:57 <Sebastinas> popcon threshold 100% ~= popcon doesn't count?
19:33:05 <elbrus> exactly
19:34:36 <elbrus> ivodd mentioned that we could probably "improve" the key package criteria even further
19:34:52 <elbrus> by reconsidering how we treat meta-packages
19:35:02 <elbrus> I think it's worth investigating
19:35:17 <elbrus> with the aim to reduce the set we now call "key"
19:35:36 <elbrus> to more resemble something like "must-be-in-to-be-able-to-release"
19:36:15 <elbrus> because I really don't like we treat some packages different from others
19:38:08 <elbrus> I guess he meant something like reconsider if all desktop tasksel should be key
19:38:30 <elbrus> we'd need a bit of buy in from kibi
19:38:36 <elbrus> for that I gues
19:38:39 <elbrus> s
19:38:42 <ginggs> definitely worth investigating
19:38:55 * bunk wonders whether packages like libreoffice would stay key or become optional
19:39:03 * elbrus too
19:40:35 <elbrus> maybe I should come up with a proposal for this
19:41:24 <elbrus> #action elbrus: make proposal of how to reduce key package set further
19:42:33 <elbrus> no other ideas?
19:43:03 <ginggs> no
19:43:16 <elbrus> #topic arch qual: number of buildds
19:43:47 <ginggs> I'm wondering if we should rethink this section of the arch qualification policy
19:43:48 <ginggs> https://salsa.debian.org/release-team/release.debian.org/-/blob/master/www/bookworm/arch_policy.html#L125-128
19:43:55 <ginggs> in particular:
19:44:07 <ginggs> "keep up with unstable with not more than two buildds"
19:44:28 * elbrus thinks we haven't enforced this in years
19:44:47 <elbrus> and doesn't know how current buildds would be judged *now*
19:44:50 <ginggs> yeah, so i think we should update that to match reality
19:45:10 <ginggs> i shouldn't think we care how many buildds there are, as long as they can keep up
19:45:35 <elbrus> the original argument was the price of maintenance
19:45:44 <elbrus> if you need more than two
19:45:52 <elbrus> is that an issue nowadays?
19:46:09 <elbrus> I haven't heard people complaining
19:46:16 <Sebastinas> At least I haven't heard complaints from DSA or buildd admin
19:46:19 <elbrus> but maybe I'm not listening in the right channels
19:47:05 <elbrus> should we ask them, and if they're fine, update our text?
19:47:46 <ginggs> sure we can ask
19:47:47 <Sebastinas> Yes, I'm with a text that would just say that buildds needs to be able to keep up
19:47:56 <elbrus> that's the idea
19:47:56 <Sebastinas> +fine
19:48:29 <ginggs> so: "The architecture is able to keep up with unstable, has redudancy..."
19:48:51 <elbrus> we can bikeshed the text in an MR... :)
19:49:13 <elbrus> ginggs: can you ask?
19:49:18 <ginggs> sure
19:49:51 <elbrus> #action ginggs: ask DSA and buildd if they're fine with the current number of buildds per arch
19:50:04 <elbrus> #topic AOB
19:50:11 <elbrus> anybody?
19:50:20 <ginggs> no
19:50:46 <Sebastinas> After the roll call it might be a good time to revisit the set of release architectures.
19:50:55 <Sebastinas> I think we didn't have enough time to do that for bullseye.
19:50:57 <elbrus> that was the whole idea, yes
19:51:04 <elbrus> to do it now
19:51:18 <elbrus> such that we have time to properly handle it
19:51:56 <elbrus> #topic Next meeting
19:52:03 <elbrus> #info Next meeting is 27th October at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:52:12 <elbrus> #endmeeting