19:07:00 <elbrus> #startmeeting
19:07:00 <MeetBot> Meeting started Wed Jan 27 19:07:00 2021 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:00 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:15 <elbrus> #topic Admin
19:07:25 <elbrus> #info Previous minutes: http://meetbot.debian.net/debian-release/2020/debian-release.2020-12-23-18.58.html
19:07:52 <elbrus> #info ginggs had an action for a patch to britney
19:08:02 * elbrus hasn't seen it ;)
19:08:14 <ginggs> no, sorry :)
19:08:17 <elbrus> #info ginggs had an action to think about a proposal for blocking binNEW in unstable
19:09:13 <elbrus> ginggs: ^?
19:09:17 <ginggs> nothing
19:09:21 <elbrus> #info elbrus had an action to continue the arch qual by mail
19:09:29 <elbrus> done and mail sent afterwards
19:09:39 <elbrus> #info elbrus had an action to list (build-)essentials
19:09:49 <elbrus> done and added to the freeze_policy
19:10:17 <elbrus> #info ginggs had an action to come up with key_package threshold impact
19:10:48 <elbrus> ginggs: did you do anything with the info ivodd added to this chat after the meeting?
19:10:49 <ginggs> i did come up some numbers, and ivodd came up with others
19:11:14 <elbrus> there was a hint to dive into meta packages...
19:11:31 <elbrus> and I think you mentioned a good reason later in private
19:11:46 <elbrus> but I can't straight remember it
19:11:57 <ginggs> i only added it to this meeting's agenda for further discussion
19:12:08 <elbrus> right, lets' have it there then
19:12:14 <elbrus> #topic Transitions
19:12:22 <elbrus> not much left :)
19:12:23 <aurel32> adsb: thanks for the reminder, i totally forgot about it. I'll do that asap
19:12:35 <elbrus> Sebastinas: ^^
19:12:45 <ginggs> openmpi and pytest are done!
19:13:03 <elbrus> \o/
19:13:09 <elbrus> quicker than I expected
19:13:28 <elbrus> Sebastinas: you had libxmlb (#981078)
19:14:37 <Sebastinas> Ah, yes.
19:15:23 <Sebastinas> But I think it's too late. At first I thought it might be beneficial to do, but that's all stuff we can't easily remove if something goes wrong
19:16:15 <elbrus> any of the more experienced members around?
19:16:23 <elbrus> to judge?
19:16:36 <elbrus> ivodd: around?
19:17:34 <elbrus> Sebastinas: maybe try to catch one of the others if your unsure
19:18:15 <elbrus> are there other things on the transitions front?
19:18:45 * elbrus spotted https://release.debian.org/transitions/html/libgdk-pixbuf-2.0-0.html
19:18:45 <Sebastinas> Not that I am aware of, but I've also been rather busy @ work this month.
19:19:01 <Sebastinas> I've added a tracker for that, but that's nothing we need to process.
19:19:15 <elbrus> right, forgot about that "soft transition"
19:19:35 <elbrus> so, looks all good for bullseye
19:19:47 <elbrus> #topic Current state of bullseye
19:20:05 <elbrus> as mentioned a couple of days ago, we have
19:20:06 <elbrus> https://release.debian.org/transitions/html/libgdk-pixbuf-2.0-0.html
19:20:11 <elbrus> arch
19:20:20 <elbrus> https://wiki.debian.org/Teams/ReleaseTeam/ReleaseCheckList/BullseyeCheckList
19:20:21 <elbrus> that
19:20:59 <elbrus> all the tasks in "Before Freeze" can be picked up or tagged if already done
19:21:08 <elbrus> shall we go through them?
19:21:15 <elbrus> or is that a bit much?
19:21:25 <elbrus> I think keys were requested
19:22:48 <elbrus> I suggest when people pick something up, they tag it at the end of the line with [<date> <nick> <moreinfo>]
19:23:42 <elbrus> anybody up to some of those tasks? if it's just me, this release is going to be slowish...
19:24:18 <elbrus> which brings me to the bugs...
19:24:19 <elbrus> https://udd.debian.org/dev/bugs.cgi?release=bullseye_and_sid&merged=ign&rtbullseye-will-remove=ign&rtbullseye-can-defer=ign&autoremovals=ign&deferred=ign&fnewer=ign&fnewerval=30&rc=1&cpopcon=1&chints=1&ctags=1&cclaimed=1&cdeferred=1&caffected=1&crttags=1&sortby=last_modified&sorto=asc&#results
19:24:27 <elbrus> 115 on that list now
19:24:40 <elbrus> but quite a few old ones
19:24:55 <elbrus> that needs triaging and $somebody to work on it
19:25:02 <elbrus> we miss BSPs
19:25:07 * elbrus guesses
19:26:37 <elbrus> anybody, comments? (feels like these presentations nowadays just talking to your own laptop and hoping that others are listening and watching)
19:27:17 <elbrus> Sebastinas: you added: - chromium (#972134)
19:28:17 <elbrus> I don't know exactly what you wanted to say on it
19:28:39 <Sebastinas> Right. chromium came as potentially unsupportable in stable.
19:28:48 <Sebastinas> I guess that has been resolved.
19:29:11 <elbrus> but as far as I'm conserned, it's the security team that has to be convinced it's maintained by enough people
19:29:52 <elbrus> they expressed their conserns
19:30:15 <Sebastinas> ACK
19:30:26 <elbrus> I haven't followed the activity in the bug, but I don't think they are convinced by a one time upload (for now)
19:30:35 <Sebastinas> carnil, jmm_: ^ unless you have more concerns, I guess it will migrate before the freeze
19:30:48 <elbrus> by others than the "normal" maintainer, who did an upload today
19:30:56 <elbrus> I guess it will not
19:31:07 <elbrus> but is still open and RC
19:31:40 <elbrus> and security team should in my opinion agree on closing or downgrading
19:32:08 <jcristau> the bug is closed afaict?  it's not fixed, but it's closed.
19:32:14 <elbrus> aha, wait, bug is closed
19:32:28 <elbrus> by latest upload
19:32:44 <nthykier> (#960786 can probably be downgraded or -ignored given builds happen on the buildds)
19:33:02 <nthykier> (from elbrus's UUD list)
19:33:26 <elbrus> nthykier: thanks for your note
19:33:37 <jcristau> nthykier: do we block binary uploads on stable?
19:34:01 <jcristau> if not then that's a recipe to have it break on a security update
19:34:32 <nthykier> jcristau: if not, bullseye might be a good release to start on doing that! ;)
19:35:37 <jcristau> maybe, but until/unless that happens i'm not sure it's advisable to ship with that bug.
19:35:57 <jmm_> Michael Gilbert was gone for a while, but seems back and he closed the task, given that two new people stepped up in helping out with Chromium that seems good enough for now
19:36:09 <elbrus> jmm_: thanks
19:37:13 <elbrus> Sebastinas: ginggs: do you intend to join triaging of open RC bugs?
19:38:02 <elbrus> the further into the freeze, the better view we need to have on the remaining bugs
19:38:17 <ginggs> can we organize a bsp for that?
19:38:18 <elbrus> to judge when we can release
19:38:45 <elbrus> do you want to organise a bsp? (that would be awesome)
19:38:53 <ginggs> or do you mean to work through them now?
19:39:15 <elbrus> I don't mean *we* fix them, just know which ones can be ignored or need to be fixed
19:39:43 <elbrus> now (but not in this meeting)
19:40:04 <elbrus> poking maintainers can sometimes have great results
19:40:12 <elbrus> and sometimes not by the way
19:40:21 <Sebastinas> I'll have more time again starting from mid February can then take a loook at some of them.
19:40:34 <elbrus> Sebastinas: any help is welcome
19:41:04 <elbrus> there's a couple of bts tags only we are allowed to set
19:41:11 <elbrus> and we have some usertags as well
19:42:12 <elbrus> for discussion on meetings or maybe even a sprint I used private usertags in the past to group stuff I looked into but didn't feel comfortable yet in official tagging
19:42:58 <elbrus> other item we need to handle is:
19:43:06 <elbrus> #topic Release Notes
19:43:31 <elbrus> last time I did most of it from our side, before that nthykier did most I think
19:43:46 <elbrus> anybody is free to help of course
19:44:13 <elbrus> there's ideas to convert it to MarkDown
19:44:24 <elbrus> does anybody have experience doing that?
19:44:43 <elbrus> I think that needs to happen soon or after the release
19:44:55 <elbrus> but the current format was difficult to get right
19:45:10 <elbrus> and adds burden to adding sections or chapters
19:45:37 <elbrus> I would love if some people would at least subscribe to the bts for those bugs
19:45:45 <elbrus> and/or to the salsa repo
19:46:10 <elbrus> https://bugs.debian.org/release-notes
19:46:27 <Sebastinas> Is https://salsa.debian.org/ddp-team/release-notes the salsa repo?
19:46:28 <elbrus> https://salsa.debian.org/ddp-team/release-notes/
19:46:31 <elbrus> yes
19:47:37 <elbrus> I'm willing to work on it again this time, but I like help
19:48:17 <ginggs> i can help you
19:48:22 <elbrus> \o/
19:49:32 <noahm> I can't promise anything meaningful, but can at least get subscribed to the right things. Maybe that'll push me to help...
19:49:47 <elbrus> \o/\o/
19:50:13 <elbrus> #topic popcon threshold for key packages (again)
19:50:18 <elbrus> ginggs: ^
19:51:32 <ginggs> so (again) this is just shall we increase the popcon threshold (currently 5%) for key packages
19:51:49 <elbrus> what was your argument again?
19:51:53 <ginggs> ivodd provided some numbers, which i'll paste here
19:52:07 <elbrus> except a tiny bit less packages on the list?
19:52:31 <ginggs> currently, there are 6493 key source packages (popcon threshold at 5%) raising that would give: at 10% 6147 key source packages, at 20% 6025 key source packages, at 100% 5869 key source packages
19:52:56 <ginggs> so besides the obvious benefit of autoremoval
19:53:42 <ginggs> dependencies of packages that are going to be autoremove are warned in the bug tracker
19:54:06 <ginggs> but this doesn't happen for key packages
19:55:02 <elbrus> so, more exposure of RC bugs impacting popular packages
19:55:08 <elbrus> where RC bugs matter most?
19:55:31 <ginggs> yes
19:55:43 <elbrus> did you check which packages would be demoted?
19:56:08 <ginggs> when ivodd wrote those numbers above, it wasn't clear to me whether he was for or against adjusting the threshold
19:56:42 <elbrus> it's trivial to do that excersize if you know how the script runs
19:56:55 <elbrus> I think he just wanted to provide the numbers
19:57:11 <ginggs> i didn't check which packages would be affected
19:57:25 <elbrus> I think the original treshold was picked by belly feeling during introduction
19:57:44 <elbrus> personally I'm OK with raising I think
19:57:46 <ginggs> so i think you and i would be happy to increase the threshold, or do away with it completly
19:58:03 <ginggs> but does anybody feel it should stay at 5%?
19:58:05 <elbrus> but I also think that ivodd had an idea to reduce the set even further
19:58:20 <elbrus> which you might want to persue too
19:59:24 <elbrus> raising to 100% is effectively removing it
20:00:10 <elbrus> so, most packages would come because of standard, important or required
20:01:15 <elbrus> and d-i
20:02:26 <elbrus> #agreed raise popcon threshold to 100%
20:02:33 <_rene_> as a data point: even LO is only ~44%. While we (including me) don't need it that much it's different for our users
20:02:41 <_rene_> firefox also is ~44%
20:02:56 <_rene_> sorry, firefox-esr
20:03:11 <elbrus> #topic AOB
20:03:16 <elbrus> anybody?
20:03:37 <elbrus> (we're close to planned closure time, much better than last time)
20:04:16 <Sebastinas> From the topics discussed last time: llvm-toolchain-10 is gone from testing.
20:04:26 * elbrus noticed, thanks
20:04:33 <elbrus> some openjdk-* versions too
20:04:44 <elbrus> and others are requested to be removed (from unstable)
20:05:25 <elbrus> yes, only 11 16 and 17 left
20:05:40 <elbrus> in bullseye
20:05:59 <elbrus> and discussion about 17 is ongoing
20:06:57 <elbrus> ok
20:07:05 <elbrus> #topic Next meeting
20:07:12 <elbrus> #info Next meeting is 24th February at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
20:07:25 <elbrus> ^ includes the freeze dates too, so you don't forget
20:07:36 <elbrus> #endmeeting