19:00:53 <nthykier> #startmeeting
19:00:53 <MeetBot> Meeting started Wed Apr 25 19:00:53 2018 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:53 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:58 <nthykier> Morning!
19:01:23 <nthykier> Time for the beloved and missed release team meeting
19:01:30 <nthykier> #topic Admin
19:02:00 <nthykier> AFAICT, the last meeting we had was 2018-01-24 (Minutes: http://meetbot.debian.net/debian-release/2018/debian-release.2018-01-24-19.12.html)
19:02:55 <nthykier> At the same time, there is a note under "Admin" saying that pochu has an action item on "Project wide feedback on the stretch release cycle" (which is not mentioned in the minutes mentioned above)
19:03:13 <pochu> nthykier: that went out on the recent d-d-a mail
19:03:19 <nthykier> ok
19:03:40 <nthykier> Does that also cover the "Buster planing" bullet under "Admin"?
19:04:14 <nthykier> (https://gobby.debian.org/export/Teams/Release/Agenda/irc-next for the lazy people / people without gobby)
19:04:50 <pochu> nthykier: I don't know, not sure what's included there
19:05:03 <pochu> but the announcement included freeze dates etc
19:05:49 <nthykier> ok, let's consider that done given it was an admin then
19:06:30 <nthykier> #topic Transitions
19:06:48 <pochu> we have some large ones ongoing or planned
19:07:03 <pochu> ghc and openmpi ongoing
19:07:18 <pochu> icu, ncurses upcoming
19:07:34 <pochu> ncurses is very big, but it can be done slowly as the old libs will still be shipped for some time
19:08:09 <pochu> also curl, which will need to migrate all in one go, so I need to find a slot when there are no conflicting transitions
19:08:29 <pochu> also r-base 3.5
19:08:47 <pochu> as for openssl1.0, we are getting close to being able to remove it from testing
19:08:58 <nthykier> \o/ for getting rid of openssl1.0 :)
19:09:09 <pochu> once the curl transition is done, the main blocker should be openssh
19:09:38 <pochu> see #828475 and the forwarded link
19:09:46 <nthykier> ok
19:10:36 <pochu> a new boost would be nice, but the maintainer gave up on it because of the copyright requirement. I hope to get some news on that front at some point, at which point we can see how to proceed
19:11:08 <nthykier> Have we had a look at the "future transitions" that we expect nearer to the freeze?  E.g. I heard that the current plan is to migrate to OpenJDK 11 (if possible), which (I think) will be released in about 5 months from now
19:11:20 <pochu> and that's all for large transitions for the time being
19:11:44 <nthykier> Ack - thanks for the update
19:11:46 <pochu> nthykier: for OpenJDK, upstream is switching to a fast-paced releases, with some series getting extended support
19:12:03 <pochu> so yes, we need to move to a newer release as OpenJDK 9 will be EOL anytime now
19:12:27 <pochu> so we are moving to 10 now (see java-defaults/experimental) and to 11 eventually
19:12:46 <pochu> but there are some blockers. doko is working on that, I talked to him about this recently
19:12:52 <nthykier> I was more curious if we had an idea of how involved that would be/how long time it would take and if it is "reasonable" to do that close to the freeze
19:13:10 <nthykier> Ok, so we have already begun to look at it?
19:14:14 <pochu> I haven't evaluated it fully (i.e. I haven't looked at the blockers) but we should be able to move to 10, and then I'd hope that the move to 11 would be easier due to fewer changes
19:14:32 <pochu> so yes, we're already looking at it, but I need to evaluate it more to have a better idea
19:15:03 <pochu> also there's the GCJ removal, I did some NMUs and we're almost ready, only blocker is pdftk
19:15:29 <pochu> also not sure about GCC 8 plans
19:15:38 <nthykier> perfect - that is sounds quite good (re: OpenJDK)! :)
19:16:03 <pochu> but I did some work on removing GCC 6 (filing bugs for gcc/g++/golang/gfortran/GCJ ...)
19:16:28 <pochu> 10 pending bugs: https://bugs.debian.org/cgi-bin/pkgreport.cgi?users=debian-gcc@lists.debian.org;tag=gcc-6-rm
19:17:14 <nthykier> :D
19:17:21 <pochu> so we could ship with 7 + 8 (not sure about the default, but we may have time to switch to 8, depending on the regressions and the release date)
19:17:41 <pochu> on a somewhat related note, the number of RC bugs affecting testing is quite large :(
19:18:20 <nthykier> Re: RC bugs - agreed but can we move that to AOB (or a separate toptic)?
19:18:21 <nthykier> topc*
19:18:23 <nthykier> bah
19:18:30 <pochu> absolutely
19:18:54 <nthykier> good, then I think we have covered transitions (quite well indeed! Nice work, pochu)
19:19:32 <nthykier> #topic Britney integration with Autopkgtests
19:20:25 <nthykier> We have a branch/patch series, we have a shadow britney integrated with ci.d.n maintained by elbrus and we also got bugs filed based on this new setup
19:21:09 <elbrus> o/
19:21:53 <nthykier> elbrus: Ah, if you are around, maybe you can give a short status on the situation (and if there are any blockers for the merge)?
19:22:16 * elbrus uploaded a new version of debci today to unstable
19:22:46 <elbrus> when that is available in the backports I can use it to have the retry mechanism in place for all DD's
19:22:55 <elbrus> that's for me the only blocker now
19:23:11 <elbrus> small blocker that is
19:23:34 <elbrus> there are some edges to shave of course, but I'm very happy with it so far
19:23:41 <pochu[m]> \o/
19:24:04 <nthykier> so, we are ready to merge in 5 days from now? :P
19:24:57 <elbrus> I am unsure how much available I am next week, so lets say the week after
19:26:35 <nthykier> elbrus: if it is, we can just start without bounty / penalities, then it will at most cause an informal note in the excuses
19:26:52 * elbrus thought about that too
19:27:15 <elbrus> but let me check the code if it produces the notes then
19:27:29 <nthykier> ok
19:29:00 <nthykier> #info Britney integration is ready for deployment after the version of debci/unstable is uploaded to backports and deployed on ci.d.n
19:31:46 <nthykier> #action nthykier will announce an ITM of the branch (possibly with a +/- 0 diff for starters) to get it deployed on respighi.
19:32:39 <nthykier> elbrus: Just ping me re ^ once you know if +/- 0 days will work.  If it does, then I will merge it later this week / early next week (and then just bump the dates when you are around for assistance)
19:32:56 <elbrus> nthykier: it has a swith to turn adt off for sure
19:33:09 <elbrus> but then no excuses with info
19:33:21 * elbrus thinks 0 works for penalty/bount
19:33:24 <elbrus> bounty
19:33:25 <nthykier> ok
19:33:41 <nthykier> perfect. :)
19:33:48 <elbrus> but I'll just run my shadow with that
19:33:52 <nthykier> thanks
19:34:03 <nthykier> I'll move on to the next topic while you do that :)
19:34:13 <nthykier> #topic Doing architecture qualification for buster
19:35:21 <nthykier> We wrote on d-d-a that we wanted automatic architecture qualification; odds are we won't have time to implement that for buster (among other because we have no volunteers working on it atm).
19:36:12 <nthykier> Short term, I know that DSA have announced some blockers for a few architectures and Mithrandir has been pinging us for starting the qualification process
19:36:27 <Mithrandir> we (debian, not only the release team) also talked about trying to get a meeting for this reasonably early in the cycle
19:36:46 <Mithrandir> it's actually more my TC hat than my DSA hat, but they're both interested in making this a smooth process
19:37:51 <nthykier> ok, I think fundamentally, what we are missing is someone who wants to drive the process
19:38:50 <Mithrandir> I think it should be the release team, but I'm otherwise happy to push for it to happen.  It shouldn't be a huge thing: find a date and time that works, get people on irc, get the issues on the table.
19:38:58 <Mithrandir> or we can do a mailing list thread of doom.
19:39:23 <pochu[m]> Even if we don't implement things in Britney and so on, we could start with defining the criteria that an architecture needs to meet, and then we evaluate them based on that criteria
19:39:40 <Mithrandir> if you want to deputise me to do those tihngs on behalf of the release team, I could do that, but I don't have time to join the team.
19:40:17 <nthykier> I am tempted
19:40:45 <Mithrandir> I'm not going to say "this month", but by mid-may we should at least know what concerns are out there.
19:42:57 <Mithrandir> pochu[m]: isn't that the matrix?
19:42:58 <nthykier> Mithrandir: Concerns being the "concerns-*" fields from the arch qual table or something else?
19:43:32 <Mithrandir> nthykier: those are the groups that need to be consulted, but I imagine some of those concerns need a paragraph or three to explain what the concern is.
19:43:56 <pochu[m]> It is
19:44:20 <Mithrandir> so yeah, basically that, but written in a way that's easier for somebody external to that team to understand and hopefully fix.
19:44:23 <pochu[m]> I think the main concern is from DSA wrt arm hw
19:45:28 <nthykier> Sounds like Mithrandir, pochu and I should go over the matrix and revise the text plus come with a draft of new/removed criteria (also based on https://lists.debian.org/debian-devel-announce/2018/04/msg00006.html)
19:45:41 <Mithrandir> that is one concern, but it's hard to know if there are concerns from, say, the toolchain folks if there's no point they're asked. :-)
19:47:01 <pochu[m]> Ack
19:48:04 <Mithrandir> we should probably have a chat about if there are groups or dimensions not covered in the table too.
19:48:11 <nthykier> true
19:48:27 <Mithrandir> but, I'm happy to find a time that works for you two and work on it, we don't have to hold up the meeting for it.
19:48:40 <nthykier> We are short on time, so I think we should close here with an action or an agreed and take the rest off meeting
19:48:44 <Mithrandir> you're both EU-ish TZ-wise?
19:48:49 <nthykier> I am
19:49:13 <pochu[m]> Yes
19:49:28 <Mithrandir> great, so let's sync up sometime later and work further on this. :-)
19:49:33 <nthykier> Ok
19:49:57 <nthykier> #agreed Mithrandir, pochu and nthykier will have a look at the architecture qualification criteria after the meeting
19:50:08 <nthykier> good and with that...
19:50:16 <nthykier> #topic Testing is drowning in RC bugs
19:50:48 <nthykier> NB: if there any AOB, please notify me in parallel (query is ok)
19:51:01 <nthykier> pochu: Did you have something on this topic?
19:51:46 <pochu[m]> There are some 200 new bugs due to various Python problems
19:51:46 <pochu[m]> Missing depends and failure to import
19:51:48 <pochu[m]> But without those we'd be at some 600+ I think
19:52:28 <pochu[m]> Some of those will be autoremoved
19:52:41 <nthykier> about ~340 is on the auto-rm list AFAICT
19:52:43 <pochu[m]> But I wonder if there's something we can do
19:52:46 <nthykier> (https://udd.debian.org/bugs/?release=buster_and_sid&merged=ign&keypackages=ign&fnewerval=7&flastmodval=7&rc=1&chints=1&ctags=1&cdeferred=1&crttags=1&cautormtime=1&sortby=id&sorto=asc&format=html#results)
19:53:10 <pochu[m]> Otoh it's good that we are getting these QA runs done now
19:53:30 <nthykier> Indeed, I am very happy that we are not in the middle of the freeze with this :)
19:54:21 <nthykier> pochu: We cannot make people fix RC bugs faster.  What we can do is to define things as "Not RC" (i.e. downgrade) or "Not RC for buster" (i.e. buster-ignore)
19:55:03 <nthykier> History repeated: We end up failing to do the latter until late in the freeze
19:55:17 <nthykier> (the latter at a wide-scale)
19:55:48 <nthykier> well, third, we can more aggresively remove things :D
19:56:16 <nthykier> that is the high level but I am not sure it is useful at this level
19:56:32 <pochu[m]> And organize BSPs
19:56:39 <nthykier> true
19:56:56 <Sledge> nod
19:57:02 <nthykier> (NB: 3 minute warning - no AOB received)
19:57:10 <Sledge> we're overdue on in the UK, for example
19:57:41 <pochu[m]> But yeah, I thought about downgrading some of those classes or asking for temporary reverts
19:57:44 <pochu[m]> That's all
19:58:20 <nthykier> #Topic AOB - Point release dates
19:58:22 <nthykier> Sledge: ^
19:58:37 <Sledge> we need to get some point release dates fixed
19:58:46 <Sledge> talking the other day, it looke like June
19:59:07 <Sledge> we're already slipping off jmw's suggested cadence - can we fix that?
19:59:24 <nthykier> is there a call for dates already?
19:59:28 <Sledge> not yet
19:59:33 <Sledge> it's overdue
19:59:51 <nthykier> #action SRMs to call for dates
20:00:01 <Sledge> ta
20:00:03 <nthykier> #undo
20:00:03 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x2390410>
20:00:07 <nthykier> #action SRMs to call for dates for next point release
20:00:12 <nthykier> adsb: jcristau: jmw: ^
20:00:16 <adsb> ack
20:00:25 <nthykier> and with that, we are out of time
20:00:39 <nthykier> #topic Next meeting
20:00:42 <nthykier> #info Next meeting is 23rd May at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
20:00:57 <nthykier> #endmeeting