19:02:40 <nthykier> #startmeeting
19:02:40 <MeetBot> Meeting started Wed May 24 19:02:40 2017 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:40 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:46 <KiBi> grüss dich, jmw
19:02:52 <nthykier> #chair jmw
19:02:52 <MeetBot> Current chairs: jmw nthykier
19:03:14 <jmw> nthykier: oh man, you're making it sound like I have a plan again
19:03:17 <adsb> I'm around, but just finished making food so may be eating
19:03:20 <nthykier> #topic admin
19:03:22 <lamby> Am around.
19:03:30 <nthykier> jmw: you do now! :P
19:03:44 <ivodd> hi
19:03:47 <nthykier> Last meetings minutes are at: http://meetbot.debian.net/debian-release/2017/debian-release.2017-04-26-19.02.html
19:03:47 <KiBi> Going to prepare final bits for d-i on the hints side, BTW. Need to sort this out before Sledge is out.
19:04:43 <nthykier> anything else for admin?
19:05:20 <nthykier> #topic Release status
19:05:32 <nthykier> Ok, Release status
19:06:01 <nthykier> To my knowledge, we have exactly one release blocker left - debian-archive-keyring (separted into two RC bugs)
19:07:12 <nthykier> adsb is currently running with that and it looks like Ganneff and ansgar has been working on their part
19:07:30 <adsb> we have a release key, jcristau is hopefully giving me a sig
19:08:32 <nthykier> Excellent news :)
19:08:51 <pochu> o/
19:09:02 <nthykier> And then it is a question of uploading  debian-archive-keyring to unstable + p-u or what?
19:09:46 <adsb> yes
19:10:27 <adsb> there's an open request for a smallish change from dkg, but I'm not entirely sure how suitable it is for late freeze tbh (or for a p-u)
19:10:49 <jmw> and presumably also another point release? or just stable-updates?
19:11:10 <nthykier> Right, I am inclined to agree that it should be deferred for buster (re: dkg's request)
19:11:10 <KiBi> #861695?
19:11:11 <adsb> stable-updates was the theory
19:11:17 <adsb> open to thoughts though
19:11:20 <adsb> KiBi: yes
19:11:32 <KiBi> looks f* too late already.
19:11:40 <KiBi> or use nthykier's wording :)
19:11:56 <adsb> ack. I know I've sat on it for a little bit, but it was filed well into full freeze
19:12:16 <KiBi> May 2nd?
19:12:29 <jmw> we can do that for buster, or a point release, or something
19:12:40 <adsb> buster, yeah, not sure about point release, as I said :)
19:12:45 <KiBi> changing such things after r0 looks like a bad idea fwiw
19:12:54 <nthykier> Re. the p-u thing, we would needd to document in the release-notes  that stable users should pull d-a-k from p-u before upgrading if we release before the next point-release, right?
19:13:17 <adsb> -updates, rather than p-u
19:13:29 <nthykier> right - I always mix those names up
19:13:34 <adsb> which should be enabled by default by d-i for the past couple of releases at least
19:13:39 <nthykier> -updates it is
19:13:51 <nthykier> (they still have to remember to update first :P)
19:14:02 <adsb> but yes, a note about making sure it's updated would probably be helpful
19:14:04 <nthykier> #info FTP masters have made a release key
19:14:11 <adsb> have they? :)
19:14:20 <nthykier> #undo
19:14:20 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x20f1ed0>
19:14:29 <nthykier> #info We have a stretch release key
19:14:32 <nthykier> better?
19:14:33 <nthykier> :)
19:14:43 <adsb> well, yes, because we still need a key from ftp-master
19:14:55 <adsb> I know there's been work on dak, but I don't have a key from them
19:15:02 <KiBi> Author: Christian Perrier <bubulle@debian.org>  2012-06-15 22:27:20
19:15:14 <adsb> ta :)
19:15:15 <nthykier> ... at some point I think I have to set down and learn all the keys we need for a release
19:15:30 <nthykier> #info We are missing GPG keys from ftp-masters
19:15:33 <KiBi> volatile→updates in apt-setup looks dated Fri Jun 15 22:27:20 2012 +0200
19:15:37 <nthykier> #undo
19:15:37 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x20f1210>
19:15:46 <KiBi> ah, the copy-paste worked. sorry for the duplicate
19:15:47 <nthykier> #info We are missing GPG keys from ftp-masters, but it seems to be WIP
19:15:53 <adsb> two for the new release, and the release key for every stable release that's still on ftp-master, because they need re-signing for name changes
19:16:22 <nthykier> and then security as well?
19:16:29 <adsb> not sure how apt reacts if it can't very all of the signatures on a Release file that has multiple signatures. I should probably know :|
19:16:31 <nthykier> or is it the ftp-master one?
19:16:32 <adsb> oh, yes
19:16:47 <adsb> no, it's a separate key that ftp-master provide
19:16:56 <mhy> the new keys are signed by ansgar and Ganneff and will be signed by me once I can verify the IDs with one of them out of band
19:17:03 <adsb> mhy: thanks
19:17:38 <nthykier> #info we need to document that stable users might have to upgrade debian-archive-keyring via jessie-updates if we release before the next point release
19:18:09 <nthykier> That is what I had for the final blocker bug - anyone have anything to add or any questions?
19:18:39 <KiBi> for dak or?
19:19:10 <KiBi> I have a couple of questions for components who might want another update (not)affecting d-i, but that can wait after the meeting, I suppose.
19:19:34 <nthykier> if it is relevant for stretch, then by all means, please give a short mention of it :)
19:20:28 <KiBi> ok. wondering whether gnupg1 should get unblocked for doc changes, but also a bug fix
19:21:09 <KiBi> mixing gpg1 and gpg2 is a complete fuck-up, and dkg already reverted the dh bump following a short discussion here. not sure an unblock request happened though
19:21:33 <KiBi> (no impact in d-i, but I'd rather include the change in the next release than later through a point release or so)
19:21:52 <nthykier> I don't think it did.  I am happy to unblock it if you are happy with it as well :)
19:22:49 <KiBi> looks fine from a d-i pov, feel free to u + u-u it
19:23:01 <nthykier> .
19:23:04 <nthykier> ok
19:23:21 <KiBi> ta; not sure about screen
19:23:46 <KiBi> it seems latest changes led to a regression, which was just fixed. looks early, can wait for a point release if needed AFAICT?
19:24:20 <KiBi> other components are d-i maintained from a quick look so I should be able to unblock those if deemed appropriate.
19:24:43 <nthykier> ok, I will have a look at screen after the meeting :)
19:25:27 <nthykier> Moving on
19:25:53 <nthykier> #topic Deadlines and handling of RC bugs that are not fixed
19:26:34 <nthykier> Historically, we have kept the last week up to the freeze completely frozen and reserved it for emergency fixes only
19:26:54 <pochu> that sounds sensible
19:27:01 <jmw> we should do that as usual
19:27:06 <nthykier> Indeed.
19:28:01 <nthykier> The issue is, I don't think we have a usual for what do we do about RC buggy non-key packages and if we are going to remove them, what is the deadline for the fix?
19:28:20 <nthykier> (RC buggy knon-key packages that will not be auto-removed prior to the freeze)
19:28:29 <nthykier> s/knon/non/
19:28:49 <jmw> we typically take a can-defer or stretch-ignore view on them
19:29:10 <jmw> if neither of those apply, that needs dealing with by a fix or removal
19:30:22 <nthykier> I am fine with that decision if it has concensus. We just have to remember to get around to tagging them -ignore
19:30:52 <ivodd> the ones that are open for some time should not get -ignore
19:31:08 <pochu> agreed. we shouldn't be removing stuff if fixes won't be allowed into testing - unless the package should really be removed
19:32:39 <ivodd> we should set a deadline: packages with rc bugs filed before date X will be removed (if unfixed) at date Y
19:33:02 <nthykier> How about we do a final screening 14 days (example number) before the release and tag things either -ignore or -will-remove.  -will-remove has to be resolved before the the complete freeze
19:33:08 <jmw> ivodd: sounds complicated
19:33:27 <jmw> nthykier: that sounds reasonable
19:33:46 <ivodd> jmw: what is complicated?
19:34:35 <jmw> ivodd: if I've learned anything about communication with 1000 developers, it's not to have if x then y unless z with these dates rules, unless they are talked about long before implementation (like our freeze dates)
19:35:17 <jmw> so ok, not complicated in itself, but potentially confusing
19:35:39 <ivodd> jmw: maybe, but less surprising than 'we removed your package without warning'
19:36:02 <jmw> so we warn
19:36:14 <nthykier> ftr, I would include the plan in the announcement I /should/ have sent last sunday
19:36:32 <jmw> I can draft something
19:36:51 <jmw> if nthykier's plan has consensus, give me an action to write it up
19:36:59 <nthykier> jmw: thanks ,  I need some help drafting a certain announcement a [Dswell
19:37:26 <nthykier> (with less keyboard fail on my part)
19:37:59 <jmw> I will happily unkeyboardflail you :)
19:38:03 <nthykier> Agreement on the proposed plan (deadline for tagging -will-remove/-ignore 14 days before the release, will-removes will be fixed or removed at least the weekend before the release)?
19:38:17 <pochu> I would rather we only remove what's really necessary at this stage, than remove everything that's older than $date
19:38:29 <KiBi> ack
19:38:33 <pochu> so yeah nthykier's plan sgtm
19:40:26 <nthykier> #agreed All RC bugs will be tagged with either -ignore or -will-remove 2 weeks before the release.  will-removes must be fixed before the last week of the freeze or they will be removed then
19:40:46 <nthykier> excellent
19:41:40 <nthykier> That is what I had for deadlines. :)
19:42:39 <jmw> #action jmw write bits to announce the final bugs plan
19:42:47 <nthykier> true that :)
19:42:55 <nthykier> #topic Outstanding unblock requests
19:43:18 <nthykier> we got some unblock requests left
19:43:45 <nthykier> 20 to be precise apparently
19:44:06 <nthykier> 3 confirmed, 6 moreinfo and 11 with neither tag
19:44:26 <nthykier> anyone have any they want to bring up or need help with?
19:44:32 <KiBi> do you have a link handy for those?
19:44:55 <nthykier> https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=release.debian.org;dist=unstable#_0_13_4
19:45:01 <KiBi> you mentioned ca-certificates yesterday, but I saw no mails?
19:45:03 <nthykier> good point :)
19:45:30 <nthykier> KiBi: right, I saw it in deferred - hadn't had time to follow up on it today
19:45:47 <KiBi> so nothing in my territory except screen and btrfs-progs?
19:46:24 <nthykier> and ca-certificats :P (I will throw it in your direction  after the meeting)
19:46:42 <nthykier> I think btrfs-progs has effectively been rejected
19:46:55 <nthykier> and we just failed at a -done + wontfix
19:46:58 <KiBi> I'd hope so given the initial request. :(
19:47:24 <jmw> I am inclined not to waste any more time on btrfs-progs, and just say no
19:47:31 <KiBi> nthykier: if ca-certificates is in deferred then it's too late for d-i.
19:47:41 <nthykier> KiBi: it is in sid today
19:47:51 <nthykier> (now - it was in deferred yesterday)
19:48:04 <KiBi> (gotcha)
19:49:20 <nthykier> ok, so I see screen + ca-certificates (both d-i related), which KiBi and I can work out after the meeting and then btrfs-progs that needs a "no" + -done
19:49:27 <nthykier> anything else?
19:49:40 <nthykier> (otherwise, I will move to AOB)
19:49:52 <KiBi> lgtm for d-i stuff.
19:50:18 <nthykier> :)
19:50:20 <pochu> some are for RC bugs, so we may want to accept those
19:50:31 <pochu> I haven't looked at them though, but I can try to find the time
19:50:40 <nthykier> ok :)
19:50:47 <nthykier> #topic AOB
19:50:48 <pochu> e.g. opendkim, opendmarc
19:50:56 <pochu> anything else to do about https://wiki.debian.org/Teams/ReleaseTeam/ReleaseCheckList/StretchCheckList#preview ?
19:51:23 <nthykier> Ah, the release check list
19:52:16 <nthykier> pochu: We are running low on time, I think we will have to punt a run through of that list after the meeting
19:52:24 <nthykier> would that work for you?
19:52:53 <pochu> I'll have to leave in a moment. but yeah we can look at it later, or sometime tomorrow
19:53:13 <nthykier> ok, lets do that :)
19:53:39 <nthykier> #action pochu and nthykier to go through the release checklist this week
19:53:52 <nthykier> any other AOB?
19:54:06 <nthykier> else it will be "next meeting" + done
19:54:08 <pochu> I'll ping you later when I'm around, and if it's too late we can take a look at it some other time
19:54:17 <nthykier> ack :)
19:54:19 <pochu> nthykier: nothing else from me :)
19:54:23 <pochu> well
19:54:33 <pochu> I thought about proposing a sprint for the actual release :P
19:54:53 <nthykier> ... it is a bit late for that .P
19:54:53 <pochu> but I imagine that'll be hard to organize due to personal agendas etc
19:54:59 <pochu> yeah
19:55:16 <nthykier> :)
19:55:18 <nthykier> #topic Next meeting
19:55:25 <nthykier> Next meeting is 28th of June at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:55:41 <nthykier> Thanks for attending :)
19:55:43 <nthykier> #endmeeting