19:01:18 <nthykier> #startmeeting
19:01:18 <MeetBot> Meeting started Wed Mar 22 19:01:18 2017 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:18 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:20 <nthykier> o/
19:01:25 <nthykier> #chair pochu
19:01:25 <MeetBot> Current chairs: nthykier pochu
19:01:36 <nthykier> Morning - time for the IRC meeting :)
19:01:45 <nthykier> #topic admin
19:02:13 <nthykier> While people check into, I will run through last meetings acion items
19:02:34 <nthykier> #info nthykier got the wget rebuilt against ssl done via tpu
19:03:27 <nthykier> #info ivodd has completed the PIE binNMUs he intended per https://lists.debian.org/debian-release/2017/03/msg00762.html
19:03:31 <nthykier> and obviously ...
19:03:45 <nthykier> #info Last meeting minutes can be found at http://meetbot.debian.net/debian-release/2017/debian-release.2017-02-22-19.03.html
19:03:51 * h01ger cheers ivo those binNMUs
19:04:58 <nthykier> I think that was it for admin
19:05:31 <nthykier> pochu, you up for "Sprint in Spain"?
19:05:59 <pochu> well, as you know the thread in the team alias didn't get much interest
19:06:11 <nthykier> #topic Sprint in Spain
19:06:15 <pochu> about three people participated in the poll
19:06:40 <pochu> I still think it'd be useful, e.g. to go through all the bugs and tag them, discuss the roadmap, ...
19:06:53 <nthykier> Indeed, I agree on that
19:07:38 <pochu> so we could still do something
19:08:24 <nthykier> Like meet online or do a telephone meeting?
19:08:40 <pochu> I was thinking a smaller face to face meeting with whoever is available :)
19:09:07 <pochu> if at all possible
19:09:26 <ivodd> might be worth another try
19:10:50 <pochu> I can set up another poll if that'd be useful
19:11:17 <nthykier> If you do, please set a deadline on it.  Alternatively we could try to piggy back on a BSP
19:11:39 <pochu> when is the next BSP?
19:11:54 <nthykier> I see "more-than-a-BSP" in May
19:11:59 <nthykier> May 13-14, 2017
19:12:16 <ivodd> and suncamp (also may)
19:13:11 <pochu> the sooner the better :)
19:14:07 <nthykier> pochu: can you setup a poll again with a deadline including either of those two weekends (and possibly others)?
19:14:31 <pochu> aye
19:15:19 <nthykier> #action pochu will do another poll for a team meeting including the weekends for the Paris BSP in May + Sun Camp as options
19:15:24 <nthykier> ok, lets move on then
19:15:42 <nthykier> #topic Secure boot status
19:15:52 <nthykier> I will keep this one short
19:16:15 <nthykier> Support for signing boot loader etc. on the FTP-master side: No news since last meeting
19:16:27 <nthykier> actually, lets make that an info
19:16:34 <nthykier> #info Support for signing boot loader etc. on the FTP-master side: No news since last meeting
19:16:49 <Mithrandir> mjg59's said our bits (on shim-review) looks fine, but waiting for a second opinion before ok-ing and letting MS go ahead.  So, progress of a sort.
19:17:31 <nthykier> #info shim is pending review on shim-review@lists.fdo - it got 1 OK so far, waiting for a second opinion before it is recommended to MS
19:17:39 <nthykier> Mithrandir: thanks for that last minute update :D
19:18:14 <nthykier> Any other updates or questions for Secure boot? Else I will move on
19:18:47 <nthykier> does not seem like it
19:19:01 <nthykier> #topic Packages requiring instructions not present in an architecture's baseline
19:19:13 <nthykier> pochu: Floor is yours
19:19:40 <pochu> that bug is closed (the binary is removed) but I wanted to see what people think in case this is raised again
19:20:03 <pochu> I think everything should support the baseline, unless we grant an exception
19:21:11 <pochu> e.g. "upstream says it will be too slow so this requires some extensions" is not ok, even if the software raises a nice error message rather than SIGILL
19:22:50 <nthykier> Not sure what side I am on in that debate
19:24:00 <ron> if it's compiled code where the upstream default is to pass -mricermode, that should be patched out for debian ...
19:24:30 <nthykier> ron: true - though I don't think that is the case here
19:24:43 <nthykier> I believe this was triggered by relying on SSE2 on i386?
19:25:03 <ron> if it's handrolled asm with a nice runtime detection and message saying "Sorry you lose", I don't see a big problem
19:25:03 <ron> ie. it still shouldn't Just Crash
19:25:35 <Mithrandir> I think it's fine as long as it's reasonably warranted, unless you want to end up requiring GPGPU tools to work in a non-GPGPU environment.
19:25:37 <nthykier> as in, upstream only had a SSE2 code path and then runtime detection + error message + exit(!0)
19:25:46 <Mithrandir> or a game to work without reasonable opengl.
19:25:47 <ron> that could at least be installed in the magic dirs
19:27:46 <nthykier> pochu: do you see this as a major concern for stretch?  If not, I think I would like to postpone this topic for buster
19:28:39 <pochu> nthykier: yeah, we don't have to make a decision until another issue pops up
19:28:53 <nthykier> ok, will put you down for that as well
19:29:22 <nthykier> #agreed pochu will bring up this topic again after the stretcj release
19:29:25 <nthykier> bah
19:29:27 <nthykier> #undo
19:29:27 <MeetBot> Removing item from minutes: <MeetBot.items.Agreed object at 0x1fbecd0>
19:29:31 <nthykier> #agreed pochu will bring up this topic again after the stretch release
19:29:51 <nthykier> #topic Outstanding unblock requests
19:30:34 <nthykier> anyone have any unblock requets they want a second pair of eyeballs on?
19:30:47 <pochu> yes
19:31:10 <pochu> one sec
19:31:56 <nthykier> I think we might need another d-i flush as well - we got 7 RC bugs with a block-udeb and no unblock/unblock request
19:32:45 <pochu> I would appreciate another look at diaspora-installer. I'm not really familiar with debconf
19:34:43 <nthykier> ok - not my strongest suit either, but I am happy to have a look at it after the meeting. :)
19:35:14 <nthykier> any others? :)
19:36:25 <pochu> that's all from me :)
19:36:38 <nthykier> As mentioned before the meeting, I am considering to pull binutils in now.  While it has a regression, it would enable other items to migrate (notably gcc-6 + its rdeps)
19:36:59 <pochu> nthykier: no objections
19:37:12 <nthykier> To my knowlegde, upstream has proposed a patch for the binutils bug, so we should see a fix soon either way (and it causes FTBFS rather than broken binaries)
19:38:11 <nthykier> ok - if there are no other unblock items (or remarks to existing ones), then I think we are rather to move to AOB
19:38:44 <nthykier> #topic AOB
19:38:49 <nthykier> I got two items
19:39:43 <nthykier> #info \o/ for the BSP @ credativ for finally bring us back on track with fixing more RC bugs than we were filing \o/
19:40:52 <nthykier> Notably, we are now just under 80 unfixed RC bugs in key packages (https://udd.debian.org/bugs/?release=stretch_and_sid&merged=ign&keypackages=only&fnewerval=7&flastmodval=7&rc=1&chints=1&ctags=1&cdeferred=1&crttags=1&sortby=id&sorto=asc&format=html#results)
19:41:21 <nthykier> which includes ivodd -ignoring some bugs - also thanks for that :)
19:41:34 <nthykier> </end of my "two" items>
19:41:42 <nthykier> any other AOB?
19:42:17 * pochu was thinking about creating a twitter/identi.ca RT account... dunno how good an idea that is
19:43:38 <nthykier> pochu: perhaps - though I think we would be wise to consider (ab)using #d-publicity more before we go there
19:44:07 <nthykier> I think they would be more than happy to do tweets/dents on our behalf we have something to say.
19:44:39 <pochu> yeah, that's a good suggestion, either way
19:45:58 <nthykier> But also, I do think you are on to something on using tweets/dents more often
19:47:14 <pochu> wdym?
19:48:42 <nthykier> pochu: that I think a lot of people might be interested in tweets/dents from us
19:49:17 <pochu> ah ok
19:49:47 <pochu> yeah I think it can be a useful tool - if we use it properly
19:49:56 <nthykier> probably the biggest problem :D
19:50:03 <nthykier> ok - I think this is it for AOB ?
19:50:09 <pochu> yep
19:50:30 <nthykier> #topic Next meeting
19:50:35 <h01ger> release-team.info (or whatever the url was) was also nice. but i agree, today its twitter/identica
19:51:01 <nthykier> #info Next meeting is 26th of April at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:51:47 <nthykier> #info Note keep DST in mind - the meeting may have shifted an hour for you
19:51:51 <nthykier> #endmeeting