19:02:01 <nthykier> #startmeeting
19:02:01 <MeetBot> Meeting started Wed Oct 26 19:02:01 2016 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:01 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:22 <nthykier> Ok
19:02:37 <nthykier> #topic admin/since last meeting
19:03:00 <adsb> I'm vaguely around but only just finished making dinner, so need to eat
19:03:07 <nthykier> jmw mentioned he didn't expect to be here either
19:04:45 <nthykier> If there are no other known absences, I'll be moving on to actions from last meeting
19:05:41 <nthykier> #info nthykier + larjona finished the artwork poll.  The theme will be "softWaves" \o/
19:05:59 <pochu> nice. thanks for leading that :)
19:06:16 <nthykier> Thanks larjona for helping me get the last mile :)
19:06:34 <nthykier> #info We got the PIE by default proposal out and it is now enabled in unstable
19:07:23 <nthykier> #info mips64el is no longer a "break arch" (but it is still a "new arch", which has similar issues)
19:08:29 <pochu> nthykier: I thought NEW was kind of a no-op
19:08:35 <nthykier> #info jmw did a poll for the arch qualification meeting. We will pick a time today during the meeting
19:08:40 <nthykier> pochu: it sadly isnt
19:08:42 <pochu> mostly for missing Sources and Packages files the first time you add it
19:09:19 <nthykier> We can take that afterwards, but we noticed a "fun" condition in Britney for it
19:09:55 <pochu> ok let's have a look later
19:09:59 <nthykier> Those are the action items I got a status on
19:10:13 <pochu> got a link for the previous meeting's minutes?
19:10:31 <nthykier> #info Last meeting minutes: http://meetbot.debian.net/debian-release/2016/debian-release.2016-09-28-19.00.html
19:10:34 <nthykier> thanks :)
19:11:23 <nthykier> Any other items for "admin/since last meeting"
19:11:25 <nthykier> ?
19:11:28 <pochu> action 3 is kind of incomplete. I guess it talks about EFI?
19:11:37 <ansgar> nthykier: New d-i alpha is in preparation maybe?
19:12:23 <nthykier> #info There is a new d-i alpha in preparation!
19:12:37 <nthykier> don't think it was an action, but I like it anyway ! :D
19:13:05 <nthykier> ok, let's finish jmw item by moving on to ...
19:13:16 <nthykier> #topic Architecture qualification meeting
19:13:48 <nthykier> jmw sent out a poll for it, which some of us answered!
19:15:08 <adsb> yes, some of us suck
19:15:12 <nthykier> :)
19:15:29 <jcristau> the ones who answered, or the rest?
19:15:42 <pochu> heh
19:16:12 <nthykier> jmw suggested the 9th of November as 8/9 can make it
19:16:25 <nthykier> http://doodle.com/poll/362qvb89cvu43d4z
19:16:29 <nthykier> There was the link
19:16:36 <jcristau> per -private i can't do that week
19:17:16 <jcristau> not that i'm needed
19:17:30 <adsb> that's the wednesday? I'll be on my way to cambridge for miniconf in the evening, not sure whether I'll be driving yet
19:17:31 <nthykier> ok - and you wouldn't make the other "optimal date" being the 6th either AFAICT?
19:17:48 <adsb> but I also don't have any particular opinions on architectures so long as they don't make SRM a misery
19:18:00 <nthykier> ok
19:18:12 <adsb> I could probably do the 6th if it ends up mattering
19:18:23 <adsb> (i.e. sunday)
19:18:45 <nthykier> I fear it might - from what was answered I and either pochu OR jmw can make it on the 9th
19:18:56 <nthykier> which means we are only 2 from the release team (that is known to make it)
19:19:30 <nthykier> If we go with the 6th, then we would be at least 3 (but still no pochu :-/)
19:19:33 <adsb> I'd have thought at least one more person would be on the way to cambridge on the 9th :)
19:19:36 <adsb> boo
19:20:07 <nthykier> Alternatively, we should ditch some of the porters
19:20:08 <jcristau> answered now
19:20:20 <pochu> nthykier: I can probably make it on the 9th and maybe on the 6th at 9pm too
19:20:37 <jcristau> sorry for sucking
19:21:10 <adsb> I haven't, but if we're choosing between the 6th and the 9th then I'm only likely to be around on the 6th
19:21:11 <aurel32> jcristau: especially for not being available in the past :)
19:22:09 <pochu> Oct 30th at 9pm looks like another good option
19:22:34 <pochu> and I may be able to make it
19:23:00 <adsb> I could do that
19:23:01 <nthykier> pfft, I cannot plan if you mark all dates red! :P
19:23:07 <nthykier> ok, Oct 30 then?
19:23:17 <adsb> 2100UTC?
19:23:21 <nthykier> On the last proposed time slot?
19:24:48 <adsb> confused as to what time that actually is
19:24:54 <adsb> you said 9, presumably that's CET?
19:25:01 <adsb> as doodle says 8 for me
19:25:06 <jcristau> yes, it's local time
19:25:10 <jcristau> 9pm berlin
19:25:13 <jcristau> 8pm london
19:25:14 <nthykier> That is why I used "last" :P
19:25:25 <jcristau> which i guess is 8pm utc
19:25:30 <adsb> nthykier: yeah, but then I had to fight doodle, because its UI sucks when it's showing that many options
19:25:49 <nthykier> $ date -d'2016-10-30 21:00 CET' -u
19:25:50 <nthykier> Sun Oct 30 20:00:00 UTC 2016
19:25:51 <adsb> but sure, that should work
19:26:13 <nthykier> Ok, so Oct 30, 20:00 UTC? All agreed
19:26:14 <nthykier> ?
19:26:25 <adsb> sure
19:26:31 <adsb> might need to remind me nearer the time :)
19:27:06 <nthykier> Will do
19:27:27 <nthykier> #agreed Architecture qualification meeting: Sun Oct 30 20:00:00 UTC 2016
19:28:06 <nthykier> I will stuff it into the release calendar that every body uses! :)
19:28:17 <nthykier> Ok
19:28:25 <nthykier> #topic Secure boot status
19:28:34 <nthykier> We got shim
19:29:09 <nthykier> jcristau: Are you up to speed here?
19:29:16 <jcristau> on my side, dak bits are on hold pending fasolo move
19:29:31 <nthykier> ok
19:30:00 <nthykier> And with shim there, we can start to move on the signin with MS, right?
19:30:06 <jcristau> yes
19:30:12 <jcristau> Mithrandir was going to do that
19:30:53 <nthykier> cool
19:30:56 <jcristau> yesterday's status was 21:36 < Mithrandir> setting up the digicert token now.
19:31:02 <nthykier> oooh
19:31:12 <Mithrandir> I'm trying to sign up for MS' sysdev thing, but I have yet to actually see a mail from them, so need to poke more.
19:31:48 <jmw> o/
19:32:00 <jmw> I have had a terrible thought about arch-qual. please prod me when I'm not interrupting something else
19:32:00 <nthykier> ok - are there anything that we expect will block the progress (MS signing, dak stuff or otherwise)
19:32:28 <jcristau> i expect that both of those will take some time
19:32:33 <Mithrandir> I suspect the actual signing will be smooth, but take a little bit of time
19:32:34 <nthykier> (jmw: you mean it is halloween?)
19:32:42 <Mithrandir> time we can't control on our side
19:33:11 <nthykier> ok
19:33:51 <nthykier> I say we move on then (if there are no actionable concerns)
19:34:20 <nthykier> jmw: did you have something about the meeting?
19:34:38 <jmw> actually I just skimmed scrollback, and you already solved my problem
19:34:43 <jmw> 30th works for me
19:34:48 <jmw> so I'll go away again now
19:34:49 <nthykier> cool
19:34:57 <nthykier> ok, moving on then! :)
19:35:07 <nthykier> #topic Transitions!
19:35:12 <nthykier> pochu: take it away!
19:35:53 <ansgar> I started looking at secure boot, but don't have much free time at the moment :-/
19:36:09 <pochu> right
19:36:53 <pochu> so the big news is the security team said they prefer / are ok with including openssl 1.1 alongside openssl 1.0 in stretch, so we will do that
19:37:14 <pochu> since we will probably ship both, there is not a lot to worry about
19:37:40 <pochu> the transition freeze is coming soon, but we may still see a few transitions. though things seem calm
19:38:09 <pochu> I want to get the new xserver in, and I have heard about some stuff (e.t. a new Qt) but we'll see what happens in the end
19:38:45 <pochu> oh, we almost got rid of two LLVMs
19:38:50 <nthykier> oooh
19:38:59 <nthykier> nice - also jasper too!
19:39:03 <pochu> (one already removed, the other one pending the introduction of llvm 3.9)
19:39:19 <pochu> so we'll likely release with 3.8, 3.9 and one of 3.5 or 3.7
19:39:25 <pochu> yeah, and jasper is gone :)
19:39:38 <nthykier> On the transition freeze, I believe we agreed on transitions just have to be acked by the start of the freeze
19:39:53 <pochu> readline7 is mostly done
19:40:00 <adsb> because pochu said he'd get bored without stuff to do :P
19:40:12 <nthykier> Yes, I do remember that argument
19:40:13 <pochu> nthykier: that's fine with me, as long as they start soonish after that
19:40:20 <mapreri> question from outsider: do you have news about ghc 8?
19:40:31 <nthykier> pochu: am fine with that too :)
19:40:41 <pochu> I know Clint has been working on that. not sure if it will be ready on time though
19:40:53 <pochu> I need to check the status of that
19:40:56 <mapreri> he still has 10 days :>
19:41:04 <Clint> pochu: with the PIE stuff i think we don't have a choice but to go forward with it
19:41:44 <pochu> Clint: oh ok. let's discuss this after the meeting
19:42:00 <nthykier> :)
19:42:17 <pochu> .
19:42:46 <nthykier> Cool
19:43:23 <nthykier> #topic Sprint in Spain
19:43:30 <nthykier> pochu: I assume that one is your? :)
19:43:58 <pochu> sigh. I haven't called the hotel yet
19:44:04 <pochu> so no venue atm
19:44:18 <pochu> give me an action and I'll do it and send a mail to team@
19:44:38 <nthykier> #action pochu to find a venue and email team@
19:44:50 <nthykier> pochu: did we have a date planned already?
19:44:58 <nthykier> I vaguely remember something about Feb 2017
19:46:19 <pochu> nthykier: yes, we said Feb
19:46:33 <nthykier> and nothin more specific than that?
19:46:37 <pochu> one of the 10th or the 17th IIRC
19:46:42 <pochu> but I need to dig it up
19:46:45 <nthykier> ok
19:46:51 * pochu looks for that
19:46:54 <nthykier> we can do that afterwards
19:47:01 <pochu> ok, move on
19:47:16 <nthykier> #topic MySQL / MariaDB
19:47:36 <nthykier> pochu: you had a comment here about mysql-5.7 and #837615 ?
19:48:38 <pochu> right. looks like the RT doesn't want to ship two mysql forks again, which means we need to finish the transition to mariadb
19:49:08 <pochu> sorry, s/RT/security team/
19:49:51 <nthykier> Do we have an idea of the scope here?
19:50:06 <nthykier> AFAICT the proposal involves changing B-D in all rdeps
19:51:01 <nthykier> oh, I know the answer to that actualy
19:51:03 <nthykier> actually*
19:51:06 <nthykier> https://lintian.debian.org/tags/build-depends-on-obsolete-package.html
19:51:32 <nthykier> looks like about 150ish packages (see the 2.5.48 -> 2.5.49 spike)
19:51:43 <pochu> nthykier: we may want to make mariadb take over libmysqlclient-dev...
19:52:01 <pochu> or just get those packages fixed/changed
19:52:16 <pochu> but I haven't looked closely at this yet
19:52:26 <nthykier> me neither
19:52:50 <_rene_> that would be the death of packages strictly requiring mysql for build because upstream is oracle and/or it uses stuff not in mariadb.
19:52:56 <_rene_> (just as data point)
19:53:17 <pochu> _rene_: unfortunately, yes
19:53:32 <pochu> if those packages can't get adapted to work with mariadb, they'll go away too
19:54:19 <nthykier> I think I will action myself on this one
19:54:52 <nthykier> #action nthykier to ask mariadb maintainers for a MFB for mysql -> mariadb
19:55:34 <rbasak> o/
19:55:36 <rbasak> Just seen this.
19:55:39 <rbasak> What's an MFB, OOI?
19:55:55 <mapreri> MBF* maybe ?
19:55:59 <nthykier> #undo
19:55:59 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x14dcc90>
19:56:09 <nthykier> #action nthykier to ask mariadb maintainers for a MBF for mysql -> mariadb
19:56:24 <nthykier> (why do I always mess up that acronym?)
19:56:34 <nthykier> rbasak: Mass Bug Filing
19:56:47 <rbasak> Ah. Thanks.
19:57:11 <nthykier> Ok, I think I will have to close here
19:57:18 <broucari> pochu: thanks about imagemagick
19:57:22 <nthykier> #topic AOB
19:57:28 <nthykier> Any last minute remarks?
19:58:05 <nthykier> Doesn't sound like it
19:58:55 <pochu> nthykier: enforcing the transition freeze
19:59:09 <nthykier> ok
19:59:10 <pochu> do we want to do that? or are we fine with the way things are?
19:59:21 <nthykier> #topic On enforcing the transition freeze
19:59:50 <pochu> enforcing it is just so that we don't have to send angry emails to debian-devel@ and maintainers because they started a transition that causes some fallout, or block rdeps from migrating
20:00:21 <nthykier> We should probably strike for a reasonable balance
20:00:23 <nthykier> I am fine with "minor" transitions (e.g. where the rdeps are maintained by the same person).
20:02:04 <nthykier> (as a personal PoV)
20:03:56 <pochu> that would be fine with me. just wondering about the technical aspect
20:04:08 <nthykier> I don't think we have anything automated
20:04:31 <pochu> i.e. if we want to "prevent" a maintainer from uploading, say, https://release.debian.org/transitions/html/auto-libevent.html which is in experimental already, to sid after the transition freeze
20:04:51 <pochu> we don't have anything atm no
20:05:05 <nthykier> true
20:05:30 <nthykier> pochu: I think this might be something that we should look at - but I doubt we will come with good solution now.
20:05:37 <nthykier> I say we look at this afterwards
20:05:45 <pochu> ok sure
20:06:02 <nthykier> Thanks
20:06:07 <nthykier> #topic Next meeting
20:06:48 <pochu> next sunday, and in 4 weeks from now ;)
20:07:03 <nthykier> Next meeting is  2016-11-23 19:00 UTC - should we move it due to summer time change?
20:07:23 * nthykier is ok either way
20:07:38 <pochu> I don't mind either
20:07:52 <adsb> there's "dak transitions", if it still works
20:09:30 <nthykier> #info Next meeting is  2016-11-23 19:00 UTC  (NB: Might change an hour for you due to summer time -> winter time)
20:09:35 <nthykier> #endmeeting