#debian-release Meeting

Meeting started by jmw at 19:00:44 UTC (full logs).

Meeting summary

  1. Admin (jmw, 19:05:57)
    1. http://meetbot.debian.net/debian-release/2016/debian-release.2016-08-24-19.05.html is the last minutes (jmw, 19:06:22)
    2. http://meetbot.debian.net/debian-release/2016/debian-release.2016-07-27-19.00.html before those (jmw, 19:07:59)

  2. MySQL/MariaDB variants (jmw, 19:08:03)
    1. There are some default-mysql-* packages now and the next version of lintian will nag about some uses of "old" MySQL packages (jmw, 19:22:43)
    2. We still need to evaluate variants for Stretch when the alternative system is feasible (jmw, 19:23:00)

  3. Porter roll-call (jmw, 19:23:05)
    1. Porter information has been updated in https://release.debian.org/stretch/arch_qualify.html (jmw, 19:23:17)

  4. Artwork (jmw, 19:23:22)
    1. Artwork has all been collated (jmw, 19:23:35)
    2. ACTION: nthykier Encourage shipping all artwork in a package (jmw, 19:24:00)
    3. ACTION: nthykier Organise selection/voting of some sort (jmw, 19:24:10)

  5. Secure boot status (jmw, 19:24:21)
    1. shim package is in progress and awaiting an upload (jmw, 19:26:03)
    2. linux signing infrastructure is in progress; there are tentative patches for dak but need ftp-master input (jmw, 19:28:41)
    3. ACTION: jcristau to continue progressing (jmw, 19:31:10)

  6. PIE by default for Stretch (jmw, 19:33:17)
    1. could reveal bugs in built binaries (but those should be fixed or PIE disabled) (jmw, 19:38:28)
    2. can cause slowdowns in register-starved architectures, including i386 (fixed in gcc5) and arm32 (jmw, 19:39:38)
    3. majority of porters believe their architecture is ready (jmw, 19:40:30)
    4. ACTION: nthykier Send mail to d-release about enabling PIE by default! If there are no major concerns brought up within a week, Stretch will go with PIE by default (nthykier, 19:54:53)

  7. Architecture qualification (jmw, 19:57:30)
    1. ACTION: jmw organise architecture qualification in late October or early November (jmw, 20:04:08)

  8. mips64el (jmw, 20:04:35)
    1. ACTION: nthykier promote mips64el to BREAK_ARCHES once libmysqlclient is available on mips64el, revert if there are issues (nthykier, 20:08:05)
    2. the problem with mariadb is upstream: https://jira.mariadb.org/browse/MDEV-10417 (jmw, 20:08:37)

  9. Release schedule (jmw, 20:10:13)
    1. Linux - 4.9 will be LTS, presumably November (jmw, 20:10:22)
    2. AGREED: Stick to the published schedule to avoid confusion (jmw, 20:12:07)

  10. Mini-Debconf Cambridge (jmw, 20:12:41)
    1. ACTION: jmw find out about meeting space requirements (jmw, 20:14:04)

  11. AOB (jmw, 20:14:27)
    1. Britney patches have been submitted for review - deadline Oct 03 for comments (nthykier, 20:16:03)

  12. Next meeting (jmw, 20:16:11)
    1. Next meeting: 2016-10-26 19:00UTC (jmw, 20:16:38)


Meeting ended at 20:17:16 UTC (full logs).

Action items

  1. nthykier Encourage shipping all artwork in a package
  2. nthykier Organise selection/voting of some sort
  3. jcristau to continue progressing
  4. nthykier Send mail to d-release about enabling PIE by default! If there are no major concerns brought up within a week, Stretch will go with PIE by default
  5. jmw organise architecture qualification in late October or early November
  6. nthykier promote mips64el to BREAK_ARCHES once libmysqlclient is available on mips64el, revert if there are issues
  7. jmw find out about meeting space requirements


Action items, by person

  1. jcristau
    1. jcristau to continue progressing
  2. jmw
    1. jmw organise architecture qualification in late October or early November
    2. jmw find out about meeting space requirements
  3. nthykier
    1. nthykier Encourage shipping all artwork in a package
    2. nthykier Organise selection/voting of some sort
    3. nthykier Send mail to d-release about enabling PIE by default! If there are no major concerns brought up within a week, Stretch will go with PIE by default
    4. nthykier promote mips64el to BREAK_ARCHES once libmysqlclient is available on mips64el, revert if there are issues


People present (lines said)

  1. jmw (108)
  2. nthykier (81)
  3. jcristau (37)
  4. doko (27)
  5. MeetBot (10)
  6. aurel32 (8)
  7. adsb (5)
  8. h01ger (2)
  9. helmut (1)


Generated by MeetBot 0.1.4.