#debian-release Meeting

Meeting started by phil at 20:02:04 UTC (full logs).

Meeting summary

  1. What will be the release architectures for squeeze? (phil, 20:05:01)
    1. ACTION: phil queues packages that have not been built this year to rebuild on sparc (phil, 20:21:32)
    2. sparc stays as a release architecture for squeeze (faw, 20:22:31)
    3. sparc stays as a release architecture for squeeze, depending on the results of a rebuild (doko, 20:22:57)
    4. ACTION: aurel32 to follow up with gcc upstream and loongson people about getting a backported fix for #519006 (jcristau, 20:28:21)
    5. ACTION: aurel32 will try to reproduce openjdk-6 toolchain issues (HE, 20:41:05)
    6. ACTION: zobel will send another loongson machine to aba, who will set it up as mipsel porter machine (HE, 20:44:10)
    7. ACTION: : zobel takes the other loongson boxes to aba next week when coming to munich (zobel, 20:44:56)
    8. ACTION: drop hppa as a release architecture, with an option to do a separate hppa-squeeze release that only contains a subset of packages, if the porters manage to hammer it into shape (phil, 20:56:33)
    9. kfreebsd-* as technology preview in squeeze, tentatively using the main suite (jcristau, 21:11:48)
    10. ACTION: we mark kfreebsd-* as technology preview in release notes etc, but don't use another infrastructure set (we can review that if necessary) (HE, 21:11:49)

  2. Remaining transitions: Status, known problems (phil, 21:13:40)
    1. There won't be a PHP transition for squeeze, sorry. (phil, 21:26:23)
    2. gnustep: RC bug on hppa, fix pending upload. Looks good otherwise. (phil, 21:26:53)
    3. Mono Transition needs to send a mail with plan (faw, 21:27:09)
    4. opencv: one FTBFS on hppa (phil, 21:27:30)
    5. ace: ftbfs on armel and kfreebsd, not a blocker (jcristau, 21:27:41)
    6. ACTION: meebey sends a mail about the mono transition to debian-release@ (phil, 21:27:50)
    7. ACTION: mvo starts the apt transition in unstable (phil, 21:29:04)

  3. Release Meeting in Paris 2-3 Oct, who's going? (phil, 21:32:09)
    1. ACTION: faw negotiates with zack (phil, 21:35:46)
    2. mehdi, jcristau, luk, adsb, phil can probably make it; HE unsure; faw relying on oversee travel sponsorship (phil, 21:36:44)
    3. Maulkin cannot make it (luk, 21:37:04)
    4. aba can probably make it, too. (phil, 21:37:33)

  4. State of Release Notes (phil, 21:37:51)
    1. ACTION: vorlon is taking care of upgrade-reports (phil, 21:43:37)
    2. timeline: 4 weeks to get them ready, 2 weeks of string freeze, 1 week of fixes and final week for translations (phil, 21:44:09)


Meeting ended at 21:44:56 UTC (full logs).

Action items

  1. phil queues packages that have not been built this year to rebuild on sparc
  2. aurel32 to follow up with gcc upstream and loongson people about getting a backported fix for #519006
  3. aurel32 will try to reproduce openjdk-6 toolchain issues
  4. zobel will send another loongson machine to aba, who will set it up as mipsel porter machine
  5. : zobel takes the other loongson boxes to aba next week when coming to munich
  6. drop hppa as a release architecture, with an option to do a separate hppa-squeeze release that only contains a subset of packages, if the porters manage to hammer it into shape
  7. we mark kfreebsd-* as technology preview in release notes etc, but don't use another infrastructure set (we can review that if necessary)
  8. meebey sends a mail about the mono transition to debian-release@
  9. mvo starts the apt transition in unstable
  10. faw negotiates with zack
  11. vorlon is taking care of upgrade-reports


Action items, by person

  1. aba
    1. zobel will send another loongson machine to aba, who will set it up as mipsel porter machine
    2. : zobel takes the other loongson boxes to aba next week when coming to munich
  2. ana
    1. drop hppa as a release architecture, with an option to do a separate hppa-squeeze release that only contains a subset of packages, if the porters manage to hammer it into shape
  3. aurel32
    1. aurel32 to follow up with gcc upstream and loongson people about getting a backported fix for #519006
    2. aurel32 will try to reproduce openjdk-6 toolchain issues
  4. faw
    1. faw negotiates with zack
  5. meebey
    1. meebey sends a mail about the mono transition to debian-release@
  6. mvo
    1. mvo starts the apt transition in unstable
  7. phil
    1. phil queues packages that have not been built this year to rebuild on sparc
  8. zobel
    1. zobel will send another loongson machine to aba, who will set it up as mipsel porter machine
    2. : zobel takes the other loongson boxes to aba next week when coming to munich
  9. UNASSIGNED
    1. we mark kfreebsd-* as technology preview in release notes etc, but don't use another infrastructure set (we can review that if necessary)
    2. vorlon is taking care of upgrade-reports


People present (lines said)

  1. phil (101)
  2. aurel32 (96)
  3. jcristau (64)
  4. HE (47)
  5. doko (39)
  6. aba (38)
  7. mehdi (30)
  8. faw (30)
  9. luk (29)
  10. adsb (21)
  11. Maulkin (20)
  12. zobel (10)
  13. MeetBot (8)
  14. weasel (8)
  15. bwh (7)
  16. dannf (6)
  17. meebey (5)
  18. _rene_ (5)
  19. DonKult (3)
  20. Ganneff (3)
  21. mvo (3)
  22. ana (2)
  23. darst (2)
  24. waldi (2)
  25. bzed (2)
  26. AbsintheSyringe (1)
  27. bdale (1)
  28. smd (1)
  29. sgnb (1)


Generated by MeetBot 0.1.4.