18:00:38 <h01ger> #startmeeting
18:00:38 <MeetBot> Meeting started Wed Aug 24 18:00:38 2016 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:38 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:00 <h01ger> still waiting for mapreri to come back from dinner… (giving him 5min)
18:01:50 <h01ger> the agenda i came up with is:
18:01:54 <h01ger> * short intro, why are we here (individually)
18:01:55 <h01ger> * jenkins.d.o migration
18:01:55 <h01ger> * git merge policy + procedures
18:01:55 <h01ger> * deployment improvements
18:01:55 <h01ger> * future meeting schedule
18:01:56 <h01ger> * give at least mattia access to my.profitbricks.com, for remote access
18:01:58 <h01ger> * AOB
18:02:08 <h01ger> any thing else / i missed?
18:02:44 <h01ger> #save
18:03:23 <h01ger> http://meetbot.debian.net/debian-qa/2016/ has the log and the automatically generated summary, for latecomers and later usage…
18:04:35 <h01ger> #info this meeting is about jenkins.debian.(net|org) (team) maintenance
18:05:55 <KGB-2> 03Holger Levsen 05master 76536ee 06jenkins.debian.net 10TODO update agenda for the meeting
18:06:10 <h01ger> changed to
18:06:13 <h01ger> * short intro, why are we here (individually)
18:06:13 <h01ger> * future meeting schedule
18:06:13 <h01ger> * jenkins.d.n status
18:06:13 <h01ger> * jenkins.d.o migration
18:06:14 <h01ger> * git merge policy + procedures
18:06:14 <h01ger> * deployment improvements
18:06:17 <h01ger> * give at least mattia access to my.profitbricks.com, for remote access
18:06:17 <h01ger> * AOB
18:06:31 <h01ger> i guess we can start now and mapreri can read backlog and join later…
18:06:41 <h01ger> #topic short intro, why are we here (individually)
18:07:05 <h01ger> so, please introduce yourself briefly and explain what you are doing with jenkins.d.(n|o)
18:07:08 <h01ger> or plan to do
18:07:12 * fil (Philip Hands) here becuase I want to be able to push to feature branches for udebs, and come back a while later to look at the email telling me if the resulting d-i still is able to install things in various scenarios (which is somewhat working at this point, but can improve in all dimensions)
18:08:44 <spectranaut> hi I'm valerie -- I've been working on tests.reproducible-builds.org as an outreachy student and presentally working on a database migration from sqlite to postgres
18:08:45 * pkern_ (Philipp Kern) I wanted to look at using Jenkins to instrument s390x installs using debian-installer to ensure that we don't break it by accident (low total user base, even less testing usage)
18:09:00 * tnnn (Tomasz Nitecki) here because I have some jenkins and CI experience and I'm wondering how it's done (or how it will be done) in Debian
18:09:09 * h01ger has been setting up this jenkins thing and wants to move the load of maintaining it on many more shoulders (and i'm happy already how well this has worked so far, despite all the flaws…) and i also would to establish a regular meeting schedule, to keep on working continously on this jenkins stuff and to also finally get the jenkins.d.o migration going
18:10:34 * StevenC99_ (Steven Chamberlain) here because I have a separate jenkins master already running jobs on kfreebsd; some may be of interest to others; I could someday integrate them into jenkins.debian.(net|org) and provide only the kfreebsd slave machine(s)
18:11:00 <mapreri> o/
18:11:26 * h01ger will wait 3-5 more minutes for people to discuss
18:11:27 * mapreri started with reproducible-related jobs, and then turned at looking at how the rest of the setup worked.  He believes it could be useful for a lot of other teams, and has great plans like continuosly building all packages and other things, that would be well fitted in it.
18:13:51 <StevenC99_> pkern_: I also like to do more d-i testing with jenkins
18:13:57 <StevenC99_> would like*
18:14:05 <StevenC99_> on the less-common arches
18:14:32 <h01ger> which reminds me we just got powerpc hw offered
18:15:20 <h01ger> pkern_: could you btw offer s390x VMs for reproducible?
18:15:28 <h01ger> #topic jenkins.d.n status
18:15:33 <mapreri> s/powerpc/ppc64el/
18:15:39 <h01ger> :)
18:15:41 <h01ger> (thx)
18:16:05 <pkern_> h01ger: I had a hard time getting some myself, so it might be a single one for continuous installs rather than continuously testing on it. I.e. if we had that running I might be able to talk with IBM about general QA.
18:16:42 <mapreri> pkern_: that sounds good already indeed.
18:16:45 <pkern_> h01ger: I know how to boot up an installer in a different VM and that's something I'd pursue for now. Details unclear, though.
18:17:11 <h01ger> jenkins frequently runs into out-of-memorys situations, despite the machine having 58G (and i could easily add more…), does someone understand java memory handling enough to help fixing those? helmut is restarting jenkins about every week to migate that, but it kills all the running jobs
18:17:52 <h01ger> pkern_: ok, no problem, was just curious… (though being able to test reproducible builds on more archs would certainly be cool)
18:18:31 <h01ger> pkern_: you should talk with fil about doing "his" tests on "your hw" :)
18:18:38 <pkern_> In theory one could KVM that.
18:19:07 <pkern_> fil: Yeah, are you actually relying on invoking your own qemus for that? On the other hand I still have your talk on my watch list, so you may want to defer me to that instead. ;-)
18:19:49 <h01ger> fil's lvc jobs should soon be ready to replace all the g-i-installation jobs, and will be much better. StevenC99_, pkern_, if you havent watched fil's talk at dc16 i highly recommend you watch it. it starts a bit slow but then gets very juicy
18:19:54 <h01ger> +beefy
18:21:07 <StevenC99_> h01ger: I did see it, I should probably try to base my future work on that
18:21:23 <h01ger> definitly. g-i-installation.sh is a dead horse :)
18:21:28 <tnnn> h01ger: I do have some experience with java and memory issues but not with jenkins tbh
18:22:06 <fil> pkern_: the stuff I've done for d-i is currently (ab)using Cucumber, which invokes the kvm, and points sikuli at it to do the typing at a X session with the vnc pointing at the VM's console (there's almost certainly a better way to do most of that, and we ought to be able to do something much simpler for serial/ssh consoles)
18:22:17 <h01ger> tnnn: http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/hosts/jenkins/etc/default/jenkins and its been using a max heap size of 14gb today…
18:22:57 <pkern_> fil: Ah, thanks. I know someone else pointed me at Cucumber before.
18:23:11 * h01ger thinks we are done with a status overview (and least i cannot think of more stuff to share right now) and we should discuss details later… ;)
18:23:48 <h01ger> fil: we should also get this 300gb extra storage used… IOW, and in general: we have more storage we could use
18:24:05 <fil> pkern_: the front page of the Cucumber site pretty-much says "If you're thinking of using Cucumber like this, don't!"
18:24:12 <h01ger> *g*
18:24:20 <h01ger> more status stuff?
18:24:34 <mapreri> h01ger: /var/lib/jenkins/job/ is constantly going > 92%.  giving some more gigs to it wouldn't be a bad idea for a start.
18:24:35 <fil> however, tails had already got it working, so seemed like a place to start
18:24:40 <pkern_> fil: I think it was intrigeri from Tails. ;)
18:24:43 <pkern_> Right.
18:24:50 <mapreri> we've added a lot more tests jobs the last growing of that partition
18:24:53 <h01ger> mapreri: right
18:25:06 <mapreri> -egrammar, but you got it :)
18:25:34 <h01ger> #action h01ger should increase the space for /var/lib/jenkins/job/ by moving it a new SSD based storage, also kindly sponsored by profitbricks.com
18:25:47 <mapreri> ^^
18:26:04 <tnnn> h01ger: I'll look into it when I get back. Is it reported somewhere?
18:26:36 <h01ger> weasel: do you use "saving artifacts" with remote jobs? the lvc jobs currently fail to do this and we cannot figure out why jenkins thinks the workspace/results/ dir is empty…
18:26:45 <tnnn> h01ger: Or at least whom to inquire about that? :)
18:26:56 <h01ger> tnnn: not really. i could file a bug against qa.debian.org
18:27:04 <h01ger> tnnn: helmut or me
18:27:11 <mapreri> (or me)
18:27:22 <fil> h01ger: it thinks it's not there actually -- clearly it's idea of $WORKSPACE is not matching ours
18:27:25 <mapreri> if you need logs or anything shut!
18:27:38 <mapreri> shout*
18:27:51 <h01ger> shall we move on to the next topic?
18:28:31 <h01ger> #topic jenkins.debian.org migration
18:28:56 <h01ger> #info the status of the jenkins.d.o migration is kept in jenkins.d.n.git/TODO
18:29:10 <tnnn> mapreri: Will definitely need those, I will give one of you a shout, thx.
18:29:19 <h01ger> the machine jerea.debian.org is setup, please go to https://jenkins.debian.org
18:29:38 <h01ger> we still need to install plugins and configure the nodes…
18:30:06 <StevenC99_> I got a Debian SSO prompt, does that actually work already?
18:30:11 <mapreri> yes
18:30:12 <h01ger> StevenC99_: it should
18:30:13 <StevenC99_> awesome!
18:30:36 * h01ger is not a happy SSO user but i guess i need to become one
18:30:36 <mapreri> everybody can already log in (though of course nobody but a few have power)
18:31:05 <mapreri> h01ger: is there something in particular about how it integrates into jenkins.d.o that concern you?
18:31:16 <h01ger> no
18:31:38 <StevenC99_> mapreri: "of course"? what is the risk of giving too much power if the user is at least a DD?
18:31:53 <h01ger> lets move on :) my concern with installing all the plugins is that i would like to see which we are actually using…
18:32:12 <h01ger> StevenC99_: the whole setup is done in a way that noone should need to login
18:32:20 <mapreri> StevenC99_: limited resources and risk that somebody might trig heavy jobs, for example.
18:32:25 <StevenC99_> ah yes because of the Git workflow
18:32:28 <h01ger> which mostly has been a good design imo
18:32:32 <mapreri> indeed.
18:33:02 <h01ger> so, speaking again of the plugins… i guess it would help if someone would install all the plugins listed in INSTALL on jarea
18:33:23 <mapreri> i can
18:34:51 <StevenC99_> #action?
18:35:32 <h01ger> i think anybody can #action
18:35:42 <h01ger> #action mapreri will install the plugins on jarea
18:35:45 <h01ger> #save
18:36:02 <mapreri> h01ger: in INSTALL the plugins are separated in groups.  what does that mean?
18:36:14 <h01ger> yup, http://meetbot.debian.net/debian-qa/2016/debian-qa.2016-08-24-18.00.html has an empty action item from StevenC99_
18:36:16 <h01ger> :)
18:36:17 <StevenC99_> oops yes apparently I can action!
18:36:28 <h01ger> mapreri: grouped by topic, roughly
18:36:37 <h01ger> StevenC99_: make action great again!
18:36:46 <mapreri> ok
18:37:39 <h01ger> and then… i think the first jobs to move are probably the general maintainance jobs… for that we will need to improve update_jdn so that we can use it (quite very differently) on jarea
18:38:41 <h01ger> mapreri: and please update TODO once you've done the plugi…
18:39:30 * fil notes that there's something not very helpful about the way the UI uses plugin names -- might be nice to fix what's in INSTALL when you notice a discrepancy (I didn't do that before, but probably should have now I think about it)
18:39:38 <mapreri> I think we could as well move some things out of update_jdn into an update_jenkins.sh thing that can be used on both j.d.[no].  after all in jerea we have very few things to do through git as compared to the currently things (i.e.: only jobs and scripts, possibly few things from userContent)
18:39:53 <h01ger> i think we are good for now for the migration topic, at least i'm reminded on another topic: meeting schedule frequency… (aka: when will we meet again to discuss the migration steps further)
18:40:11 <h01ger> mapreri: excellent idea
18:40:16 <mapreri> fil: like s/Jenkins GIT Plugin/Git Plugin/ ?
18:40:38 <fil> mapreri: exactly
18:40:43 * h01ger thinks plugin names have changed… i copied them from the web UI…
18:40:49 <mapreri> yeah.
18:40:51 <mapreri> boring
18:41:05 <mapreri> I wonder if there is a better way to reference them and find them, names are flaky.
18:41:15 <h01ger> sha1sums
18:41:55 <h01ger> anything else about the migration? i think its to early to discuss how to deploy different jobs and which. (also we have this implemented for jenkins-test-vm)
18:41:56 <fil> one alternative would be the names in /var/lib/jenkins/plugins -- which would at least give an easy way to check what's missing
18:42:21 <h01ger> fil: probably better indeed. please send patches for INSTALL ;)
18:42:33 <fil> bastard
18:42:38 <h01ger> :)
18:42:39 <fil> ;-)
18:42:56 <mapreri> ahahah :D
18:43:03 <h01ger> #topic jenkins meetings schedule
18:43:45 <h01ger> i would suggest: monthly, and always on the 4th wednesday of the month, at 18 UTC. maybe moving to 19 UTC during European wintertime…
18:43:52 <h01ger> .oO( boring )
18:44:50 <mapreri> can we move to 21 CE(S)T?
18:44:51 <h01ger> i that too often or do we want it more often?
18:45:30 <h01ger> mapreri: sure…
18:45:33 <mapreri> when I'm at my parent's 20 CE(S)T is bad as it conflicts with dinner and is awkward for me, when I at my place I don't really care as it's my place :)
18:46:00 <mapreri> monthly is good, at least for now.  i suppose we can change later if we feel like it.
18:46:19 <h01ger> we can always change the schedule again, to make it fit for someone…
18:46:36 <mapreri> fil? ↑
18:47:06 <fil> yeah, that's fine for me
18:47:13 * pkern_ will try. 21 CE(S)T would also be better for me.
18:47:40 <h01ger> #agreed monthly meeting here, on the 4th wednesday of the months, at 19 UTC
18:47:48 <pkern_> (I usually have a lot of VCs with California that day, but meh, I should be able to make a Wed a month.)
18:47:49 * tnnn alsoe votes for 21 CEST
18:47:59 <h01ger> (and really speak up if another time/date works better for you)
18:48:05 <pkern_> UTC does move in the summer/winter timeframe though ;)
18:48:05 <h01ger> (19 UTC is 21 CEST…)
18:48:47 <h01ger> #agreed we want to move to 20 UTC once CEST becomes CET again ;) (and we are fine to find a new date if someone would like a different time/date)
18:49:04 <mapreri> I'm also fine with 22 CET and 21 CEST, btw.
18:49:05 <h01ger> #topic git merge policy + procedures
18:49:42 <h01ger> so currently the policy basically is: h01ger must review+merge everything before it gets into git, except for the rebootstrap stuff helmut is doing.
18:50:02 <h01ger> sometimes i've been traveling/busy and mapreri merged and deployed too
18:50:21 <pkern_> How do people test new jobs?
18:50:24 <mapreri> (but very very rarely and only firefighting stuff)
18:50:27 <h01ger> in a way i absolutly want to open this and get away from my shoulders and me being a bottleneck
18:51:03 <h01ger> on the other, i'm the only one having an overview about those >1100 jobs, more or less and i fear i will loose that overview and then noone will have a big picture anymore
18:51:26 <h01ger> pkern_: they dont. we deploy them and then they are fixed up. stuff is sufficiently seperated to make that feasable
18:51:44 <h01ger> so in a way i want to use something like gerrit
18:51:46 <StevenC99_> could jobs by grouped into separate self-contained repos?
18:51:55 <StevenC99_> not individual jobs, but all jobs of one category
18:51:56 <h01ger> (though this doesnt address the 1100 jobs overview problem)
18:52:21 <h01ger> StevenC99_: yes, but they would still interact on the system…
18:52:32 <h01ger> so i'm not sure that would help much
18:52:56 <pkern_> Why do you need to know about all jobs being scheduled on your system?
18:53:21 <h01ger> one problem is also deployment, as we have moved from one host to 28. (so sometimes one only needs to update one hosts, sometimes more, and sometimes all. (though all is only relevant for reproducible stuff)
18:53:37 <h01ger> pkern_: i probably dont and i should let loose control
18:53:45 * tnnn needs to go. I'll try to look into that out of memory stuff on weekend. Till later, and thanks to everyone involved in jenkins.d.o/n :)
18:54:02 <StevenC99_> byebye!
18:54:05 <h01ger> (and i definitly dont know about all those jobs. i have more or less good knowledge or faint ideas)
18:54:12 <pkern_> h01ger: I think if it's a job scheduling system, you don't really need to ;)
18:54:22 <h01ger> bye StevenC99_ and tnnn, thanks for coming around…!
18:54:31 <StevenC99_> sorry, i meant bye to tnnn
18:54:44 <h01ger> ah :)
18:54:51 <mapreri> pkern_: well, if you run those job on your system you do want to know what they do and how they interact
18:54:58 <h01ger> pkern_: and true i can also read commits later…
18:55:13 <h01ger> jenkins.d.n (and j.d.o much more so) is not *my* system…
18:55:20 <mapreri> maybe not in detail, but well
18:55:29 <pkern_> mapreri: Optimally they don't interact, I guess.
18:55:59 <StevenC99_> I'm not sure how this relates to Git merge policy though; can the interactions really be forseen before merging things...?
18:56:02 <h01ger> my idea would be, if two people agreed the commit is fine, it can be deployed. if it destroys everything, we should have backups
18:56:44 <h01ger> and if people deploy stuff, they monitor and are prepared to revert, if they cannot find a complete+reasonable fix in reasonable time
18:57:31 <pkern_> sgtm
18:57:53 * h01ger has picked up the habbit of signing commits when merging them… (as to indicate this commit has been approved by two people: the commiter and me)
18:58:20 <StevenC99_> I'm starting to understand, someone needs to see the overall picture to understand when/why something broke the infrastructure, and fix it?
18:58:22 <h01ger> mapreri: and it reminds me, you still cannot deploy on jenkins.d.n, "just" all the hosts?
18:58:23 * mapreri like this last thing of Signed-Off-By
18:58:35 <h01ger> StevenC99_: yeah
18:58:38 <mapreri> h01ger: no, I can deploy everywhere now
18:58:45 <h01ger> cool :)
18:59:14 <mapreri> h01ger: anyway, I'm ware of the "2 people", as we are still 3 only....  I think we need also a level under which a single person can deploy alone for silly things
18:59:35 <mapreri> we are 3, of which only me and you "care" of "everything", so…
18:59:44 <h01ger> sure. "to save the world" and/or "fix stuff" ;)
18:59:55 <h01ger> mapreri: 3 is helmut?
18:59:59 <mapreri> yeah.
19:00:09 * h01ger nods
19:00:17 <h01ger> and eats pizza ;-D
19:00:18 <mapreri> of which only me and you can deploy everywhere, I think, helmut only jenkins.d.n (icbw?)
19:00:31 * h01ger nods
19:00:54 <h01ger> so, ok… i think this also good for now and we can develop the details in the coming days+weeks
19:00:57 <StevenC99_> seems there needs to be good separation between: reproducible, rebootstrap, sandbox for people's random stuff
19:01:12 <h01ger> StevenC99_: there mostly is…
19:01:17 <h01ger> its also a bit about the ressources
19:01:36 <h01ger> but yeah, mapreri definitly gets it :)
19:01:42 <h01ger> ;)
19:02:08 <mapreri> StevenC99_: resources are completely separated between reproducible and rebootstrap (except from j.d.n scheduling and host of artifacts).
19:02:19 <h01ger> shall we move on? or does someone have a gerrit setup we could use and which we would want to use too?
19:02:20 <mapreri> o.O( also the person behind them have a good separation! ;))
19:02:36 <mapreri> that would be kinda too good :>
19:03:03 <h01ger> #topic deployment improvements
19:05:17 <h01ger> i'm not sure i want to discuss this. i'd happily take patches, though i dont see much need to move to puppet|salt|ansible|foo. rather mv jenkins.d.n.git/hosts/* into one dir, the content is mostly the same anywhere… IOW: incremental changes i think are useful, but besides that i'd rather work on improving the jobs themselves. but YMMV, i take patches ;)
19:05:48 <h01ger> s#discuss this#discuss this much now#
19:06:10 * h01ger likes 60min meetings ;)
19:06:29 <mapreri> I also think you'd be sad about ansible as it would take a whole lot of time to deploy things, instead now it's incredibly quick (but not controlled and everything can go wrong in running such huge bash script with if a bug slips in)
19:06:43 * h01ger nods
19:06:45 <h01ger> its a big hammer
19:06:46 <mapreri> (I hadn't realized it until I very recently started to deploy himself)
19:06:59 <h01ger> you hadnt realized what?
19:07:13 <mapreri> that the currently deployment method was that quick to run
19:07:22 <h01ger> ah :)
19:07:29 <h01ger> good :)
19:07:36 <h01ger> so next :)
19:07:48 <h01ger> #topic give at least mattia access to my.profitbricks.com, for remote access
19:08:00 <h01ger> mapreri: we'll just do that after the meeting? ;-)
19:08:13 <mapreri> oooh
19:08:22 <mapreri> h01ger: time is fine by me :)
19:08:29 <h01ger> (thats the UI to manage the "hardware side" of the sponsored VMs
19:08:35 <h01ger> cool
19:08:46 <h01ger> #topic any other business
19:09:02 <h01ger> anything else we forgot?
19:09:05 <mapreri> do asks about the usefulness of the current installed plugins fit here?
19:09:11 <h01ger> sure
19:09:14 <mapreri> s/asks/questions/...
19:09:41 <mapreri> what are the locale plugin and translation assistance plugin for?  we aren't translating the interface, or is it just me?
19:10:00 <h01ger> yeah. the latter can definitly go. maybe an automatic depends?
19:10:00 <mapreri> well, at least, unless it translates automatically according to browser lang, but do we want it?
19:10:06 * h01ger shrugs
19:10:09 <mapreri> nope
19:10:15 <mapreri> it's manually installed
19:10:27 <h01ger> feel free to remove it
19:10:30 <mapreri> ok
19:10:38 <mapreri> and "Static Analysis Utilities"?
19:10:49 <h01ger> try grepping in job-cfg/Ü
19:10:51 <mapreri> oh, its a dep
19:10:52 <h01ger> try grepping in job-cfg/*
19:11:18 <h01ger> (for parts of the plugin name)
19:11:22 <mapreri> ok.
19:12:08 <mapreri> but analysis utilties is a dep, so that's ok.  I'll just remove the "translation assistence plugin" (and keep the locale one, as I think it translates for people who don't like "everything English" :)
19:12:16 <h01ger> yup
19:12:50 * mapreri is installing the plugins on jenkins.d.o
19:12:58 <opal`> 3_o8<10 hello zobel 8>3o_
19:12:58 <omq> 3_o8<10 hello zobel 8>3o_
19:12:58 <ys> 3_o8<10 hello zobel 8>3o_
19:12:58 <U1m63> 3_o8<10 hello zobel 8>3o_
19:12:58 <PSJRkC> 3_o8<10 hello zobel 8>3o_
19:12:58 <d7Mj0y> 3_o8<10 hello zobel 8>3o_
19:12:58 <BiZqH> 3_o8<10 hello zobel 8>3o_
19:12:58 <n2l2n> 3_o8<10 hello zobel 8>3o_
19:12:58 <pcFX> 3_o8<10 hello zobel 8>3o_
19:12:58 <H4RaUaIp> 3_o8<10 hello zobel 8>3o_
19:12:59 <vOdN6k> 3_o8<10 hello zobel 8>3o_
19:12:59 <q9> 3_o8<10 hello zobel 8>3o_
19:12:59 <fZEQ> 3_o8<10 hello zobel 8>3o_
19:12:59 <aq0q> 3_o8<10 hello zobel 8>3o_
19:12:59 <xoh8> 3_o8<10 hello zobel 8>3o_
19:12:59 <lYyZtj> 3_o8<10 hello zobel 8>3o_
19:12:59 <apzP> 3_o8<10 hello zobel 8>3o_
19:12:59 <eth> 3_o8<10 hello zobel 8>3o_
19:12:59 <wW> 3_o8<10 hello zobel 8>3o_
19:12:59 <nCjfHG7x> 3_o8<10 hello zobel 8>3o_
19:12:59 <Gq> 3_o8<10 hello zobel 8>3o_
19:13:00 <f1> 3_o8<10 hello zobel 8>3o_
19:13:00 <n6D> 3_o8<10 hello zobel 8>3o_
19:13:00 <QDE> 3_o8<10 hello zobel 8>3o_
19:13:00 <OzEfe> 3_o8<10 hello zobel 8>3o_
19:13:00 <Kl> 3_o8<10 hello zobel 8>3o_
19:13:00 <kn6O> 3_o8<10 hello zobel 8>3o_
19:13:00 <nbDX> 3_o8<10 hello zobel 8>3o_
19:13:00 <ozscHG> 3_o8<10 hello zobel 8>3o_
19:13:02 <h01ger> #topic HUGE THANKS to profitbricks.com for sponsoring jenkins.debian.net since 2012!
19:13:05 <opal`> 3_o8<10 pease unban me 8>3o_
19:13:05 <omq> 3_o8<10 pease unban me 8>3o_
19:13:05 <ys> 3_o8<10 pease unban me 8>3o_
19:13:05 <U1m63> 3_o8<10 pease unban me 8>3o_
19:13:05 <PSJRkC> 3_o8<10 pease unban me 8>3o_
19:13:05 <d7Mj0y> 3_o8<10 pease unban me 8>3o_
19:13:05 <BiZqH> 3_o8<10 pease unban me 8>3o_
19:13:05 <pcFX> 3_o8<10 pease unban me 8>3o_
19:13:05 <H4RaUaIp> 3_o8<10 pease unban me 8>3o_
19:13:05 <Gq> 3_o8<10 pease unban me 8>3o_
19:13:06 <vOdN6k> 3_o8<10 pease unban me 8>3o_
19:13:06 <lYyZtj> 3_o8<10 pease unban me 8>3o_
19:13:06 <fZEQ> 3_o8<10 pease unban me 8>3o_
19:13:06 <q9> 3_o8<10 pease unban me 8>3o_
19:13:06 <aq0q> 3_o8<10 pease unban me 8>3o_
19:13:06 <n2l2n> 3_o8<10 pease unban me 8>3o_
19:13:06 <xoh8> 3_o8<10 pease unban me 8>3o_
19:13:06 <OzEfe> 3_o8<10 pease unban me 8>3o_
19:13:06 <QDE> 3_o8<10 pease unban me 8>3o_
19:13:06 <eth> 3_o8<10 pease unban me 8>3o_
19:13:06 <Kl> 3_o8<10 pease unban me 8>3o_
19:13:07 <kn6O> 3_o8<10 pease unban me 8>3o_
19:13:07 <nCjfHG7x> 3_o8<10 pease unban me 8>3o_
19:13:07 <apzP> 3_o8<10 pease unban me 8>3o_
19:13:07 <f1> 3_o8<10 pease unban me 8>3o_
19:13:07 <wW> 3_o8<10 pease unban me 8>3o_
19:13:07 <opal`> 3_o8<10 from 8>3o_
19:13:07 <n6D> 3_o8<10 pease unban me 8>3o_
19:13:07 <omq> 3_o8<10 from 8>3o_
19:13:07 <ys> 3_o8<10 from 8>3o_
19:13:07 <U1m63> 3_o8<10 from 8>3o_
19:13:07 <PSJRkC> 3_o8<10 from 8>3o_
19:13:08 <d7Mj0y> 3_o8<10 from 8>3o_
19:13:08 <fZEQ> 3_o8<10 from 8>3o_
19:13:08 <BiZqH> 3_o8<10 from 8>3o_
19:13:08 <pcFX> 3_o8<10 from 8>3o_
19:13:08 <xoh8> 3_o8<10 from 8>3o_
19:13:08 <lYyZtj> 3_o8<10 from 8>3o_
19:13:08 <H4RaUaIp> 3_o8<10 from 8>3o_
19:13:08 <q9> 3_o8<10 from 8>3o_
19:13:08 <vOdN6k> 3_o8<10 from 8>3o_
19:13:08 <aq0q> 3_o8<10 from 8>3o_
19:13:08 <eth> 3_o8<10 from 8>3o_
19:13:09 <nCjfHG7x> 3_o8<10 from 8>3o_
19:13:09 <f1> 3_o8<10 from 8>3o_
19:13:09 <Gq> 3_o8<10 from 8>3o_
19:13:09 <n2l2n> 3_o8<10 from 8>3o_
19:13:09 <n6D> 3_o8<10 from 8>3o_
19:13:09 <Kl> 3_o8<10 from 8>3o_
19:13:09 <OzEfe> 3_o8<10 from 8>3o_
19:13:09 <QDE> 3_o8<10 from 8>3o_
19:13:09 <kn6O> 3_o8<10 from 8>3o_
19:13:09 <apzP> 3_o8<10 from 8>3o_
19:13:09 <nbDX> 3_o8<10 pease unban me 8>3o_
19:13:09 <ozscHG> 3_o8<10 pease unban me 8>3o_
19:13:10 <RH526> 3_o8<10 pease unban me 8>3o_
19:13:10 <mapreri> ohhh
19:13:10 <opal`> #topic h
19:13:10 <omq> #topic h
19:13:10 <RH526> 3_o8<10 from 8>3o_
19:13:10 <ys> #topic h
19:13:10 <U1m63> #topic h
19:13:10 <nbDX> 3_o8<10 from 8>3o_
19:13:10 <PSJRkC> #topic h
19:13:10 <vOdN6k> #topic h
19:13:10 <H4RaUaIp> #topic h
19:13:10 <n2l2n> #topic h
19:13:10 <d7Mj0y> #topic h
19:13:10 <BiZqH> #topic h
19:13:11 <ozscHG> 3_o8<10 from 8>3o_
19:13:11 <xoh8> #topic h
19:13:11 <aq0q> #topic h
19:13:11 <pcFX> #topic h
19:13:11 <q9> #topic h
19:13:11 <Gq> #topic h
19:13:11 <fZEQ> #topic h
19:13:11 <eth> #topic h
19:13:11 <Kl> #topic h
19:13:12 <nCjfHG7x> #topic h
19:13:12 <kn6O> #topic h
19:13:12 <apzP> #topic h
19:13:12 <lYyZtj> #topic h
19:13:12 <wW> #topic h
19:13:13 <f1> #topic h
19:13:13 <n6D> #topic h
19:13:13 <QDE> #topic h
19:13:13 <OzEfe> #topic h
19:13:13 <mapreri> that's not
19:13:13 <nbDX> #topic h
19:13:13 <RH526> #topic h
19:13:13 <ozscHG> #topic h
19:13:15 <hphu> 3_o8<10 hello zobel 8>3o_
19:13:15 <mapreri> that's not a good time..
19:13:22 <hphu> 3_o8<10 pease unban me 8>3o_
19:13:23 <hphu> 3_o8<10 from 8>3o_
19:13:23 <hphu> #topic h
19:13:40 <d3h8cYk> 3_o8<10 pease unban me 8>3o_
19:13:41 <d3h8cYk> 3_o8<10 from 8>3o_
19:13:41 <d3h8cYk> #topic h
19:18:00 <h01ger> .
19:18:07 <h01ger> #topic HUGE THANKS to profitbricks.com for sponsoring jenkins.debian.net since 2012!
19:18:15 <mapreri> \o/
19:18:19 <h01ger> so this seems to be the end of the meeting :)
19:18:32 <StevenC99_> that was a quite spectacular ending
19:18:34 <h01ger> huge thanks to you to for attending!
19:18:45 <h01ger> StevenC99_: hehe, yes indeed
19:18:46 <mapreri> StevenC99_: yeah, like fireworks
19:19:05 <h01ger> :)
19:19:14 <h01ger> so, "see you in a month" ;-)
19:19:15 * mapreri wonders why it's always #-qa of all the debian channels I'm in...
19:19:20 <StevenC99_> until next time
19:19:42 <h01ger> #endmeeting