12:00:01 <zack> #startmeeting
12:00:01 <MeetBot> Meeting started Fri Dec 12 12:00:01 2014 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:01 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:06 <zack> #chairs zack matthieucan
12:00:10 <zack> #chair zack matthieucan
12:00:10 <MeetBot> Current chairs: matthieucan zack
12:00:24 <zack> #topic weekly review
12:00:39 <zack> sophiejjj: let's go through the plan for the past week, shall we?
12:00:48 <sophiejjj> yeah.
12:01:03 <zack> so, "ls -l"
12:01:10 <zack> it looks like done, or do you want to make other changes?
12:01:28 <sophiejjj> I think it's fine, extra changes could be done in new ticket.
12:01:33 <matthieucan> I really like the look of it :)
12:01:39 <zack> ok, so I'll integrate and deploy the patch
12:01:51 <zack> #action zack to merge patch for #763921
12:02:10 <zack> sophiejjj: how about #762946 (multiple pop-up messages)? anything done on that front?
12:02:17 <sophiejjj> no.
12:02:22 <sophiejjj> single threaded mode.
12:02:39 <zack> sophiejjj: ok. Do you want to work on it next week, or shall we put it back in the backburner?
12:02:58 <sophiejjj> maybe backburner.
12:03:09 <zack> sophiejjj: ok, can you move the card on trello?
12:03:15 <sophiejjj> the next ticket is to increase the test coverage.
12:03:17 <sophiejjj> sure
12:03:31 <sophiejjj> done.
12:03:31 <matthieucan> what's the current coverage?
12:03:36 <sophiejjj> 79%
12:03:52 <zack> ok, coverage
12:04:00 <zack> sophiejjj: dare to set an objective for next week on that front?
12:04:06 <matthieucan> we're still on the plan of adding a few percents per week?
12:04:16 <zack> note, I think it could be quite boring to work *only* on that, so I suggest alternating between test coverage and other stuff
12:04:19 <sophiejjj> 85?
12:04:28 <zack> sounds good to me
12:04:32 <matthieucan> yes
12:04:33 <sophiejjj> I haven't added 1 percent, though.
12:04:40 <zack> eh :)
12:04:47 <zack> sure, but you started only now, so that's totally ok
12:05:30 <zack> sophiejjj: can you add the item to trello for week n.2? (I've created the corresponding list already)
12:05:31 * sophiejjj can bare the boringness.
12:05:55 <matthieucan> sophiejjj: side question: do the icons work with flask server now?
12:06:00 <zack> but we do *not* want you to be bored! :)
12:06:35 <sophiejjj> aha. Haven't done that, due to the afraid of git pach origin/master updated thing. I will check it now.
12:07:14 <zack> sophiejjj: please do it later
12:07:22 <zack> so that we can focus on the meeting and then we all have our action items
12:08:01 <zack> sophiejjj: how about the reading items? MDN and flask?
12:08:09 <sophiejjj> mostly the MDN
12:08:25 <zack> sophiejjj: ok, please archive the corresponding item them
12:08:25 * sophiejjj didn't touch the blueprint thing yet. sorry.
12:08:33 <zack> sophiejjj: no problem, just move it to next week
12:09:03 <sophiejjj> and what about the infra?
12:09:06 <sophiejjj> what's the for?
12:09:15 <zack> i'll get to that in a minute
12:09:32 <zack> sophiejjj: what else do you llike to work on next week? I've put some stuff I think is high priority on the backburner list
12:09:37 <zack> can you have a look and pick some?
12:09:59 <sophiejjj> 761121
12:10:14 <zack> great, and it's also related to your recent work, so it make sense
12:10:23 <sophiejjj> yup.
12:10:33 <zack> sophiejjj: I think #761861 should be easy enough too and very useful
12:10:48 <zack> if you agree it's doable, can you pick that one up too?
12:11:16 <sophiejjj> aha got it.
12:11:23 <sophiejjj> moved.
12:11:28 <zack> cool
12:11:41 <zack> so, regarding the infra
12:12:03 <zack> we should have all the needed resources on sor.d.o, but I have only checked out the debsources code on /srv/sources.debian.org
12:12:11 <zack> there is work for me there for now
12:12:29 <zack> sophiejjj: if you could just check if the basics (as per HACKING) work on the machine, that would be great
12:12:34 <zack> I'll do the "real" setup later on
12:12:44 <sophiejjj> after meeting?
12:12:55 <zack> I was thinking next week, but it's when you want
12:13:05 * sophiejjj goes to add a card.
12:13:07 <zack> should be quick, I'll just need to you you the postgres credential
12:13:12 <zack> there is one already, it's "have "make test" work on sor.d.o"
12:13:14 <zack> on the right
12:13:17 <zack> just move it
12:14:05 <zack> (thanks)
12:14:15 <sophiejjj> moved.
12:14:22 <sophiejjj> no delete option. only archive?
12:14:44 <zack> I think there is delete if you do edit, but yes, it sucks :)
12:15:14 <zack> sophiejjj: sounds like a very decent hacking plan for next week, what do you think?
12:15:26 * sophiejjj nods.
12:15:36 <zack> sophiejjj: are you familiar with debian/copyright files?
12:15:41 <sophiejjj> no.
12:16:03 <sophiejjj> but I am very interested in debian itself.
12:16:10 <zack> ok, so, the very last "reading" thing I propose is...
12:16:20 <sophiejjj> like how it works, etc. (though not quite pertain to debsources)
12:16:35 <zack> the one I've just added to week 2
12:16:41 <zack> "read machine-readable debian/copyright spec"
12:16:46 <sophiejjj> yeah. I see it.
12:16:48 <zack> there is a link to the actual doc in the description
12:16:50 <zack> it's short
12:17:00 <sophiejjj> cool.
12:17:01 <zack> and it's realted to a secret plan I've for sources.d.n in the near future *g*
12:17:10 <matthieucan> is the plan to have new metadata info on packages regarding copyrights?
12:17:23 <zack> I'll prepare a draft and share if with you all
12:17:36 <zack> but essentially I'd like to have a portal that presents all machine-parseable d/copyright info
12:17:41 <zack> and that's fairly easy to do on top of debsources
12:17:53 <zack> ... and it'd be nice to design it as a flask blueprint
12:18:02 <zack> (hence the other reading I suggested)
12:18:02 <matthieucan> that looks cool!
12:18:11 <zack> it does! :)
12:18:17 * sophiejjj is at a loss, but blueprint seems indispensable.
12:18:31 <zack> sophiejjj: no worries, I'll give more info later on
12:18:44 <zack> I'm at loss *myself* with blueprints, they look cool, but I've never really used them
12:18:49 <sophiejjj> aha. presents all licsences files, extracting them from the source?
12:18:53 <zack> so I'm OK with learning a thing or two about them together
12:19:05 <zack> sophiejjj: that's sort of the idea, yes
12:19:38 <zack> sophiejjj: it would allow you to also somehow work on a part of debsources "from scratch", and having quite a bit of design freedom, in case you like the idea
12:19:39 <matthieucan> blueprints are a bit painful regarding correct imports of the app
12:19:44 <matthieucan> but it's doable for sure
12:20:05 <sophiejjj> that sounds cool.
12:20:09 <zack> anyway, that's not for next week :), let's just learn the background technologies for now
12:20:20 <zack> ok, looks like we have a plan for next week
12:20:25 <sophiejjj> yes.
12:20:26 <zack> #topic feedback
12:20:35 <zack> sophiejjj: any feedback about this first week?
12:20:59 <zack> please tell us how it went, if you are happy, not happy, blocked on something, *anything* we could do to help more
12:21:12 <sophiejjj> yeah. I am thinking.
12:22:08 <sophiejjj> I think, say, the ls -l bug, shouldn't take me much time. But I am blocked by the css, the lstat weird result, etc.
12:22:37 <zack> well, underestimating what we can achieve in a given time period is entirely normal
12:22:50 <zack> also, this week was shorter than an actual week
12:22:56 <sophiejjj> things don't go as smooth as I expected. For example, I originally think, the filetype is like a bitwise of the mode bits, but it's not.
12:23:24 <sophiejjj> ^^ just for example, the above sentence is not human comprehensible.
12:23:39 <zack> (actually, it is ;))
12:23:58 <sophiejjj> and then I set back and think what makes the problem, and time flies by.
12:24:10 <zack> don't worry about that, really
12:24:27 <zack> let's just see if we get better over time at setting objectives
12:24:45 <zack> as long as you enjoyed hacking and made good use of the past week, that's fine
12:24:55 <sophiejjj> it's cool.
12:24:58 <zack> cool
12:24:59 <sophiejjj> TIL everyday.
12:25:15 <zack> anything else?
12:25:41 <sophiejjj> the interesting part of taking part in programs like opw is, by diving into a real working system, I will see a lot of problems I wasn't aware of before.
12:25:58 <sophiejjj> feeling good. nothing else I guess.
12:26:03 <zack> yup
12:26:05 <zack> and great!
12:26:14 <zack> sophiejjj: before I forget, do not forget to blog about your first week
12:26:27 <zack> sophiejjj: do you want to add an item about that?
12:26:28 <sophiejjj> got it.
12:26:31 <matthieucan> sophiejjj: what's your blog url?
12:26:50 <sophiejjj> sophiejjj.wordpress.com
12:26:52 <zack> matthieucan: pro tip: if you go to planet.d.o, you've on the right a list of blog links for all participants
12:26:54 <matthieucan> thanks
12:27:17 <zack> #topic next meeting
12:27:18 <matthieucan> zack: indeed, I forgot this option. thanks
12:27:32 <zack> sophiejjj, matthieucan: so, very last point on the "agenda", next meeting
12:27:37 <zack> same time/place next week?
12:27:52 <matthieucan> it's fine for me
12:28:05 <sophiejjj> fine for me too
12:28:05 <matthieucan> sandwich at work, perfect :)
12:28:16 <zack> (FWIW, I'll try to come with a real/organized agenda next time)
12:28:17 <zack> #agreed next meeting 1 week from now, same time/place
12:28:21 <zack> matthieucan: eh, same here :)
12:28:23 <zack> great
12:28:32 <zack> #topic additional business
12:28:39 <zack> anything else, or can we adjourn?
12:29:03 <sophiejjj> hmm. nothing.
12:29:38 <zack> cool, let's end this then
12:29:40 <zack> #endmeeting