12:28:33 <pjain> #startmeeting
12:28:33 <MeetBot> Meeting started Tue Feb  9 12:28:33 2021 UTC.  The chair is pjain. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:28:33 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:28:58 <pjain> Hi JaminyP srud
12:29:03 <srud> hi
12:29:11 <Jaminy> Hi
12:29:24 <pjain> Do you know Abhijith's nick?
12:29:25 <srud> bhe[m]: You here?
12:30:31 <srud> let us wait for a minute or two for bhe[m] to join.. then we can start
12:30:35 <pjain> Sure
12:30:41 <Jaminy> Okay
12:32:31 <srud> I think we can start..
12:32:33 <pjain> Let us start, bhe[m] would be able to see the logs once he joins
12:32:50 <pjain> #topic Debian participation in Outreach activities 2021
12:32:54 <Jaminy> Yes, I sent a mail
12:33:03 <pjain> We are currently planning to participate in GSoC 2021 as well as Outreachy May 2021 round. Are there any upfront concerns regarding the same before we go into the details?
12:33:31 <srud> only main change we should consider is gsoc revised timeline
12:34:04 <pjain> Yes - I think timeline remains quite same but overall the program structure has changed
12:34:10 <srud> I think we need not worry about that because Debian will definitely have projects of all sizes
12:34:23 <srud> what I meant is dedicated hours
12:34:49 <pjain> Mentors now need to define projects with the scope of 175 hrs per project instead of ~350
12:35:08 <srud> yes, when we do call for proposals, we can specify that
12:35:40 <pjain> Yes. Usually our project scope are quite big and it doesn't gets completed in 350 hours also
12:36:11 <pjain> We need to focus more on defining clear end goals and deliverables for each project and it should be attainable within ~175 hours.
12:36:21 <srud> but we might have smaller projects which never get proposed because of 350 hour requirement
12:36:27 <pjain> Ofcourse, students can always continue to work on their projects outside GSoC later on
12:37:08 <pjain> srud: Agreed. We need more messaging/communication around new 175hrs rule in the Debian community
12:37:24 <pjain> Ideally we should be getting more projects and students with this new rule
12:37:28 <srud> yes, we should start off a discussion on this asap
12:37:44 <pjain> Sure.
12:37:58 <pjain> As of now, we are using wiki pages to organize GSoC: https://wiki.debian.org/SummerOfCode2020
12:38:11 <Jaminy> Yes, mentors should be aware of this as well when proposing the project.
12:38:28 <pjain> I think we can continue doing the same with few changes (like more explicit calling out the new rules)
12:38:29 <srud> we need to update the wiki
12:38:43 <pjain> Yes, we need to set the new page for 2021 GSoC
12:38:59 <pjain> Someone wants to take that action item?
12:39:21 <srud> I think first we can register, then update the wiki, do call for proposals..
12:39:29 <srud> I do not mind taking that
12:39:35 <pjain> Thanks srud
12:39:44 <pjain> Registration on the portal can be done anytime until the deadline
12:39:51 <srud> I think bhe[m] might also be interested.. will coordinate with him
12:40:01 <Jaminy> Yes, we should start the application before updating the wiki
12:40:06 <pjain> We need to submit tentative list of ideas as well number of mentors while registering on the portal
12:40:25 <srud> ohk.. I was aware of that requirement
12:40:26 <pjain> #action srud to create GSoC 2021 wiki pages
12:40:43 <srud> then I am not sure we have enough time to collect proposals
12:40:53 <pjain> #action pjain to start application for GSoC on Google portal
12:41:07 <pjain> srud: We don't need all the ideas right now but few of them to start with
12:41:17 <srud> ohks
12:41:19 <pjain> Here is the timeline: https://developers.google.com/open-source/gsoc/timeline
12:41:58 <Jaminy> I can also help in starting the organization application.
12:42:03 <pjain> Ideally we should have all the selected projects listed on the wiki by March 15
12:42:14 <pjain> Jaminy: okay
12:42:47 <pjain> I think once the wiki page is up, we can send out a community wide notification asking mentors to submit their ideas
12:43:19 <srud> this time the call should highlight the changes
12:43:27 <srud> *changed rules
12:43:41 <pjain> We can give Feb 25th deadline for them to submit the ideas. And then we can take couple of weeks to approve (or reject) them
12:43:46 <pjain> srud: Yes, it will
12:44:45 <pjain> Also, earlier we used to encourage all the mentors to submit their ideas for both GSoC and Outreachy in order to promote Outreachy more
12:45:01 <pjain> But now GSoC and Outreachy has separate commitment hours per project
12:45:15 <srud> how much is outreachy hours?
12:45:19 <pjain> So many ideas might not be cross posted but we should still encourage
12:45:40 <pjain> I need to find the official number but afaik it is ~350 same as GSoC (until 2020)
12:45:53 <srud> ohks
12:46:22 <srud> we can encourage
12:46:53 <pjain> I think we can use the same community wide mails to announce Debian's participation in both the programs
12:46:59 <srud> some projects might be flexible with increasing and decreasing hours
12:47:03 <pjain> Yes
12:47:10 <Jaminy> Yes
12:47:20 <pjain> I think instead of having a wiki for GSoC 2021, we should have wiki page for Outreach2021
12:47:35 <srud> one thing I think we should do is giving more publicity for the cfp
12:47:37 <pjain> and it should list out rules for both as well as allow mentors to submit their ideas on wiki for GSoC 2021
12:47:45 <Jaminy> But still it's a 3 month program...so they can invest the extra hours on improving it or something?
12:48:12 <pjain> srud: Agreed! We will publish it on Debian Bits etc
12:48:25 <pjain> Jaminy: Do you mean wrt to GSoC?
12:48:30 <Jaminy> Yes
12:48:30 <srud> Outreach 2021 page sounds fine
12:48:38 <srud> I can take up that then
12:48:50 <pjain> Jaminy: Yes, they can continue working post GSoC too.
12:48:55 <pjain> thanks srud
12:49:18 <pjain> We used to have wiki pages for Outreachy but then we dropped them at some point of time: https://wiki.debian.org/Outreachy/Round17?action=show&redirect=Outreachy
12:49:34 <pjain> Outreachy projects are to be uploaded directly on the outreachy website and not our wiki
12:49:57 <Jaminy> We also need to decide on how we are going to divide project for GSoC & Outreachy?
12:50:28 <srud> pjain: we can still have a wiki with information
12:50:32 <pjain> Jaminy: I think that is more of a mentors' call rather than us
12:51:02 <Jaminy> Okay
12:51:08 <pjain> Yes, I think Outreach2021 page can act as a central page with all the information regarding both the programs and it can link to a separate wiki page for mentors to upload ideas for GSoC 2021
12:51:43 <srud> also we can link to outreachy website to propose their projects there directly
12:51:52 <pjain> srud: Yes
12:52:14 <srud> so I am taking responsibility for the wiki
12:52:24 <srud> who will be taking responsibility for mail?
12:52:33 <pjain> srud: Thanks
12:52:37 <Jaminy> I can take that up.
12:52:48 <Jaminy> For mail
12:52:50 <srud> I think Jaminy agreed to do portal registration right?
12:53:04 <srud> or did I misunderstand?
12:53:07 <pjain> #action Jaminy to draft emails to communicate about our participation
12:53:12 <Jaminy> I and Pranav will be doing it together
12:53:18 <pjain> srud: I am doing the portal registration work along with Jaminy
12:53:21 <srud> ohks
12:53:31 <pjain> #topic Guidelines
12:53:45 <srud> Guidelines regarding?
12:53:52 <pjain> I am still in strong favor of having these same guidelines for both the programs
12:53:53 <pjain> https://wiki.debian.org/SummerOfCode2020#Guidelines_for_GSoC_Projects_in_Debian
12:54:06 <pjain> srud: It is related to the projects/emntors that we accept for these programs
12:54:25 <srud> got it
12:54:38 <pjain> srud: We have formed these after lots of feedback and experiences..
12:54:44 <srud> are we planning any changes for this guidelines?
12:55:04 <pjain> srud: I am okay with the current version. Open to feedback
12:55:23 <srud> I cannot point out anything wrong right away
12:55:31 <pjain> "All projects must have at least one mentor with a formal affiliation to the Debian project or be widely recognized as a contributor to the Debian community"
12:55:44 <srud> I suppose the guideline is same for gsoc and outreachy
12:55:49 <pjain> Mentors are only mentors for one project (That applies to mentors and co-mentors)
12:56:06 <pjain> One exception to these is that we do allow same mentor to have one project in GSoC as well as one in Outreachy
12:56:14 <pjain> But not 2 projects in the same program
12:56:19 <pjain> We do that just to promote Outreachy more
12:56:35 <srud> sounds reasonable
12:56:53 <pjain> But ideally, co-mentors should be different so that attention to each student can be given fairly
12:57:52 <srud> I think we can stick on to the current guideline
12:57:56 <pjain> Great
12:58:04 <Jaminy> I am fine with original guideline
12:58:09 <pjain> #topic Outreachy funding
12:58:17 <srud> if bhe[m] has some suggestions, we can take up the call later
12:58:30 <pjain> I propose that we take approval for 2 intern slots as of now from the DPL
12:58:36 <pjain> We can always increase/decrease it
12:58:45 <srud> sounds ok to me
12:58:52 <Jaminy> Okay
12:59:00 <pjain> Great
12:59:01 <srud> last time it was unfortunate that we did not get any students
12:59:05 <pjain> Yes
12:59:12 <pjain> I think we got quite late last time to send announcements
12:59:23 <Jaminy> Yes, we need to increase the publicity
12:59:33 <pjain> #topic Timelines for Admin team
12:59:41 <Jaminy> The announcement was on time
12:59:52 <pjain> How about we send out an announcement this weekend?
13:00:03 <pjain> srud: Jaminy would wiki and email draft be ready by then?
13:00:08 <srud> I think we should do earlier than that
13:00:23 <srud> I will try to complete the wiki in a day or two
13:00:31 <srud> we should send the announcement asap
13:00:38 <pjain> Agree!
13:00:50 <srud> the mentors should also have enough time to work on proposal
13:00:54 <utkarsh2102> fwiw, it wasn't the delay but the quality of students interested weren't good enough to go ahead with.
13:01:05 <utkarsh2102> re: less students in outreachy last round.
13:01:18 <srud> utkarsh2102: agree
13:01:26 <Jaminy> Agreed!
13:01:33 <cdesai> that was for the winter round though, right?
13:01:37 <pjain> Yes, there were several projects without any proposal too
13:01:38 <Jaminy> yes
13:01:43 <utkarsh2102> yeah.
13:01:53 <pjain> Jaminy: when would you be able to get a draft for the email?
13:02:38 <Jaminy> I can send the final announcement by this weekend
13:02:41 <utkarsh2102> pjain: because they couldn't contribute -> because they couldn't understand -> because unfortunately interested people didn't have the right skills for the projects proposed.
13:03:10 <utkarsh2102> but anyway, please move ahead with the discussion^^
13:03:20 <utkarsh2102> thanks for all your work \o/
13:03:31 <Jaminy> we need your help in publicity
13:03:38 <pjain> utkarsh2102: Hmmm.. I think we also need to ramp up the efforts in helping students with the initial project taks and do bit of hand holding for newcomers but that need more resources and time
13:04:17 <pjain> Jaminy: please send us the draft whenever you are ready and we can then discuss it further
13:04:30 <Jaminy> Alrighto
13:04:39 <pjain> I don't have any more topics to discuss for this meeting. I think we are on a good start \o/
13:04:45 <pjain> srud: Jaminy do you have anything to discuss?
13:04:51 <srud> this weekend means 13 and we expect the proposal by 25th?
13:05:10 <srud> that sounds too soon for mentors to work on project ideas
13:05:27 <pjain> I think we would have to push the proposal dates. We can make it 27th
13:05:53 <pjain> And if we feel that mentors are asking for more time then we can try revisiting it again
13:06:05 <srud> I have a suggestion, we can send out a reminder mail saying -- hey we have gsoc and outreachy round the corner, be prepared with your projects. Detailed call will follow
13:06:26 <srud> this we can send today or tomorrow and by weekend send the detailed mail
13:06:57 <pjain> Also, if we are ready with the wiki front page by tomorrow then we can send that
13:07:04 <pjain> It will anyway have most of the details
13:07:15 <pjain> We can then work on project submission page over the week
13:07:25 <srud> ohks, will do that
13:07:42 <pjain> GSoC Deadline is Feb 19th and we do need at least few projects listed on our wiki till then
13:07:58 <pjain> Because Google will be evaluating our application based on that (one of the factors)
13:08:00 <srud> yes, earlier the better
13:08:26 <pjain> Yes, we can continue following on this action item over emails
13:08:32 <pjain> Do we have something else to discuss?
13:08:55 <srud> I have some ideas to increase our horizons
13:09:23 <pjain> srud: Nice! Do you want to discuss them in the meeting or over emails with bhe[m]  too?
13:09:29 <srud> Outreach team should not restrict ourselves to just gsoc and outreachy
13:09:40 <srud> over emails is not a good idea
13:10:04 <Jaminy> srud: we would like to hear them
13:10:05 <pjain> srud: Agree. We did have few ideas in past but then never got a chance to put resources/time to execute them
13:10:11 <srud> may be we can have a meeting sometime later when we are done with gsoc and outreachy proposal submission
13:10:50 <pjain> srud: Sure, let us meet sometime in March once we have things rolling for GSoC/Outreachy. Do you thinks that is okay?
13:10:54 <utkarsh2102> would y'all be interested in GSoD?
13:10:57 <utkarsh2102> Google Summer of Docs^
13:11:05 <srud> sounds good to me
13:11:19 <pjain> utkarsh2102: We applied for GSoD first round but weren't selected. (That time they selected very few organizations)
13:11:36 <utkarsh2102> yeah, probably this year?
13:11:38 <pjain> utkarsh2102:  We can surely try again if we have projects for that
13:11:58 <pjain> I would also like to have Debian's own innitatives along with the ones being run by Google
13:12:01 <utkarsh2102> Debian could really use some help w/ documentations :)
13:12:13 <pjain> But let us have this discussion sometime along with srud
13:12:23 <pjain> and thank you for suggestions :)
13:12:28 <srud> my actual suggestion is we should move forward from these Google and outreachy projects and have somethings tailor made for Debian
13:12:38 <utkarsh2102> pjain: Debian Summer of Code? :P
13:12:49 <srud> something on that lines
13:13:00 <pjain> srud: Yes, we thought about it earlier once afaik
13:13:16 <pjain> But if we have enough energy in time then we can surely have a discussion on this again
13:13:32 <pjain> *energy in team
13:13:43 <srud> I will put forward my ideas in detail in the next meeting
13:13:51 <pjain> srud: Thanks
13:14:02 <pjain> Do we have anything else to discuss? Jaminy srud ?
13:14:31 <srud> nothing from me now
13:14:56 <Jaminy> Let's send a summary mail so that Abhijith is aware about the meeting note.
13:15:02 <Jaminy> Nothing else.
13:15:07 <Jaminy> Thanks.
13:15:10 <pjain> Okay. Thanks for your time. Super excited to have srud and bhe[m] onboard.
13:15:50 <pjain> Anyone who is watching the conversation. Please feel to reach out to us at outreach@debian.org for suggestions/feedback
13:16:09 <pjain> I will end the meeting now. Thank You
13:16:19 <pjain> #endmeeting