20:06:22 <larjona> #startmeeting
20:06:22 <MeetBot> Meeting started Sun Dec  2 20:06:22 2018 UTC.  The chair is larjona. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:22 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:31 <larjona> #chair mollydb
20:06:31 <MeetBot> Current chairs: larjona mollydb
20:06:39 <mollydb> Oooh, power
20:06:48 <mollydb> Who is participating in the meeting?
20:07:27 * larjona says hello
20:07:31 * formorer 
20:07:55 <bhe_> *bhe
20:08:05 * pjain says Hola!
20:08:43 <mollydb> Great. Let's make a start.
20:09:12 <formorer> good
20:09:15 <pjain> Please set a topic :)
20:10:10 <mollydb> January 15th is then GSoC applications start, and they close February 6th. By that time, we ought to decide if there is enough interest for Debian to apply to participate. Application does -not- mean they'll accept us as a mentoring org.
20:10:39 <formorer> chances are however high that they do accept us
20:10:58 <pjain> #topic GSoC Deadline
20:11:14 <mollydb> I think that's true, as long as we pull together a good application, have enough mentors, etc.
20:11:36 <mollydb> I believe we can assume there's enough interest to apply again this year.
20:12:02 <pjain> Yes, I think it is fair to assume that
20:12:06 <formorer> hopefully
20:12:12 <mollydb> That's all I have to say on this, does anyone else have anything to add before we move onto our rules for participation?
20:12:48 <formorer> nothing from my side
20:12:58 <pjain> same
20:13:23 <bhe_> big ok from me
20:13:37 <mollydb> #topic Agreement for Debian Participation
20:14:30 <mollydb> in the pad, I posted formorer's proposed rules/guidelines/agreement for Debian participation: https://pads.ccc.de/7knDZoDRw5
20:14:39 <pjain> That would be #agreed
20:15:24 <formorer> I do of course agree with those rules
20:15:43 <pjain> I still want to discuss those
20:15:54 <pjain> What do we mean by connection to Debian?
20:15:58 <mollydb> Yes, so let's discuss them and see if we have anything else to add.
20:16:07 <mollydb> pjain: do you mind working our way down the list?
20:16:13 <bhe_> Can someone elaborate "Debian isn't an umbrella organisation again"
20:16:19 <formorer> pjain: the usual thing. visible in debian before
20:16:36 <mollydb> bhe_: It's related to the question of "connected with Debian."
20:16:37 <formorer> bhe_: an umbrella org serves as a host for different projects
20:16:38 <pjain> mollydb: sure
20:17:02 <pjain> Lets go one by one
20:17:02 <formorer> bhe_: in the past we hosted several projects that had nothing to do with debian
20:17:10 <formorer> which didn't worked that well (in my eyes)
20:17:11 <mollydb> bhe_: Last year Debian effectively hosted non-Debian projects, providing a home for things with tenuous connections to Debia so they could participate in GSoC
20:17:23 <mollydb> formorer: +1
20:17:39 <pjain> First: Debian isn’t an umbrella organisation (which we are discussing already)
20:17:39 <bhe_> formorer: mollydb  : Thanks
20:17:52 <mollydb> I am under the impression that in general umbrella orgs for GSoC are a bad idea.
20:18:18 <formorer> having people/projects from outside usually means that you don't know those mentors
20:18:40 <formorer> I do like the idea of somewhat trusted mentors we already know (thats the connection to debian)
20:18:46 <pjain> But how do we define that they are connected to Debian?
20:18:57 <pjain> I dont want to restrict them to DD
20:18:59 <mollydb> Also, you don't know the projects / other people around don't know the projects, so we cannot evaluate or judge success adaquately
20:19:11 <mollydb> I think it's fine to restrict projects to DD/DMs
20:19:25 <formorer> pjain: there are several indicators, DD/DM/Uploaders, activity on mailinglists, activity on irc
20:20:00 <pjain> So do we want all the mentors and co-mentors to be one of those or at least one in each project?
20:20:04 <bhe_> and bug reports :)
20:20:17 <mollydb> pjain: I think one per project should be a minimum.
20:20:25 <pjain> mollydb: Could you please make me chair? I will log things too
20:20:34 <mollydb> #chair pjain
20:20:34 <MeetBot> Current chairs: larjona mollydb pjain
20:21:15 <pjain> Do we all agree to have at least 1 mentor related to Debian per project?
20:21:26 <formorer> and what I really, really don't want to see again are mentors that are in multiple projects
20:21:39 <pjain> This might reduce the number of projects by a lot but will help us maintain a quality
20:21:58 <mollydb> I think we should NOT have as many projects as we did last year
20:22:02 <mollydb> But we can talk about that later
20:22:07 <formorer> the last year was painful and I would prefer to not have that again
20:22:25 <formorer> if that means having less projects: fine.
20:22:33 <pjain> Works for me
20:22:39 <formorer> we should concentrate on quality, not quantity
20:22:46 <formorer> in the end its not our money.
20:23:07 <larjona> I don't plan to be mentor or admin for GSoC this year (more interested in Outreachy), but I find the rules you propose reasonable and good both for mentors, students and Debian in general
20:23:14 <mollydb> So, proposal: All projects must have at least one mentor with a formal affiliation to the Debian project or be widely recognized as a contributor to the Debian community
20:23:47 <bhe_> Is there any limit on how many mentors a project can have ?
20:24:08 <pjain> +1 for mollydb proposal
20:24:25 <formorer> mollydb: +1
20:24:31 <pjain> bhe_: I don’t think so but I would prefer to not crowd it much
20:25:19 <mollydb> bhe_: I think 2-3 is pretty common for bigger projects.
20:25:21 <formorer> imho 2-3 are ideal
20:25:32 <bhe_> I think then every mentors should be related to debian.
20:25:44 <mollydb> Google recommends 2: https://developers.google.com/open-source/gsoc/help/slot-allocation
20:26:02 <pjain> Every mentor related to Debian would be difficult
20:26:14 <formorer> I have good experiences with 1 DD and one outsider
20:26:54 <mollydb> I have no opinion on this, since the process of mentoring itself is outside of my range of experience.
20:28:01 <pjain> Let’s agree to have at least one mentor for now and maybe revisit it again?
20:28:10 <formorer> fine for me
20:28:54 <mollydb> pjain: Agree to have one mentor, or agree to have one DD/DM mentor and another mentor that may or may not have a formal affiliation?
20:29:33 <pjain> Second one. One debian affiliated mentor and other ones might not be
20:29:47 <bhe_> outsiders/ not related to debian, how they come to debian for mentoring ? Are they upstream developers of the proposed project.
20:30:18 <formorer> bhe_: for example
20:30:53 <pjain> It might be that they have good technical skills related to that project and the main mentor of projects knows them. So they are lending a helping hand
20:31:32 <pjain> Technical skill can be general programming skill related to that coding language too
20:31:52 <formorer> in my last project a developer of a related software offered help and it was really helpful to have him onboard
20:33:48 <mollydb> bhe_: do you have more questions?
20:33:51 <bhe_> Ok.
20:34:10 <pjain> #agreed All projects must have at least one mentor with a formal affiliation to the Debian project or be widely recognized as a contributor to the Debian community
20:34:14 <bhe_> No. We can continue with next topic
20:34:25 <mollydb> Thanks!
20:34:37 <mollydb> Next point: Mentors are only mentors for one project
20:34:56 <mollydb> formorer: want to say something about this?
20:35:18 <pjain> Are we including both the mentors and co-mentors in this?
20:36:01 <mollydb> pjain: so a co-mentor should be ready to step up as a primary mentor should the mentor go MIA or need to step away
20:36:16 <formorer> last time we had sort of crossmentoring, which leaded to mentors being in 5 or more projects and they ended more or less a primary mentors in those projects
20:36:50 <pjain> MIA?
20:37:15 <formorer> missed in action
20:37:22 <pjain> Thanks
20:37:50 <pjain> I agree on this point. Let us keep this strict for both mentors and co-mentors
20:38:08 <formorer> I can live with 1 primary and 1 co-mentors
20:38:11 <formorer> but please not more.
20:38:17 <pjain> Does GSoC allow mentors to be part of 2 organisations?
20:38:46 <formorer> no idea
20:39:25 <mollydb> no clue.
20:39:45 <pjain> Okay. We can look at it kater
20:39:49 <pjain> *later
20:40:18 <pjain> Do we all agree to allow mentors/co-mentor to be part of one project only?
20:40:37 <mollydb> Yes
20:40:44 <bhe_> Agree.
20:40:58 <formorer> ack.
20:41:50 <pjain> #agreed Allow mentors/co-mentor to be part of one project only.
20:42:37 <pjain> #topic Every project should be related to Debian
20:42:55 <pjain> Isn’t this related to umbrella organisation point?
20:43:06 <formorer> its basically the same, yes.
20:43:30 <pjain> How do we define the term ‘Debian related’?
20:43:44 <mollydb> "Be a part of a pre-existing Debian project."
20:43:50 <mollydb> debian team?
20:44:29 <formorer> debian should benefit from the project. and it should be about debian itself, not just run by accident on a debian system too
20:45:16 <pjain> I was part of Free RTC under Debian GSoC. Do we consider something related to Debian anymore?
20:45:19 <pjain> https://wiki.debian.org/Teams/RTC
20:45:30 <pjain> Just trying to be clear on our scope here
20:45:58 <formorer> none of the rfc projects were about debian
20:46:15 <formorer> they are one of the reasons I want this rule.
20:46:16 <pjain> So we won’t accept such projects anymore?
20:46:25 <mollydb> AIUI projects ought to be things that bring people into the community and help them learn about how to contribute to that FLOSS org
20:47:13 <mollydb> I think we should be able to answer the question: Does this project open someone up to becoming a contributor to the Debian Project and Debian community?
20:47:25 <mollydb> (Not to assume or require them to stick around, but to open that possibility.)
20:47:45 <formorer> or does the project enhance debian or makes it better
20:48:10 <formorer> imho "it runs on debian too" isn't enough
20:49:04 <pjain> We really need to have strict guidelines about this beforehand else it will lead to lot of confusions and questions later on
20:49:39 <pjain> I don’t have much experience on this so I will agree with team
20:49:52 <formorer> you can't have strict rules about that, there is always some room left for questions
20:50:14 <formorer> or as I usually say as ftpmaster: "if in doubt, ask"
20:50:23 <pjain> Strict as in that we need to at least have a common definition
20:51:45 <bhe_> Personally, I don't think such project should be accepted. Initially I thought this RTC team is for packaging things related to RTC in debian.
20:53:29 <mollydb> proposed language: All proposed projects must directly relate to Debian and fit into the pre-existing work of a Debian team.
20:54:51 <formorer> should work as a starter
20:56:44 <pjain> Seeing the projects from past 2 years , I think we are going to have very less projects now
20:57:00 <pjain> :(
20:57:33 <bhe_> pjain: We already agreed on quality, not quantity
20:57:38 <mollydb> I think that's okay
20:57:42 <pjain> Okay
20:57:54 <larjona> you never know. Some person last year may have thought "ok enough projects, I won't mentor anything this year" , and some person this year may feel more motivated to propose project because being GSoC more Debian-related
20:57:56 <mollydb> I think having smaller participation is a good thing.
20:58:17 <pjain> I agree
20:58:41 <formorer> +1
20:59:33 <mollydb> Do we agree to the above language, or do we want to tweak it more?
21:00:17 <pjain> Agree
21:02:08 <pjain> I don’t think we have more things on agenda
21:02:11 <pjain> Do we?
21:02:17 <mollydb> yes
21:02:19 <mollydb> We do
21:02:27 <pjain> Okay sorry
21:02:35 <mollydb> It's okay
21:02:46 <mollydb> If anyone needs to leave, they should feel free to.
21:03:17 <mollydb> We can try to move faster as well
21:03:23 <formorer> I have to prepare a customer presentation, however, I guess I should have a few minutes left
21:04:01 <mollydb> We also want to have a set of requirements for project selection, so that when it comes time to pick projects people have more understanding of why their project was or wasn't selected for GSoC participation.
21:04:20 <mollydb> Does someone want to take point on that and draft up some ideas of what would be good guidelines?
21:04:34 <pjain> I think it is a combination of all the points we discussed in this meeti g
21:04:35 <mollydb> (I also want to talk about cross-participation with Outreachy, which I hope can be brief.)
21:04:41 <pjain> *meeting
21:04:44 <formorer> I can start with something on the wiki
21:04:53 <mollydb> Cool.
21:05:08 <pjain> Thanks formorer
21:05:10 <mollydb> pjain: I also think it includes things like "All mentors as enthusiastic about the intern."
21:05:11 <formorer> we should revise some of the docs anyhow
21:05:26 <mollydb> We need to review lots of the docs, which we can talk about next time :(
21:06:04 <pjain> I agree. We can keep revisiting these docs :)
21:06:20 <mollydb> #action formorer starts wiki page concerning guidelines an requirements for intern selection process.
21:06:42 <mollydb> Anything else on this, or can we move onto the last point for today?
21:07:29 <mollydb> Actually, I think we can nail everything today, since really the last thing to do is agree when we want to meet next.
21:07:49 <pjain> Let us discuss about Outreachy?
21:08:00 <pjain> I mean cross participation
21:08:40 <mollydb> I think we should require that all GSoC projects also register as potential Outreachy projects
21:10:22 <pjain> You mean only for the round which runs parallel to GSoC right?
21:10:41 <mollydb> yes
21:11:28 <mollydb> Last session we had a hard time getting Outreachy projects, and only had one, while we had dozens of GSoC projects.
21:11:46 <mollydb> There's no reason why, especially when we have the funding for two outreachy projects, we should not have enthusiasm.
21:11:57 <pjain> We can do that. We can also promote Outreachy to eligible GSoC applicants
21:12:16 <pjain> It is win win for both Debian as well as students
21:12:26 <mollydb> Additionally, plenty of people who are selected for Outreachy also qualify for GSoC, and it makes more sense to have GSoC fund them, to maximize participation all around
21:12:27 <formorer> what are the concequences of doing that? I am not familiar enough with outreach to decide.
21:13:07 <mollydb> I don't see any negative consequences, mostly that we have significantly more Outreachy projects.
21:13:28 <pjain> There might be a case that same mentor likes one Outreachy intern and one GSoC
21:13:30 <mollydb> I think negative consequences could be around objections from people who think we shouldn't be participating / putting resources into D&I efforts
21:16:14 <formorer> ok, then go ahead
21:16:42 <mollydb> Wooo!
21:17:07 <pjain> +1
21:17:26 <pjain> Outreachy \o/
21:17:52 <mollydb> Anything else on that, or can we move onto planning a next meeting?
21:17:57 <pjain> When can we start asking for project proposals from mentors? Earlier we do better it is.
21:18:26 <mollydb> I think there's such a thing as too early :P
21:18:50 <pjain> Well the mail from GSoC says that we should
21:19:05 <pjain> Organizations -- If you would like to apply for the 2019 program please start thinking about the projects you would like students to work on and also reach out to your community members to ask if they would like to be mentors for the program. Having a thorough and well thought out list of Project Ideas is the most important part of your application.
21:19:19 <mollydb> Okay!
21:19:22 <pjain> ^ From the Googles mail
21:19:31 <mollydb> I don't care when we start talking to people
21:20:05 <pjain> Okay
21:20:07 <formorer> we should write an announcement to d-a about our plans and asking for projects
21:20:52 <pjain> Let us finalise the announcement content in next meeting?
21:21:16 <formorer> sounds good, but we should have another meeting in december then
21:21:30 <mollydb> it is december ;)
21:21:42 <pjain> Sure and maybe at another time too? :P
21:21:45 <mollydb> Two weeks?
21:22:16 <mollydb> Between the 16th - 23rd?
21:22:24 <pjain> You are in which time zone? mollydb formorer bhe_ larjona
21:22:36 <mollydb> EST (GMT -5
21:22:54 <formorer> CET
21:23:01 <formorer> aka GMT+1
21:23:03 <bhe_> +530 UTC
21:23:11 * larjona GMT+1 too
21:23:54 <mollydb> I don't mind meeting early/earlier. Does someone want to send out a poll to outreach@lists?
21:26:13 <pjain> I can do that sometime this week but I might not be able to attend the next meeting
21:28:10 <mollydb> pjain: thanks
21:28:33 <mollydb> Anything else?
21:28:34 * pjain says welcome
21:29:09 <formorer> I guess thats all
21:29:56 <pjain> Thank you all
21:30:31 <mollydb> Great! Thanks everyone! We'll talk again in two weeks.
21:30:48 <larjona> thanks
21:30:58 <pjain> #endmeeting