11:00:24 <OdyX> #startmeeting
11:00:24 <MeetBot> Meeting started Sun Feb  5 11:00:24 2012 UTC.  The chair is OdyX. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:00:24 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:01:07 <OdyX> Apsu, kilobyte, lindi-, Mirv, pabs, Sicelo, wolog, Zeroedout, znalo, zumbi: I propose to start the planned IRC meeting now (we are at 11h00 UTC, right ?).
11:01:31 <Zeroedout> I'm here
11:01:34 <OdyX> #topic 1. Presentation roundtable
11:02:01 <Zeroedout> Is there some sort of agenda for the meeting?
11:02:23 <OdyX> Zeroedout: agenda is : http://whiteboard.debian.net/debian-mobile_860048.rst
11:03:07 <Zeroedout> sweet thanks
11:05:49 <wolog> hello, i'm currently at fosdem with a limited network connection, but better than nothing
11:06:24 <OdyX> okay nice. As I pinged everyone present at 11:02, let's wait some more minutes...
11:07:15 <Zeroedout> :)
11:07:53 <Zeroedout> I'm going to take this time to bitch about printing in Linux, is everyone okay with that?
11:08:17 <wolog> i've also to admit i've not followed the chan recently, do you have a url with some the list of topics ?
11:08:45 <Zeroedout> [03:03:18] <OdyX> Zeroedout: agenda is : http://whiteboard.debian.net/debian-mobile_860048.rst
11:10:50 * pabs apologises for lateness
11:11:10 * Zeroedout spanks pabs
11:11:58 <wolog> oups, sorry, my phone'sscren is not big enough ;) i missed it
11:13:11 <OdyX> pabs: No problem. Let's start with the introduction round. Everyone of you, please rapidly introduce yourself, in one-two sentences.
11:13:56 * pabs is Paul Wise, owner of an OpenMoko FreeRunner, Debian member, but not working on mobile stuff at all
11:14:11 <Zeroedout> Hi, Alishams Hassam, former director at Free Geek Vancouver, Director at vanLUG and linux enthusiast
11:14:24 <Zeroedout> lol, openmoko owner as well
11:15:27 * OdyX is Didier Raboud, owner of OpenMoko FreeRunner brick, Debian member, tried-to-revive the former pkg-meego team, tried to have people meet at DebConf11 about "Mobile".
11:15:48 <OdyX> and honestly, not much time these days for mobile-*
11:16:34 <wolog> Olivier Guerrier, sw manager at Zodiac aerospace, working on a in house linux distro, debian based, not really involded in embeded wotk, but following it closely, my phone is a galaxy note (sorry ;)
11:18:58 <OdyX> Okay, thanks. Let's move forward trough the meeting.
11:18:59 <OdyX> #topic 2. Immediate actions
11:19:36 * lindi- noticed the meeting
11:19:59 <OdyX> My idea behind that point is to gather a list of #action 's to be done "rapidly" to have more people join -mobile and have discussion started.
11:20:38 <OdyX> One idea was to get the multiple lists around to close and have people join -mobile. Opinions ?
11:20:39 <pabs> for those who came late, this is the agenda: http://whiteboard.debian.net/debian-mobile_860048.rst
11:20:57 <Zeroedout> is there a list of lists?
11:21:03 <lindi-> OdyX: which lists in particular?
11:22:18 <OdyX> There is no list of lists, but for example pkg-meego-maintainers@lists.alioth.debian.org
11:23:12 <Zeroedout> sounds good to me. The debian mobile community is fairly tiny so better to have it all in one place
11:23:33 <lindi-> Zeroedout: but debian-mobile isn't about debian mobile community? it has a narrower scope: mobile user interfaces?
11:23:41 <OdyX> that also asks a new question: should we open a new alioth project (to have bugs and automated mails go there instead of on debian-mobile@) ?
11:25:26 <pabs> I don't think we have enough traffic to need a new list yet
11:25:39 <OdyX> Agreed.
11:25:56 <OdyX> #info No need to create a -mobile-specific Alioth project.
11:26:22 <wolog> I tend to thin that defining a clear scope can helŝ (general or specific to gui) and yes the less lists the better
11:26:35 <OdyX> #action OdyX will make sure to get pkg-meego-maintainers@l.a.d.o closed.
11:27:53 <OdyX> wolog: isn't the scope as proposed in the mailing list annoucement enough ?
11:28:31 <OdyX> #url http://lists.debian.org/debian-mobile/2012/01/msg00001.html Scope definition (from the mailing list annoucement).
11:29:19 <lindi-> OdyX: it is, problem is that it seems people just read the name and think it's about everything related to using debian on a mobile device
11:29:46 <OdyX> Okay. What do we do to help, then ?
11:30:43 <pabs> point folks at -kernel if they start discussing kernel stuff or -boot for installer stuff
11:31:01 <pabs> I don't think this will be too much of a problem
11:31:02 <OdyX> Agreed.
11:31:54 <OdyX> #agreed The "Mobile" scope is sufficiently well defined for us to direct folks  at -kernel if they start discussing kernel stuff or -boot for installer stuff.
11:32:14 <OdyX> .oO(Just rise your voice if I'm being too fast or directive...)
11:32:41 <Zeroedout> #agree
11:32:59 <Zeroedout> #agreed
11:33:05 <OdyX> Are there other immediate actions ?
11:34:18 <pabs> merging wiki.d.o/Smartphone into /Mobile
11:34:24 <pabs> adding more folks to https://wiki.debian.org/Mobile#People
11:35:05 <OdyX> pabs: the merge is point 4. in the agenda, but agreed for the second.
11:35:14 <pabs> ah
11:35:33 <lindi-> pabs: hmm, /Mobile does not mention user interfaces at all, is it intended to be more general than the mailing list?
11:35:46 <lindi-> and it even discusses kernel :)
11:36:09 <pabs> I think it is more general yeah
11:36:10 <OdyX> Okay. Let's reorder the agenda as we are deriving.
11:36:39 <OdyX> #topic 3. Wiki namespace: Merge /Mobile and /Smartphone, + add more people to /Mobile#People.
11:36:58 <OdyX> So. Is the merge necessary ?
11:38:07 <pabs> I think there is a lot of redundant stuff. Smartphone is pretty disorganised in parts, I think I would prefer to have just /Mobile, with some smartphone-specific parts
11:38:28 <OdyX> + we can use other pages under /Mobile .
11:38:29 <lindi-> I'm in general in favor of merging/removing wiki pages that have not been touched for a while
11:38:46 <lindi-> wiki.openmoko.org for example is a horrible mess :)
11:39:12 <pabs> /Smartphone was a user's "I want Debian on my Android. oh it actually takes work? lets abandon this idea then"
11:39:23 <Zeroedout> lindi-: holy fuck yes it is
11:39:41 <Zeroedout> lol, I think we have consensus on the merge
11:39:42 <OdyX> Do we have volunteers for that work ?
11:39:59 <Zeroedout> I can help, but I may need a couple reminders through the week
11:40:07 <Zeroedout> does meetbot do reminders?
11:40:11 <OdyX> #agreed wiki.d.o pages /Smartphone and /Mobile should be re-organized and merged.
11:40:15 <pabs> I wrote a fair amount of /Smartphone, was planning on working on that but would prefer if others beat me to it
11:40:42 <OdyX> Zeroedout: it does #action (#agreed is only doable by Chair (today, I'm), #action is doable by anyone)
11:40:44 <pabs> Zeroedout: I can poke you about it
11:41:24 <Zeroedout> sounds good
11:41:31 <OdyX> so Zeroedout, you can write #action Zeroedout works towards merging /Smartphone and /Mobile (+ in which delay ?)
11:41:54 <Zeroedout> #action Zeroedout works towards merging /Smartphone and /Mobile
11:42:04 <pabs> #action pabs to poke Zeroedout about merging /Smartphone into /Mobile
11:42:09 <pabs> :)
11:42:11 <OdyX> great, guys !
11:42:11 <lindi-> anyways, hacking kernels and boot loaders to make it possible to run debian on different devices is something that people already understand quite well. having a usable user interface is something where I don't see a good solution yet, I think we should concentrate on that
11:42:35 <OdyX> before that^ are we done with the "Wiki namespace" agenda point ?
11:42:55 <pabs> on wiki stuff, I would like to point out the InstallingDebianOn namespace
11:44:10 <OdyX> #info There is the /InstallingDebianOn namespace
11:44:32 <OdyX> Ah, about the wiki...
11:44:57 <OdyX> #action OdyX Creates a section / subpage to list the meetings (both IRL and IRC), including agendas and minutes.
11:45:05 <OdyX> More on wiki ?
11:45:31 <OdyX> #topic 4. Long-term goals
11:45:41 <OdyX> lindi-: can you elaborate your above position ?
11:46:28 <OdyX> .oO(Here, anyone can use the #info, #idea, #action , #help and #link tags)
11:46:37 <pabs> #idea perhaps we should have a work session looking at all the UXen, their status upstream and in Debian
11:46:45 <lindi-> there's a general lack of good free software mobile user interfaces that have a future
11:47:05 <pabs> #info pabs put some links to various mobile UXen on wiki.d.o/Smartphone
11:47:10 <OdyX> pabs: Real-life Sprint ?
11:47:11 <lindi-> android is probably the only one that seems to be be free, good and have a future but it is unfortunately not very suitable for debian
11:47:37 <svuorela> lindi-: plasma-active
11:48:01 <pabs> #link http://wiki.debian.org/Smartphone#UI
11:48:11 <lindi-> svuorela: do they have a calendar?
11:48:29 <svuorela> lindi-: full groupware solutions.
11:48:31 <wolog> my question is this mist is abouy "packaging" only (so someone else must take care of the gui itself) oorif what's onside the packahe does lsa matter
11:48:52 <lindi-> svuorela: the screenshots at http://plasma-active.org/ mention things like Okular and Kwrite, aren't these desktop apps?
11:49:12 <wolog> there are lot of on gping project, for example in the efl area
11:49:28 <pabs> wolog: generally in Debian we only package stuff and do development upstream outside Debian
11:49:41 <svuorela> lindi-: they are. and they are kind of like the only two desktop apps that doesn't have a mobile edition.  Okular is though very touch usable. And a mobile okular is very high on the plasma active people's TODO list
11:49:56 <lindi-> svuorela: also the screenshots show an ui that is usable on a tablet but I'd have hard time using that on the openmoko screen
11:50:23 <pabs> I think Plasma Active would be too slow on the OpenMoko?
11:50:32 <svuorela> openmoko screen might be a bit too small for the current one, but a n9/n900/n950 (nokia) it is running quite okay.
11:50:48 <pabs> svuorela: are there any plans for packaging Plasma Active?
11:50:50 <OdyX> svuorela: .oO(I know I have been asking you that every 4 months, but still...) What amount of work would it need to integrate /package Plasma Active in Debian?
11:51:10 <svuorela> pabs: the gta02 might be a bit too slow, but the gta04 should definately be able
11:51:38 <svuorela> OdyX: 2-3 weeks spare time work of someone with clue, and a couple of swift kicks in the rear to people trying to put up obstacles.
11:52:39 <lindi-> svuorela: is there some way to test it without n900?
11:52:57 <svuorela> lindi-: what do you mean by 'test it' ?
11:53:08 <svuorela> on a device?
11:53:45 <lindi-> svuorela: I guess running in on a desktop would make it possible to evalute it too
11:53:51 <lindi-> svuorela: maybe in some emulation
11:54:35 <svuorela> lindi-: there is opensuse live images by openslx ('balsam') at least.
11:54:43 <OdyX> Okay. We are approaching 1 hour meeting time.
11:54:44 <svuorela> for ix86
11:55:04 <OdyX> We are at the topic "Long-Term goals".
11:55:42 <OdyX> My personal feeling is that we definitely lack manpower; Opinions ?
11:56:08 * pabs agrees
11:56:28 <OdyX> Is anyone willing to hire me ? ;-)
11:56:56 <Zeroedout> I can pay in your compliments and possible free beer if you come to Vancouver
11:57:32 <pabs> hehe
11:57:52 <OdyX> Let's rephrase the question differently: what reasonable goal can we set to ourselves (and in which timeframe) ?
11:58:16 <OdyX> I think we cannot aim for anything released with Wheezy. Our goal can probably only be for Wheezy+1.
11:58:40 <OdyX> unless svuorela thinks it might be realistic to have plasma-active by then.
12:00:01 <svuorela> it could be done, but it would require manpower that pkg-kde doesn't have.
12:00:27 <OdyX> svuorela: is there manpower "available" on the Ubuntu side ?
12:00:38 <svuorela> dunno.
12:01:08 <OdyX> Okay. Despite explicit consensus, I think we mostly agree then.
12:01:35 <OdyX> #agreed Plasma-Active is the most realistic "Mobile" UI that should get packaged in Debian.
12:01:58 <OdyX> #agreed Despite it's importance, there is a clear lack of manpower to get Plasma-Active packaged in Debian.
12:02:44 <OdyX> svuorela: would a real-life one-weekend sprint with 3-4 clueful people be enough ?
12:03:04 <OdyX> all other people: Would you be interested in such a sprint ?
12:03:31 <svuorela> OdyX: no. I would expect too much of the work to be things that can't be parallelized.
12:03:36 * pabs lives too far away from any likely location for such a sprint
12:04:10 <lindi-> haven't used plasma-active so I can't really have an opinion yet :/
12:04:39 <svuorela> lindi-: there is very soon going to be 7" tablets on the market with plasma-active. so that's how 'ready' it is.
12:04:58 <OdyX> svuorela: reasonably hackable to get Debian on them ?
12:05:09 <svuorela> OdyX: should be.
12:05:26 <lindi-> svuorela: yeah but tablets are a different thing
12:05:53 <svuorela> lindi-: from openmokophone, yes. from n9/n900/n950 not that much.
12:06:07 <OdyX> So if I try to further summarize (continuing on the two #agreed above), there is currently no manpower to get that done ?
12:07:51 <OdyX> ah. What about Mer ? Is there anything we can re-use / build-on from them ?
12:08:14 <svuorela> mer's platform or mer's UI ?
12:08:27 <OdyX> the first
12:10:41 <OdyX> #help We need clueful manpower willing to help / collaborate towards packaging plasma-active.
12:12:24 <OdyX> Okay. We are past the one-hour for the meeting duration.
12:12:46 <OdyX> #info The Mer project pursues similar goals than Debian-Mobile.
12:13:01 <OdyX> Anything else to mention about our Long-Term Goals ?
12:15:19 * pabs can't think of anything
12:15:30 <OdyX> okay, thanks.
12:15:48 <OdyX> Now to our final Topic for today:
12:15:54 <OdyX> #topic 5. Next IRC meeting, at better times ?
12:16:26 <OdyX> According to pabs' proposal to follow the Games Team procedure, the next meeting should happen in 3 months from now, what  do you think ?
12:17:16 <svuorela> with a agenda of "did any magic manpower appear since last time" ?
12:18:08 <OdyX> svuorela: that sure would be a pity, but there have been some #actions that people proposed to do. Review / Acknowledge them (done or "not yet") would be good anyway.
12:18:17 <OdyX> .oO(We can also just "give up"...)
12:23:47 <OdyX> Okay. No opinions. I think having regular meetings helps nevertheless.
12:24:15 <OdyX> #action OdyX calls for a meeting during May (Doodle, Agenda), on the mailing-list.
12:24:25 <OdyX> #topic 6. Varia ?
12:24:31 <OdyX> Anything else to add ?
12:25:24 <OdyX> #endmeeting