18:59:56 <highvoltage> #startmeeting
18:59:56 <MeetBot> Meeting started Mon Jun 17 18:59:56 2019 UTC.  The chair is highvoltage. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:56 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:09 <highvoltage> #chair highvoltage hartmans
19:00:09 <MeetBot> Current chairs: hartmans highvoltage
19:00:14 <highvoltage> #topic Roll call
19:00:27 * lamby 
19:00:29 <hartmans> Sam Hartman
19:00:44 * highvoltage = Jonathan Carter / jcc@d.o
19:00:45 <utkarsh2102[m]> Utkarsh Gupta
19:01:04 <paddatrapper> Kyle Robbertze
19:01:22 <highvoltage> I'm going to continue since I prepared a bunch of information, so feel free to type your name later on if you were distracted
19:01:35 <highvoltage> #topic Introduction to paper cuts
19:01:49 <highvoltage> Ubuntu originally ran its first 100 paper cuts campaign in 2009 and since then, the paper cuts project had some successors although it's died out a bit in recent years. The wiki still has some subpages that have some interesting ideas on them:
19:01:59 <highvoltage> #link: https://wiki.ubuntu.com/One%20Hundred%20Papercuts
19:02:17 <highvoltage> During these paper cut projects the overall quality, and especially perceived quality improved because problems that are pain points for users of the system were smoothed out or removed.
19:02:43 <highvoltage> oh I guess I should've started with what a paper cut bug actually is... d'oh :)
19:02:52 <highvoltage> Wikipedia says:
19:02:52 <highvoltage> """
19:02:53 <highvoltage> In usability and interaction design, a paper cut bug is defined as "a trivially fixable usability bug".
19:03:11 <highvoltage> The developers of the Ubuntu Linux-based operating system describe it as a bug that average users would encounter on their first day using a brand new installation of the latest version of Ubuntu Desktop Edition. The analogy is with a paper cut; small, not seriously damaging, but surprisingly painful. The use of the term has since spread to other software projects.
19:03:16 <highvoltage> """
19:03:19 <highvoltage> #link https://en.wikipedia.org/wiki/Paper_cut_bug
19:04:01 <highvoltage> not sure if there are any questions yet, because I know those present would more or less know about the above already, but feel free to jump in any time :)
19:04:33 <highvoltage> #topic papercuts in Debian
19:04:37 * IslandUsurper is Lyle Mantooth.
19:04:40 <highvoltage> So, we have quite a few papercuts in Debian.
19:04:44 <lamby> I just finished a fascinating book that underlined «inter alia» that fixing these kinds of issues has a psychological value to users of systems that are often underlooked by people more rationally-inclined (eg. programmers, accountants, etc.)
19:05:17 <lamby> "oh, that's just a…"  Yes, but… :)
19:05:35 <highvoltage> lamby: yeah! I was part of a project that deployed 200+ linux computer labs in schools, and we did a survey with a lot of teachers about differnt aspects of using linux in schools
19:06:03 <highvoltage> lamby: one thing that came up a *lot* was "I feel stupid when things don't work" and many variations of that
19:07:17 <highvoltage> but yes I do think we tend to overlook that. because we look at a popup and says "oh, that happens because xyz and it's obviously harmless" but a user might look at it and think "is my computer broken? is my data safe? am I being hacked?"
19:08:03 <highvoltage> anyway, I digress but I think that is a critically relevant point to paper cut bugs, how the interaction with the system makes people feel and how it can affect them psychologically
19:08:39 <highvoltage> Over the last year or so, I tried to solve many of the papercuts that bother me on the Debian Live images. I managed to make good progress but couldn't get to all of them.
19:08:59 <highvoltage> Earlier this month, on the debian-devel mailing list, kilobyte made a post about things that bother him that makes Debian feel "ugly and unwieldy" to him. While I don't particularly agree with the tone and the approach of his mail, the sentiments he expresses there are quite common.
19:09:00 <coucouf> yes, I remember an (admittedly a bit paranoid user) at an install party who was convinced their computer was hacked for reasons that were mere bugs and the kind of popups you describe
19:09:27 * utkarsh2102[m] nods
19:09:27 <highvoltage> He mostly refers to light-grey panels that look dated, default icon themes and fonts configurations that don't work well, I'll link to the full post so that you can read it later.
19:09:31 <highvoltage> #link https://lists.debian.org/debian-devel/2019/06/msg00134.html
19:09:53 <utkarsh2102[m]> People still think that installation is still a big problem in/with Debian.
19:10:22 <highvoltage> I think between all of us as active Debian users, we probably all have our favourite paper cuts and I think it would be great if we co-ordinate those
19:10:51 <highvoltage> utkarsh2102[m]: yeah when I announced this meeting, the first email I got was about installing.
19:11:12 <highvoltage> but I think that's a much larger enineering project rather than just a trivial papercut
19:11:46 <highvoltage> at leas calamares helps for the 95% plus of typical end users that just need a basic install to a laptop/desktop
19:11:55 <utkarsh2102[m]> CF: https://twitter.com/arcsaberxx/status/1139362619943317504
19:12:15 <utkarsh2102[m]> That might seem vague, but it is what it is :(
19:12:32 <highvoltage> ah yeas from that thread it does seem like Srihari didn't initially know about calamares
19:12:59 <coucouf> well, I’m not so sure about that "us as active Debian users" as we’ve usally worked around, patched, configured out of these papercuts
19:13:18 <highvoltage> coucouf: or just learned to not see them anymore
19:13:23 <coucouf> also "we" rarely install Debian on our own machines
19:13:52 <coucouf> the first commented out lines of my apt sources say jessie
19:14:02 <highvoltage> coucouf: when I talked to the maintainer of ibus-gtk3 about https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=905790 he said he'd never seen it before!
19:15:07 <coucouf> what I mean is that it would be helpful to get some feedback from new users or specifically use new default installs to try and detect some of these
19:15:38 <highvoltage> yeah I used to sit with users a lot and watch them install but haven't done that in a while
19:15:41 <coucouf> I’m pretty sure reviewing the list of default packets for some of the desktops may already make a difference
19:15:44 <utkarsh2102[m]> Of course, we need a lot of data/feedback to make it work.
19:15:55 <highvoltage> not sure if this works with meetbot but at least it's greppable...
19:16:12 <highvoltage> #idea Do new user testing with installer and see where problem areas are
19:16:48 <utkarsh2102[m]> We are having a sort of an install fest at DebConf, no?
19:17:10 <lamby> I w
19:17:20 <highvoltage> utkarsh2102[m]: doubtful
19:17:41 <lamby> re. user testing, I would suggest trying to link in Deb Nicholson (who will be speaking at DebConf IIRC) regarding her experience with…
19:17:45 <lamby> #link https://www.eximiousproductions.com/2018/03/09/spinachcon-2018/
19:17:55 <coucouf> do we really want to target install testing ? or post-install testing ?
19:18:11 <hartmans> coucouf:  Both
19:18:23 <hartmans> So, install testing is important because it often is people's first experience.
19:18:25 <coucouf> install could very well be something you get help with, but I’d say the first week alone with your system afterwards is critical
19:18:26 <highvoltage> yeah anything that can ruin or improve a user's experience with debian
19:18:39 <hartmans> but yeah, there are a class of users where they get help with the install.
19:18:54 <hartmans> so, there is one class that enters through install and another than enters through something later.
19:19:05 <highvoltage> installing isn't an issue for us, but for new users it gives a huge first impression and often causes the biggest stumbling blocks
19:19:40 <hartmans> for that matter, start with image finding and downloading.
19:20:05 <highvoltage> although I wouldn't put an immense focus on the installer, there are things that can be easier but I don't think it strikes me as something that has a lot of paper cuts
19:20:26 <highvoltage> hartmans: yeah I thought of that one today actually! I think it will end up high on the list
19:20:29 <hartmans> I'm actually serious.  I think there probably are papercuts related to  getting installation media and burning to a device say on a windows desktop or mac or chromebook.
19:20:44 <hartmans> And yeah, the answer for chromebook is probably "you lose"
19:21:14 <highvoltage> I've also been considering asking the web team whether we can use one of the live images for the default download image... a netinst image just doesn't feel like the write thing for a newcommer
19:21:40 <coucouf> highvoltage: yes, I had a couple of "surprising" successes with d-i by really non-technical users, at least on standard computers
19:22:30 <highvoltage> yeah me too. although on two occasions I saw people get stuck on the proxy server screen having no idea what it's talking about
19:23:02 <hartmans> How do we handle the diversity of desktops in Debian in terms of this project?
19:23:02 <coucouf> in French it has a translation that you find only in Debian so it’s even more cryptic :)
19:23:24 <hartmans> do we look at papercuts for each desktop?  Or only one? or what?
19:23:31 <highvoltage> ah, let me copy and paste some experiences with desktops since we're going back on that topic...
19:23:40 <highvoltage> So, a few years back, I wanted to make some suggestions to the Debian Gnome maintainers based on things that my customers routinely complain about (you have *no* idea how bored I was of people complaining about light-grey panels) but back then the Debian Gnome maintainers were completely against changing any default from upstream whatsoever except for the Debian wallpaper to the point that I
19:23:46 <highvoltage> even perceived them as being hostile about it, and it put me off from persuing that further.
19:24:00 <highvoltage> I believe that things have improved over the years and that the desktop maintainer teams are more open to changes. The leader of the Xfce team said that he's open to a proposal for some of the problems that I pointed out before. And the new Lxqt flavour looks way better than the default Lxqt session, here's a screenshot:
19:24:05 <highvoltage> #link https://jonathancarter.org/files/debian/dump/lxqt.jpg
19:24:20 <highvoltage> It's also worth noting that any changes in default deskop settings can have ugly unintended consequences and introduce more issues than they solve. Some upstreams even insist that their apps not be themed, mostly to the typical breakage that it can lead to. Here is a link to one such group of developers:
19:24:25 <highvoltage> #link https://stopthemingmy.app/
19:24:28 * highvoltage gives a little time to catch up
19:25:14 <coucouf> last experience I had was for stretch and the gnome maintainers were OK with patching GDM to get our wallpaper on the login screen
19:25:28 <coucouf> we didn’t end up doing that, but things have changed it seems
19:25:38 <hartmans> Our own Neil McGovern has a fairly good response to the stop theming apps petition.  I'm not sure if it is somewhere public yet.
19:25:40 <coucouf> or maybe it depends on how intrusive the patches are
19:25:43 <highvoltage> coucouf: oh yeah, the new maintainers are great, my problem was with the old ones
19:25:56 <hartmans> But if not, it should be posted to the foundation's blog relatively soon.
19:26:12 <utkarsh2102[m]> MATE, the default one, has a few such bad reviews too :(
19:26:28 <highvoltage> hartmans: my take on it is that if someone doesn't want me to change the appearance of their app, they better make sure that it's usable in its default state
19:27:53 <highvoltage> so for the papercuts project I suggest that it targets small, specific problems, I don't really want it to get the responsibility of choosing themes and look+feel of all the desktop environments in debian
19:28:13 <highvoltage> although obviously there are some theming problems that are relevant
19:28:42 <highvoltage> (for example, xfce's default icon theme in buster is missing a 'run' icon which you see is missing every time you click on the main menu)
19:29:51 <highvoltage> and also that said, paper cuts wouldn't just be for installer or desktop, but also for GUIless systems
19:31:00 <coucouf> slightly different topic, but how much can we make it recommended to patch these in stable ?
19:31:09 <ansgar> highvoltage: That Lxqt screenshot is very confusing. What is a "Multilingual Terminal"? And so on :)
19:31:18 <lamby> ansgar: *exactly* :3
19:31:42 <coucouf> at least for KDE where I have interest (and I now the team is heavily understaffed) it feels like stable is fire & forget, besides security fixes
19:31:46 <highvoltage> ansgar: hah, that multilingual terminal is on all the live images and I have no freakin' clue why and at the -live bof at debconf I want to ask if anyone knows and remove it
19:32:13 <highvoltage> ansgar: more confusingly, it's the only terminal emulator on the cinnamon image
19:32:26 <coucouf> ideally we should catch these before a release, but…
19:32:30 <highvoltage> ansgar: but yeah, that is certainly a paper cut of sorts :)
19:32:51 <lamby> Perhaps (at some point and perhaps not even now) we could share ideas/experiences on how to best communicate these papercuts (which are often trivial technical patches) in a way that doesn't generate pushback, misunderstanding of the importance of such issues or straight-up bikeshedding from others. I can recall a number of my own that I eventually just dropped.
19:33:46 <highvoltage> nice, yes absolutely, and a great segway to the next topic!
19:34:01 <highvoltage> oh but first
19:34:32 <highvoltage> #idea find best ways to communicate papercuts (often trivial patches) in a way that doesn't generate pushback with steakholders
19:34:41 <highvoltage> I suppose that captures the gist of it?
19:34:42 <lamby> nom steak
19:35:09 <highvoltage> *stakeholders :P
19:35:26 <highvoltage> #topic Things to figure out
19:35:57 <highvoltage> I made a small list of initial things I thought about, there is no doubt more.
19:36:12 <highvoltage> (not sure if I should paste them one by one so that we can discuss them or all at once)
19:36:30 <highvoltage> (but since time is passing so quickly I'll just paste them for now)
19:36:37 <highvoltage> * How will we collect bugs? Use the BTS? Salsa? Wiki pages? Email alias? All of the above?
19:36:41 <highvoltage> * Probably best to have final bugs in BTS along with debtags.
19:36:44 <highvoltage> * Probably a good idea to categorize the bugs, will probably depend on the final list
19:36:47 <highvoltage> * Perhaps we can salvage some of the unfixed bugs on https://bugs.launchpad.net/hundredpapercuts and fix them in Debian? (I'm sure there's a lot of crud there, but possibly worth looking through)
19:36:50 <highvoltage> * We can probably find 100 small but important bugs that have gone unfixed in the BTS, perhaps most of these should come from there?
19:36:53 <highvoltage> * Workflow? Should we have monthly check-ins to see how it's going with people who work on papercut bugs and re-assign those if they get to busy?
19:37:46 <lamby> May I suggest ensuring we at-least plan a followup meeting (I guess the "workflow" question). That way, even if we fail to decide/agree on anything else we at least get another run at it.
19:38:12 <highvoltage> yeah I'm thinkin of taking it to the lists, and then we can probably do one more irc meeting before debconf
19:38:41 <highvoltage> I think that we could have a solid plan ready by the end of debconf
19:39:14 <highvoltage> how about July 8? that's not long before DebCamp
19:40:13 <paddatrapper> 4 weeks for list discussion, should be long  enough
19:40:20 <highvoltage> (ah I forgot to mention that there will also be a 100 papercuts session at DebConf, don't have an exact date for that yet)
19:40:27 <highvoltage> yeah I thought so too
19:40:35 <hartmans> Which list will this be discussed on?
19:41:17 <highvoltage> hartmans: I think that it's on-topic for debian-devel, but open to suggestions
19:41:34 <hartmans> Sounds great.  I could have seen an argument for -devel or -project.
19:42:10 <highvoltage> perhaps even -qa but I'd rather maximise the audience
19:42:32 <highvoltage> less people are on -project and -qa
19:42:35 <hartmans> Between Adam, me, this and a few other things, -devel is starting to get lively again.  It reminds me of back in the day (in good ways)
19:43:33 <highvoltage> hehe, yeah I think some of Adam's post might be more appropriate for after the release though
19:44:37 <highvoltage> someone asked about splitting / prioritising among desktop environments and now I can't find it, but...
19:45:11 <highvoltage> I think it would be a good idea to have some categories for all the paper cuts, not sure where that split would lie, will probably depend all the bugs we can identify
19:45:37 <highvoltage> and I don't think any particular desktop environment should be prioritised
19:46:14 <highvoltage> one of my personal goals is that I could spin up any desktop environment on debian-live media and that there should be nothing obviously broken about them
19:47:10 <highvoltage> it really irks me that all these tiny shitty little distros that kids make over the xmas holidays get that right but that we don't
19:47:34 <highvoltage> (oops I'm nearly snapping back to politician mode again)
19:48:03 <highvoltage> but yeah that's something we can and should get right. I don't have too much more to add at this point :)
19:49:29 <highvoltage> I like the feedback from everyone so far, thanks a lot! anything you'd like to touch on before we close off?
19:49:56 <coucouf> I think a wiki page about the project would be useful in any case, where we can redirect people interested and not attending now, keeping the next meetings info…
19:50:17 <lamby> #link https://distrotest.net/Debian Might be useful to take the meta-papercuts out of finding papercuts. :)
19:51:47 <highvoltage> ah interesting, I didn't know about that. I was thinking of setting up something like that for final ISO testing for debian-live images. thanks!
19:52:56 <highvoltage> #info next meeting is on 2019-07-08 at 19:00 UTC
19:53:41 <highvoltage> I guess we can close off if there's no further comments
19:54:09 <highvoltage> sorry for the huge text dumps, my original intent was to send out an email before but ran out of time
19:54:45 <highvoltage> #action create a wiki page for the project with all the relevant info
19:55:05 * fil arrived late, and just spent my time reading/skimming it all -- very interesting, so probably ought to be mailed/wikied
19:55:23 <highvoltage> great, you're just in time for the ending :)
19:56:20 <highvoltage> well, thanks everyone, I'll start a thread on debian-devel (probably tomorrow) and then we take it further from there!
19:56:41 <highvoltage> #endmeeting