14:58:25 <h01ger> #startmeeting
14:58:25 <MeetBot> Meeting started Thu Mar 25 14:58:25 2021 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:25 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:33 <h01ger> please say hi again :)
14:58:33 <cpina_> Hey - this is carles from pts-no-dsa :-) I thought to drop by and say hi. Busy the next hour but I'll read it later :-)
14:58:40 * h01ger = Holger Levsen
14:58:46 * lamby = Chris Lamb
14:58:48 <h01ger> cpina_: hi carles!
14:59:09 <buxy> hi
14:59:09 <h01ger> the agenda is at https://pad.riseup.net/p/lts-meeting-agenda - please check if a topic you care about is missing
14:59:10 <apo> hi all
14:59:12 <el_cubano> hi
14:59:15 <gladk_> hi
14:59:20 <h01ger> we plan to finish the meeting in 60min
14:59:39 <Beuc> o/
14:59:41 <ta> hi
15:00:07 <ola> hi
15:00:10 * h01ger is happy to see so many faces^wnicks
15:00:51 * h01ger added pts-no-dsa as first topic as cpina_ is here
15:01:29 * h01ger waits some 60 seconds more before really starting
15:02:39 <h01ger> ok, lets start
15:02:53 <h01ger> #topic 2. pts-no-dsa improvement
15:03:13 <h01ger> cpina_: nice work! :) & thank you too!
15:03:24 <h01ger> any other comments?
15:03:30 <cpina_> Thanks all of you for the fast feedback!
15:03:34 <h01ger> cpina_: do you have more plans / ideas to work on?
15:04:01 <cpina_> Not the next weeks (busy for some more weeks) but I'd like to do more things for the distro-tracker
15:04:16 <utkarsh2102> hi
15:04:30 <cpina_> I'm keeping an eye on tickets there and happy to discuss ideas anytime
15:04:52 <buxy> cpina_: how did you find out about this project BTW? do you follow planet debian?
15:05:30 <cpina_> I did follow on an off (more now). A friend sent me the link when he saw it
15:06:10 <h01ger> its good to have friends :)
15:06:11 <cpina_> he knew that I like Django and was looking for some extra-work and that I like Debian so it was a no brainer! :-)
15:07:18 <buxy> I'm glad that we managed to complete this first project but it also showed that it's real work to coordinate everybody even when all parties have the best intentions of the world. In the end, some issues were found after the project had been officially recognized as "completed" by Freexian.
15:07:21 <cpina_> I thought that if now familiar with Debian (even a bit internal debian-security concepts) it was a bit hard to get it right straight away
15:07:39 <cpina_> that would be my only comment, but not impossible so not a problem!
15:07:56 <cpina_> (I mean for a 100% good understanding of the requirements)
15:08:22 <cpina_> if now familiar -> if not familiar
15:08:24 <h01ger> buxy: i expect these kind of problems to persist / happen again and thus should be taken into account for future projects
15:09:41 <h01ger> shall we move on to the next topic?
15:09:44 <buxy> yes
15:09:50 <ola> yes
15:10:27 <cpina_> yes
15:11:00 <h01ger> #topic 3. future of freexians offer (thread on the internal list)
15:11:11 <h01ger> buxy said he'd be fine to discuss this here
15:11:34 <h01ger> buxy: i think you should give further introduction here
15:12:17 <buxy> Ok. I'd like to thank everybody for the feedback and the answers to last month questions. It was really interesting to read them.
15:13:41 <buxy> At this point, there's no timeline and clear action plan but I'm mostly set on the desire to move from pure "Debian LTS" to some broader "Debian Software Assurance" offer for our sponsors.
15:14:18 <ola> So you limit this still to assurance, not any general Debian work.
15:14:21 <ola> ?
15:14:53 * h01ger doesnt really like the idea of having a third DSA acronym... (within Debian)
15:15:15 <h01ger> (which is a totally minor point)
15:15:24 <buxy> Well, I sell it as "assurance" because that's what companies are more likely to buy but what we put behind this is more diverse, and includes random debian project funding.
15:16:31 <buxy> But the whole exercise is futile if we are not able to show that we can use the supplementary money that such a move could bring.
15:16:39 <h01ger> buxy: and that should combine 'everything' (under one umbrella, though i guess customers can opt out of paying for elts||php (as examples) if they dont use it?)
15:17:15 <buxy> h01ger: yes, they commit a yearly budget and allocate it based on their needs
15:17:37 <buxy> and what's not used ends up funding debian projects
15:17:51 <ola> buxy: Do I understand correctly that one of the reasons for this is that we have companies that in fact do not really use LTE but would like to give away money to make Debian successful. Or are there also other more specific work asked for?
15:18:07 <el_cubano> buxy: There might be a need for multiple coordinators (one for LTS/ELTS, as h01ger is/was) and perhaps one or two more to keep supplementary efforts moving.
15:18:36 <h01ger> el_cubano: or someone spending more than i did. i did <10h month
15:18:42 <h01ger> more time
15:18:55 <buxy> ola: yes but Freexian has been doing packaging work as well, it could also be integrated, and technical support
15:18:57 <el_cubano> very true
15:19:34 <gladk_> @buxy it would be better to know, what do companies prefer: more packaged software, better package qualities, more often key-software releases in Debian (Boost for instance)
15:20:39 <buxy> anyway, my focus is thus on making the debian project funding successful and given the workload that was generated for this first small project, I'm convinced that I need to work with someone acting as project manager and I'm trying to recruit that profile
15:22:00 <buxy> gladk_: there's no generic answer, needs vary quite much and are often not very specific, we have cloud companies that just want Debian to work well for their customers
15:22:20 <ola> buxy: Yes we need someone to coordinate. My experience is that when customers have specific demands that discussion may take more time than the actual technical work involved.
15:22:21 * h01ger points out https://lists.debian.org/161651690066.764341.17186951678348314598@auryn.jones.dk on debian-vote where Jonas described some undesirable sideeffects of funding volunteer work
15:22:52 <h01ger> i do think that lts work is more like accounting. almost noone wants to do lts or accounting for fun
15:23:13 <h01ger> while if... well, read what Jonas has written
15:23:40 <buxy> ola: in this case, it's not even with customers, it's between the security team, cpina, distro-tracker maintainer and Freexian
15:24:24 <h01ger> arent those parties customers too? (without paying, except freexian)
15:24:32 <buxy> h01ger: yes, we need to always keep those side-effects in mind in anything that we setup
15:25:28 <ola> buxy: Ah. I thought this was about getting customers to fund other things.
15:26:12 <ola> h01ger: They are stake-holders, not customers. A customer always pay (I hope :-)
15:26:20 <h01ger> buxy: nods. i agree this worked well so far. and i agree that funding people to work on debian is a good goal. i'm just afraid the line (to walk on) might be too thin...
15:26:24 <h01ger> ola: right
15:26:33 <buxy> Anyway I have been drafting a document outlining the challenges and the direction I'd like to follow, I shared it with a few already but I intend to refine it and then share it with the team nad likely post it on my blog too.
15:26:47 <ola> buxy: Sounds good.
15:28:26 * h01ger agrees
15:29:08 <h01ger> shall we move on the the next topic? (happy either way)
15:29:26 <buxy> I need to expand the team behind Freexian and so far none of you expressed any desire to somehow change your career and try to take a more active role in Freexian. But if you do, let me know.
15:29:38 <el_cubano> It seems like there are some areas where Jonas' identified problem don't really come into play (like, backporting entire packages or package groups)
15:30:35 * h01ger holds on (we have (a bit) time..)
15:31:04 <buxy> h01ger: go ahead, I think I said what I could
15:31:12 <h01ger> :)
15:31:15 <h01ger> ok
15:31:53 <h01ger> #topic 4. Future of Holger's role (coordinating/managing the (E)LTS team)
15:32:39 <h01ger> the topic basically says it, iirc i said i'd do it for two more months, though i wouldnt mind to start helping someone else with this role now and quit sooner
15:32:59 <ola> How much time do you spend on this per month?
15:33:15 <h01ger> 7-8h in average
15:33:46 <ola> Oh, I thought it was more.
15:34:05 <buxy> on my side, I just explaind that I want to hire someone with project management skills to run the project-funding side and I believe such a person would likely also have the skills to coordinate the team, so my preferred outcome would be to find that person quickly and have it take both roles
15:34:06 <h01ger> just checked, it was more a year ago
15:35:07 <buxy> but on the other side, that person might not be a DD so could probably not do everything that h01ger was doing either
15:35:11 <h01ger> there's definitly more work to do (than 8h/month)
15:35:41 <el_cubano> buxy: By "hire" are you saying you want someone as a Freexian employee (though not necessarily full-time), or someone who acts in an independent contractor capacity?
15:36:14 <h01ger> https://lists.debian.org/debian-lts/2021/03/msg00002.html is a good example of the things the role contains, though it misses things like coordinating/mediating and onboarding new people too
15:36:56 <cpina_> On the previous topic (sorry) and this one: Django has two Django fellows. As a volunteer I am really happy that they are there and I have never seen anyone not volunteering because of this. It's different than paying volunteers because they are not volunteers (in my mind) but maybe something to look at and get ideas from.
15:37:16 <buxy> el_cubano: I believe I can only have French persons as employee so I guess I need to accept contractors, but ideally I would like someone that could be full-time on Debian even if contractor but in that case, with a monthly salary that is fixed and not at the usual rate that we use for paid contributors....
15:37:29 <buxy> full time on Freexian sorry
15:38:00 <el_cubano> buxy: Thanks for clarifying
15:40:03 <buxy> el_cubano: at this point, I think I can't have full time project manager, that person should likely also be able to do other paid missions to compensate their salary
15:40:52 <buxy> (be it LTS, packaging, support, or possibly development through Freexian's own grant... which would require some external reviewer)
15:43:04 <h01ger> while we got two replies from interested people (hello, you know who you are :) - buxy is still looking forward to more people applying
15:45:30 <buxy> Well, I don't necessarily need more, but it's nice to know who is interested and to see that you care about this issue.
15:45:30 <h01ger> so i guess we are done with this topic for today too :)
15:45:42 <ola> Yes I guess so.
15:45:44 <h01ger> right! :)
15:46:35 <h01ger> #topic 5. next meeting(s)
15:46:56 <ola> I'll have to leave now unfortunately. o/
15:47:07 <h01ger> last thursday of the month
15:47:19 <h01ger> ola: its logged so you can read backkog on meetbot.debian.net
15:47:21 <h01ger> ola: o/
15:47:35 <h01ger> last thursday of the month means april, t29th 2021
15:47:44 <h01ger> last thursday of the month means april, 29th 2021
15:47:46 <h01ger> and
15:47:58 <h01ger> last thursday of the month means may, 27th 2021
15:48:06 <h01ger> both 15 UTC
15:48:18 <h01ger> and the april one should be video, the one in may irc
15:48:55 <h01ger> was i the only one with problems with the last technical video solution (nextcloud running on apo's system)?
15:49:39 <h01ger> and apo would you be willing to offer that again?
15:49:55 <apo> I believe it worked quite well for the rest of us, I can provide another nextcloud instance if you find it useful, sure
15:50:25 <buxy> Or we can try again jitsi. I was the only one with issues last time IIRC and they were hardware related AFAIK.
15:50:46 <Beuc> do we target a visioconf every 2 months ? (I thought we targetted every 3 months)
15:51:15 <h01ger> Beuc: your memory is faulty :) we strive for every 2 month
15:51:21 <buxy> Beuc: I believe we always said one out of two, yes
15:51:38 <Beuc> if you say so
15:52:32 <h01ger> so, debian.social jitsi or apo's nextcloud? :)
15:53:17 <lamby> Either work for me. :)
15:54:04 <buxy> I would say let's try to use the Debian infra and not bother apo to setup an extra instance for us though that was really nice of you Markus.
15:54:09 <apo> me too, it's always online, so we can switch to Nextcloud if there should be a problem with jitsi and vice versa
15:54:51 <h01ger> #agreed we'll use the debian jitsi instance and if that fails we go to apo's nextcloud
15:55:00 <apo> ok, then jitsi and nextcloud is backup, right
15:55:06 <h01ger> yup
15:55:11 <h01ger> #topic 6. any other business
15:55:16 <h01ger> you have 3min :)
15:55:28 <h01ger> (or more, if useful)
15:55:35 <el_cubano> "Other Business: The Lightning Round!"
15:56:59 <buxy> Time to google Lightning round and I already lost one minute of the 3 :-)
15:57:22 <h01ger> 45sec left. no stress, no stress!!11
15:57:31 <lamby> :-)
15:57:57 <el_cubano> Lol
15:58:04 <h01ger> oki
15:58:15 <buxy> Thank you everybody for your work!
15:58:26 <h01ger> thank you all for participating and for improving and maintaining Debian!
15:58:33 <h01ger> o/
15:58:42 <lamby> thanks all
15:58:42 <gladk_> Thanks
15:58:47 <ta> thanks
15:58:57 <Beuc> Thanks!
15:59:01 <apo> thank you all, and cu next time
15:59:09 <el_cubano> thanks!
15:59:31 <h01ger> #endmeeting